Autor Thema: Ursachensuche Sky Ultimate Dual on Pi4 (alt) + Fujitsu Futro S740 mit TVHeadend  (Gelesen 1757 mal)

chili

  • Newbie
  • *
  • Beiträge: 19
    • Profil anzeigen
Hallo,

ich mache wieder mal ein Thema auf. Obwohl es besser wurde funktioniert es immer noch nicht zuverlässig.
Verbessert hat es sich nachdem ich täglich per Cron in der Nacht reboote.
Aktuell ist im TvHeadend alles ok, Sender kommen trotzdem nicht rein.
Bevor ich neustartete hab ich mal dmesg ausgeführt. Hier die Meldungen:

[    3.394658] random: systemd: uninitialized urandom read (16 bytes read)
[    3.399107] systemd[1]: Created slice system-systemd\x2dfsck.slice.
[    3.401448] random: systemd: uninitialized urandom read (16 bytes read)
[    3.402309] systemd[1]: Reached target Swap.
[    3.405218] systemd[1]: Listening on Journal Socket (/dev/log).
[    3.407662] systemd[1]: Started Forward Password Requests to Wall Directory Watch.
[    3.410116] systemd[1]: Listening on initctl Compatibility Named Pipe.
[    3.413320] systemd[1]: Created slice User and Session Slice.
[    3.417367] systemd[1]: Listening on Syslog Socket.
[    3.522952] i2c /dev entries driver
[    4.144046] EXT4-fs (mmcblk0p2): re-mounted. Opts: (null)
[    4.241243] systemd-journald[121]: Received request to flush runtime journal from PID 1
[    4.861016] gpio-fan gpio-fan@0: GPIO fan initialized
[    4.912015] rpivid-mem feb00000.hevc-decoder: rpivid-hevcmem initialised: Registers at 0xfeb00000 length 0x00010000
[    4.913136] rpivid-mem feb10000.rpivid-local-intc: rpivid-intcmem initialised: Registers at 0xfeb10000 length 0x00001000
[    4.913771] rpivid-mem feb20000.h264-decoder: rpivid-h264mem initialised: Registers at 0xfeb20000 length 0x00010000
[    4.914303] rpivid-mem feb30000.vp9-decoder: rpivid-vp9mem initialised: Registers at 0xfeb30000 length 0x00010000
[    4.984147] vc_sm_cma: module is from the staging directory, the quality is unknown, you have been warned.
[    4.986752] bcm2835_vc_sm_cma_probe: Videocore shared memory driver
[    4.986783] [vc_sm_connected_init]: start
[    4.988169] mc: Linux media interface: v0.10
[    4.988464] vc_sm_cma_vchi_init: failed to open VCHI service (-1)
[    4.988483] [vc_sm_connected_init]: failed to initialize shared memory service
[    5.023923] videodev: Linux video capture interface: v2.00
[    5.102118] bcm2835_mmal_vchiq: module is from the staging directory, the quality is unknown, you have been warned.
[    5.104702] bcm2835_mmal_vchiq: module is from the staging directory, the quality is unknown, you have been warned.
[    5.109824] bcm2835_isp: module is from the staging directory, the quality is unknown, you have been warned.
[    5.112799] bcm2835_v4l2: module is from the staging directory, the quality is unknown, you have been warned.
[    5.120154] bcm2835_codec: module is from the staging directory, the quality is unknown, you have been warned.
[    5.125125] bcm2835_mmal_vchiq: Failed to open VCHI service connection (status=-1)
[    5.149918] bcm2835_mmal_vchiq: Failed to open VCHI service connection (status=-1)
[    5.174868] bcm2835_mmal_vchiq: Failed to open VCHI service connection (status=-1)
[    5.933336] ads7846 spi0.1: supply vcc not found, using dummy regulator
[    5.934975] ads7846 spi0.1: touchscreen, irq 63
[    5.940447] input: ADS7846 Touchscreen as /devices/platform/soc/fe204000.spi/spi_master/spi0/spi0.1/input/input0
[    7.998800] random: crng init done
[    7.998823] random: 7 urandom warning(s) missed due to ratelimiting
[    8.102476] 8021q: 802.1Q VLAN Support v1.8
[    8.332330] cfg80211: Loading compiled-in X.509 certificates for regulatory database
[    8.551905] cfg80211: Loaded X.509 cert 'sforshee: 00b28ddf47aef9cea7'
[    8.614902] Adding 102396k swap on /var/swap.  Priority:-2 extents:4 across:4206588k SSFS
[    8.721091] bcmgenet fd580000.ethernet: configuring instance for external RGMII (RX delay)
[    8.722470] bcmgenet fd580000.ethernet eth0: Link is Down
[   13.203469] input: Sundtek Remote Control as /devices/virtual/input/input1
[   13.914947] bcmgenet fd580000.ethernet eth0: Link is Up - 1Gbps/Full - flow control off
[   13.914975] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   15.919538] ICMPv6: process `dhcpcd' is using deprecated sysctl (syscall) net.ipv6.neigh.eth0.retrans_time - use net.ipv6.neigh.eth0.retrans_time_ms instead
[   16.743668] usb 1-1.2: usbfs: process 524 (mediasrv) did not claim interface 0 before use
[   16.804780] input: Sundtek Remote Control as /devices/virtual/input/input2
[   22.758805] fuse: init (API version 7.32)
[   33.125222] usb 1-1.1: usbfs: process 557 (mediasrv) did not claim interface 2 before use


Konfiguration hier ist: Oben auf dem Boden ein Pi4 mit Sky Ultimate Dual (RaspiOS mit Touchscreen, Pihole und Unbound)
Netzteil bringt stabil 3A das wurde schon vor Monaten gekauft. Seitdem sind der Undervioltage Meldungen weg

Pi4 an 7590 Client-Box, diese per 1Gb Meshlan an 7590 Masterbox (DSL50)
Ebenfalls an dieser Masterbox ist der 2. Pi4 (Libreelec) mit Gbit Lan

Vielleicht helfen ja die dmesg Meldungen vom Pi4 mit dem Sky Uötimate Dual

Aktuell bin ich auch im Chat
« Letzte Änderung: August 06, 2023, 07:46:54 Nachmittag von chili »

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8433
    • Profil anzeigen
Re: Ursachensuche Sky Ultimate Dual on Pi4 mit TVHeadend
« Antwort #1 am: Januar 28, 2022, 04:04:47 Vormittag »
Die Logfile sagt soweit nichts aus, wenn Du mir Zugriff geben kannst kann ich das direkt überprüfen.

Wir hatten einen Kunden der hatte eine alte Raspberry Pi4 USB Firmware die den Tuner gestört hat, mit einem Update war dann auf einmal alles stabil

https://www.minidvblinux.de/forum/index.php/topic,10158.msg81146.html#msg81146

Zitat
Raspberry PI OS installieren und folgenden Befehl ausführen:

rpi-update firmware

https://github.com/raspberrypi/linux/issues/3919#issuecomment-717151759

Zitat


Der USB Controller für den Raspberry PI 4 benötigt ebenfalls eine Firmware.

https://www.raspberrypi.org/documentation/computers/raspberry-pi.html
The VLI805 USB firmware EEPROM image - ignored on 1.4 and later board revisions which do not have a dedicated VLI EEPROM

Jene RPIs welche die Firmware vom Eeprom laden haben eventuell noch eine alte Version - bitte die Updates beachten.

« Letzte Änderung: Januar 29, 2022, 10:58:07 Vormittag von Sundtek »
Failure is a good thing! I'll fix it

chili

  • Newbie
  • *
  • Beiträge: 19
    • Profil anzeigen
Re: Ursachensuche Sky Ultimate Dual on Pi4 mit TVHeadend
« Antwort #2 am: Februar 22, 2022, 08:42:09 Nachmittag »
So. Seit gestern sind wieder die Satellite Config des VIII Dualtuners weg und kommen auch in TVHeadend nicht wieder.
Bisher habe ich TV-Headend komplett gelöscht (apt remove purge) und neu installiert und konnte dann auch den VIII wieder in Betrieb nehmen.
Jetzt hab ich es mal so gelassen und warte auf Hilfe.

Der VI funktioniert hingegen seid Jahren zuverlässig. Mein Problem ist der VIII Dual an Pi4 mit  Debian

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8433
    • Profil anzeigen
Re: Ursachensuche Sky Ultimate Dual on Pi4 mit TVHeadend
« Antwort #3 am: Februar 22, 2022, 09:10:00 Nachmittag »
Defekte SD Karte? So einfach verschwinden sollte im TVHeadend nichts.
Failure is a good thing! I'll fix it

chili

  • Newbie
  • *
  • Beiträge: 19
    • Profil anzeigen
Re: Ursachensuche Sky Ultimate Dual on Pi4 mit TVHeadend
« Antwort #4 am: Februar 22, 2022, 10:57:17 Nachmittag »
Nein. Ich lösche jetzt mal TV Headend wieder und richte es komplett neu ein.

Wie gehabt. Gelöscht, Wieder installiert. Aktuell scannen alle 3 Tuner die Channels.

Mal sehen wie lange es diesmal dauert.
« Letzte Änderung: Februar 22, 2022, 11:59:53 Nachmittag von chili »

chili

  • Newbie
  • *
  • Beiträge: 19
    • Profil anzeigen
Re: Ursachensuche Sky Ultimate Dual on Pi4 mit TVHeadend
« Antwort #5 am: März 22, 2022, 10:56:36 Vormittag »
So. Anscheinend hat sich mein Problem gelöst.
Ich hab jetzt den TV-Adapter auf 4-Port switch (Universal LNB) gelassen und anscheinend gibt es jetzt keine Probleme mehr.
Ich beobachte weiter und melde mich im Zweifel wieder

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8433
    • Profil anzeigen
Re: Ursachensuche Sky Ultimate Dual on Pi4 mit TVHeadend
« Antwort #6 am: April 08, 2022, 08:40:20 Vormittag »
Der Tuner verschwindet normalerweise nur wenn das System zu wenig Power hat und das Netzteil nicht angeschlossen ist.
Bei Dual Tunern werden ca 450mA benötigt bei 5V (=ca 2.5W vom System) das Netzteil ist nur für den LNB Betrieb zuständig.
Das bitte beim Netzteil beachten.

Sollte es sonst noch irgendwas geben lade die "dmesg" Ausgabe hier hoch.
« Letzte Änderung: April 08, 2022, 10:33:35 Nachmittag von Sundtek »
Failure is a good thing! I'll fix it

chili

  • Newbie
  • *
  • Beiträge: 19
    • Profil anzeigen
Re: Ursachensuche Sky Ultimate Dual on Pi4 mit TVHeadend
« Antwort #7 am: Mai 17, 2022, 10:31:53 Vormittag »
Noch einmal ein Feedback. Läuft jetzt stabil.
Vielleicht noch ein Hinweis.
Ich hab jetzt im Home-Verzeichnis den .hts Ordner gesichert und hoffe mir dadurch im Fall der Fälle die Neueinrichtung zu sparen.
Vor allem das Abonnieren und nachträgliches rausschmeissen der uninteressanten Kanäle war immer lästig.


Edit: Nachdem ich wieder den Sky Ultimate Dual im TV-Headend auf dem Pi4 verloren hatte hatte ich dich per Mail angeschrieben. Aber keine Antwort erhalten. Ich hänge den Auszug des  dmesg hier noch einmal an:

input: Sundtek Remote Control as /devices/virtual/input/input1
fuse: init (API version 7.32)
usb 1-1.4: device descriptor read/64, error -110
usb 1-1.4: new high-speed USB device number 5 using xhci_hcd
usb 1-1.4: device descriptor read/64, error -110
usb 1-1.4: device descriptor read/64, error -110
usb 1-1-port4: attempt power cycle
usb 1-1.4: new high-speed USB device number 6 using xhci_hcd
usb 1-1.4: device descriptor read/8, error -110
usb 1-1.4: device descriptor read/8, error -110
usb 1-1.4: new high-speed USB device number 7 using xhci_hcd
usb 1-1.4: device descriptor read/8, error -110
usb 1-1.4: device descriptor read/8, error -110
usb 1-1-port4: unable to enumerate USB device
usb 1-1.3: usbfs: process 529 (mediasrv) did not claim interface 2 before use

Die Mail schickte ich dir am 11.08. - bekam aber keine Antwort.
« Letzte Änderung: August 26, 2022, 04:03:25 Nachmittag von chili »

chili

  • Newbie
  • *
  • Beiträge: 19
    • Profil anzeigen
Re: Ursachensuche Sky Ultimate Dual on Pi4 mit TVHeadend
« Antwort #8 am: August 28, 2022, 02:37:13 Nachmittag »
Hmm. Editieren des letzten Beitrages wird hier anscheinend nicht angezeigt.
Wie gesagt. Der Sky Ultimate Dual war wieder plötzlich weg.
Ich hab, wie du empfohlen hast, vor kurzem den Cron-Job zu täglichen Neustart herausgenommen und nun taucht das Problem wieder auf. Siehe im obigen Beitrag den Auszug aus dmesg bevor ich den Pi4 wieder neustartete.

Das passiert irgendwann, aber nur mit dem Dual. Der Sky Ultimate 6 läuft dauerhaft zuverlässig.
Undervoltage habe ich auch nicht mehr.


chili

  • Newbie
  • *
  • Beiträge: 19
    • Profil anzeigen
Re: Ursachensuche Sky Ultimate Dual on Pi4 mit TVHeadend
« Antwort #9 am: August 06, 2023, 07:45:45 Nachmittag »
Es ist wieder passiert.
Die LNBs des Sky Ultimate VIII Dual sind wieder verschwunden und tauchen auch nicht nach einem Reboot im TVHeadend wieder auf.
Hardware ist jetzt seit 3 Monaten ein Fujitsu S740 mit Proxmox und einem LXC Container. Also mehr Power.
Es lief jetzt mehr als einen Monat zuverlässig. Jetzt habe ich wieder das gleiche Problem.
Historie:
Anfangs hatte ich den Sky Ultimate VI und den Sky Ultimate VIII dual an einem Raspberry Pi4.
Sky VI ist einfach ein Felsen, der läuft und läuft und liefert störungsfreie Streams auf allen Sendern.
Der Sky VIII Dual hat von Anfang an bei Privaten wie Nitro etc. immer wieder Klötzchenbildung und/oder Aussetzer, nicht aber bei ÖR
Ebenfalls von Anfang an, auch an verschiedenen Antennenanschlüssen, verschwinden zudem irgendwann die LNBs des VIII im TVHeadend unter "Configuration" "DVB Inputs"
Sie sind auch nicht durch reboots wieder zu beleben. Bisher habe ich immer TVHeadend "removed --purge" und komplett neu installiert. Dann waren die LNBs wieder da für ein paar Wochen.

Was habe ich bisher gemacht:
1. Pi4 mit neuem 3A Netzteil - keine Fehlermeldungen mehr im dmesg (Low Voltage)
2. Pi4 mit USB Y-Kabel und zusätzlicher Spannungsversorgung um die Spannungsversorgung noch mehr zu stabilisieren
3. Entfernen der Dect-Telefone aus dem Umfeld des Tuners (Verdacht auf Störeinwirkungen)
4. Umzug auf neue Hardware (Fujitsu Futro S740) mit LXC-Container unter Proxmox

Das Fehlerbild ist immer das gleiche. Mittlerweile gehe ich von einem Problem direkt auf dem Tuner aus.

Kann ich euch den Sky Ultimate Dual VIII schicken zum überprüfen?

Der VIII treibt mich in den Wahnsinn.

hier mal die Ausgabe von:
/opt/bin/mediaclient --testastra -d /dev/dvb/adapter0/frontend0
Testing Astra 19.2 Frequencies
DVBS
LO Band / 18V:
Checking for lock:
..........
LO Band / 13V:
Checking for lock:
. [LOCKED]
HI Band / 18V:
Checking for lock:
. [LOCKED]
HI Band / 13V:
Checking for lock:
. [LOCKED]
DVB-S2 ZDF HD / 18V
Checking for lock:
.. [LOCKED]

/opt/bin/mediaclient --testastra -d /dev/dvb/adapter1/frontend0
Testing Astra 19.2 Frequencies
DVBS
LO Band / 18V:
Checking for lock:
..........
LO Band / 13V:
Checking for lock:
..........
HI Band / 18V:
Checking for lock:
..........
HI Band / 13V:
Checking for lock:
..........
DVB-S2 ZDF HD / 18V
Checking for lock:
..........

/opt/bin/mediaclient --testastra -d /dev/dvb/adapter2/frontend0
Testing Astra 19.2 Frequencies
DVBS
LO Band / 18V:
Checking for lock:
..........
LO Band / 13V:
Checking for lock:
..........
HI Band / 18V:
Checking for lock:
..........
HI Band / 13V:
Checking for lock:
..........
DVB-S2 ZDF HD / 18V
Checking for lock:
..........


dmesg bringt keine Fehlermeldungen

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8433
    • Profil anzeigen
Re: Ursachensuche Sky Ultimate Dual on Pi4 (alt) + Fujitsu Futro S740 mit TVHeadend
« Antwort #10 am: August 15, 2023, 04:32:03 Vormittag »
Ich denke ich hatte das Thema ausgiebig (via Mail) beantwortet, zuerst muss einmal die Sat Anlage in Ordnung gebracht werden - Klötzchen im Bild deuten auf ein Problem mit der Sat Anlage hin.

Gerade Klötzchen bei den Privaten dürften nicht vorkommen, die Tuner wurden an unserer Sat Anlage getestet und diese treten dort nicht auf. Klötzchen bei den Privaten dürfen nicht vorkommen!

Somit bleiben eigentlich nur zwei Möglichkeiten.
1. Die Sat-Anlage ist nicht ordentlich ausgerichtet und der Tuner tut sich einfach sehr schwer die Sender zu dekodieren und benötigt daher wohl mehr Strom als der Raspberry PI bei Dir liefern kann.
2. Der Tuner ist tatsächlich defekt, das kann man aber eigentlich ausschließen wenn beide Tuner das gleiche Ergebnis für die privaten Sender auf Deiner Seite liefern.
Failure is a good thing! I'll fix it

chili

  • Newbie
  • *
  • Beiträge: 19
    • Profil anzeigen
Re: Ursachensuche Sky Ultimate Dual on Pi4 (alt) + Fujitsu Futro S740 mit TVHeadend
« Antwort #11 am: August 15, 2023, 06:39:47 Vormittag »
Prinzipiell ginge ich da ja mit, Aber:
1. Warum hat der Sky Ultimate VI am gleichen Koax diese Probleme nicht?
2. Warum verschwinden die beiden LNBs im TVHeadend unter "Configuration" "DVB-Inputs" "TV-Adapters"

Und zu zweitens - kann ich die wenigstens irgendwie wieder installieren/einbinden ohne apt remove -purge TVHeadend?
Wenn ich das wenigstens alle 1-2 Monate reparieren kann ohne das TVHeadend komplett von 0 neu zu installieren und zu konfigurieren.

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8433
    • Profil anzeigen
Re: Ursachensuche Sky Ultimate Dual on Pi4 (alt) + Fujitsu Futro S740 mit TVHeadend
« Antwort #12 am: August 15, 2023, 08:41:31 Vormittag »
Zwei verschwinden da der Tuner über einen USB Port angebunden ist.

Wie sind die Tuner dort angebunden über ein Multiswitch?
Wie sieht die Signalstatistik auf einem betroffenen Sender mit Klötzchen aus?

/opt/bin/mediaclient --readsignal=0 -d /dev/dvb/adapter0/frontend0 --band universal
(oder adapter1)

Die BER sollte stets 0 sein.


Es muss kein remove --purge durchgeführt werden, ein service tvheadend restart sollte ausreichen (wenn /opt/bin/mediaclient -e Tuner anzeigt).

Vielleicht die Logfile des Tuners einschalten
/etc/sundtek.conf erzeugen und dort loglevel=min einfügen (denke das sollte ausreichen um zu sehen welche Frequenz der Tuner eingeschalten hatte). Anschließend den Treiber neu starten (oder einfach das System neu starten um den Treiber neu zu starten).

Auch sicherstellen dass der aktuelle Treiber installiert ist, der Treiber vor 1-2 Jahren hatte tatsächlich einen Fehler wodurch sich die Tuner gegenseitig beeinflusst haben.
Failure is a good thing! I'll fix it

chili

  • Newbie
  • *
  • Beiträge: 19
    • Profil anzeigen
Re: Ursachensuche Sky Ultimate Dual on Pi4 (alt) + Fujitsu Futro S740 mit TVHeadend
« Antwort #13 am: August 15, 2023, 04:49:53 Nachmittag »
/opt/bin/mediaclient -e zeigt:
**** List of Media Hardware Devices ****
device 0: [SkyTV Ultimate 6 2016/Q1]  DVB-S/S2, ANALOG-TV, REMOTE-CONTROL, OSS-AUDIO
  [INFO]:
     STATUS: ACTIVE
  [BUS]:
     ID: 1-8.1
  [SERIAL]:
     ID: U180216131419
  [DVB-S/S2]:
     FESTATUS: ACTIVE
     LNBVOLTAGE: ENABLED
     LNBSUPPLY: USBPOWER
     LNBSTATUS: OK
     FRONTEND: /dev/dvb/adapter0/frontend0
     DVR: /dev/dvb/adapter0/dvr0
     DMX: /dev/dvb/adapter0/demux0
  [ANALOG-TV]:
     VIDEO0: /dev/video0
     VBI0: /dev/vbi0
  [REMOTECONTROL]:
     INPUT0: /dev/mediainput0
  [OSS]:
     OSS0: /dev/dsp0

device 1: [             Dual S2]  DVB-S/S2, REMOTE-CONTROL, DVB-S/S2
  [INFO]:
     STATUS: ACTIVE
  [BUS]:
     ID: 1-8.2
  [SERIAL]:
     ID: U200627083240
  [DVB-S/S2]:
     FESTATUS: ACTIVE
     LNBVOLTAGE: ENABLED
     LNBSUPPLY: USBPOWER
     LNBSTATUS: OK
     FRONTEND: /dev/dvb/adapter1/frontend0
     DVR: /dev/dvb/adapter1/dvr0
     DMX: /dev/dvb/adapter1/demux0
  [REMOTECONTROL]:
     INPUT0: /dev/mediainput1
  [DVB-S/S2]:
     FESTATUS: ACTIVE
     FRONTEND: /dev/dvb/adapter2/frontend0
     DVR: /dev/dvb/adapter2/dvr0
     DMX: /dev/dvb/adapter2/demux0

Beide Tuner sind also da, nach meiner Meinung. Restart TVHeadend bring die Tuner dort nicht zurück. Neustart des Linuxsystems ebenfalls nicht.
Ich hab auch bei den letzten verschwinden einfach den Setup-Wizard im TVHeadend neu ausgeführt aber auch dort tauchten die Tuner des Dual nicht auf.
Deswegen wurde ja bisher immer mit -purge TVheadend deinstalliert und komplett neuinstalliert und konfiguriert.
Wie gesagt. Der 6er ist absolut stabil.
« Letzte Änderung: August 15, 2023, 04:52:20 Nachmittag von chili »

chili

  • Newbie
  • *
  • Beiträge: 19
    • Profil anzeigen
Re: Ursachensuche Sky Ultimate Dual on Pi4 (alt) + Fujitsu Futro S740 mit TVHeadend
« Antwort #14 am: August 15, 2023, 05:16:40 Nachmittag »
Unter /home/hts/.hts/tvheadend/inputs/linuxdvb/adapters sind 2 kleine Tuner-configs (VIII) und eine grosse (VI)
Bei den kleinen fehlen die folgenden Zeilen

                       "satconf": {
                                "type": "simple",
                                "early_tune": true,
                                "diseqc_repeats": 0,
                                "diseqc_full": true,
                                "lnb_poweroff": false,
                                "lnb_highvol": 1,
                                "elements": [
                                        {
                                                "enabled": true,
                                                "priority": 0,
                                                "networks": [
                                                        "adc7961695378a6890ca0490518958d5"
                                                ],
                                                "lnb_type": "Universal",
                                                "uuid": "ddc0a106a64683399985a923fceb27eb",
                                                "lnb_conf": {
                                                }
                                        }
                                ],
                                "uuid": "b01e767ed9394eb22b40440ec2ce9d0f"
                        }
                }