Autor Thema: MiniPC mit 3 Sundtek-Recivers  (Gelesen 10988 mal)

hlzhnz

  • Newbie
  • *
  • Beiträge: 27
    • Profil anzeigen
MiniPC mit 3 Sundtek-Recivers
« am: Januar 08, 2016, 11:36:28 Vormittag »
Hallo,
ich habe einen MiniPc (Zotac ZBOX-ID41) mit 3 Sundteck Recivern:
ein Sundtek SkyTV Ultimate 5, ein Sundtek SkyTV II und für Digital-Terrestrisch den    
Sundtek TNT DVB-T.


Solange ich nur 2 Stick dran hatte, war alles OK, seitdem ich allerdings den Sundtek SkyTV Ultimate 5 dazugesteckt habe, hate ich immer wieder Probleme mit den Sticks.

Ab und zu hab ich ein paar "Klötzchen", das ist aber nur sehr selten und nicht schlimm.
Viel größer ist das Problem, dass sich einer der Sticks ab und zu "verabschiedet". Es erscheint dann ein "Channel: no data" Fehler am VDR.

Ich habe auch versucht verschiedene USB-Ports zu verwenden, und auch aktive USB-Hubs dazwischen zu schalten, richtig stabil läuft die Sache aber nicht mehr.

Es läuft VDR 2.2 auf ArchLinux, Kernel 4.3.3.

Danke & Grüsse
« Letzte Änderung: Januar 08, 2016, 02:57:53 Nachmittag von Sundtek »

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8317
    • Profil anzeigen
Re:MiniPC mit 3 Sundtek-Recivers
« Antwort #1 am: Januar 08, 2016, 02:49:13 Nachmittag »
Bezüglich des IIer Tuners schau dir mal das an:
http://support.sundtek.com/index.php/topic,1929.0.html

Ansonsten würde ich an Deiner stelle erst mal verschiedene Konstellationen durchtesten und den USB Port auf Maximallast laufen lassen.
1. DVB-T Tuner - einen Sender einstellen und die Daten streamen
2. die 2 Sat Tuner - jeweils einen Sender einstellen und Daten streamen

Am Besten testet man das mit diversen mediaclient Befehlen.

z.B
/opt/bin/mediaclient --testastra -d /dev/dvb/adapterN/frontend0
Sobald diese Frequenzen getestet wurden bleibt zum Schluss ZDF HD eingestellt

wobei adapterN der jeweilige Sat Adapter ist welchen du mit /opt/bin/mediaclient -e angezeigt bekommst.
Anschließend den Datentransfer auf einem Terminal anschauen und überprüfen

/opt/bin/mediaclient --cat /dev/dvb/adapterN/dvr0 | /opt/bin/mediaclient --pipecount=1000

Und für DVB-T
/opt/bin/mediaclient -m DVBT -f 506000000 -b 8 -d /dev/dvb/adapterN/frontend0
/opt/bin/mediaclient --cat /dev/dvb/adapterN | /opt/bin/mediaclient --pipecount=1000

Wenn der Datentransfer dann irgendwo abreisst ist es ein Anzeichen dafür das der USB Controller die Tuner nicht handlen kann.
Du solltest aber auch überprüfen welcher der Tuner Dir da Schwierigkeiten bereitet.

Du kannst auch einfach im Chat fragen falls Du dazu fragen hast.
« Letzte Änderung: Januar 08, 2016, 03:09:24 Nachmittag von Sundtek »
Failure is a good thing! I'll fix it

hlzhnz

  • Newbie
  • *
  • Beiträge: 27
    • Profil anzeigen
Re:MiniPC mit 3 Sundtek-Recivers
« Antwort #2 am: Januar 09, 2016, 09:13:21 Nachmittag »


Das habe ich nun alles ausprobiert. Ich habe 9 Aufnahmen zugleich gemacht und es 2 Stunden lang laufen lassen. Hierbei hat alles wunderbar funktioniert.. ist wohl der "Vorführeffekt" :-)

Mal sehen ob es stabil bleibt.

Danke!

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8317
    • Profil anzeigen
Re:MiniPC mit 3 Sundtek-Recivers
« Antwort #3 am: Januar 10, 2016, 12:50:05 Vormittag »
Scanne die DVB-S/S2 Sender am Besten über den neuen Tuner neu damit die Frequenztabellen auch aktuell sind.
Failure is a good thing! I'll fix it

hlzhnz

  • Newbie
  • *
  • Beiträge: 27
    • Profil anzeigen
Re:MiniPC mit 3 Sundtek-Recivers
« Antwort #4 am: Januar 10, 2016, 12:11:34 Nachmittag »
Nun ist es wieder passiert, dass nach dem reboot nur 2 von 3 Tunern verfügbar sind.
mediaclient -e listet nur den TVB-T und 5er DVB-S2 auf, der IIer fehlt.


Ist die Zbox mit 3 USB-Tunern überfordert?


Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8317
    • Profil anzeigen
Re:MiniPC mit 3 Sundtek-Recivers
« Antwort #5 am: Januar 10, 2016, 03:20:01 Nachmittag »
Logfiles.

1. Systemlog
dmesg

2. Treiberlog einschalten, aber bevor der Tuner verwendet wird (oder /etc/sundtek.conf erste Zeile loglevel=min):
/opt/bin/mediaclient --loglevel=min


Ich sehe der Rechner hat USB 3.0 Ports, nimm nur USB 2.0 Ports. USB 3.0 ist nicht zuverlässig mit USB 2.0 Geräten unter Linux (das ist ein Linux Bug kein Bug auf unserer Seite, es ist ein Software Bug im Linux USB Controller Treiber).
Mac und Windows haben damit keine Probleme.

Die Tuner müssen beim Auflisten mit lsusb -t unter ehci angezeigt werden.
« Letzte Änderung: Januar 10, 2016, 04:03:26 Nachmittag von Sundtek »
Failure is a good thing! I'll fix it

hlzhnz

  • Newbie
  • *
  • Beiträge: 27
    • Profil anzeigen
Re:MiniPC mit 3 Sundtek-Recivers
« Antwort #6 am: Januar 16, 2016, 06:54:02 Nachmittag »
[    0.855737] ACPI: bus type USB registered
[    0.855814] usbcore: registered new interface driver usbfs
[    0.855842] usbcore: registered new interface driver hub
[    0.855919] usbcore: registered new device driver usb
[    0.861233] ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver
[    0.862151] ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver
[    0.862569] ohci-pci: OHCI PCI platform driver
[    0.863254] QUIRK: Enable AMD PLL fix
[    0.863324] ohci-pci 0000:00:12.0: OHCI PCI host controller
[    0.863348] ohci-pci 0000:00:12.0: new USB bus registered, assigned bus number 1
[    0.863352] ehci-pci: EHCI PCI platform driver
[    0.863477] ohci-pci 0000:00:12.0: irq 18, io mem 0xfeb4e000
[    0.864157] xhci_hcd 0000:01:00.0: xHCI Host Controller
[    0.864183] xhci_hcd 0000:01:00.0: new USB bus registered, assigned bus number 2
[    0.864333] xhci_hcd 0000:01:00.0: hcc params 0x014042cb hci version 0x96 quirks 0x00000004
[    0.864882] hub 2-0:1.0: USB hub found
[    0.864904] hub 2-0:1.0: 2 ports detected
[    0.865182] xhci_hcd 0000:01:00.0: xHCI Host Controller
[    0.865194] xhci_hcd 0000:01:00.0: new USB bus registered, assigned bus number 3
[    0.869187] hub 3-0:1.0: USB hub found
[    0.869217] hub 3-0:1.0: 2 ports detected
[    0.869443] libata version 3.00 loaded.
[    0.918548] hub 1-0:1.0: USB hub found
[    0.918589] hub 1-0:1.0: 5 ports detected
[    0.919168] ohci-pci 0000:00:13.0: OHCI PCI host controller
[    0.919183] ohci-pci 0000:00:13.0: new USB bus registered, assigned bus number 4
[    0.919236] ohci-pci 0000:00:13.0: irq 18, io mem 0xfeb4c000
[    0.975048] hub 4-0:1.0: USB hub found
[    0.975088] hub 4-0:1.0: 5 ports detected
[    0.975661] ohci-pci 0000:00:14.5: OHCI PCI host controller
[    0.975675] ohci-pci 0000:00:14.5: new USB bus registered, assigned bus number 5
[    0.975727] ohci-pci 0000:00:14.5: irq 18, io mem 0xfeb4a000
[    1.031486] hub 5-0:1.0: USB hub found
[    1.031511] hub 5-0:1.0: 2 ports detected
[    1.032235] ehci-pci 0000:00:12.2: EHCI Host Controller
[    1.032251] ehci-pci 0000:00:12.2: new USB bus registered, assigned bus number 6
[    1.032262] ehci-pci 0000:00:12.2: applying AMD SB700/SB800/Hudson-2/3 EHCI dummy qh workaround
[    1.032294] ehci-pci 0000:00:12.2: debug port 1
[    1.032369] ehci-pci 0000:00:12.2: irq 17, io mem 0xfeb4d000
[    1.040514] ehci-pci 0000:00:12.2: USB 2.0 started, EHCI 1.00
[    1.041209] hub 6-0:1.0: USB hub found
[    1.041233] hub 6-0:1.0: 5 ports detected
[    1.097344] hub 1-0:1.0: USB hub found
[    1.097386] hub 1-0:1.0: 5 ports detected
[    1.098176] ehci-pci 0000:00:13.2: EHCI Host Controller
[    1.098191] ehci-pci 0000:00:13.2: new USB bus registered, assigned bus number 7
[    1.098201] ehci-pci 0000:00:13.2: applying AMD SB700/SB800/Hudson-2/3 EHCI dummy qh workaround
[    1.098218] ehci-pci 0000:00:13.2: debug port 1
[    1.098276] ehci-pci 0000:00:13.2: irq 17, io mem 0xfeb4b000
[    1.107161] ehci-pci 0000:00:13.2: USB 2.0 started, EHCI 1.00
[    1.107874] hub 7-0:1.0: USB hub found
[    1.107911] hub 7-0:1.0: 5 ports detected
[    1.164026] hub 4-0:1.0: USB hub found
[    1.164069] hub 4-0:1.0: 5 ports detected
[    1.164641] ehci-pci 0000:00:16.2: EHCI Host Controller
[    1.164656] ehci-pci 0000:00:16.2: new USB bus registered, assigned bus number 8
[    1.164667] ehci-pci 0000:00:16.2: applying AMD SB700/SB800/Hudson-2/3 EHCI dummy qh workaround
[    1.164698] ehci-pci 0000:00:16.2: debug port 1
[    1.164756] ehci-pci 0000:00:16.2: irq 17, io mem 0xfeb48000
[    1.173841] ehci-pci 0000:00:16.2: USB 2.0 started, EHCI 1.00
[    1.174562] hub 8-0:1.0: USB hub found
[    1.174587] hub 8-0:1.0: 4 ports detected
[    1.177179] scsi host0: pata_atiixp
[    1.177434] scsi host1: pata_atiixp
[    1.177553] ata1: PATA max UDMA/100 cmd 0x1f0 ctl 0x3f6 bmdma 0xf100 irq 14
[    1.177558] ata2: PATA max UDMA/100 cmd 0x170 ctl 0x376 bmdma 0xf108 irq 15
[    1.177705] ahci 0000:00:11.0: version 3.0
[    1.178018] ahci 0000:00:11.0: AHCI 0001.0200 32 slots 4 ports 6 Gbps 0xf impl SATA mode
[    1.178026] ahci 0000:00:11.0: flags: 64bit ncq sntf ilck pm led clo pmp pio slum part sxs
[    1.179585] scsi host2: ahci
[    1.179838] scsi host3: ahci
[    1.180052] scsi host4: ahci
[    1.180337] scsi host5: ahci
[    1.180455] ata3: SATA max UDMA/133 abar m1024@0xfeb4f000 port 0xfeb4f100 irq 19
[    1.180461] ata4: SATA max UDMA/133 abar m1024@0xfeb4f000 port 0xfeb4f180 irq 19
[    1.180466] ata5: SATA max UDMA/133 abar m1024@0xfeb4f000 port 0xfeb4f200 irq 19
[    1.180470] ata6: SATA max UDMA/133 abar m1024@0xfeb4f000 port 0xfeb4f280 irq 19
[    1.180771] ohci-pci 0000:00:16.0: OHCI PCI host controller
[    1.180797] ohci-pci 0000:00:16.0: new USB bus registered, assigned bus number 9
[    1.180848] ohci-pci 0000:00:16.0: irq 18, io mem 0xfeb49000
[    1.238596] hub 9-0:1.0: USB hub found
[    1.238640] hub 9-0:1.0: 4 ports detected
[    1.346926] usb 6-1: new high-speed USB device number 2 using ehci-pci
[    1.413857] usb 7-4: new high-speed USB device number 2 using ehci-pci
[    1.477207] usb 6-1: device descriptor read/64, error -71
[    1.500548] ata6: SATA link down (SStatus 0 SControl 300)
[    1.500599] ata5: SATA link down (SStatus 0 SControl 300)
[    1.500641] ata4: SATA link down (SStatus 0 SControl 300)
[    1.513844] tsc: Refined TSC clocksource calibration: 1600.000 MHz
[    1.667184] ata3: SATA link up 3.0 Gbps (SStatus 123 SControl 300)
[    1.692575] ata3.00: ATA-8: TOSHIBA MQ01ABB200, AY000U, max UDMA/100
[    1.692592] ata3.00: 3907029168 sectors, multi 16: LBA48 NCQ (depth 31/32), AA
[    1.695377] ata3.00: configured for UDMA/100
[    1.695989] scsi 2:0:0:0: Direct-Access     ATA      TOSHIBA MQ01ABB2 0U   PQ: 0 ANSI: 5
[    1.704680] sd 2:0:0:0: [sda] 3907029168 512-byte logical blocks: (2.00 TB/1.81 TiB)
[    1.704690] sd 2:0:0:0: [sda] 4096-byte physical blocks
[    1.704838] sd 2:0:0:0: [sda] Write Protect is off
[    1.704845] sd 2:0:0:0: [sda] Mode Sense: 00 3a 00 00
[    1.704898] sd 2:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[    1.710549] usb 6-1: device descriptor read/64, error -71
[    1.830089]  sda: sda1 sda127 sda128
[    1.831375] sd 2:0:0:0: [sda] Attached SCSI disk
[    1.920562] usb 6-1: new high-speed USB device number 3 using ehci-pci
[    2.053884] usb 6-1: device descriptor read/64, error -71
[    2.293643] raid6: sse2x1    1034 MB/s
[    2.293657] usb 6-1: device descriptor read/64, error -71
[    2.350260] raid6: sse2x2    1057 MB/s
[    2.406910] raid6: sse2x4    2223 MB/s
[    2.406914] raid6: using algorithm sse2x4 (2223 MB/s)
[    2.406917] raid6: using ssse3x2 recovery algorithm
[    2.407532] xor: measuring software checksum speed
[    2.440324]    prefetch64-sse:  3237.600 MB/sec
[    2.473632]    generic_sse:  3186.000 MB/sec
[    2.473642] xor: using function: prefetch64-sse (3237.600 MB/sec)
[    2.514117] Switched to clocksource tsc
[    2.527206] usb 6-1: new high-speed USB device number 4 using ehci-pci
[    2.538317] Btrfs loaded
[    2.564564] BTRFS: device label root devid 1 transid 288957 /dev/sda1
[    2.947138] usb 6-1: device not accepting address 4, error -71
[    3.044198] BTRFS info (device sda1): disk space caching is enabled
[    3.044210] BTRFS: has skinny extents
[    3.053863] usb 6-1: new high-speed USB device number 5 using ehci-pci
[    3.473803] usb 6-1: device not accepting address 5, error -71
[    3.474538] usb usb6-port1: unable to enumerate USB device
[    3.543080] random: nonblocking pool is initialized
[    3.590525] usb 6-2: new high-speed USB device number 6 using ehci-pci
[    3.777168] usb 1-1: new full-speed USB device number 2 using ohci-pci
[    3.910507] usb 1-1: device descriptor read/64, error -62
[    4.147178] usb 1-1: device descriptor read/64, error -62
[    4.380512] usb 1-1: new full-speed USB device number 3 using ohci-pci
[    4.513864] usb 1-1: device descriptor read/64, error -62
[    4.750500] usb 1-1: device descriptor read/64, error -62
[    4.983844] usb 1-1: new full-speed USB device number 4 using ohci-pci
[    5.390472] usb 1-1: device not accepting address 4, error -62
[    5.520520] usb 1-1: new full-speed USB device number 5 using ohci-pci
[    5.927126] usb 1-1: device not accepting address 5, error -62
[    5.927875] usb usb1-port1: unable to enumerate USB device
[   25.954069] ip_tables: (C) 2000-2006 Netfilter Core Team
[   25.994563] systemd[1]: systemd 228 running in system mode. (+PAM -AUDIT -SELINUX -IMA -APPARMOR +SMACK -SYSVINIT +UTMP +LIBCRYPTSETUP +GCRYPT +GNUTLS +ACL +XZ +LZ4 +SECCOMP +BLKID +ELFUTILS +KMOD +IDN)
[   25.994960] systemd[1]: Detected architecture x86-64.
[   26.013197] systemd[1]: Set hostname to <zbox>.
[   27.388862] systemd[1]: display-manager.service: Cannot add dependency job, ignoring: Unit display-manager.service failed to load: No such file or directory.
[   27.390120] systemd[1]: Listening on Journal Socket (/dev/log).
[   27.390441] systemd[1]: Listening on udev Control Socket.
[   27.390522] systemd[1]: Listening on /dev/initctl Compatibility Named Pipe.
[   27.390631] systemd[1]: Started Dispatch Password Requests to Console Directory Watch.
[   27.390715] systemd[1]: Listening on Journal Socket.
[   27.390758] systemd[1]: Reached target Encrypted Volumes.
[   27.430900] systemd[1]: Listening on udev Kernel Socket.
[   27.431783] systemd[1]: Created slice User and Session Slice.
[   27.431818] systemd[1]: Reached target Remote File Systems.
[   27.432046] systemd[1]: Created slice System Slice.
[   27.432314] systemd[1]: Created slice system-getty.slice.
[   27.432537] systemd[1]: Created slice system-netctl.slice.
[   27.444911] systemd[1]: Starting Apply Kernel Variables...
[   27.446454] systemd[1]: Mounting Temporary Directory...
[   27.448386] systemd[1]: Starting Setup Virtual Console...
[   27.449993] systemd[1]: Mounting Debug File System...
[   27.451677] systemd[1]: Mounting Configuration File System...
[   27.453233] systemd[1]: Mounting POSIX Message Queue File System...
[   27.453456] systemd[1]: Started Forward Password Requests to Wall Directory Watch.
[   27.455201] systemd[1]: Starting Journal Service...
[   27.455250] systemd[1]: Reached target Slices.
[   27.455404] systemd[1]: Listening on LVM2 metadata daemon socket.
[   27.455503] systemd[1]: Listening on Device-mapper event daemon FIFOs.
[   27.457193] systemd[1]: Starting Remount Root and Kernel File Systems...
[   27.459064] systemd[1]: Starting Create list of required static device nodes for the current kernel...
[   27.459140] systemd[1]: Reached target Paths.
[   27.463448] systemd[1]: Mounting Huge Pages File System...
[   27.464024] systemd[1]: Set up automount Arbitrary Executable File Formats File System Automount Point.
[   27.468209] systemd[1]: Started Create list of required static device nodes for the current kernel.
[   27.890406] systemd[1]: Started Apply Kernel Variables.
[   28.001561] systemd[1]: Mounted Configuration File System.
[   28.066780] systemd[1]: Mounted POSIX Message Queue File System.
[   28.066955] systemd[1]: Mounted Temporary Directory.
[   28.068295] BTRFS info (device sda1): disk space caching is enabled
[   28.070430] systemd[1]: Mounted Debug File System.
[   28.071105] systemd[1]: Started Remount Root and Kernel File Systems.
[   28.071379] systemd[1]: Mounted Huge Pages File System.
[   28.123208] systemd[1]: Starting udev Coldplug all Devices...
[   28.125041] systemd[1]: Starting Load/Save Random Seed...
[   28.128185] systemd[1]: Starting Create Static Device Nodes in /dev...
[   28.481218] systemd[1]: Started Load/Save Random Seed.
[   28.725468] systemd[1]: Started Create Static Device Nodes in /dev.
[   28.725689] systemd[1]: Reached target Local File Systems (Pre).
[   28.727284] systemd[1]: Starting udev Kernel Device Manager...
[   28.948270] systemd[1]: Started udev Coldplug all Devices.
[   28.948592] systemd[1]: Started Journal Service.
[   29.100863] systemd-journald[171]: Received request to flush runtime journal from PID 1
[   30.755195] input: Power Button as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input2
[   30.755209] ACPI: Power Button [PWRB]
[   30.755329] input: Lid Switch as /devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0D:00/input/input3
[   30.755384] ACPI: Lid Switch [LID]
[   30.755483] input: Power Button as /devices/LNXSYSTM:00/LNXPWRBN:00/input/input4
[   30.755488] ACPI: Power Button [PWRF]
[   30.991093] shpchp: Standard Hot Plug PCI Controller Driver version: 0.4
[   31.711334] piix4_smbus 0000:00:14.0: SMBus Host Controller at 0xb00, revision 0
[   31.711456] piix4_smbus 0000:00:14.0: Auxiliary SMBus Host Controller at 0xb20
[   31.844710] sp5100_tco: SP5100/SB800 TCO WatchDog Timer Driver v0.05
[   31.844845] sp5100_tco: PCI Revision ID: 0x42
[   31.844914] sp5100_tco: Using 0xfed80b00 for watchdog MMIO address
[   31.844927] sp5100_tco: Last reboot was not triggered by watchdog.
[   31.845149] sp5100_tco: initialized (0xffffc90000648b00). heartbeat=60 sec (nowayout=0)
[   31.958851] [drm] Initialized drm 1.1.0 20060810
[   32.344207] BTRFS: could not find root 8
[   32.395073] sound hdaudioC1D0: autoconfig for ALC892: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:line
[   32.395085] sound hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[   32.395091] sound hdaudioC1D0:    hp_outs=0 (0x0/0x0/0x0/0x0/0x0)
[   32.395095] sound hdaudioC1D0:    mono: mono_out=0x0
[   32.395099] sound hdaudioC1D0:    dig-out=0x1e/0x0
[   32.395102] sound hdaudioC1D0:    inputs:
[   32.395107] sound hdaudioC1D0:      Mic=0x18
[   32.402175] input: HD-Audio Generic HDMI/DP,pcm=3 as /devices/pci0000:00/0000:00:01.1/sound/card0/input5
[   32.412588] input: HDA ATI SB Mic as /devices/pci0000:00/0000:00:14.2/sound/card1/input6
[   32.412669] input: HDA ATI SB Line Out as /devices/pci0000:00/0000:00:14.2/sound/card1/input7
[   32.426418] Adding 4195324k swap on /dev/sda127.  Priority:-1 extents:1 across:4195324k FS
[   32.655599] cfg80211: Calling CRDA to update world regulatory domain
[   32.717766] r8169 Gigabit Ethernet driver 2.3LK-NAPI loaded
[   32.717796] r8169 0000:06:00.0: can't disable ASPM; OS doesn't have ASPM control
[   32.718543] r8169 0000:06:00.0 eth0: RTL8168e/8111e at 0xffffc9001075e000, 00:01:2e:3a:e3:24, XID 0c200000 IRQ 28
[   32.718549] r8169 0000:06:00.0 eth0: jumbo features [frames: 9200 bytes, tx checksumming: ko]
[   32.758858] [drm] radeon kernel modesetting enabled.
[   32.959342] ieee80211 phy0: rt2x00_set_rt: Info - RT chipset 2872, rev 0200 detected
[   32.978291] ieee80211 phy0: rt2x00_set_rf: Info - RF chipset 0003 detected
[   33.048788] AMD IOMMUv2 driver by Joerg Roedel <jroedel@suse.de>
[   33.048797] AMD IOMMUv2 functionality not available on this system
[   33.109649] CRAT table not found
[   33.109659] Finished initializing topology ret=0
[   33.109763] kfd kfd: Initialized module
[   33.110550] checking generic (b0000000 130000) vs hw (b0000000 10000000)
[   33.110560] fb: switching to radeondrmfb from VESA VGA
[   33.110609] Console: switching to colour dummy device 80x25
[   33.112461] [drm] initializing kernel modesetting (PALM 0x1002:0x9802 0x19DA:0xA183).
[   33.112497] [drm] register mmio base: 0xFEB00000
[   33.112500] [drm] register mmio size: 262144
[   33.112593] ATOM BIOS: AMD
[   33.112676] radeon 0000:00:01.0: VRAM: 384M 0x0000000000000000 - 0x0000000017FFFFFF (384M used)
[   33.112682] radeon 0000:00:01.0: GTT: 1024M 0x0000000018000000 - 0x0000000057FFFFFF
[   33.112686] [drm] Detected VRAM RAM=384M, BAR=256M
[   33.112689] [drm] RAM width 32bits DDR
[   33.112898] [TTM] Zone  kernel: Available graphics memory: 1822826 kiB
[   33.112902] [TTM] Initializing pool allocator
[   33.112914] [TTM] Initializing DMA pool allocator
[   33.112966] [drm] radeon: 384M of VRAM memory ready
[   33.112970] [drm] radeon: 1024M of GTT memory ready.
[   33.112999] [drm] Loading PALM Microcode
[   33.185959] ieee80211 phy0: Selected rate control algorithm 'minstrel_ht'
[   33.269267] [drm] Internal thermal controller without fan control
[   33.269398] [drm] Found smc ucode version: 0x00010200
[   33.269490] [drm] radeon: dpm initialized
[   33.310204] [drm] GART: num cpu pages 262144, num gpu pages 262144
[   33.320980] [drm] PCIE GART of 1024M enabled (table at 0x0000000000274000).
[   33.321217] radeon 0000:00:01.0: WB enabled
[   33.321224] radeon 0000:00:01.0: fence driver on ring 0 use gpu addr 0x0000000018000c00 and cpu addr 0xffff8801478fdc00
[   33.321230] radeon 0000:00:01.0: fence driver on ring 3 use gpu addr 0x0000000018000c0c and cpu addr 0xffff8801478fdc0c
[   33.322007] radeon 0000:00:01.0: fence driver on ring 5 use gpu addr 0x0000000000072118 and cpu addr 0xffffc90011b32118
[   33.322012] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[   33.322014] [drm] Driver supports precise vblank timestamp query.
[   33.322018] radeon 0000:00:01.0: radeon: MSI limited to 32-bit
[   33.322079] radeon 0000:00:01.0: radeon: using MSI.
[   33.322121] [drm] radeon: irq initialized.
[   33.341271] [drm] ring test on 0 succeeded in 1 usecs
[   33.341290] [drm] ring test on 3 succeeded in 3 usecs
[   33.387419] [drm] ring test on 5 succeeded in 1 usecs
[   33.407447] [drm] UVD initialized successfully.
[   33.408253] [drm] ib test on ring 0 succeeded in 0 usecs
[   33.408302] [drm] ib test on ring 3 succeeded in 0 usecs
[   33.435654] input: PC Speaker as /devices/platform/pcspkr/input/input9
[   33.662081] kvm: disabled by bios
[   33.686282] BTRFS: could not find root 8
[   33.731398] microcode: CPU0: new patch_level=0x05000029
[   33.737680] microcode: CPU1: new patch_level=0x05000029
[   33.926958] [drm] ib test on ring 5 succeeded
[   33.953021] r8169 0000:06:00.0 enp6s0: renamed from eth0
[   33.963173] [drm] Radeon Display Connectors
[   33.963182] [drm] Connector 0:
[   33.963185] [drm]   DP-1
[   33.963187] [drm]   HPD1
[   33.963192] [drm]   DDC: 0x6430 0x6430 0x6434 0x6434 0x6438 0x6438 0x643c 0x643c
[   33.963195] [drm]   Encoders:
[   33.963198] [drm]     DFP1: INTERNAL_UNIPHY
[   33.963201] [drm] Connector 1:
[   33.963203] [drm]   HDMI-A-1
[   33.963205] [drm]   HPD2
[   33.963208] [drm]   DDC: 0x6440 0x6440 0x6444 0x6444 0x6448 0x6448 0x644c 0x644c
[   33.963210] [drm]   Encoders:
[   33.963213] [drm]     DFP2: INTERNAL_UNIPHY
[   33.963215] [drm] Connector 2:
[   33.963217] [drm]   VGA-1
[   33.963220] [drm]   DDC: 0x64d8 0x64d8 0x64dc 0x64dc 0x64e0 0x64e0 0x64e4 0x64e4
[   33.963222] [drm]   Encoders:
[   33.963225] [drm]     CRT1: INTERNAL_KLDSCP_DAC1
[   33.975609] rt2800pci 0000:03:00.0 wlp3s0: renamed from wlan0
[   33.980663] radeon 0000:00:01.0: No connectors reported connected with modes
[   33.980683] [drm] Cannot find any crtc or sizes - going 1024x768
[   33.981992] [drm] fb mappable at 0xB0478000
[   33.981996] [drm] vram apper at 0xB0000000
[   33.981998] [drm] size 3145728
[   33.982001] [drm] fb depth is 24
[   33.982003] [drm]    pitch is 4096
[   33.982189] fbcon: radeondrmfb (fb0) is primary device
[   33.982367] Console: switching to colour frame buffer device 128x48
[   33.987375] radeon 0000:00:01.0: fb0: radeondrmfb frame buffer device
[   33.987378] radeon 0000:00:01.0: registered panic notifier
[   34.000667] [drm] Initialized radeon 2.41.0 20080528 for 0000:00:01.0 on minor 0
[   35.671006] r8169 0000:06:00.0 enp6s0: link down
[   35.671028] r8169 0000:06:00.0 enp6s0: link down
[   35.671155] IPv6: ADDRCONF(NETDEV_UP): enp6s0: link is not ready
[   37.331145] r8169 0000:06:00.0 enp6s0: link up
[   37.331172] IPv6: ADDRCONF(NETDEV_CHANGE): enp6s0: link becomes ready
[   41.989940] input: Sundtek Ltd. Remote Control as /devices/virtual/input/input10
[   48.788128] input: Sundtek Ltd. Remote Control as /devices/virtual/input/input11

hlzhnz

  • Newbie
  • *
  • Beiträge: 27
    • Profil anzeigen
Re:MiniPC mit 3 Sundtek-Recivers
« Antwort #7 am: Januar 16, 2016, 06:59:05 Nachmittag »
Ich habe inzwischen den PC gewechselt, nun ist es eine andere zotac zbox AD10 mit e350.
Ein paar Tage lief alles super, jetzt fehlt wieder der DVB-T Tuner.

root@zbox:~# lsusb -t
/:  Bus 09.Port 1: Dev 1, Class=root_hub, Driver=ohci-pci/4p, 12M
/:  Bus 08.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/4p, 480M
/:  Bus 07.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/5p, 480M
    |__ Port 4: Dev 2, If 0, Class=Vendor Specific Class, Driver=, 480M
/:  Bus 06.Port 1: Dev 1, Class=root_hub, Driver=ehci-pci/5p, 480M
    |__ Port 2: Dev 6, If 0, Class=Vendor Specific Class, Driver=, 480M
    |__ Port 2: Dev 6, If 1, Class=Vendor Specific Class, Driver=, 480M
    |__ Port 2: Dev 6, If 2, Class=Vendor Specific Class, Driver=, 480M
    |__ Port 2: Dev 6, If 3, Class=Vendor Specific Class, Driver=, 480M
    |__ Port 2: Dev 6, If 4, Class=Vendor Specific Class, Driver=, 480M
    |__ Port 2: Dev 6, If 5, Class=Vendor Specific Class, Driver=, 480M
    |__ Port 2: Dev 6, If 6, Class=Vendor Specific Class, Driver=, 480M
/:  Bus 05.Port 1: Dev 1, Class=root_hub, Driver=ohci-pci/2p, 12M
/:  Bus 04.Port 1: Dev 1, Class=root_hub, Driver=ohci-pci/5p, 12M
/:  Bus 03.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/2p, 5000M
/:  Bus 02.Port 1: Dev 1, Class=root_hub, Driver=xhci_hcd/2p, 480M
/:  Bus 01.Port 1: Dev 1, Class=root_hub, Driver=ohci-pci/5p, 12M

Bus 008 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 009 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 002: ID eb1a:51be eMPIA Technology, Inc.
Bus 007 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 006: ID 2659:1503 Sundtek
Bus 006 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8317
    • Profil anzeigen
Re:MiniPC mit 3 Sundtek-Recivers
« Antwort #8 am: Januar 16, 2016, 07:02:38 Nachmittag »
Wie schließt du die Dinge überhaupt an?

Mach am Besten mal ein Foto davon.

Wenn etwas nicht aufgelistet wird liegt's wohl daran das die Boxen nicht genug Strom liefern.

Werden die Sat Tuner mit oder ohne Netzteil betrieben? (Ohne Netzteil verwenden sie den Strom vom USB Port um den LNB zu betreiben - und dann kann's je nach LNB oder Multiswitch leicht mal zu Engpässen bei der Spannungsversorgung kommen).
Failure is a good thing! I'll fix it

hlzhnz

  • Newbie
  • *
  • Beiträge: 27
    • Profil anzeigen
Re:MiniPC mit 3 Sundtek-Recivers
« Antwort #9 am: Januar 16, 2016, 08:30:17 Nachmittag »
Beide sind mit Netzteil angeschlossen. Auch der Multiswitch hängt am Netzteil
« Letzte Änderung: Januar 16, 2016, 08:34:03 Nachmittag von hlzhnz »

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8317
    • Profil anzeigen
Re:MiniPC mit 3 Sundtek-Recivers
« Antwort #10 am: Januar 16, 2016, 08:34:30 Nachmittag »
Ok super dass du das Foto gemacht hast.

Was für ein Netzteil hat der Zotac?

Das scheint ein AMD Board zu sein, AMD ist im allgemeinen dafür bekannt eine unausgereifte Linux USB Unterstützung zu haben.
Zitat
[    1.032262] ehci-pci 0000:00:12.2: applying AMD SB700/SB800/Hudson-2/3 EHCI dummy qh workaround

Läuft der DVB-C/T Tuner problemlos und zuverlässig neben dem V5 Sat Tuner (ohne dem V2 Sat Tuner)
Versuche auch mal andere USB Ports zu verwenden (eher die hinteren vom Board) - aber nicht die USB 3.0 Ports.
Failure is a good thing! I'll fix it

hlzhnz

  • Newbie
  • *
  • Beiträge: 27
    • Profil anzeigen
Re:MiniPC mit 3 Sundtek-Recivers
« Antwort #11 am: Januar 16, 2016, 08:50:58 Nachmittag »
Die Zbox hat das originale 19V 3,42A Netzteil.

Ja stimmt, es ist eine AD10 mit AMD E-350.

Die andere Zbox, mit der ich die selben Probleme habe, ist eine ID41 mit Intel Atom D525.


Ohne den V2 habe ich es noch nicht versucht, ist aber auch schwierig zu sagen, denn es hat ja über eine Woche mit allen 3 Tunern geklappt. Erst heute war das Problem wieder da.

Ich habe mit der anderen ZBox alle möglichen USBports versucht.
Auf dieser hier habe ich nur noch 1 freien USB2 Port.
« Letzte Änderung: Januar 16, 2016, 08:55:25 Nachmittag von hlzhnz »

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8317
    • Profil anzeigen
Re:MiniPC mit 3 Sundtek-Recivers
« Antwort #12 am: Januar 16, 2016, 09:05:18 Nachmittag »
Hast du schon mal versucht die Tuner später anzuschließen? Und nicht dann wenn das System die Haupt-Systemkomponenten initialisiert?
Ich kenne die Stromversorgung dieser Systeme nicht, eventuell hilft dort ein aktives USB Hub. Es sieht mir irgendwie so aus als ob den 3 Tunern nicht genug Strom zur Verfügung steht.
An der Stelle wo die Fehler ausgegeben werden wird aber auch ziemlich viel beim System initialisiert.

Das mit den V2er Tunern ist schwierig zu sagen bei denen ist es wirklich am Besten wenn man das Upgrade-Angebot zu beanspruchen (2013-2014 wurde bei uns alles umgebaut und nun wird die Hardware auch in Berlin entwickelt)
« Letzte Änderung: Januar 16, 2016, 09:14:52 Nachmittag von Sundtek »
Failure is a good thing! I'll fix it

hlzhnz

  • Newbie
  • *
  • Beiträge: 27
    • Profil anzeigen
Re:MiniPC mit 3 Sundtek-Recivers
« Antwort #13 am: Januar 16, 2016, 09:08:10 Nachmittag »
Ja,  das klappt immer.  Das Problem scheint nur direkt beim  boot auf zu treten

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8317
    • Profil anzeigen
Re:MiniPC mit 3 Sundtek-Recivers
« Antwort #14 am: Januar 16, 2016, 09:19:29 Nachmittag »
Zu wenig Strom. Wenn das System die USB Ports einschaltet werden eventuell die Kondensatoren geladen welche an den USB Ports sind.
Linux sollte die Ports eventuell langsamer initialisieren damit es etwas mehr Zeit gibt zum Laden.

Ich denke es gibt so 150uF Kondensatoren an den USB Ports (die sind so vom USB Standard vorgeschrieben), wahrscheinlich packt das die 5V Stromversorgung bei den Zotacs einfach nicht diese zu laden und die USB Tuner zu versorgen..
Failure is a good thing! I'll fix it