Autor Thema: Stick geht nach booten nicht und lirc auch nicht  (Gelesen 14616 mal)

tbark

  • Newbie
  • *
  • Beiträge: 7
    • Profil anzeigen
Stick geht nach booten nicht und lirc auch nicht
« am: September 05, 2009, 05:35:33 Nachmittag »
Hallo,
seit gestern bin ich, inzwischen nicht mehr ganz so glücklicher, Besitzer des TV Sticks. Ich hatte ja gedacht das die Bastelei endlich ein Ende hat, tja...

Also folgende Probs habe ich:
1.) nach dem booten muß ich den Stick erstmal rausziehen und wieder einstecken damit er dann erkannt wird und
2.) wenn ich versuche nach eurer Anleitung lirc zu konfigurieren erhalte ich folgende Fehlermeldung:
 
# dpkg-reconfigure lirc
insserv: Script mediasrv is broken: incomplete LSB comment.
insserv: missing `Required-Stop:'  entry: please add even if empty.
insserv: missing `Default-Stop:'   entry: please add even if empty.
insserv: Script mediasrv is broken: incomplete LSB comment.
insserv: missing `Required-Stop:'  entry: please add even if empty.
insserv: missing `Default-Stop:'   entry: please add even if empty.
insserv: Default-Stop  undefined, assuming empty stop  runlevel(s) for script `mediasrv'

Ich hoffe das sich die Probs kurzfristig lösen lassen :-)
Mein Sytem: Sidux 2009-2 32bit

mfg
Th. Bark



Neue Umfrage

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8309
    • Profil anzeigen
Re:Stick geht nach booten nicht und lirc auch nicht
« Antwort #1 am: September 06, 2009, 01:39:55 Vormittag »
Die Initialisierungsskripte wurden ursprünglich für Ubuntu 8.10 entwickelt, wir haben den Treiber soweit unter Sidux derzeit lediglich auf die Funktionalität getestet.

Wir werden die Skripte ebenfalls umgehend anpassen und ein Update diesbezüglich freigeben, der Treiber an sich bleibt unberührt.
Failure is a good thing! I'll fix it

fritv

  • Jr. Member
  • **
  • Beiträge: 63
    • Profil anzeigen
Re:Stick geht nach booten nicht und lirc auch nicht
« Antwort #2 am: September 06, 2009, 12:21:32 Nachmittag »
Bitte auch an Ubuntu 9.04, 64-Bit, Kernel 2.6.30-8, denken. Auch bei mir funktioniert der Treiber nach dem Booten nicht mehr. Vermute den gleichen Fehler (Treiberrestart ?).

Momentan ist nach dem Booten des Treibers vom 4.9.09 eine Deinstallation (-u), eine Neuinstallation, anschließend /opt/bin/mediaclient -e und /opt/bin/mediaclient -D DVBC erforderlich, damit bei mir tvtime und kaffeine am Kabelanschluss funktionieren. Ansonsten fehlt der Datenstrom bei tvtime  und bei kaffeine der "TV-Button".

Danke.

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8309
    • Profil anzeigen
Re:Stick geht nach booten nicht und lirc auch nicht
« Antwort #3 am: September 12, 2009, 02:53:19 Vormittag »
Ubuntu 9.04 32-bit funktioniert einwandfrei, Sidux wird in den kommenden Tagen ebenfalls evaluiert.

Sundtek kann bezüglich Ihrem Ubuntu 9.04 Problem Remote Support anbieten (kontakt at sundtek de)

Vorgehensweise:

1. Installation von Ubuntu
2. Installation des Treibers
3. Installation von tvtime
4. starten von tvtime - ok (ohne reboot)
5. reboot
6. starten von tvtime - ok

/opt/bin/mediaclient -e zeigt ebenfalls immer Geräte an.
Failure is a good thing! I'll fix it

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8309
    • Profil anzeigen
Re:Stick geht nach booten nicht und lirc auch nicht
« Antwort #4 am: September 12, 2009, 05:49:52 Nachmittag »
Die Sidux Probleme wurden allesamt behoben. Die Probleme mit der Fernbedienung wurden durch ein defektes Sidux lirc Skript ausgelöst.

Um die Fernbedienung endgültig zu installieren muss nach der Treiberinstallation folgendes Skript ausgeführt werden:

$ /opt/doc/lirc_install.sh

« Letzte Änderung: September 12, 2009, 06:03:32 Nachmittag von Sundtek »
Failure is a good thing! I'll fix it

tbark

  • Newbie
  • *
  • Beiträge: 7
    • Profil anzeigen
Re:Stick geht nach booten nicht und lirc auch nicht
« Antwort #5 am: September 14, 2009, 09:15:38 Nachmittag »
Die Sidux Probleme wurden allesamt behoben. Die Probleme mit der Fernbedienung wurden durch ein defektes Sidux lirc Skript ausgelöst.

sorry, aber nix ist gelöst ;-(

# /opt/doc/lirc_install.sh

Do you want to install a preconfigured remote control setup for
Sundtek MediaTV? [Y/N]

Wollen Sie die vorkonfigurierte Einstellungen für die
Sundtek MediaTV Fernbedienung installieren? [J/N]
J
Copying preconfigured lirc setup from /opt/doc to /etc/lirc
done...
restarting lirc
Stopping remote control daemon(s): LIRC: failed!
Loading LIRC modules:.
Starting remote control daemon(s) : LIRC : failed!
done...
now you can test lirc by running irw
KDE also offers irkick for a comfortable graphical configuration

offensichtlich sucht der lircd nach irgendwelchen Modulen aber der Bereich in der hardware.conf ist leer. Muss da was eingetragen werden?

Zum zweiten Punkt:
Nach einem Warmstart kann gleich wieder Fern gesehen werden, jedoch nicht nach einem Kaltstart. Woran kann das liegen?

mfg
tbark

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8309
    • Profil anzeigen
Re:Stick geht nach booten nicht und lirc auch nicht
« Antwort #6 am: September 14, 2009, 09:35:56 Nachmittag »
Etwas passt mit Ihren Lirc Skripten wohl nicht, können Sie /etc/lirc an kontakt at sundtek de schicken?

Haben Sie das Skript als root gestartet?

Der Kalt bzw. Neustart sollte keinen unterschied machen, eventuell hatten Sie den Kaltstart noch mit den älteren Treibern durchgeführt?

bei dpkg-reconfigure lirc kommt bei Sidux kein Menü, da Sidux dies nicht so implementiert hat.
Failure is a good thing! I'll fix it

tbark

  • Newbie
  • *
  • Beiträge: 7
    • Profil anzeigen
Re:Stick geht nach booten nicht und lirc auch nicht
« Antwort #7 am: September 14, 2009, 10:07:31 Nachmittag »
Etwas passt mit Ihren Lirc Skripten wohl nicht, können Sie /etc/lirc an kontakt at sundtek de schicken?
ja gern, ist gleich unterwegs

Zitat
Haben Sie das Skript als root gestartet?
ja, geht ja nicht anders

Zitat
Der Kalt bzw. Neustart sollte keinen unterschied machen, eventuell hatten Sie den Kaltstart noch mit den älteren Treibern durchgeführt?
Nein, bin in der angegebenen Reihenfolge vorgegangen

Zitat
bei dpkg-reconfigure lirc kommt bei Sidux kein Menü, da Sidux dies nicht so implementiert hat.
gibt es dann eine andere Methode das Menü aufzurufen?

mfg
tbark

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8309
    • Profil anzeigen
Re:Stick geht nach booten nicht und lirc auch nicht
« Antwort #8 am: September 14, 2009, 10:43:14 Nachmittag »
Versuchen Sie eventuell lirc-modules-source.conf umzubenennen.

Zitat
gibt es dann eine andere Methode das Menü aufzurufen?

Nein, bei Sidux muss dies manuell konfiguriert werden.

Ist denn nach einem Kaltstart mediasrv im System gestartet?
Failure is a good thing! I'll fix it

tbark

  • Newbie
  • *
  • Beiträge: 7
    • Profil anzeigen
Re:Stick geht nach booten nicht und lirc auch nicht
« Antwort #9 am: September 15, 2009, 07:59:59 Vormittag »
Zitat
Ist denn nach einem Kaltstart mediasrv im System gestartet?

Wie kann ich das checken?

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8309
    • Profil anzeigen
Re:Stick geht nach booten nicht und lirc auch nicht
« Antwort #10 am: September 15, 2009, 08:56:45 Vormittag »
$ ps fax | grep mediasrv
 9407 ?        S<l  139:45 /opt/bin/mediasrv -d -susbfs --pluginpath=/opt/bin
 9427 ?        S<Ll  41:20  \_ /opt/bin/mediasrv -d -susbfs --pluginpath=/opt/bin

$ /opt/bin/mediaclient -e
**** List of Media Hardware Devices ****
device 0: [ Sundtek MediaTV Pro] DVB-C, DVB-T, ANALOG-TV, FM-RADIO, REMOTE-CONTROL
  [DVB-C]:
     FRONTEND: /dev/dvb/adapter0/frontend0
     DVR: /dev/dvb/adapter0/dvr0
     DMX: /dev/dvb/adapter0/demux0
  [DVB-T]:
     FRONTEND: /dev/dvb/adapter0/frontend0
     DVR: /dev/dvb/adapter0/dvr0
     DMX: /dev/dvb/adapter0/demux0
  [ANALOG-TV]:
     VIDEO0: /dev/video1
     VBI0: /dev/vbi0
  [FM-RADIO]:
     RADIO0: /dev/radio0
  [REMOTECONTROL]:
     INPUT0: /dev/mediainput0

Failure is a good thing! I'll fix it

tbark

  • Newbie
  • *
  • Beiträge: 7
    • Profil anzeigen
Re:Stick geht nach booten nicht und lirc auch nicht
« Antwort #11 am: September 15, 2009, 03:22:32 Nachmittag »
Hallo,
also folgende Ausgaben erhalte ich:

# ps fax | grep mediasrv
 2254 ?        S<l    0:02 /opt/bin/mediasrv -d -susbfs --pluginpath=/opt/bin
 2789 ?        S<     0:00  \_ /opt/bin/mediasrv -d -susbfs --pluginpath=/opt/bin
 2300 ?        S<l    0:02 /opt/bin/mediasrv -d -susbfs --pluginpath=/opt/bin
 2378 ?        S<     0:00  \_ /opt/bin/mediasrv -d -susbfs --pluginpath=/opt/bin
 5927 pts/0    S+     0:00              \_ grep mediasrv

und

# /opt/bin/mediaclient -e
**** List of Media Hardware Devices ****
device 0: [ Sundtek MediaTV Pro] REMOTE-CONTROL
  [REMOTECONTROL]:
     INPUT0: /dev/mediainput0

diese Ausgaben habe ich wie gesagt nach einem Kaltstart. Folgendes noch der Vollständigkeit halber:

# uname -a
Linux hh22159 2.6.30-5.slh.1-sidux-686 #1 SMP PREEMPT Sun Aug 16 22:55:52 UTC 2009 i686 GNU/Linux


Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8309
    • Profil anzeigen
Re:Stick geht nach booten nicht und lirc auch nicht
« Antwort #12 am: September 15, 2009, 04:02:54 Nachmittag »
Das ist bereits das Problem, es ist eigentlich nur möglich den Treiber 1x zu starten. Gibt es jedoch zum Zeitpunkt des Ladens der ersten Instanz keine Schreibberechtigung auf der Festplatte kann es unter Umständen vorkommen das der Treiber 2x gestartet wird und die zweite Instanz nicht ordnungsgemäß geladen wird.

Es wurde hierfür ein weiteres Ticket angelegt und sollte umgehend von einem Entwickler bearbeitet werden.
Failure is a good thing! I'll fix it

tbark

  • Newbie
  • *
  • Beiträge: 7
    • Profil anzeigen
Re:Stick geht nach booten nicht und lirc auch nicht
« Antwort #13 am: September 15, 2009, 09:36:00 Nachmittag »
Das ist bereits das Problem, es ist eigentlich nur möglich den Treiber 1x zu starten. Gibt es jedoch zum Zeitpunkt des Ladens der ersten Instanz keine Schreibberechtigung auf der Festplatte kann es unter Umständen vorkommen das der Treiber 2x gestartet wird und die zweite Instanz nicht ordnungsgemäß geladen wird.

Es wurde hierfür ein weiteres Ticket angelegt und sollte umgehend von einem Entwickler bearbeitet werden.

Naja, dann muss ich wohl noch warten, hoffentlich nicht zu lange :-)
Ich wurde gestern Abend gebeten, meine Dateien aus /etc/lirc per Mail an Sie zu schicken. Gibt es da schon was neues?

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8309
    • Profil anzeigen
Re:Stick geht nach booten nicht und lirc auch nicht
« Antwort #14 am: September 15, 2009, 09:39:06 Nachmittag »
Können Sie lirc-modules-source.conf umbenennen in lirc-modules-source.conf.old, und versuchen Lirc neu zu starten.
Failure is a good thing! I'll fix it