Autor Thema: MythTV Analog TV Audio ist zu langsam  (Gelesen 7135 mal)

devebete

  • Newbie
  • *
  • Beiträge: 4
    • Profil anzeigen
MythTV Analog TV Audio ist zu langsam
« am: November 21, 2010, 11:32:47 Nachmittag »
Hallo,

bei mythtv 0.23 auf Debian Testing habe ich verlangsamte Audio Wiedergabe. Insgesamt ca 5-10% Verlangsamung gegenüber der Realität - Video ist wohl auch langsamer, nur fällt das nicht so auf.

Kurzum - alle Stimmen sind ein bischen tiefer und zuwenig bpms.

Wer kennt das Problem noch?
Sundtek Media TV Pro
MythTV 0.23 auf Debian-Testing
MSI MS-7191

troubi

  • Newbie
  • *
  • Beiträge: 6
    • Profil anzeigen
Re:MythTV Analog TV Audio ist zu langsam
« Antwort #1 am: Dezember 30, 2010, 11:00:29 Nachmittag »
Hallo,

habe gerade mythtv 0.23 neu eingerichtet und ebenfalls eine zu langsame Audio-Wiedergabe. In den Logfiles finde ich verdächtige Zeilen 

mythbackend.log:
(unknown video codec / audio codec; sample rate 32000, got 48000)

2010-12-30 21:24:44.551 TVRec(3): Changing from None to WatchingLiveTV
2010-12-30 21:24:44.563 TVRec(3): HW Tuner: 3->3
2010-12-30 21:24:47.541 ProgramInfo(): Updated pathname '':'' -> '2004_20101230212447.nuv'
2010-12-30 21:24:47.563 NVR(/dev/video33): Unknown video codec.  Please go into the TV Settings, Recording Profiles and setup the four 'Software Encoders' profiles.  Assuming RTjpeg for now.
2010-12-30 21:24:47.564 NVR(/dev/video33) Error: Unknown audio codec
2010-12-30 21:24:47.573 AudioInOSS(/dev/dsp0) Error: requested sample rate 32000, got 48000
2010-12-30 21:24:47.608 AutoExpire: CalcParams(): Max required Free Space: 2.0 GB w/freq: 15 min
2010-12-30 21:24:47.613 ProgramInfo(): Updated pathname '':'' -> '2004_20101230212447.nuv'
2010-12-30 21:24:47.628 AudioInOSS(/dev/dsp0) Error: requested sample rate 32000, got 48000
2010-12-30 21:24:47.653 ProgramInfo(): Updated pathname '':'' -> '2004_20101230212447.nuv'
2010-12-30 21:24:47.982 RecBase(3:/dev/video33): GetKeyframePositions(0,9223372036854775807,#1) out of 1
2010-12-30 21:24:48.150 ProgramInfo(): Updated pathname '':'' -> '2004_20101230212447.nuv'


mediasrv.log:
(unknown ioctl, not handled by v4l1 api c0445636)

2010-12-30 21:24:44 [1414] switching to analog TV
2010-12-30 21:24:44 [1414] SETTING PAL/SECAM
2010-12-30 21:24:47 [1414] unknown ioctl, not handled by v4l1 api c0445636
2010-12-30 21:24:47 [1414] Setting frequency: 203250000
2010-12-30 21:24:47 [1414] Using settings for Europe

Hallo Sundtek, könnt Ihr daraus eine Lösung schlussfolgern?

troubi

  • Newbie
  • *
  • Beiträge: 6
    • Profil anzeigen
Re:MythTV Analog TV Audio ist zu langsam
« Antwort #2 am: Dezember 31, 2010, 12:02:21 Vormittag »
Ich habe das Problem lösen können.
Aufgrund des Hinweises im mythbackend.log habe ich in den Aufnahmeprofilen (Konfiguration->TV->Aufnahmeprofile) die Software-Enkoderprofile so geändert, dass die MP3-Abtastrate auf 48000 gestellt ist.
Die Audio-Geschwindigkeit passt jetzt und die Fehlermeldungen "Unknown video / audio codec" und die mit der Sample-Rate im mythbackend.log sind jetzt weg.

Das
unknown ioctl, not handled by v4l1 api c0445636taucht allerdings in der mediasrv.log immer noch bei jedem Tuning auf.
Ist das bedenklich?

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8514
    • Profil anzeigen
Re:MythTV Analog TV Audio ist zu langsam
« Antwort #3 am: Januar 01, 2011, 05:56:09 Vormittag »
Zitat
Das
unknown ioctl, not handled by v4l1 api c0445636taucht allerdings in der mediasrv.log immer noch bei jedem Tuning auf.
Ist das bedenklich?

c0445636, VIDIOC_G_MODULATOR wird von uns nicht benötigt und wurde daher intern nicht implementiert. Es ist unbedenklich und wird auf weiteres auch nicht implementiert werden.
Failure is a good thing! I'll fix it