Autor Thema: tvheadend verliert Adapter  (Gelesen 4971 mal)

joch40

  • Newbie
  • *
  • Beiträge: 7
    • Profil anzeigen
tvheadend verliert Adapter
« am: Juli 07, 2010, 12:06:49 Nachmittag »
Hallo,

ich habe ein Problem mit tvheadend. Nach dem in der Installation tvheadend den Sundtek-Stick mühelos erkannt hat und alle Programme gescannt hat, findet er den Stick einem Neustart nicht mehr.

Mplayer und Kaffeine arbeiten einwandfrei, DVB-C ist eingestellt, der Stick ist auch nicht von einer der anderen Applicationen "besetzt". Was ist zu tun?

Gruß

joch40

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8330
    • Profil anzeigen
Re:tvheadend verliert Adapter
« Antwort #1 am: Juli 07, 2010, 12:33:11 Nachmittag »
Versuchen Sie eventuell folgenden Treiber:

http://www.sundtek.de/media/sundtek_installer_development.sh (derzeitiger Stand vom 6. Juli 2010).
Es gab in den letzten Monaten einige Aenderungen beim Startverhalten von einigen Linux Distributionen.

Um was fuer eine Distribution handelt es sich?

Um sicherzugehen das der Stick nicht von einer anderen Applikation benutzt wird koennen Sie die Ausgabe von folgendem Befehl hier angeben:

Zitat
/opt/bin/mediaclient --lc

Dies zeigt die Applikationen an welche mit dem Treiber verbunden sind.
« Letzte Änderung: Juli 07, 2010, 12:53:44 Nachmittag von Sundtek »
Failure is a good thing! I'll fix it

joch40

  • Newbie
  • *
  • Beiträge: 7
    • Profil anzeigen
Re:tvheadend verliert Adapter
« Antwort #2 am: Juli 07, 2010, 09:35:34 Nachmittag »
Hallo,

das hat leider nichts gebracht...

Ich nutze ein neues (5 Tage) altes Ubuntu 10.04 mit allen Updates auf einem mittel alten Rechner.

Der Treiber ließ sich gut installieren. MPlayer (ohne HD) und Kaffeine (mit HD) laufen, tvheadend findet den Stick weiterhin nicht mehr. Interessant: wenn man tvheadend schließt bekommt man u.a. die folgende Meldung:

[INFO]:dvb: Found adapter /dev/dvb/adapter0 (Sundtek DVB-C) via PCI
wobei es sich natürlich nicht um ein PCI sondern um ein UDB Device handelt.
 
Was jetzt ?

Gruß

joch40

joch40

  • Newbie
  • *
  • Beiträge: 7
    • Profil anzeigen
Re:tvheadend verliert Adapter
« Antwort #3 am: Juli 07, 2010, 09:39:32 Nachmittag »
Hallo nochmal ich vergaß

/opt/bin/mediaclient --lc

ergibt nichts keiner hält den Stick fest.

Danke für die Unterstützung


joch40

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8330
    • Profil anzeigen
Re:tvheadend verliert Adapter
« Antwort #4 am: Juli 07, 2010, 11:09:12 Nachmittag »
tvheadend funktioniert hier soweit problemlos.

zeigen denn die tvheadend logfiles etwas an?

OK Nach einem Neustart heisst wohl PC Neustart?

Falls dem so ist wird tvheadend gestartet bevor der Treiber geladen wurde, dies ist natuerlich ein Problem von tvheadend da es mit hotplug Devices nicht umgehen kann, der Stick kann ja jederzeit angeschlossen oder abgezogen werden.

Als Workaround hat der Treiber eine Option welche es erlaubt Applikationen oder Skripte zu starten sobald ein Geraet angeschlossen oder abgezogen wird.

/etc/sundtek.conf
device_attach=/etc/init.d/tvheadend restart
device_detach=/etc/init.d/tvheadend restart

Dies wuerde tvheadend dann einfach neu starten sobald der Stick vom System erkannt wird.
Das gleiche beim abziehen des Sticks (es ist uns bekannt das tvheadend auf 100% CPU last geht sobald der Stick gezogen wird - wie erwaehnt aus dem Grund das es kein hotplugging unterstuetzt)


Wie uns vor kurzem mitgeteilt wurde:
Der jeweilige TVheadend Entwickler wird den DVB Support in Zukunft noch ueberarbeiten um auch Hotplugging zu unterstuetzen.
« Letzte Änderung: Juli 08, 2010, 01:56:11 Nachmittag von Sundtek »
Failure is a good thing! I'll fix it