Autor Thema: DVB-T Sendersuche nicht möglich: tuning failed [Solved]  (Gelesen 7805 mal)

Hell-G

  • Newbie
  • *
  • Beiträge: 11
    • Profil anzeigen
DVB-T Sendersuche nicht möglich: tuning failed [Solved]
« am: April 30, 2010, 09:10:40 Nachmittag »
Hallo Forum

Ich habe die neusten Treiber für den Sundtek MediaTV Pro Stick unter Gentoo Linux installiert (100426). Analog TV klappt mit tvtime und dem zugehörigen Sendersuchlauf ohne Probleme.
Die Sendersuche für DVB-T scheitert jedoch. Das Tuning scheint nicht zu klappen. Wenn ich mit dvbscan nach den Sendern suche, bekomme ich die unten angehängte Fehlermeldung. Bei der Sendersuche mit Kaffeine hängt sich das Programm auf ohne eine Meldung. Kaffeine findet das Device aber. Seltsamerweise werden bei mir 2 Geräte erkannt, obwohl ich nur einen Stick anhänge (siehe Ausgabe von "mediaclient -e"). Ich habe alle 3 USB Ports an meinem Laptop ausprobiert. An einem anderen PC konnte ich es bisher noch nicht testen. Hat jemand eine Idee, wo bei mir das Problem liegt?

Die unten aufgeführten Ausgaben sind in der Reihenfolge, wie ich die Befehle ausgeführt habe.

Vielen Dank

Hell-G

hell-g@gentoo ~ $ dmesg
usb 1-1: new high speed USB device using ehci_hcd and address 4
usb 1-1: New USB device found, idVendor=eb1a, idProduct=51b2
usb 1-1: New USB device strings: Mfr=3, Product=1, SerialNumber=2
usb 1-1: Product: MediaTV Pro
usb 1-1: Manufacturer: Sundtek
usb 1-1: SerialNumber: 98043088
usb 1-1: configuration #1 chosen from 1 choice
input: Sundtek Ltd. Remote Control as /devices/virtual/input/input8
input: Sundtek Ltd. Remote Control as /devices/virtual/input/input9

hell-g@gentoo ~ $ mediaclient -e
**** List of Media Hardware Devices ****
device 0: [Sundtek MediaTV Pro/Digital Home]  DVB-C, DVB-T, ANALOG-TV, FM-RADIO, REMOTE-CONTROL, OSS-AUDIO, RDS
  [DVB-C]:
     FRONTEND: /dev/dvb/adapter0/frontend0
     DVR: /dev/dvb/adapter0/dvr0
     DMX: /dev/dvb/adapter0/demux0
  [DVB-T]:
     FRONTEND: /dev/dvb/adapter0/frontend0
     DVR: /dev/dvb/adapter0/dvr0
     DMX: /dev/dvb/adapter0/demux0
  [ANALOG-TV]:
     VIDEO0: /dev/video0
     VBI0: /dev/vbi0
  [FM-RADIO]:
     RADIO0: /dev/radio0
     RDS: /dev/rds0
  [REMOTECONTROL]:
     INPUT0: /dev/mediainput0
  [OSS]:
     OSS0: /dev/dsp0

device 1: [Sundtek MediaTV Pro/Digital Home]  DVB-C, DVB-T, ANALOG-TV, FM-RADIO, REMOTE-CONTROL, OSS-AUDIO, RDS
  [DVB-C]:
     FRONTEND: /dev/dvb/adapter1/frontend0
     DVR: /dev/dvb/adapter1/dvr0
     DMX: /dev/dvb/adapter1/demux0
  [DVB-T]:
     FRONTEND: /dev/dvb/adapter1/frontend0
     DVR: /dev/dvb/adapter1/dvr0
     DMX: /dev/dvb/adapter1/demux0
  [ANALOG-TV]:
     VIDEO0: /dev/video1
     VBI0: /dev/vbi1
  [FM-RADIO]:
     RADIO0: /dev/radio1
     RDS: /dev/rds1
  [REMOTECONTROL]:
     INPUT0: /dev/mediainput1
  [OSS]:
     OSS0: /dev/dsp1


hell-g@gentoo ~ $ mediaclient -m DVBT
Using device: /dev/dvb/adapter0/frontend0
.

hell-g@gentoo ~ $ mediaclient -D DVBT
Using device: /dev/dvb/adapter0/frontend0
Setting Frontend Properties to: DVBT
Done.

hell-g@gentoo ~ $ dvbscan /usr/share/dvb/dvb-t/ch-All
scanning /usr/share/dvb/dvb-t/ch-All
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
Frontend can not do INVERSION_AUTO, trying INVERSION_OFF instead
initial transponder 482000000 0 5 9 1 1 3 0
initial transponder 514000000 0 5 9 1 1 3 0
initial transponder 522000000 0 5 9 1 1 3 0
initial transponder 538000000 0 5 9 1 1 3 0
initial transponder 554000000 0 5 9 1 1 3 0
initial transponder 562000000 0 5 9 1 1 3 0
initial transponder 578000000 0 5 9 1 1 3 0
initial transponder 594000000 0 5 9 1 1 3 0
initial transponder 602000000 0 5 9 1 1 3 0
initial transponder 618000000 0 5 9 1 1 3 0
initial transponder 626000000 0 5 9 1 1 3 0
initial transponder 642000000 0 5 9 1 1 3 0
initial transponder 658000000 0 5 9 1 1 3 0
initial transponder 666000000 0 5 9 1 1 3 0
initial transponder 674000000 0 5 9 1 1 3 0
initial transponder 682000000 0 5 9 1 1 3 0
initial transponder 690000000 0 5 9 1 1 3 0
initial transponder 698000000 0 5 9 1 1 3 0
initial transponder 714000000 0 5 9 1 1 3 0
initial transponder 722000000 0 5 9 1 1 3 0
initial transponder 738000000 0 5 9 1 1 3 0
initial transponder 754000000 0 5 9 1 1 3 0
initial transponder 762000000 0 5 9 1 1 3 0
initial transponder 786000000 0 5 9 1 1 3 0
initial transponder 802000000 0 5 9 1 1 3 0
initial transponder 826000000 0 5 9 1 1 3 0
>>> tune to: 482000000:INVERSION_OFF:BANDWIDTH_8_MHZ:FEC_5_6:FEC_AUTO:QAM_16:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_4:HIERARCHY_NONE
WARNING: >>> tuning failed!!!
>>> tune to: 482000000:INVERSION_OFF:BANDWIDTH_8_MHZ:FEC_5_6:FEC_AUTO:QAM_16:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_4:HIERARCHY_NONE (tuning failed)
WARNING: >>> tuning failed!!!
>>> tune to: 514000000:INVERSION_OFF:BANDWIDTH_8_MHZ:FEC_5_6:FEC_AUTO:QAM_16:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_4:HIERARCHY_NONE
WARNING: >>> tuning failed!!!
>>> tune to: 514000000:INVERSION_OFF:BANDWIDTH_8_MHZ:FEC_5_6:FEC_AUTO:QAM_16:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_4:HIERARCHY_NONE (tuning failed)
WARNING: >>> tuning failed!!!


hell-g@gentoo ~ $ cat /var/log/mediasrv.log
2010-04-30 19:59:43 [6865] restarting logging
2010-04-30 19:59:43 [6865] registering ID: 0
2010-04-30 19:59:43 [6865] disconnecting kernel driver
2010-04-30 19:59:44 [6865] attaching Videodecoder
2010-04-30 19:59:46 [6865] attaching DVB-T, DVB-C
2010-04-30 19:59:50 [6865] demodulator successfully attached (DVB_C)!
2010-04-30 19:59:50 [6865] requesting to attach tuner(s) now
2010-04-30 19:59:52 [6865] registering: adapter0
2010-04-30 19:59:52 [6865] registered virtual: /dev/dvb/adapter0/frontend0
2010-04-30 19:59:52 [6865] registered virtual: /dev/dvb/adapter0/demux0
2010-04-30 19:59:52 [6865] registered virtual: /dev/dvb/adapter0/dvr0
2010-04-30 19:59:52 [6865] registered virtual: /dev/video0
2010-04-30 19:59:52 [6865] registered virtual: /dev/radio0
2010-04-30 19:59:52 [6865] registered virtual: /dev/rds0
2010-04-30 19:59:52 [6865] registered virtual: /dev/vbi0
2010-04-30 19:59:52 [6865] registered virtual: /dev/mediainput0
2010-04-30 19:59:52 [6865] Registering OSS emulation
2010-04-30 19:59:52 [6865] registered virtual: /dev/dsp0
RC: IR Event /dev/input/event8
2010-04-30 19:59:52 [6865]
2010-04-30 19:59:52 [6865] Sundtek MediaTV Driver loaded. This driver is licensed for non-commercial use
2010-04-30 19:59:52 [6865] with Sundtek MediaTV only
2010-04-30 19:59:52 [6865] registering ID: 1
2010-04-30 19:59:52 [6865] disconnecting kernel driver
2010-04-30 19:59:53 [6865] attaching Videodecoder
2010-04-30 19:59:55 [6865] attaching DVB-T, DVB-C
2010-04-30 19:59:59 [6865] demodulator successfully attached (DVB_C)!
2010-04-30 19:59:59 [6865] requesting to attach tuner(s) now
2010-04-30 20:00:01 [6865] registering: adapter1
2010-04-30 20:00:01 [6865] registered virtual: /dev/dvb/adapter1/frontend0
2010-04-30 20:00:01 [6865] registered virtual: /dev/dvb/adapter1/demux0
2010-04-30 20:00:01 [6865] registered virtual: /dev/dvb/adapter1/dvr0
2010-04-30 20:00:01 [6865] registered virtual: /dev/video1
2010-04-30 20:00:01 [6865] registered virtual: /dev/radio1
2010-04-30 20:00:01 [6865] registered virtual: /dev/rds1
2010-04-30 20:00:01 [6865] registered virtual: /dev/vbi1
2010-04-30 20:00:01 [6865] registered virtual: /dev/mediainput1
2010-04-30 20:00:01 [6865] Registering OSS emulation
2010-04-30 20:00:01 [6865] registered virtual: /dev/dsp1
2010-04-30 20:00:01 [6865] switching to analog TV
2010-04-30 20:00:01 [6865]
2010-04-30 20:00:01 [6865] Sundtek MediaTV Driver loaded. This driver is licensed for non-commercial use
2010-04-30 20:00:01 [6865] with Sundtek MediaTV only
2010-04-30 20:00:02 [6865] SETTING PAL/SECAM
2010-04-30 20:00:16 [6865] Enabling standby
2010-04-30 20:00:17 [6865] Enabling standby
2010-04-30 20:01:39 [6865] Using settings for Europe
2010-04-30 20:01:40 [6865] opening in digital TV mode
2010-04-30 20:01:40 [6865] SETTING DVB-C
2010-04-30 20:01:45 [6865] SETTING DVB-T
2010-04-30 20:02:00 [6865] Enabling standby
2010-04-30 20:02:01 [6865] SETTING DVB-T
2010-04-30 20:02:32 [6865] Enabling standby
« Letzte Änderung: Mai 04, 2010, 03:12:32 Nachmittag von Hell-G »

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8329
    • Profil anzeigen
Re:DVB-T Sendersuche nicht möglich: tuning failed
« Antwort #1 am: April 30, 2010, 10:38:22 Nachmittag »
Diese Informationen sollten fuer uns bereits ausreichend sein, wir werden in kuerze ein Update freigeben welches eine Doppelregistrierung verhindern wird, und ebenfalls die von Ihnen angegebenen Frequenzen mit einem Signalgenerator testen. Weitere Informationen gibt es dann mit dem Update (welches voraussichtlich bereits am Samstag zur Verfuegung gestellt werden kann).
Grund fuer die Doppelregistrierung kann lediglich eine falsche Notifikation vom Systemkernel sein welche eigentlich nicht vorkommen sollte.
« Letzte Änderung: Mai 01, 2010, 09:38:11 Vormittag von Sundtek »
Failure is a good thing! I'll fix it

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8329
    • Profil anzeigen
Re:DVB-T Sendersuche nicht möglich: tuning failed
« Antwort #2 am: Mai 01, 2010, 09:38:21 Vormittag »
http://www.sundtek.de/media/sundtek_installer_100501.sh

Verwenden Sie bitte diesen Treiber, die Moeglichkeit zur Doppelregistrierung sollte hierbei auch bei mehrfachen Systemnotifikationen nicht mehr bestehen. Zudem wurde die erste Frequenz von ch-All mit unserem Signalgenerator getestet. Dieses Doppelregistrierungsproblem betrifft derzeit auf jeden Fall weniger als 1% aller Kunden und ist systemspezifisch.
Failure is a good thing! I'll fix it

Hell-G

  • Newbie
  • *
  • Beiträge: 11
    • Profil anzeigen
Re:DVB-T Sendersuche nicht möglich: tuning failed
« Antwort #3 am: Mai 01, 2010, 01:07:02 Nachmittag »
Vielen Dank für die schnelle Antwort. Das Problem mit der Doppelregistrierung scheint gelöst mit dem neuen Treiber. Bei der Sendersuche hat sich jedoch nichts geändert und ich bekomme immer noch die Meldung "tuning failed".

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8329
    • Profil anzeigen
Re:DVB-T Sendersuche nicht möglich: tuning failed
« Antwort #4 am: Mai 01, 2010, 01:09:10 Nachmittag »
Lassen Sie alle Frequenzen durchscannen, ch-All heisst das alle in der Schweiz bekannten Frequenzen gescannt werden, viele davon werden in Wirklichkeit keinen Transponder dahinter haben.

Tuning Failed ist nur eine allgmeine Aussage des Scan Programs, dies sagt nichts ueber Probleme mit dem Tuner aus - lediglich das auf der jeweiligen Frequenz kein TV Transponder gesendet wird.

Mittels w_scan koennen Sie ebenfalls eine Frequenzliste erstellen, w_scan nimmt das komplette Frequenzband, dvbscan benoetigt die jeweils vorgegebenen Scan Files (z.B.: ch-All) welche eventuell ein paar wenige Transponderfrequenzen in Ihrer Gegend in der Schweiz nicht gelistet hat.

Das gleiche gilt uebrigens auch fuer Oesterreich, lediglich in Deutschland und einigen anderen Laendern sind die Scanfiles strikt nach Region aufgeteilt.
« Letzte Änderung: Mai 02, 2010, 11:19:58 Vormittag von Sundtek »
Failure is a good thing! I'll fix it

Hell-G

  • Newbie
  • *
  • Beiträge: 11
    • Profil anzeigen
Re:DVB-T Sendersuche nicht möglich: tuning failed
« Antwort #5 am: Mai 04, 2010, 03:11:41 Nachmittag »
Vielen Dank für den Hinweis! Mit dem neuen Treiber funktioniert es nun tatsächlich.

Ich habe die Meldung wirklich fälschlicherweise so verstanden, dass "tuning failed" bedeutet, dass die gewünschte Frequenz nicht eingestellt werden kann. Daher habe ich zu früh angenommen, dass der selbe Fehler besteht. Als ich den Scan ganz durchlaufen liess, wurden alle Sender gefunden und es funktioniert einwandfrei. Auch Kaffeine kann nun die Sendersuche durchführen und findet alle Sender.