Autor Thema: LIRC funktioniert nicht mehr  (Gelesen 385 mal)

firefly

  • Newbie
  • *
  • Beiträge: 33
    • Profil anzeigen
LIRC funktioniert nicht mehr
« am: August 30, 2018, 11:56:07 Vormittag »
Nach Update auf Ubuntu 18.04 LTS funktioniert LIRC nicht mehr.
Im Syslog steht:

lircd -D5 --nodaemon
lircd-0.10.0[4631]: Notice: lircd:  Opening log, level: Notice
lircd-0.10.0[4631]: Warning: Running as root
lircd-0.10.0[4631]: Notice: lircd(devinput) ready, using /var/run/lirc/lircd
lircd-0.10.0[4631]: Notice: accepted new client on /var/run/lirc/lircd
lircd-0.10.0[4631]: Cannot run glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*: No such file or directory
lircd-0.10.0[4631]: Notice: No input device available for devinput driver. Consider stopping lircd.socket or reconfigure lirc
lircd-0.10.0[4631]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
lircd-0.10.0[4631]: Warning: Failed to initialize hardware
lircd-0.10.0[4631]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*

Die letzte Zeile wird sekündlich wiederholt. Das Verzeichnis /sys/class/rc/ existiert schon nicht.

Die Konfiguration sieht wie folgt aus (alle Kommentarzeilen jeweils entfernt):


/etc/lirc/hardware.conf (Der Eintrag REMOTE_DEVICE=/dev/mediainput1 habe ich per mediaclient -e ermittelt)

REMOTE="Linux input layer (/dev/input/eventX)"
REMOTE_MODULES=""
REMOTE_DRIVER="devinput"
REMOTE_DEVICE=/dev/mediainput1
REMOTE_SOCKET=""
REMOTE_LIRCD_CONF="devinput/lircd.conf.devinput"
REMOTE_LIRCD_ARGS=""
TRANSMITTER="Custom"
TRANSMITTER_MODULES=""
TRANSMITTER_DRIVER=""
TRANSMITTER_DEVICE=""
TRANSMITTER_SOCKET=""
TRANSMITTER_LIRCD_CONF=""
TRANSMITTER_LIRCD_ARGS=""

START_LIRCD="true"
LOAD_MODULES="true"
LIRCMD_CONF=""
FORCE_NONINTERACTIVE_RECONFIGURATION="false"
START_LIRCMD=""



/etc/lirc/lircd.conf

include "/opt/doc/SundtekRemoteV3.conf"


/etc/lirc/lirc_options.conf

[lircd]
nodaemon        = False
driver          = devinput
device          = auto
output          = /var/run/lirc/lircd
pidfile         = /var/run/lirc/lircd.pid
plugindir       = /usr/lib/x86_64-linux-gnu/lirc/plugins
permission      = 666
allow-simulate  = No
repeat-max      = 600

[lircmd]
uinput          = False
nodaemon        = False


mediaclient -e

device 0: [Sundtek SkyTV Ultimate 5]  DVB-S/S2, ANALOG-TV, REMOTE-CONTROL, OSS-AUDIO
  [INFO]:
     STATUS: ACTIVE
  [BUS]:
     ID: 1-7
  [SERIAL]:
     ID: U151103174508
  [DVB-S/S2]:
     FESTATUS: ACTIVE
     LNBVOLTAGE: ENABLED
     LNBSUPPLY: ACADAPTER
     LNBSTATUS: OK
     FRONTEND: /dev/dvb/adapter2/frontend0
     DVR: /dev/dvb/adapter2/dvr0
     DMX: /dev/dvb/adapter2/demux0
  [ANALOG-TV]:
     VIDEO0: /dev/video2
     VBI0: /dev/vbi2
  [REMOTECONTROL]:
     INPUT0: /dev/mediainput2
  [OSS]:
     OSS0: /dev/dsp2

device 1: [Sundtek SkyTV Ultimate 5]  DVB-S/S2, ANALOG-TV, REMOTE-CONTROL, OSS-AUDIO
  [INFO]:
     STATUS: ACTIVE
  [BUS]:
     ID: 1-8
  [SERIAL]:
     ID: U151229185014
  [DVB-S/S2]:
     FESTATUS: ACTIVE
     LNBVOLTAGE: ENABLED
     LNBSUPPLY: USBPOWER
     LNBSTATUS: SHORTCIRCUIT
     FRONTEND: /dev/dvb/adapter1/frontend0
     DVR: /dev/dvb/adapter1/dvr0
     DMX: /dev/dvb/adapter1/demux0
  [ANALOG-TV]:
     VIDEO0: /dev/video1
     VBI0: /dev/vbi1
  [REMOTECONTROL]:
     INPUT0: /dev/mediainput1
  [OSS]:
     OSS0: /dev/dsp1

Hat jemand ein ähnliches Problem oder kann mir einen Hinweis geben wie das zu beheben ist?
Die google Suche habe ich bereits bemueht, konnte aber nichts hilfreiches finden.



Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 7826
    • Profil anzeigen
Re: LIRC funktioniert nicht mehr
« Antwort #1 am: August 30, 2018, 01:05:17 Nachmittag »
Hi,

/dev/mediainput1

das geht nicht, in /opt/bin gibt es ein Skript /opt/bin/getinput.sh dieses sollte den richtigen Pfad ausspucken.
mediainput gibt die Fernbedienungsdaten in einem anderen Format wieder (und sobald darauf zugegriffen wird - wird devinput im Treiber abgeschalten um doppelte Tastendrücke im System zu verhindern).
Sundtek Support Engineer

firefly

  • Newbie
  • *
  • Beiträge: 33
    • Profil anzeigen
Re: LIRC funktioniert nicht mehr
« Antwort #2 am: August 30, 2018, 02:27:30 Nachmittag »
Hallo,

danke für die schnelle Antwort, das Skript funktioniert scheinbar nicht korrekt.

/opt/bin/getinput.sh
waiting 5 seconds...
/opt/bin/getinput.sh: Zeile 10: [: /dev/input/event/sys/devices/virtual/input/input10: Zweistelliger (binärer) Operator erwartet.

ls -al getinput.sh
-rwxr-xr-x 1 root root 380 Dez 31  2016 getinput.sh

cat getinput.sh
#!/bin/bash
ls /dev > /dev/null # just to take care that the driver will start
echo "waiting 5 seconds..."
sleep 5
INPUTPATH=`grep -A2 Sundtek /proc/bus/input/devices | grep Sysfs | sed 's#.*Sysfs=#/sys#g'`

EVENT=`ls ${INPUTPATH}/event* -d | sed 's#.*event##g'`

EVENTFILE=/dev/input/event${EVENT}
if [ -c $EVENTFILE ]; then
        echo "Sundtek IR Event: /dev/input/event${EVENT}"
fi


Ich habe das #!/bin/bash um -x ergaenzt:
/opt/bin/getinput.sh
+ ls /dev
+ echo 'waiting 5 seconds...'
waiting 5 seconds...
+ sleep 5
++ grep -A2 Sundtek /proc/bus/input/devices
++ grep Sysfs
++ sed 's#.*Sysfs=#/sys#g'
+ INPUTPATH='/sys/devices/virtual/input/input10
/sys/devices/virtual/input/input21'
++ ls /sys/devices/virtual/input/input10 /sys/devices/virtual/input/input21/event6 -d
++ sed 's#.*event##g'
+ EVENT='/sys/devices/virtual/input/input10
6'
+ EVENTFILE='/dev/input/event/sys/devices/virtual/input/input10
6'
+ '[' -c /dev/input/event/sys/devices/virtual/input/input10 6 ']'
/opt/bin/getinput.sh: Zeile 10: [: /dev/input/event/sys/devices/virtual/input/input10: Zweistelliger (binärer) Operator erwartet.

Den Pfad gibt es nicht.

ls -al /dev/input/event/sys/devices/virtual/input/input10
ls: Zugriff auf '/dev/input/event/sys/devices/virtual/input/input10' nicht möglich: Datei oder Verzeichnis nicht gefunden


Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 7826
    • Profil anzeigen
Re: LIRC funktioniert nicht mehr
« Antwort #3 am: August 30, 2018, 03:00:11 Nachmittag »
Das Skript sollte eigentlich funktionieren - hat es auch jahrelang.
Wir können es ja Schritt für Schritt durchgehen:

was zeigt denn folgendes an bei Dir:
cat /proc/bus/input/devices

Sundtek Support Engineer

firefly

  • Newbie
  • *
  • Beiträge: 33
    • Profil anzeigen
Re: LIRC funktioniert nicht mehr
« Antwort #4 am: August 30, 2018, 03:06:42 Nachmittag »
I: Bus=0019 Vendor=0000 Product=0001 Version=0000
N: Name="Power Button"
P: Phys=PNP0C0C/button/input0
S: Sysfs=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0C0C:00/input/input0
U: Uniq=
H: Handlers=kbd event0
B: PROP=0
B: EV=3
B: KEY=10000000000000 0

I: Bus=0019 Vendor=0000 Product=0001 Version=0000
N: Name="Power Button"
P: Phys=LNXPWRBN/button/input0
S: Sysfs=/devices/LNXSYSTM:00/LNXPWRBN:00/input/input1
U: Uniq=
H: Handlers=kbd event1
B: PROP=0
B: EV=3
B: KEY=10000000000000 0

I: Bus=0003 Vendor=03f0 Product=0024 Version=0110
N: Name="CHICONY HP Basic USB Keyboard"
P: Phys=usb-0000:00:14.0-1/input0
S: Sysfs=/devices/pci0000:00/0000:00:14.0/usb1/1-1/1-1:1.0/0003:03F0:0024.0001/input/input5
U: Uniq=
H: Handlers=sysrq kbd event2 leds
B: PROP=0
B: EV=120013
B: KEY=1000000000007 ff9f207ac14057ff febeffdfffefffff fffffffffffffffe
B: MSC=10
B: LED=7

I: Bus=0019 Vendor=0000 Product=0006 Version=0000
N: Name="Video Bus"
P: Phys=LNXVIDEO/video/input0
S: Sysfs=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/LNXVIDEO:00/input/input6
U: Uniq=
H: Handlers=kbd event3
B: PROP=0
B: EV=3
B: KEY=3e000b00000000 0 0 0

I: Bus=0019 Vendor=0000 Product=0000 Version=0000
N: Name="Fujitsu FUJ02E3"
P: Phys=FUJ02E3/input0
S: Sysfs=/devices/LNXSYSTM:00/LNXSYBUS:00/PNP0A08:00/device:13/FUJ02E3:00/input/input7
U: Uniq=
H: Handlers=rfkill kbd event4
B: PROP=0
B: EV=13
B: KEY=40000 0 0 0 0 81000000000c00 300000 0 0
B: MSC=10

I: Bus=0003 Vendor=2659 Product=0001 Version=0001
N: Name="Sundtek Remote Control"
P: Phys=
S: Sysfs=/devices/virtual/input/input10
U: Uniq=
H: Handlers=sysrq rfkill kbd event7
B: PROP=0
B: EV=100017
B: KEY=fff 402001fffff000f 7ffffffffffffff ffffffff00000000 0 feffffffffffff ffffffffffffffff ffffffffffffffff fffffffffffffffe
B: REL=0
B: MSC=0

I: Bus=0003 Vendor=2659 Product=0001 Version=0001
N: Name="Sundtek Remote Control"
P: Phys=
S: Sysfs=/devices/virtual/input/input21
U: Uniq=
H: Handlers=sysrq rfkill kbd event6
B: PROP=0
B: EV=100017
B: KEY=fff 402001fffff000f 7ffffffffffffff ffffffff00000000 0 feffffffffffff ffffffffffffffff ffffffffffffffff fffffffffffffffe
B: REL=0
B: MSC=0

firefly

  • Newbie
  • *
  • Beiträge: 33
    • Profil anzeigen
Re: LIRC funktioniert nicht mehr
« Antwort #5 am: August 30, 2018, 03:15:14 Nachmittag »
Das Skript sollte eigentlich funktionieren - hat es auch jahrelang.
Wir können es ja Schritt für Schritt durchgehen:

was zeigt denn folgendes an bei Dir:
cat /proc/bus/input/devices

Wenn ich die Inhalte des Skriptes manuell ausfuehre, dann erhalte ich:

grep -A2 Sundtek /proc/bus/input/devices | grep Sysfs | sed 's#.*Sysfs=#/sys#g'
/sys/devices/virtual/input/input10
/sys/devices/virtual/input/input21

 ls ${INPUTPATH}/event* -d | sed 's#.*event##g'
/sys/devices/virtual/input/input10
6

das [ -c  testet gegen "chacracter special"

Nur die Ziffer 6 ist kein file.

Anmerkung: Ich habe zwei Devices angschlossen.



Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 7826
    • Profil anzeigen
Re: LIRC funktioniert nicht mehr
« Antwort #6 am: August 30, 2018, 03:25:14 Nachmittag »
oh du hast 2 Tuner, da würde ich einen Fernbedienungsempfänger abschalten.

/opt/bin/mediaclient -e

dort wird dir die Seriennummer der Tuner angezeigt.

Erstelle folgende Datei mit der Referenz zu einem Tuner (irgendeine Seriennummer auswählen die Du abschalten möchtest). Die Seriennummer des Tuners ist im übrigen auch auf der Verpackung (Bubblebag) aufgedruckt, wir kleben das nicht auf den Tuner drauf da es unschön aussieht.

Das Skript funktioniert scheinbar nur mit einem Tuner, wir werden das heute noch nacharbeiten.

/etc/sundtek.conf

[SERIENNUMMER]
ir_disabled=1
Sundtek Support Engineer

firefly

  • Newbie
  • *
  • Beiträge: 33
    • Profil anzeigen
Re: LIRC funktioniert nicht mehr
« Antwort #7 am: August 30, 2018, 03:38:21 Nachmittag »
oh du hast 2 Tuner, da würde ich einen Fernbedienungsempfänger abschalten.

/opt/bin/mediaclient -e

dort wird dir die Seriennummer der Tuner angezeigt.

Erstelle folgende Datei mit der Referenz zu einem Tuner (irgendeine Seriennummer auswählen die Du abschalten möchtest). Die Seriennummer des Tuners ist im übrigen auch auf der Verpackung (Bubblebag) aufgedruckt, wir kleben das nicht auf den Tuner drauf da es unschön aussieht.

Das Skript funktioniert scheinbar nur mit einem Tuner, wir werden das heute noch nacharbeiten.

/etc/sundtek.conf

[SERIENNUMMER]
ir_disabled=1


Ich habe das Skript angepasst. Ist quick'n'dirty, Geht bestimmt eleganter.

#!/bin/bash

ls /dev > /dev/null # just to take care that the driver will start

echo "waiting 5 seconds..."
sleep 5

OLDIFS=$IFS
IFS="
"


INPUTPATH=`grep -A2 Sundtek /proc/bus/input/devices | grep Sysfs | sed 's#.*Sysfs=#/sys#g'`


for INPUT in ${INPUTPATH}
  do
    EVENT=`ls ${INPUT}/event* -d | sed 's#.*event##g'`
    EVENTFILE=/dev/input/event${EVENT}

    if [ -c $EVENTFILE ]; then
      echo "Sundtek IR Event: /dev/input/event${EVENT}"
    fi
  done

firefly

  • Newbie
  • *
  • Beiträge: 33
    • Profil anzeigen
Re: LIRC funktioniert nicht mehr
« Antwort #8 am: August 30, 2018, 03:48:03 Nachmittag »
oh du hast 2 Tuner, da würde ich einen Fernbedienungsempfänger abschalten.

/opt/bin/mediaclient -e

dort wird dir die Seriennummer der Tuner angezeigt.

/etc/sundtek.conf

[SERIENNUMMER]
ir_disabled=1

Habe ich gemacht:

mediaclient -e
**** List of Media Hardware Devices ****
device 0: [Sundtek SkyTV Ultimate 5]  DVB-S/S2, ANALOG-TV, REMOTE-CONTROL, OSS-AUDIO
  [INFO]:
     STATUS: ACTIVE
  [BUS]:
     ID: 1-7
  [SERIAL]:
     ID: U151103174508
  [DVB-S/S2]:
     FESTATUS: ACTIVE
     LNBVOLTAGE: ENABLED
     LNBSUPPLY: ACADAPTER
     LNBSTATUS: OK
     FRONTEND: /dev/dvb/adapter0/frontend0
     DVR: /dev/dvb/adapter0/dvr0
     DMX: /dev/dvb/adapter0/demux0
  [ANALOG-TV]:
     VIDEO0: /dev/video0
     VBI0: /dev/vbi0
  [REMOTECONTROL]:
     INPUT0: /dev/mediainput0
  [OSS]:
     OSS0: /dev/dsp0

device 1: [Sundtek SkyTV Ultimate 5]  DVB-S/S2, ANALOG-TV, REMOTE-CONTROL, OSS-AUDIO
  [INFO]:
     STATUS: ACTIVE
  [BUS]:
     ID: 1-8
  [SERIAL]:
     ID: U151229185014
  [DVB-S/S2]:
     FESTATUS: ACTIVE
     LNBVOLTAGE: ENABLED
     LNBSUPPLY: USBPOWER
     LNBSTATUS: OK
     FRONTEND: /dev/dvb/adapter1/frontend0
     DVR: /dev/dvb/adapter1/dvr0
     DMX: /dev/dvb/adapter1/demux0
  [ANALOG-TV]:
     VIDEO0: /dev/video1
     VBI0: /dev/vbi1
  [REMOTECONTROL]:
     INPUT0: /dev/mediainput1
  [OSS]:
     OSS0: /dev/dsp1


cat /etc/sundtek.conf
[U151229185014]
ir_disabled=1

Alle mediasrv Prozesse beendet und mit /opt/bin/mediasrv -d --pluginpath=/opt/bin erneut gestartet.
Dennoch sind beide IR aktiv.

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 7826
    • Profil anzeigen
Re: LIRC funktioniert nicht mehr
« Antwort #9 am: August 30, 2018, 04:03:18 Nachmittag »
Es wird angezeigt da der Tuner es unterstützt aber es werden dort vom "ausgeschalteten" Empfänger keine Infrarot-Daten mehr weitergeleitet.

Der Treiber muss nach dem Konfigurationsupdate neu gestartet werden. Als root /opt/bin/mediaclient --shutdown; /opt/bin/mediaclient --start
Sundtek Support Engineer

firefly

  • Newbie
  • *
  • Beiträge: 33
    • Profil anzeigen
Re: LIRC funktioniert nicht mehr
« Antwort #10 am: August 31, 2018, 01:05:47 Nachmittag »
Hallo,
Es wird angezeigt da der Tuner es unterstützt aber es werden dort vom "ausgeschalteten" Empfänger keine Infrarot-Daten mehr weitergeleitet.

Der Treiber muss nach dem Konfigurationsupdate neu gestartet werden. Als root /opt/bin/mediaclient --shutdown; /opt/bin/mediaclient --start

Trotz all dieser Massnahmen, funktioniert LIRC nicht.

Aug 31 12:57:13 nas systemd[1]: Starting lircd(8) initialization helper tool...
Aug 31 12:57:13 nas systemd[1]: Started lircd(8) initialization helper tool.
Aug 31 12:57:13 nas lircd-0.10.0[19723]: Info: lircd:  Opening log, level: Info
Aug 31 12:57:13 nas lircd-0.10.0[19723]: Notice: Version: lircd 0.10.0
Aug 31 12:57:13 nas lircd[19723]: lircd-0.10.0[19723]: Info: lircd:  Opening log, level: Info
Aug 31 12:57:13 nas lircd[19723]: lircd-0.10.0[19723]: Warning: Running as root
Aug 31 12:57:13 nas lircd-0.10.0[19723]: Notice: System info: Linux nas 4.15.0-33-generic #36-Ubuntu SMP Wed Aug 15 16:00:05 UTC
Aug 31 12:57:13 nas lircd-0.10.0[19723]: Info: Initial device: auto
Aug 31 12:57:13 nas lircd-0.10.0[19723]: Info: Initial device: auto
Aug 31 12:57:13 nas lircd-0.10.0[19723]: Notice: Options: driver: devinput
Aug 31 12:57:13 nas lircd-0.10.0[19723]: Notice: Options: output: /var/run/lirc/lircd
Aug 31 12:57:13 nas lircd-0.10.0[19723]: Notice: Options: nodaemon: 1
Aug 31 12:57:13 nas lircd-0.10.0[19723]: Notice: Options: plugindir: /usr/lib/x86_64-linux-gnu/lirc/plugins
Aug 31 12:57:13 nas lircd-0.10.0[19723]: Notice: Options: logfile: syslog
Aug 31 12:57:13 nas lircd-0.10.0[19723]: Notice: Options: immediate-init: 0
Aug 31 12:57:13 nas lircd-0.10.0[19723]: Notice: Options: permission: 666
Aug 31 12:57:13 nas lircd-0.10.0[19723]: Notice: Options: driver-options:
Aug 31 12:57:13 nas lircd-0.10.0[19723]: Notice: Options: pidfile: /var/run/lirc/lircd.pid
Aug 31 12:57:13 nas lircd-0.10.0[19723]: Notice: Options: listen: 0
Aug 31 12:57:13 nas lircd-0.10.0[19723]: Notice: Options: connect: (null)
Aug 31 12:57:13 nas lircd-0.10.0[19723]: Notice: Options: userelease: 0
Aug 31 12:57:13 nas lircd-0.10.0[19723]: Notice: Options: effective_user: (null)
Aug 31 12:57:13 nas lircd-0.10.0[19723]: Notice: Options: release_suffix: _EVUP
Aug 31 12:57:13 nas lircd-0.10.0[19723]: Notice: Options: allow_simulate: 0
Aug 31 12:57:13 nas lircd-0.10.0[19723]: Notice: Options: repeat_max: 600
Aug 31 12:57:13 nas lircd-0.10.0[19723]: Notice: Options: configfile: /etc/lirc/lircd.conf
Aug 31 12:57:13 nas lircd-0.10.0[19723]: Notice: Options: dynamic_codes: (null)
Aug 31 12:57:13 nas lircd-0.10.0[19723]: Notice: Current driver: devinput
Aug 31 12:57:13 nas lircd-0.10.0[19723]: Notice: Driver API version: 4
Aug 31 12:57:13 nas lircd-0.10.0[19723]: Notice: Driver  version: 0.10.0
Aug 31 12:57:13 nas lircd-0.10.0[19723]: Notice: Driver  info: See file:///usr/share/doc/lirc/plugindocs/devinput.html
Aug 31 12:57:13 nas lircd-0.10.0[19723]: Info: lircd:  Opening log, level: Info
Aug 31 12:57:13 nas lircd-0.10.0[19723]: Warning: Running as root
Aug 31 12:57:13 nas lircd[19723]: lircd-0.10.0[19723]: Info: Using remote: SundtekRemoteV3.conf.
Aug 31 12:57:13 nas lircd[19723]: lircd-0.10.0[19723]: Notice: lircd(devinput) ready, using /var/run/lirc/lircd
Aug 31 12:57:13 nas lircd-0.10.0[19723]: Info: Using remote: SundtekRemoteV3.conf.
Aug 31 12:57:13 nas lircd-0.10.0[19723]: Notice: lircd(devinput) ready, using /var/run/lirc/lircd
Aug 31 12:57:15 nas vdr: [19712] reconnected to lircd
Aug 31 12:57:15 nas lircd-0.10.0[19723]: Notice: accepted new client on /var/run/lirc/lircd
Aug 31 12:57:15 nas lircd[19723]: lircd-0.10.0[19723]: Notice: accepted new client on /var/run/lirc/lircd
Aug 31 12:57:15 nas lircd[19723]: lircd-0.10.0[19723]: Info: initializing 'auto'
Aug 31 12:57:15 nas lircd[19723]: lircd-0.10.0[19723]: Cannot run glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*: No such file or
Aug 31 12:57:15 nas lircd[19723]: lircd-0.10.0[19723]: Notice: No input device available for devinput driver. Consider stopping l
Aug 31 12:57:15 nas lircd[19723]: lircd-0.10.0[19723]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
Aug 31 12:57:15 nas lircd[19723]: lircd-0.10.0[19723]: Warning: Failed to initialize hardware
Aug 31 12:57:15 nas lircd-0.10.0[19723]: Info: initializing 'auto'
Aug 31 12:57:15 nas lircd-0.10.0[19723]: Cannot run glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*: No such file or directory
Aug 31 12:57:15 nas lircd-0.10.0[19723]: Notice: No input device available for devinput driver. Consider stopping lircd.socket or
Aug 31 12:57:15 nas lircd-0.10.0[19723]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
Aug 31 12:57:15 nas lircd-0.10.0[19723]: Warning: Failed to initialize hardware
Aug 31 12:57:16 nas lircd[19723]: lircd-0.10.0[19723]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
Aug 31 12:57:16 nas lircd-0.10.0[19723]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
Aug 31 12:57:17 nas lircd[19723]: lircd-0.10.0[19723]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
Aug 31 12:57:17 nas lircd-0.10.0[19723]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
Aug 31 12:57:18 nas lircd[19723]: lircd-0.10.0[19723]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
Aug 31 12:57:18 nas lircd-0.10.0[19723]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
Aug 31 12:57:19 nas lircd[19723]: lircd-0.10.0[19723]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
Aug 31 12:57:19 nas lircd-0.10.0[19723]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
Aug 31 12:57:20 nas lircd[19723]: lircd-0.10.0[19723]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
Aug 31 12:57:20 nas lircd-0.10.0[19723]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
Aug 31 12:57:21 nas lircd[19723]: lircd-0.10.0[19723]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
Aug 31 12:57:21 nas lircd-0.10.0[19723]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
Aug 31 12:57:22 nas lircd[19723]: lircd-0.10.0[19723]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*
Aug 31 12:57:22 nas lircd-0.10.0[19723]: Error: Cannot glob /sys/class/rc/rc0/input[0-9]*/event[0-9]*

Von dem angegeben Pfad "/sys/class/rc/rc0/input[0-9]*/event[0-9]*" exisitert schon das rc nach class nicht.

Die /etc/lirc/hardware.conf sieht jetzt so aus:

REMOTE="Linux input layer (/dev/input/eventX)"
REMOTE_MODULES=""
REMOTE_DRIVER="devinput"
REMOTE_DEVICE=/dev/input/event5
REMOTE_SOCKET=""
REMOTE_LIRCD_CONF="devinput/lircd.conf.devinput"
REMOTE_LIRCD_ARGS=""
TRANSMITTER="Custom"
TRANSMITTER_MODULES=""
TRANSMITTER_DRIVER=""
TRANSMITTER_DEVICE=""
TRANSMITTER_SOCKET=""
TRANSMITTER_LIRCD_CONF=""
TRANSMITTER_LIRCD_ARGS=""
START_LIRCD="true"
LOAD_MODULES="true"
LIRCMD_CONF=""
FORCE_NONINTERACTIVE_RECONFIGURATION="false"
START_LIRCMD=""

Das "angepasste getinput Skript liefert:

Sundtek IR Event: /dev/input/event5
Sundtek IR Event: /dev/input/event6


Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 7826
    • Profil anzeigen
Re: LIRC funktioniert nicht mehr
« Antwort #11 am: September 10, 2018, 11:14:58 Nachmittag »
dort sollten keine 2 Zeilen ausgegeben werden, das Skript überschreibt die Konfiguration jedes mal.
Wenn der Stick neu angeschlossen wird könnten sich die Nodenamen verändern daher wird die Konfiguration erneut erstellt.

Wenn Du damit noch Probleme hast kannst Du dich ja im Chat melden

https://support.sundtek.de/chat.php
Sundtek Support Engineer