Autor Thema: Leipzig: DVB-T private mpeg4  (Gelesen 7568 mal)

fsdjk

  • Newbie
  • *
  • Beiträge: 11
    • Profil anzeigen
Leipzig: DVB-T private mpeg4
« am: Januar 03, 2010, 10:36:16 Nachmittag »
Hallo,

ich habe jetzt gelesen, dass im Raum Leipzig die RTL Gruppe Sender über DVB-T ausstahlt. Diese sind aber mpeg4 codiert und man benötigt einen speziellen Receiver.

Zitat
Für den Empfang dieses innovativen Programmangebots benötigen Zuschauer einen MPEG 4-tauglichen DVB-T-Receiver, der das Verschlüsselungssystem Conax verarbeiten kann. ... Mit dem Einsatz des Komprimierungsverfahrens MPEG-4 lassen sich verfügbare DVB-T-Frequenzen wesentlich effizienter und wirtschaftlicher nutzen.1

Zitat
*** Zum Empfang dieser Programme braucht man einen speziellen DVB-T-Receiver2

Meine Fragen:
1. Braucht man dafür wirklich eine neue Hardware oder kann das per Software gelöst werden?
2. Wäre das dann eine Aufgabe für den Treiber oder für die Applikation die das Bild darstellt?
3. Ist von Ihnen eine Erweiterung möglich bzw. geplannt? Und was kommt dabei auf mich zu?

Vielen Dank und Gruß.

Quellen:
1 http://kommunikation.rtl.de/de/pub/aktuell/pressemitteilungen/detail_pressemitteilung.cfm?subpageobject_ID=15202&subpagenumber=1
2 http://www.dvbt-mitteldeutschland.de/index.php?content=Programme

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8357
    • Profil anzeigen
Re:Leipzig: DVB-T private mpeg4
« Antwort #1 am: Januar 04, 2010, 03:37:43 Nachmittag »
Leipzig/Halle scheint MPEG4 ueber DVB-T zu verwenden (nicht ueber DVB-T2). Dies sollte mit dem derzeitigen Geraet kein Problem darstellen.
Mit mplayer wird man diesen Datenstrom auf jeden Fall abspielen koennen, bei anderen freien Applikationen muesste es getestet werden.
Sofern Sie uns einen Sample Kanal aus Leipzig zur Verfuegung stellen koennen, koennen wir Ihnen auch mehr Informationen geben wie sie diese Sender abspielen koennen.

Hierfuer koennen Sie auch unseren Support via Skype kontaktieren (sundtek)
Failure is a good thing! I'll fix it

fsdjk

  • Newbie
  • *
  • Beiträge: 11
    • Profil anzeigen
Re:Leipzig: DVB-T private mpeg4
« Antwort #2 am: Februar 14, 2010, 10:28:09 Nachmittag »
Hallo,

jetzt hatte ich mal wieder Zeit zum Testen. Leider komme ich mit der Erstellung der Senderliste nicht zurecht. Folgendes habe ich ausgeführt:

/opt/bin/mediaclient -D DVBT
Using device: /dev/dvb/adapter0/frontend0
Setting Frontend Properties to: DVBT
Done.

./w_scan -f t -c DE > channels.conf.dvbt                     
ERROR: ld.so: object '/opt/lib/libmediaclient.so' from /etc/ld.so.preload cannot be preloaded: ignored.
w_scan version 20091230 (compiled for DVB API 5.0)                                                     
using settings for GERMANY                                                                             
DVB aerial                                                                                             
DVB-T Europe                                                                                           
frontend_type DVB-T, channellist 4                                                                     
output format vdr-1.6                                                                                 
Info: using DVB adapter auto detection.                                                               
main:2911: FATAL: ***** NO USEABLE DVB CARD FOUND. *****                                               
Please check wether dvb driver is loaded and                                                           
verify that no dvb application (i.e. vdr) is running.

/opt/bin/mediaclient --lc
**** List of Media Clients ****                                   
/dev/dvb/adapter0/frontend0:                                     
  No client connected                                             
/dev/dvb/adapter0/dvr0:                                           
  No client connected                                             
/dev/dvb/adapter0/demux0:                                         
  No client connected                                             
/dev/video1:                                                     
  No client connected                                             
/dev/vbi0:                                                       
  No client connected                                             
/dev/radio0:                                                     
  No client connected                                             
/dev/rds0:                                                       
  No client connected                                             
/dev/mediainput0:                                                 
  No client connected                                             
/dev/dsp0:                                                       
  No client connected

Treiberversion war 091130 und jetzt ist sie 100211. OS = Suse 11.1 mit KDE4.

Der Kaffein interne scan funktioniert, den habe ich nur bei 21% abgebrochen weil es recht lange gedauert hat.

Kann mir jemand sagen was ich falsch mache?

Dank und Gruß.

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8357
    • Profil anzeigen
Re:Leipzig: DVB-T private mpeg4
« Antwort #3 am: Februar 14, 2010, 10:31:18 Nachmittag »
Sie verwenden warscheinlich das 32bit w_scan Tool mit dem 64bit System.
Um w_scan verwenden zu koennen muessen Sie entweder das 64bit w_scan Paket fuer Ihre Distribution installieren oder w_scan selber kompilieren.
Failure is a good thing! I'll fix it

fsdjk

  • Newbie
  • *
  • Beiträge: 11
    • Profil anzeigen
Re:Leipzig: DVB-T private mpeg4
« Antwort #4 am: März 11, 2010, 10:15:23 Nachmittag »
Vielen Dank, das war es. Ich habe jetzt eine channels.conf aber mplayer tut immernoch nicht so wie ich es gern hätte.

Der Ton kommt normal aber das Bild in Zeitlupe.

/opt/bin/mediaclient -m DVBC -f 113000000 -S 6900000 -M Q64
cat /dev/dvb/adapter0/dvr0 | mplayer -cache 10240 -
erzeut folgende Ausgabe:
MPlayer dev-SVN-r29796-4.3-openSUSE Linux 11.1 (x86_64)-Packman (C) 2000-2009 MPlayer TeamCan't open joystick device /dev/input/js0: No such file or directory                                                                          
Can't init input joystick                                                                                          
mplayer: could not connect to socket                                                                                
mplayer: No such file or directory                                                                                  
Failed to open LIRC support. You will not be able to use your remote control.                                      

Playing -.
Reading from stdin...
Cache fill: 19.77% (2072576 bytes)  
TS file format detected.            
VIDEO MPEG2(pid=601) AUDIO MPA(pid=602) SUB Teletext(pid=604)  PROGRAM N. 28111
VIDEO:  MPEG2  720x576  (aspect 3)  25.000 fps  15000.0 kbps (1875.0 kbyte/s)  
Failed to open VDPAU backend libvdpau_nvidia.so: cannot open shared object file: No such file or directory
[vdpau] Error when calling vdp_device_create_x11: 1                                                      
==========================================================================                                
Opening video decoder: [mpegpes] MPEG 1/2 Video passthrough                                              
Could not find matching colorspace - retrying with -vf scale...                                          
Opening video filter: [scale]                                                                            
The selected video_out device is incompatible with this codec.                                            
Try appending the scale filter to your filter list,                                                      
e.g. -vf spp,scale instead of -vf spp.                                                                    
VDecoder init failed :(                                                                                  
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family                                          
Unsupported PixelFormat -1                                                                                
Selected video codec: [ffmpeg2] vfm: ffmpeg (FFmpeg MPEG-2)                                              
==========================================================================                                
==========================================================================                                
Opening audio decoder: [mp3lib] MPEG layer-2, layer-3                                                    
AUDIO: 48000 Hz, 2 ch, s16le, 192.0 kbit/12.50% (ratio: 24000->192000)                                    
Selected audio codec: [mp3] afm: mp3lib (mp3lib MPEG layer-2, layer-3)                                    
==========================================================================                                
AO: [oss] 48000Hz 2ch s16le (2 bytes per sample)
Starting playback...
Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
VO: [xv] 720x576 => 1024x576 Planar YV12
A:11477.1 V:11462.9 A-V: 14.248 ct: -0.200  51/ 51 40%  2% 804.2% 50 0 0%

           ************************************************
           **** Your system is too SLOW to play this!  ****
           ************************************************

Possible reasons, problems, workarounds:
- Most common: broken/buggy _audio_ driver
  - Try -ao sdl or use the OSS emulation of ALSA.
  - Experiment with different values for -autosync, 30 is a good start.
- Slow video output
  - Try a different -vo driver (-vo help for a list) or try -framedrop!
- Slow CPU
  - Don't try to play a big DVD/DivX on a slow CPU! Try some of the lavdopts,
    e.g. -vfm ffmpeg -lavdopts lowres=1:fast:skiploopfilter=all.
- Broken file
  - Try various combinations of -nobps -ni -forceidx -mc 0.
- Slow media (NFS/SMB mounts, DVD, VCD etc)
  - Try -cache 8192.
- Are you using -cache to play a non-interleaved AVI file?
  - Try -nocache.
Read DOCS/HTML/en/video.html for tuning/speedup tips.
If none of this helps you, read DOCS/HTML/en/bugreports.html.

A:11488.5 V:11464.2 A-V: 24.244 ct: -0.332  84/ 84 29%  1% 820.0% 83 0 0%
Exiting... (Quit)

Vermutich ist das wieder ein ganz banaler Fehler von mir.

Achso ich versuche gerade den mplayer erst mit DVB-C zum laufen zu bekommen.

Zitat
Restricted Formats/Codecs Suse:
http://opensuse-community.org/Restricted_Formats/11.1
Das habe ich auch installiert.

System:
Lenovo T400
Intel(R) Core(TM)2 Duo CPU P8700 @ 2.53GHz
4GB RAM
Linux 2.6.27.42-0.1-default x86_64
openSUSE 11.1 (x86_64)
4.3.4 (KDE 4.3.4) "release 2"
ATI Mobility Radeon HD 3400 Series
Treiber: 2.1.8870

Oder ist das System tatsächlich zu langsam?

Nachtrag:
- mplayer analog
- tvtime analog
- kaffeine dvb-t und dvb-c
funktionieren.
« Letzte Änderung: März 11, 2010, 10:28:54 Nachmittag von fsdjk »

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8357
    • Profil anzeigen
Re:Leipzig: DVB-T private mpeg4
« Antwort #5 am: März 11, 2010, 10:26:19 Nachmittag »
Das System sollte hierfuer auf jeden Fall schnell genug sein. Haben Sie schon einmal kaffeine verwendet?
mplayer kann diese Meldung bringen falls der Sender eventuell keine optimale Signalqualitaet besitzt, zudem hat kaffeine auch eine einfachere Bedienung.
Failure is a good thing! I'll fix it

fsdjk

  • Newbie
  • *
  • Beiträge: 11
    • Profil anzeigen
Re:Leipzig: DVB-T private mpeg4
« Antwort #6 am: März 11, 2010, 10:31:41 Nachmittag »
Wow, das ging ja schnell. Hatte gerade noch Infos nachgetragen.

Den mplayer möchte ich zum laufen bekommen um dann mit DVB-T die die in Leipzig ausgestrahlen privaten zu empfangen. Noch habe ich meinen analogen Kabelanschluß.

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8357
    • Profil anzeigen
Re:Leipzig: DVB-T private mpeg4
« Antwort #7 am: März 11, 2010, 10:37:55 Nachmittag »
Sollte es Probleme mit dem MPlayer xvideo output geben versuchen Sie eventuell

Zitat
$ cat /dev/dvb/adapter0/dvr0 | mplayer -cache 10240 -vo x11 -

Folgender Befehl zeigt die verfuegbaren Videoplugins an:
Zitat
$ mplayer -vo help
MPlayer SVN-r30137-4.4.1 (C) 2000-2009 MPlayer Team
Available video output drivers:
   vdpau   VDPAU with X11
   xv   X11/Xv
   x11   X11 ( XImage/Shm )
   xover   General X11 driver for overlay capable video output drivers
   gl   X11 (OpenGL)
...
Failure is a good thing! I'll fix it