Autor Thema: Treiber-Bug Linux-Treiber vom 24.03.2015 (?!)  (Gelesen 2306 mal)

crawler

  • Newbie
  • *
  • Beiträge: 6
    • Profil anzeigen
Treiber-Bug Linux-Treiber vom 24.03.2015 (?!)
« am: April 06, 2015, 01:18:55 Nachmittag »
Hallo Sundtek,

ich habe einen extra Post zu meinem Problem in http://support.sundtek.com/index.php/topic,1848.0.html aufgemacht.

Kurz und knapp:
Mein System:

Cubietruck mit Debian Wheezy -> uname -a:
Linux cubie 3.4.61+ #2 SMP PREEMPT Sat Mar 8 11:16:50 UTC 2014 armv7l GNU/Linux

, VDR headless und Streamdev.
vdr (2.0.5/2.0.0) - The Video Disk Recorder
streamdev-server (0.6.1-git) - VDR Streaming Server

mediaclient -e:
**** List of Media Hardware Devices ****
device 0: [Sundtek SkyTV Ultimate IV]  DVB-S/S2, ANALOG-TV, REMOTE-CONTROL, OSS-AUDIO
  [INFO]:
     STATUS: ACTIVE
  [BUS]:
     ID: 2-1
  [SERIAL]:
     ID: U140919020324
  [DVB-S/S2]:
     FESTATUS: ACTIVE
     LNBVOLTAGE: ENABLED
     LNBSUPPLY: ACADAPTER
     LNBSTATUS: OK
     FRONTEND: /dev/dvb/adapter0/frontend0
     DVR: /dev/dvb/adapter0/dvr0
     DMX: /dev/dvb/adapter0/demux0
  [ANALOG-TV]:
     VIDEO0: /dev/video0
     VBI0: /dev/vbi0
  [REMOTECONTROL]:
     INPUT0: /dev/mediainput0
  [OSS]:
     OSS0: /dev/dsp0

Sundtek Linux-Treiber vom 24.03.2015.


Seit vier Tagen habe ich die SkyTV Ultimate IV auf diesem System im Einsatz und bekomme immer wieder Ausfälle der Karte, welche in einem "Frontend timed out" resultieren.

Zuvor hatte ich bei identischem System und Konfiguration eine TT4600USB laufen, unter welcher diese Probleme NIE aufgetreten sind, die Probleme begannen mit der SkyTV-Karte.

Hinzufügen muss ich noch, dass die Karte an einem Unicable-System hängt (SCR6, 1980).
Die Unicable-Konfig wird über den VDR vorgenommen (scr.conf) und hat bis zum Kartenwechsel auch einwandfrei funktioniert.

Am System / VDR kann es nicht liegen, daher wäre es sinnvoll, wenn man über mediaclient Debug-Infos während des Streamdev-Betriebs im Unicable-Mode erhalten könnte.

Auffällig ist, dass nach einem reboot und damit nach einem "reset" der Karte alles wieder funktioniert.


...mit der freundlichen Bitte um Hilfe :)

P.S.: lsusb -v :

...hätte ich gerne nachgereicht, ABER:
Fehler beim Schreiben des Beitrags.
Beitrag hat die max. Länge erreicht (20000 Zeichen).

What the ...?

...und eben wieder (14:16 Uhr):
Apr  6 14:16:02 cubie vdr: [2371] frontend 0/0 timed out while tuning to channel 23, tp 111836
Apr  6 14:16:03 cubie vdr: [2373] Streamdev: Accepted new client (HTTP) 192.168.1.55:50411
Apr  6 14:16:03 cubie vdr: [2490] streamdev-writer thread started (pid=2367, tid=2490, prio=high)
Apr  6 14:16:03 cubie vdr: [2491] streamdev-livestreaming thread started (pid=2367, tid=2491, prio=high)
Apr  6 14:16:05 cubie vdr: [2492] receiver on device 1 thread started (pid=2367, tid=2492, prio=high)
Apr  6 14:16:06 cubie vdr: [2493] TS buffer on device 1 thread started (pid=2367, tid=2493, prio=high)
Apr  6 14:16:16 cubie vdr: [2371] frontend 0/0 timed out while tuning to channel 1, tp 110743
Apr  6 14:16:23 cubie vdr: [2373] client (HTTP) 192.168.1.55:50411 has closed connection
Apr  6 14:16:23 cubie vdr: [2373] streamdev-server: closing HTTP connection to 192.168.1.55:50411
Apr  6 14:16:23 cubie vdr: [2491] streamdev-livestreaming thread ended (pid=2367, tid=2491)
Apr  6 14:16:23 cubie vdr: [2490] streamdev-writer thread ended (pid=2367, tid=2490)
Apr  6 14:16:23 cubie vdr: [2373] buffer stats: 0 (0%) used
Apr  6 14:16:23 cubie vdr: [2373] Streamdev: Accepted new client (HTTP) 192.168.1.55:50415
Apr  6 14:16:23 cubie vdr: [2495] streamdev-livestreaming thread started (pid=2367, tid=2495, prio=high)
Apr  6 14:16:23 cubie vdr: [2494] streamdev-writer thread started (pid=2367, tid=2494, prio=high)
Apr  6 14:16:24 cubie vdr: [2493] TS buffer on device 1 thread ended (pid=2367, tid=2493)
Apr  6 14:16:24 cubie vdr: [2492] buffer stats: 0 (0%) used
Apr  6 14:16:24 cubie vdr: [2492] receiver on device 1 thread ended (pid=2367, tid=2492)
Apr  6 14:16:24 cubie vdr: [2496] receiver on device 1 thread started (pid=2367, tid=2496, prio=high)
Apr  6 14:16:26 cubie vdr: [2497] TS buffer on device 1 thread started (pid=2367, tid=2497, prio=high)
Apr  6 14:16:33 cubie vdr: [2371] frontend 0/0 timed out while tuning to channel 24, tp 111836

mediaclient -e:
**** List of Media Hardware Devices ****
device 0: [Sundtek SkyTV Ultimate IV]  DVB-S/S2, ANALOG-TV, REMOTE-CONTROL, OSS-AUDIO
  [INFO]:
     STATUS: ACTIVE
  [BUS]:
     ID: 2-1
  [SERIAL]:
     ID: U140919020324
  [DVB-S/S2]:
     FESTATUS: ACTIVE
     LNBVOLTAGE: ENABLED
     LNBSUPPLY: ACADAPTER
     LNBSTATUS: OK
     FRONTEND: /dev/dvb/adapter0/frontend0
     DVR: /dev/dvb/adapter0/dvr0
     DMX: /dev/dvb/adapter0/demux0
  [ANALOG-TV]:
     VIDEO0: /dev/video0
     VBI0: /dev/vbi0
  [REMOTECONTROL]:
     INPUT0: /dev/mediainput0
  [OSS]:
     OSS0: /dev/dsp0

dmesg:
[   23.214588] usb 2-1: usbfs: process 775 (mediasrv) did not claim interface 0 before use
« Letzte Änderung: April 06, 2015, 02:20:31 Nachmittag von crawler »