Autor Thema: gnome-dvb-daemon scanning problem  (Gelesen 7071 mal)

Alfafa

  • Newbie
  • *
  • Beiträge: 5
    • Profil anzeigen
gnome-dvb-daemon scanning problem
« am: November 17, 2009, 10:47:39 Vormittag »
Hi

Right now I am testing the mediatv pro on some of my laptops before reinstalling my normal "media machine"

So I would try some of the more simple programs(eventually I will probably run mythtv)

One thing I find interesting is gnome-dvb-daemon with integration to Rygel(an upnp server - so I can see the dvb channels on my ps3)

But when gnome-dvb-daemon is scanning for channels it doesn't find anything. I can choose the Sundtek dvb-t device but the scanning doesn't find anything. Both the scan from dvb-tools and w_scan works without problems

Anyone have some experience with this? I will have to have a closer look at dvb-daemon to find out if it will read a channels.conf file or something like it from some secret place, but I fear it only will use "it's own scan"

Alfafa

  • Newbie
  • *
  • Beiträge: 5
    • Profil anzeigen
Re:gnome-dvb-daemon scanning problem
« Antwort #1 am: November 18, 2009, 10:49:26 Vormittag »
I also have problem scanning channels in me-tv(https://launchpad.net/me-tv) this is tested for dvb-t for now

I also notices when scanning channels in kaffeine that the signal level is quite low. Maybe that is the problem? (the picture fine though except for our "new" mpeg4 channels here in denmark where it was heavely stuttering both video and audio)

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8034
    • Profil anzeigen
Re:gnome-dvb-daemon scanning problem
« Antwort #2 am: November 18, 2009, 01:50:56 Nachmittag »
We will check this, currently we are preparing another update which should be released within this week.

Your messages will be checked at the beginning of next week.
Failure is a good thing! I'll fix it

JiiP

  • Newbie
  • *
  • Beiträge: 4
    • Profil anzeigen
Re:gnome-dvb-daemon scanning problem
« Antwort #3 am: November 19, 2009, 11:52:55 Nachmittag »
Hi,

I am experienced same kind of problem for months now. Every new driver update is getting me closer to see tv with ubuntu. I have tried the stick in two computers (NC10 netbook and desktop, both with ubuntu karmic) and I have a cable tv.

I have had my best luck with Kaffeine, which has found plenty of channels. Unfortunately most of these are crypted. I can see about five free channels which are not the main operators channels in Finland. I have noticed same thing that signal strength is low eventhough my cable systems are okay and signal is strong for real. When I use win XP and free version of ProgDVB software I can see all free channels which I should be seeing. Signal is 100% in every channel. Howerver, in this circumstance I had a little bit trouble to scan the channels with progDVB's normal way but eventually I succeeded by using generalised scanning.

I have troubles also with Me-TV. Scanning is difficult - sometimes it works partly sometimes not. I have also tried other suggested softwares with no luck.

I got feeling that problems might be caused by somekind of differences in DVB standard between countries? Here we have mainly QAM128 and also QAM256. Could it be that driver is somehow inaccurate or "out of tune" with some specifications and that is the reason for poor signal?

Hopefully you can spot the problem.

Alfafa

  • Newbie
  • *
  • Beiträge: 5
    • Profil anzeigen
Re:gnome-dvb-daemon scanning problem
« Antwort #4 am: November 22, 2009, 10:26:08 Nachmittag »
Ok. I have some more scanning related problems. This time with dvb-c(Which is actually what I am planning to use most)

I can scan some channels, but there is a lot of channels where i just get lines like this when using the scan tool from dvb-utils:

0x0000 0x0065: pmt_pid 0x0065 (null) -- DR1 (???)

But I also get this for the same channel

0x0000 0x073a: pmt_pid 0x0000 (null) -- DR1 (running)


I think the first one is the mpeg4 and second(which is working) the mpeg2

So somehow scanning doesn't work with mpeg4 here in denmark(it was also mpeg4 failing whe I used dvb-t)

Hope this info can used to somehow make the driver work. I will have to check. I had these channels working with a technotrend card with dvbviewer under windows...maybe I should check with dvbviewer and the sundtek using windows(but I would have to restore windows then)

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8034
    • Profil anzeigen
Re:gnome-dvb-daemon scanning problem
« Antwort #5 am: November 23, 2009, 03:23:46 Nachmittag »
We think this is mostly a problem of your client. We also had some mixed experience with mpeg-4 streams.
But so far as we requested by mail maybe you can provide a sample of this channel so we can verify this mpeg-4 format.
Failure is a good thing! I'll fix it

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8034
    • Profil anzeigen
Re:gnome-dvb-daemon scanning problem
« Antwort #6 am: November 27, 2009, 07:11:18 Vormittag »
What system do you use? We tried to set it up with Ubuntu 9.04 and 9.10 and failed due unsolved dependencies. gnome-dvb-daemon seems to be rather new, but surely we can have a look at it.
Failure is a good thing! I'll fix it

Alfafa

  • Newbie
  • *
  • Beiträge: 5
    • Profil anzeigen
Re:gnome-dvb-daemon scanning problem
« Antwort #7 am: November 27, 2009, 04:26:52 Nachmittag »
For dvb-daemon I used archlinux, but I also have problems with mythtv both on mythbuntu and arch. Maybe the problem is my cable provider