Autor Thema: ME-TV  (Gelesen 16367 mal)

kalibari

  • Gast
ME-TV
« am: November 07, 2009, 01:57:58 Nachmittag »
Hallo! Ich bekomme ME-TV 1.0.0 mit DVB-C nicht zum Laufen. Kann mir Jemand einen Tipp geben wie ich die channels.conf importieren oder erstellen kann?
Beides funktioniert bei mir nicht obwohl ich den USB-TV-Stick auf "opt/bin/mediaclient -D DVBC" eingestellt hab.
Wenn ich einen Sendersuchlauf starte (dvb-c de-Kabel_BW), werden keine Sender gefunden. Wenn ich eine erstellte channels.conf versuche zu importieren (erstellt mit w_scan UTF-8), bekomme ich den Fehler:
"Fehler: Invalid parameter count on line 1"

kalibari

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8317
    • Profil anzeigen
Re:ME-TV
« Antwort #1 am: November 07, 2009, 03:00:52 Nachmittag »
welchen w_scan Parameter haben Sie zum scannen verwendet?
Failure is a good thing! I'll fix it

kalibari

  • Gast
Re:ME-TV
« Antwort #2 am: November 07, 2009, 03:51:33 Nachmittag »
Hallo! w_scan -f c -c DE > channels.conf.dvbc

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8317
    • Profil anzeigen
Re:ME-TV
« Antwort #3 am: November 07, 2009, 04:00:51 Nachmittag »
Das wird so nicht funktionieren, da die Channelfile dann für VDR gemacht wird,

w_scan --help
-X tzap/czap/xine output instead of vdr channels.conf
Failure is a good thing! I'll fix it

kalibari

  • Gast
Re:ME-TV
« Antwort #4 am: November 07, 2009, 05:06:23 Nachmittag »
Danke, jetzt bin ich schon einen Schritt weiter. Die Senderliste konnte ich importieren.
Es funktioniert aber noch nicht. Ich bekomme folgenden Fehler:
me-tv --verbose
Me TV 1.0.0
07.11.2009 15:49:36: Scanning DVB devices ...
07.11.2009 15:49:36: Opening frontend device: /dev/dvb/adapter0/frontend0
07.11.2009 15:49:36: Closing frontend device: /dev/dvb/adapter0/frontend0
07.11.2009 15:49:36: Database 'exists'
07.11.2009 15:49:36: Opening database file '/home/martin/.me-tv/me-tv.db'
07.11.2009 15:49:36: Application constructor
07.11.2009 15:49:36: sqlite3_threadsafe() = 1
07.11.2009 15:49:36: Loading GtkBuilder file '/usr/share/me-tv/glade/me-tv.ui' ...
.
.
.
07.11.2009 15:50:01: Channel changed to n-tv(RTL)
07.11.2009 15:50:02: Changing channel to RTL 2(RTL)
07.11.2009 15:50:02: Stopping engine
07.11.2009 15:50:02: Engine stopped
07.11.2009 15:50:02: Thread 'Stream' created
07.11.2009 15:50:02: Creating StreamThread
07.11.2009 15:50:02: StreamThread created
07.11.2009 15:50:02: Removing demuxers
07.11.2009 15:50:03: Auf Signalsperre warten …
07.11.2009 15:50:03: Signalsperre erhalten
07.11.2009 15:50:03: Exception: Auslesen des Headers fehlgeschlagen
07.11.2009 15:50:03: Destroying StreamThread
07.11.2009 15:50:03: Removing demuxers
07.11.2009 15:50:03: StreamThread destroyed
07.11.2009 15:50:03: Error message: 'Auslesen des Headers fehlgeschlagen'
07.11.2009 15:50:04: Updating EPG
07.11.2009 15:50:04: EPG update complete
07.11.2009 15:50:04: Channel changed to RTL 2(RTL)

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8317
    • Profil anzeigen
Re:ME-TV
« Antwort #5 am: November 07, 2009, 08:07:16 Nachmittag »
Ist der Sender eventuell verschlüsselt?

Kaffeine ist einfach zu verwenden und zeigt auch ob die Sender verschlüsselt sind.
Failure is a good thing! I'll fix it

kalibari

  • Gast
Re:ME-TV
« Antwort #6 am: November 07, 2009, 11:05:58 Nachmittag »
Der Sender ist nicht verschlüsselt. Es funktioniert gar kein Sender. Kaffeine funktioniert auch nicht. Der Sendersuchlauf geht zwar, aber es fehlt Bild und Ton. Ich hab allerdings nicht weiter gesucht, da mir Me-TV unter Gnome besser gefällt.

Mit Kaffeine bekomme ich folgenden Fehler:
kbuildsycoca running...
/dev/dvb/adapter0/frontend0 : opened ( Sundtek DVB-C )
0 EPG plugins loaded for device 0:0.
Loaded epg data : 922 events (22 msecs)
Tuning to: VOX / autocount: 0
DvbCam::probe(): /dev/dvb/adapter0/ca0: : Datei oder Verzeichnis nicht gefunden
Using DVB device 0:0 "Sundtek DVB-C"
tuning DVB-C to 113000000
inv:2 sr:6900000 fecH:0 mod:3
. LOCKED.
NOUT: 1
dvbEvents 0:0 started
Tuning delay: 624 ms
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
[martin@intel2200 Desktop]$ EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
pipe opened
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
demux_wavpack: (open_wv_file:127) open_wv_file: non-seekable inputs aren't supported yet.
xine pipe opened /home/martin/.kaxtv.ts
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)
EIT (0:0) : buffer overflow! Rejected
Stop parsing EIT (0:0)

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8317
    • Profil anzeigen
Re:ME-TV
« Antwort #7 am: November 07, 2009, 11:39:01 Nachmittag »
was zeigt:

/opt/bin/mediaclient --build
an?

Ebenfalls was für eine Distribution, Architektur wird denn verwendet?

Sind die Codecs ebenfalls installiert (MPEG2)?
« Letzte Änderung: November 07, 2009, 11:45:27 Nachmittag von Sundtek »
Failure is a good thing! I'll fix it

kalibari

  • Gast
Re:ME-TV
« Antwort #8 am: November 08, 2009, 12:41:43 Nachmittag »
OK. Kaffeine läuft jetzt auch. Es hat tatsächlich noch ein Codec gefehlt (unter Fedora 11 i686 xine-lib-extras-freeworld). Ich verwende den neusten Treiber vom Nov  3 2009. ME-TV läuft noch nicht, allerdings bekomme ich nächste Woche ein neues Notebook und werde dann wieder Debian verwenden und es dann nochmal versuchen. Danke

kalibari

  • Gast
Re:ME-TV
« Antwort #9 am: November 21, 2009, 10:21:43 Nachmittag »
Den selben Fehler bei ME-TV konnte ich jetzt auch unter Ubuntu reproduzieren.

user@ubuntu:~/Desktop$ /opt/bin/mediaclient --build
Build date: Nov  3 2009
user@ubuntu:~/Desktop$ uname -r
2.6.31-14-generic

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8317
    • Profil anzeigen
Re:ME-TV
« Antwort #10 am: November 22, 2009, 12:28:22 Vormittag »
Koennten Sie den letzten Treiber diesbezueglich testen?
Failure is a good thing! I'll fix it

kalibari

  • Gast
Re:ME-TV
« Antwort #11 am: November 22, 2009, 04:12:58 Nachmittag »
Ich habe das selbe Problem auch mit dem Treiber vom 09 November. Allerdings kommt noch hinzu, dass Pulseaudio dann nicht mehr funktioniert.
tail /var/log/messages

Nov 22 17:48:23 intel4100 pulseaudio[1822]: protocol-native.c: Denied access to client with invalid authorization data.
Nov 22 17:48:28 intel4100 pulseaudio[1822]: protocol-native.c: Denied access to client with invalid authorization data.
Nov 22 17:48:28 intel4100 pulseaudio[1822]: protocol-native.c: Denied access to client with invalid authorization data.
Nov 22 17:48:33 intel4100 pulseaudio[1822]: protocol-native.c: Denied access to client with invalid authorization data.

« Letzte Änderung: November 22, 2009, 08:43:54 Nachmittag von kalibari »

Doesbaddel

  • Newbie
  • *
  • Beiträge: 4
    • Profil anzeigen
Re:ME-TV
« Antwort #12 am: Dezember 02, 2009, 07:03:01 Nachmittag »
Bei mir findet Me-TV auch keine Sender (ohne Fehlermeldung).
Kaffeine läuft prima, findet auch die Sender.
w_scan kennt die DVB-API 5.1 noch nicht.
scan findet die Sender, die channel.conf lässt sich aber nicht in Me-TV importieren.

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8317
    • Profil anzeigen
Re:ME-TV
« Antwort #13 am: Dezember 02, 2009, 07:14:12 Nachmittag »
Das Pulseaudio Problem von kalibari sollte mittlerweile behoben sein.

Zitat
w_scan kennt die DVB-API 5.1 noch nicht.

Wir werden eine Option hinzufuegen um die API Nummer intern auf andere Werte zu stellen.
Es gibt keinen Grund warum w_scan mit DVB-API 5.1 nicht funktionieren sollte, zudem die API rueckwaerts kompatibel ist. Dies ist eher eine restriktion des w_scan Entwicklers.

Zitat
Bei mir findet Me-TV auch keine Sender (ohne Fehlermeldung).

Ist das Geraet auf den richtigen Modus konfiguriert? Werden die richtigen Frequenzen gescannt?
ME-TV verwendet das Commandline "dvbscan" bzw "scan" Tool um nach Sendern zu suchen, da wir dieses Tool auch regelmaessig verwenden sollte dies eigentlich problemlos funktionieren.
Failure is a good thing! I'll fix it

Doesbaddel

  • Newbie
  • *
  • Beiträge: 4
    • Profil anzeigen
Re:ME-TV
« Antwort #14 am: Dezember 02, 2009, 10:01:36 Nachmittag »
"Ist das Geraet auf den richtigen Modus konfiguriert"

Entsprechend der Anleitung habe ich das Gerät jedenfalls für Kaffeine richtig konfiguriert,
"/opt/bin/mediaclient --setdtvmode=DVBC"
die Frequenztabelle ist auch die gleiche wie bei Kaffeine

Dann habe ich die mit scan erstellte channel.conf importiert (jedenfalls einen Teil davon.) Damit werden Sender angezeigt, jedoch liefert nun Me-TV die Meldung.
"Auslesen des Headers fehlgeschlagen."

me-tv --verbose
Me TV 1.0.0
02.12.2009 21:02:09: Scanning DVB devices ...
02.12.2009 21:02:09: Opening frontend device: /dev/dvb/adapter0/frontend0
02.12.2009 21:02:09: Closing frontend device: /dev/dvb/adapter0/frontend0
02.12.2009 21:02:09: Database 'exists'
02.12.2009 21:02:09: Opening database file '/home/papa/.me-tv/me-tv.db'
02.12.2009 21:02:09: Application constructor
02.12.2009 21:02:09: sqlite3_threadsafe() = 1
02.12.2009 21:02:09: Loading GtkBuilder file '/usr/share/me-tv/glade/me-tv.ui' ...
02.12.2009 21:02:09: Application constructed
02.12.2009 21:02:09: Initialising table 'version'
02.12.2009 21:02:09: Required Database version: 2
02.12.2009 21:02:09: Actual Database version: 2
02.12.2009 21:02:09: Me TV database initialised successfully
02.12.2009 21:02:09: Opening frontend device: /dev/dvb/adapter0/frontend0
02.12.2009 21:02:09: Using 'Sundtek DVB-C' (/dev/dvb/adapter0/frontend0)
02.12.2009 21:02:09: Loading channels ...
02.12.2009 21:02:09: Loading channel 'SAT.1'
02.12.2009 21:02:09: Channel 'SAT.1' added
...
02.12.2009 21:02:52: Auf Signalsperre warten …
02.12.2009 21:02:52: Signalsperre erhalten
02.12.2009 21:02:52: Exception: Auslesen des Headers fehlgeschlagen
02.12.2009 21:02:52: Destroying StreamThread
02.12.2009 21:02:52: Removing demuxers
02.12.2009 21:02:52: StreamThread destroyed
02.12.2009 21:02:52: Error message: 'Auslesen des Headers fehlgeschlagen'
« Letzte Änderung: Dezember 02, 2009, 10:09:25 Nachmittag von Doesbaddel »