Autor Thema: QNAP mit tvheadend: Treiberproblem auf x86 NAS, ARM läuft  (Gelesen 5230 mal)

mcbyte

  • Newbie
  • *
  • Beiträge: 18
    • Profil anzeigen
QNAP mit tvheadend: Treiberproblem auf x86 NAS, ARM läuft
« am: März 27, 2014, 11:00:35 Nachmittag »
Hallo,

ich habe ein QNAP TS-219P+ mit zwei Sundteksticks DVB-S2 III mit tvheadend am Laufen - alles ist prima.

Nun bin ich umgestiegen auf ein TS-269L mit X86 CPU.
Gleiche tvheadend Version (3.5.126), nur eben für x86, aktuelle sundtek Treiber.
Die Settings von tvheadend gesichert und im neuen NAS wieder eingespielt, alle Muxes und Services sind da.
Nur kann ich nicht einen einzigen Sender empfangen, egal mit welchem Client. "NO service enabled"

Nach diesem Kommando kann ich dann alle Sender von diesem Transponder (z.B. ARD HD usw.) empfangen, mit allen Clients.

/opt/bin/mediaclient -m DVBS2 -f 11494000 -M 8PSK -S 22000000 -V H -E 2/3
.....
Checking for lock:
.. [LOCKED]

Wenn ich nun mit dem Client einen Sender eines anderen Transponders wähle, gleiche Fehlermelung.
Erst mit dem o.g. Kommando angepasst für die neue Transponderfrequenz geht es dann wieder.

Treiber auf dem neuen NAS (x86)
Build date: 2014-03-21 09:46:02

Treiber auf dem alten NAS (ARM)
Build date: 2014-03-12 15:13:57

Gruß
mcbyte




2 x Sundtek Sky TV Ultimate DVB-S2 (III)
an QNAP TS 219P+ mit TVHeadend
19,2E + 13,0E an Kreiling 9-16 MSK

mcbyte

  • Newbie
  • *
  • Beiträge: 18
    • Profil anzeigen
Re:QNAP mit tvheadend: Treiberproblem auf x86 NAS, ARM läuft
« Antwort #1 am: März 30, 2014, 06:15:14 Nachmittag »
noch ein Nachtrag:
auf dem ARM System habe ich den Treiber aktualisiert (buid date 21.03.2014) und es läuft genau so perfekt.

Auf dem x86 System habe ich die Tuner testhalber mal an USB 3.0 angeschlossen.
Gleiches Problem...

Gibt es hier jemand, bei dem tvheadend auf einem x86 QNAP mit Sundtek Ultimate problemlos läuft?

Habe nur noch eine Woche Rückgaberecht für das TS-269L.
Wenn das nicht läuft mit tvheadend, habe ich mit dem Umstieg ja nichts gewonnen...

Gruß
mcbyte
2 x Sundtek Sky TV Ultimate DVB-S2 (III)
an QNAP TS 219P+ mit TVHeadend
19,2E + 13,0E an Kreiling 9-16 MSK

mcbyte

  • Newbie
  • *
  • Beiträge: 18
    • Profil anzeigen
Re:QNAP mit tvheadend: Treiberproblem auf x86 NAS, ARM läuft
« Antwort #2 am: März 31, 2014, 11:04:37 Nachmittag »

Problem gelöst:

Mit der aktuellen tvheadend version 3.9.422 (qpkg version 0.7.1) klappt es nun auf dem TS-269L.
Allerdings nur mit der 64bit Version, die 32bit Version findet nur einen Bruchteil der Muxes.
Leider lassen sich die Settings aus der alten tvheadend Version nicht übernehmen, so dass ich alles neu einrichten musste.
Die ganze Verwaltung der Tuner hat sich hier grundlegend geändert.
Auch CAM Support funktioniert hier bestens.
Meine beiden Sundtek Tuner laufen sogar auch an den USB 3.0 Ports, was ja bei einigen Synology Modellen Probleme machen soll. Insgesamt habe ich nun 5 USB Ports zur Verfügung und kann nun noch 2 Tuner nachrüsten.
Das war mit ein Grund, warum ich wieder ein QNAP genommen habe, obwohl die Synos vom P/L Verhältnis besser sind.

Gruß
mcbyte






2 x Sundtek Sky TV Ultimate DVB-S2 (III)
an QNAP TS 219P+ mit TVHeadend
19,2E + 13,0E an Kreiling 9-16 MSK

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8387
    • Profil anzeigen
Re:QNAP mit tvheadend: Treiberproblem auf x86 NAS, ARM läuft
« Antwort #3 am: April 06, 2014, 12:00:37 Vormittag »
Hmm.. zwischen 32 und 64bit sollte es keine Unterschiede im Treiber geben.

/opt/bin/mediaclient --readsignal=0 -d /dev/dvb/adapter0/frontend0 --band UNIVERSAL zeigt dir an welcher Transponder bei DVB-S eingestellt ist.
Failure is a good thing! I'll fix it