Autor Thema: DVBC keine Sender / Analog kein Device  (Gelesen 4791 mal)

zappendappen

  • Newbie
  • *
  • Beiträge: 4
    • Profil anzeigen
DVBC keine Sender / Analog kein Device
« am: März 04, 2014, 05:03:41 Nachmittag »
Hi,

habe den Stick Sundtek MediaTV Pro III (DVB-C/T/T2, FM-Radio, AnalogTV) an meine Raspberry Pi (Raspbian) angeschlossen, habe die Treiber installiert und soweit schien auch alles problemlos.

Als ich dann allerdings die Sendersuche testen wollte, fand er nichts. Außerdem erhalte ich eine Fehlermeldung "tuning failed".

Hier ein kurzer Auszug:
scanning de-neftv
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
initial transponder 113000000 6900000 0 3
initial transponder 346000000 6875000 0 3
initial transponder 354000000 6875000 0 3
initial transponder 362000000 6875000 0 3
initial transponder 370000000 6875000 0 3
initial transponder 378000000 6875000 0 3
initial transponder 386000000 6875000 0 3
initial transponder 394000000 6875000 0 3
initial transponder 402000000 6875000 0 3
initial transponder 410000000 6900000 0 3
initial transponder 418000000 6875000 0 3
initial transponder 426000000 6900000 0 3
initial transponder 434000000 6900000 0 3
initial transponder 442000000 6900000 0 5
initial transponder 450000000 6900000 0 5
initial transponder 458000000 6875000 0 3
initial transponder 466000000 6900000 0 3
initial transponder 474000000 6875000 0 3
initial transponder 490000000 6875000 0 3
initial transponder 498000000 6875000 0 3
initial transponder 514000000 6875000 0 3
initial transponder 522000000 6900000 0 3
initial transponder 546000000 6875000 0 3
initial transponder 618000000 6900000 0 3
initial transponder 634000000 6900000 0 3
initial transponder 786000000 6900000 0 5
initial transponder 794000000 6900000 0 3
initial transponder 802000000 6900000 0 3
initial transponder 810000000 6900000 0 3
>>> tune to: 113000000:INVERSION_AUTO:6900000:FEC_NONE:QAM_64
WARNING: >>> tuning failed!!!
>>> tune to: 113000000:INVERSION_AUTO:6900000:FEC_NONE:QAM_64 (tuning failed)
WARNING: >>> tuning failed!!!
>>> tune to: 346000000:INVERSION_AUTO:6875000:FEC_NONE:QAM_64
WARNING: >>> tuning failed!!!
>>> tune to: 346000000:INVERSION_AUTO:6875000:FEC_NONE:QAM_64 (tuning failed)
WARNING: >>> tuning failed!!!
>>> tune to: 354000000:INVERSION_AUTO:6875000:FEC_NONE:QAM_64

de-neftv habe ich genommen, weil ich nichts passendes für mich gefunden habe. Kein Kabel Deutschland und auch nichts Hamburgmäßiges (bin aus Hamburg).

Nun habe ich ein wenig gegoogelt und einmal w_scan getestet. Dort finde ich auch genau 0 Services.

Dann kam mir die Idee, dass vielleicht kein digitales Signal bei mir anliegt. Deshalb wollte ich nach Analogen Sendern suchen. Dabei erhalte ich allerdings auch eine Fehlermeldung:
root@tv01:/usr/share/dvb/dvb-c# scantv -C /dev/video0
vid-open-auto: failed to open an analog TV device
vid-open: could not find a suitable videodev
no analog TV device available

Angezeigt wird mir bei mediaclient -e ein Analoges Gerät:
root@tv01:~# /opt/bin/mediaclient -e
**** List of Media Hardware Devices ****
device 0: [MediaTV Pro III USB (EU)]  DVB-C, DVB-T, DVB-T2, ANALOG-TV, FM-RADIO, REMOTE-CONTROL, OSS-AUDIO, RDS
  [BUS]:
     ID: 1-1.3.1.4
  [SERIAL]:
     ID: U140218173007
  [DVB-C]:
     FRONTEND: /dev/dvb/adapter0/frontend0
     DVR: /dev/dvb/adapter0/dvr0
     DMX: /dev/dvb/adapter0/demux0
  [DVB-T]:
     FRONTEND: /dev/dvb/adapter0/frontend0
     DVR: /dev/dvb/adapter0/dvr0
     DMX: /dev/dvb/adapter0/demux0
  [DVB-T2]:
     FRONTEND: /dev/dvb/adapter0/frontend0
     DVR: /dev/dvb/adapter0/dvr0
     DMX: /dev/dvb/adapter0/demux0
  [ANALOG-TV]:
     VIDEO0: /dev/video0
     VBI0: /dev/vbi0
  [FM-RADIO]:
     RADIO0: /dev/radio0
     RDS: /dev/rds0
  [REMOTECONTROL]:
     INPUT0: /dev/mediainput0
  [OSS]:
     OSS0: /dev/dsp0

Mit DVB-T finde ich Sender. Das möchte ich aber nicht benutzen, weil mein Singal extrem schwach in meiner Bude ist.

Über Hilfe würde ich mich freuen.

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8317
    • Profil anzeigen
Re:DVBC keine Sender / Analog kein Device
« Antwort #1 am: März 04, 2014, 05:08:14 Nachmittag »
Kennst du denn eine DVB-C Frequenz die funktioniert?

w_scan -f c -c de sollte eigentlich ausreichend sein.

AnalogTV wirst du auf dem Raspberry PI nicht zum Laufen bekommen, das benötigt eindeutig mehr Power.

Was für einen Anbieter hast du denn?
Failure is a good thing! I'll fix it

zappendappen

  • Newbie
  • *
  • Beiträge: 4
    • Profil anzeigen
Re:DVBC keine Sender / Analog kein Device
« Antwort #2 am: März 04, 2014, 05:20:16 Nachmittag »
Kennst du denn eine DVB-C Frequenz die funktioniert?
Leider nicht. Bin mit TV-Kram nicht allzu vertraut.

w_scan -f c -c de sollte eigentlich ausreichend sein.
Da findet er 0 Services ohne Fehlermeldung.

Was für einen Anbieter hast du denn?
Kabel Deutschland ist mein Anbieter. Das wird aber mit den Nebenkosten von meinem Vermieter bezahlt. Jetzt kann es natürlich sein, dass die nur Analog zur Verfügung stellen. Aber müsste ich dann nicht wenigstens bei einer digitalen Suche verschlüsselte Sender finden?


Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8317
    • Profil anzeigen
Re:DVBC keine Sender / Analog kein Device
« Antwort #3 am: März 04, 2014, 05:23:45 Nachmittag »
Für Kabel Deutschland dürfte die Frequenzliste nicht mehr stimmen, aber w_scan müsste etwas finden.

/opt/bin/mediaclient -m DVBC -f 114000000 -M Q256 -S 6900000 -d /dev/dvb/adapter0/frontend0
/opt/bin/mediaclient -m DVBC -f 114000000 -M Q64 -S 6900000 -d /dev/dvb/adapter0/frontend0
/opt/bin/mediaclient -m DVBC -f 113000000 -M Q256 -S 6900000 -d /dev/dvb/adapter0/frontend0
/opt/bin/mediaclient -m DVBC -f 113000000 -M Q64 -S 6900000 -d /dev/dvb/adapter0/frontend0


Einer dieser Befehle sollte ein [LOCKED] zurückgeben.

Wenn DVB-T schon funktioniert dann muss DVB-C auch funktionieren bzw. wenigstens ein LOCKED zurückgeben.

Die öffentlich rechtlichen sind üblicherweise unverschlüsselt.

Bevor du mittels w_scan scannst, gib eventuell noch /opt/bin/mediaclient -D DVBC ein um das Gerät auf den DVB-C Modus zu schalten.

scantv sollte übrigens mit einem kleinen c verwendet werden.

Eine mögliche Ursache warum es überhaupt nicht funktioniert ist auch immer wieder mal das Kabel (den Stick eventuell versuchen direkt an die Dose zu stecken).

Eventuell auch die Logfile ansehen, echo "loglevel=min" >> /etc/sundtek.conf danach den Treiber neu starten /opt/bin/mediaclient --shutdown; /opt/bin/mediaclient --start
Ab sofort sollte eine Logfile /var/log/mediasrv.log geschrieben werden.

Update habe adapter1 -> adapter0 geändert
« Letzte Änderung: März 04, 2014, 05:35:55 Nachmittag von Sundtek »
Failure is a good thing! I'll fix it

zappendappen

  • Newbie
  • *
  • Beiträge: 4
    • Profil anzeigen
Re:DVBC keine Sender / Analog kein Device
« Antwort #4 am: März 04, 2014, 06:44:02 Nachmittag »
Okay, also bei z. B. /opt/bin/mediaclient -m DVBC -f 114000000 -M Q256 -S 6900000 -d /dev/dvb/adapter0/frontend0 kriege ich:
root@tv01:~# /opt/bin/mediaclient -m DVBC -f 114000000 -M Q256 -S 6900000 -d /dev/dvb/adapter0/frontend0
Using device: /dev/dvb/adapter0/frontend0
Checking for lock:
..........

Bei allen Anderen kriege ich die gleiche Ausgabe.

Den Rest teste ich, sobald ich zu Hause bin. Vielen Dank schonmal für die echt schnelle Hilfe!

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8317
    • Profil anzeigen
Re:DVBC keine Sender / Analog kein Device
« Antwort #5 am: März 04, 2014, 07:11:56 Nachmittag »
Also dann würde ich erst mal die Hausverwaltung fragen ob dort tatsächlich DVB-C anliegt und welcher Anbieter das wäre.

Es gibt auch Wohnanlagen welche eigene Umsetzer installiert haben.
Failure is a good thing! I'll fix it

zappendappen

  • Newbie
  • *
  • Beiträge: 4
    • Profil anzeigen
Re:DVBC keine Sender / Analog kein Device
« Antwort #6 am: März 06, 2014, 10:16:40 Vormittag »
Laut Hausverwaltung ist es tatsächlich so, dass dort nur analoges TV bereit gestellt wird. Hätte ich vielleicht mal vorher klären sollen. Aber trotzdem vielen Dank für den Support!

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8317
    • Profil anzeigen
Re:DVBC keine Sender / Analog kein Device
« Antwort #7 am: März 06, 2014, 10:23:27 Vormittag »
Du kannst ja immer noch DVB-T verwenden und auch via Netzwerk in deiner Wohnung verteilen.

Linux Konfiguration (z.B auf dem RPI)
http://support.sundtek.com/index.php/topic,178.0.html
Windows:
http://support.sundtek.com/index.php/topic,834.0.html

Der native Windows Treiber wird wohl Anfang kommender Woche verfügbar sein dann empfängt man auch AnalogTV im Windows.
Failure is a good thing! I'll fix it