Autor Thema: Treiber Installation Raspbmc(RPi) Fehlermeldung  (Gelesen 6736 mal)

Suptra

  • Newbie
  • *
  • Beiträge: 15
    • Profil anzeigen
Treiber Installation Raspbmc(RPi) Fehlermeldung
« am: Mai 22, 2013, 04:58:12 Nachmittag »
Aloa!

Ich versuche gerade diesen Treiber auf dem Raspberry zu installieren. Es schlägt jedoch immer fehl.

Ich log mich via ssh ein:

Der Download funktioniert auch doch danach:

root@raspbmc:/tmp# chmod 777 sundtek_netinst.sh
root@raspbmc:/tmp# ./sundtek_netinst.sh
bash: ./sundtek_netinst.sh: Permission denied <--- Ich bekomm immer das

Hat jmd eine Idee was ich falsch mache?

Beste Grüße

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8096
    • Profil anzeigen
Re:Treiber Installation Raspbmc(RPi) Fehlermeldung
« Antwort #1 am: Mai 22, 2013, 04:59:32 Nachmittag »
Was gibt denn der Befehl "mount" aus?
Failure is a good thing! I'll fix it

Suptra

  • Newbie
  • *
  • Beiträge: 15
    • Profil anzeigen
Re:Treiber Installation Raspbmc(RPi) Fehlermeldung
« Antwort #2 am: Mai 22, 2013, 05:10:39 Nachmittag »
Mount:
/dev/mmcblk0p2 on / type ext4 (rw,noatime)
proc on /proc type proc (rw)
devpts on /dev/pts type devpts (rw,noexec,nosuid,relatime,gid=5,mode=620)
/dev/mmcblk0p1 on /boot type vfat (rw,noatime)
/dev/sda1 on /media/CN-MEMORY type vfat (rw,nosuid,nodev,uid=1000,gid=1000,shortname=mixed,dmask=0077,utf8=1,showexec,uhelper=udisks)

lsusb:
Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 004: ID 0846:9041 NetGear, Inc. WNA1000M 802.11bgn [Realtek RTL8188CUS]
Bus 001 Device 005: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
Bus 001 Device 006: ID 046d:c52b Logitech, Inc. Unifying Receiver
Bus 001 Device 007: ID 174c:55aa ASMedia Technology Inc.
Bus 001 Device 008: ID 2659:1208 Sundtek Sundtek SkyTV Ultimate III

Immerhin erkennt er den Sundtek

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8096
    • Profil anzeigen
Re:Treiber Installation Raspbmc(RPi) Fehlermeldung
« Antwort #3 am: Mai 22, 2013, 05:19:26 Nachmittag »
ls -rtlha /

Grundsätzlich nehme ich an das bei dir /tmp mit noexec gemountet ist.
Failure is a good thing! I'll fix it

Suptra

  • Newbie
  • *
  • Beiträge: 15
    • Profil anzeigen
Re:Treiber Installation Raspbmc(RPi) Fehlermeldung
« Antwort #4 am: Mai 22, 2013, 05:39:26 Nachmittag »
Das soll jetzt was genau heißen?


total 101K
drwxr-xr-x  5 root root 1.0K Jan  1  1970 boot
dr-xr-xr-x 91 root root    0 Jan  1  1970 proc
dr-xr-xr-x 12 root root    0 Jan  1  1970 sys
drwxr-xr-x 10 root root 4.0K Jan  1  1970 var
drwxr-xr-x 24 root root 4.0K Jan  1  1970 ..
drwxr-xr-x 24 root root 4.0K Jan  1  1970 .
drwxr-xr-x  2 root root 4.0K Jun 20  2012 selinux
drwxr-xr-x  2 root root 4.0K Dec 26 05:12 mnt
drwxr-xr-x  3 root root 4.0K Feb  8 14:31 home
drwxr-xr-x  3 root root 4.0K Feb  8 14:32 srv
drwxr-xr-x  2 root root 4.0K Feb  8 14:42 sbin
drwxr-xr-x  2 root root 4.0K Feb  8 14:45 bin
drwxr-xr-x  2 root root 4.0K Feb  8 14:45 splash
drwx------  2 root root  16K Feb  8 14:51 lost+found
-rwxr-xr-x  1 root root   73 Feb  8 14:51 standalone-02.sh
-rwxr-xr-x  1 root root  878 Feb  8 14:51 standalone-01.sh
-rwxr-xr-x  1 root root 1.5K Feb  8 14:51 standalone-00.sh
drwxr-xr-x 14 root root 4.0K Mar 13 17:53 lib
drwxr-xr-x 10 root root 4.0K May 11 13:29 usr
drwxr-xr-x  6 root root 4.0K May 14 18:00 scripts
drwxr-xr-x  4 root root 4.0K May 14 18:15 opt
drwx------  2 root root 4.0K May 22 14:49 root
drwxr-xr-x  3 root root 4.0K May 22 15:07 media
drwxr-xr-x 87 root root 4.0K May 22 15:07 etc
drwxrwxrwt  6 root root 4.0K May 22 15:29 tmp
drwxr-xr-x 19 root root  560 May 22 15:30 run
drwxr-xr-x 14 root root 3.1K May 22 15:30 dev

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8096
    • Profil anzeigen
Re:Treiber Installation Raspbmc(RPi) Fehlermeldung
« Antwort #5 am: Mai 22, 2013, 06:11:50 Nachmittag »
Was ist denn das für ein Image?
Die Images welche wir von der RPI Website getestet hatten haben alle funktioniert.


Ich sehe nicht das /tmp gemounted wurde oder das /tmp ein Link wäre, ist die Ausgabe von mount vollständig?
Failure is a good thing! I'll fix it

Suptra

  • Newbie
  • *
  • Beiträge: 15
    • Profil anzeigen
Re:Treiber Installation Raspbmc(RPi) Fehlermeldung
« Antwort #6 am: Mai 22, 2013, 06:17:46 Nachmittag »
Die Ausgabe sollte vollständig sein. Hab es gerade noch einmal probiert:
Bus 001 Device 008: ID 2659:1208 Sundtek Sundtek SkyTV Ultimate III         
pi@raspbmc:~$ mount
/dev/mmcblk0p2 on / type ext4 (rw,noatime)                                                           
proc on /proc type proc (rw)                                                                         
devpts on /dev/pts type devpts (rw,noexec,nosuid,relatime,gid=5,mode=620)                             
/dev/mmcblk0p1 on /boot type vfat (rw,noatime)                                                       
/dev/sda1 on /media/CN-MEMORY type vfat (rw,nosuid,nodev,uid=1000,gid=1000,shortname=mixed,dmask=0077,
utf8=1,showexec,uhelper=udisks)                                                                       
pi@raspbmc:~$

Ich benütze Raspbmc. Ich Teste später oder morgen mal ein anderes xbmc Image. Mal sehen was da raus kommt :)

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8096
    • Profil anzeigen
Re:Treiber Installation Raspbmc(RPi) Fehlermeldung
« Antwort #7 am: Mai 22, 2013, 06:23:23 Nachmittag »
Also wir haben Raspbmc auch verwendet und hatten dort keinerlei Probleme den Installer auszuführen.

Was zeigt denn "ls -rltha /tmp/sundtek_netinst.sh" an?
Failure is a good thing! I'll fix it

Suptra

  • Newbie
  • *
  • Beiträge: 15
    • Profil anzeigen
Re:Treiber Installation Raspbmc(RPi) Fehlermeldung
« Antwort #8 am: Mai 22, 2013, 06:30:33 Nachmittag »
pi@raspbmc:~$ ls -rltha /tmp/sundtek_netinst.sh
ls: cannot access /tmp/sundtek_netinst.sh: No such file or directory

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8096
    • Profil anzeigen
Re:Treiber Installation Raspbmc(RPi) Fehlermeldung
« Antwort #9 am: Mai 22, 2013, 07:02:43 Nachmittag »
Naja da hast du's der Installer befindet sich nicht dort :-)
Ohne Installer kannst du den Treiber auch nicht installieren, eventuell gibt chmod keinen Fehler aus bei der nicht vorhandenen Datei (wäre ein Bug des Images).

Zitat
cd /tmp
wget http://sundtek.de/media/sundtek_netinst.sh
chmod 777 sundtek_netinst.sh
./sundtek_netinst.sh
Failure is a good thing! I'll fix it

Suptra

  • Newbie
  • *
  • Beiträge: 15
    • Profil anzeigen
Re:Treiber Installation Raspbmc(RPi) Fehlermeldung
« Antwort #10 am: Mai 22, 2013, 07:29:48 Nachmittag »
Ich hab das jetzt zum x-Ten mal gemacht. Ist wohl wirklich ein Bug...

pi@raspbmc:/tmp$ wget http://www.sundtek.de/media/sundtek_netinst.sh                                 
--2013-05-22 17:18:41--  http://www.sundtek.de/media/sundtek_netinst.sh                               
Resolving www.sundtek.de (www.sundtek.de)... 85.10.198.106                                           
Connecting to www.sundtek.de (www.sundtek.de)|85.10.198.106|:80... connected.                         
HTTP request sent, awaiting response... 200 OK                                                       
Length: 90674 (89K) [text/x-sh]                                                                       
Saving to: `sundtek_netinst.sh'                                                                       

100%[============================================================>] 90,674      10.4K/s   in 8.5s     

2013-05-22 17:18:51 (10.4 KB/s) - `sundtek_netinst.sh' saved [90674/90674]                           

pi@raspbmc:/tmp$ chmod 777 sundtek_netinst.sh
pi@raspbmc:/tmp$ ./sundtek_netinst.sh                                                                 
-bash: ./sundtek_netinst.sh: Permission denied                                                       
pi@raspbmc:/tmp$

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8096
    • Profil anzeigen
Re:Treiber Installation Raspbmc(RPi) Fehlermeldung
« Antwort #11 am: Mai 22, 2013, 07:34:32 Nachmittag »
Befindet sich die Datei auch dort nach dem Download?

Was zeigt dann "ls -rlta /tmp/sundtek_netinst.sh" an?
Failure is a good thing! I'll fix it

Suptra

  • Newbie
  • *
  • Beiträge: 15
    • Profil anzeigen
Re:Treiber Installation Raspbmc(RPi) Fehlermeldung
« Antwort #12 am: Mai 22, 2013, 07:41:57 Nachmittag »
root@raspbmc:/home/pi# ls -rlta /tmp/sundtek_netinst.sh
-rwxrwxrwx 1 pi pi 90674 Mar 27 11:11 /tmp/sundtek_netinst.sh

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8096
    • Profil anzeigen
Re:Treiber Installation Raspbmc(RPi) Fehlermeldung
« Antwort #13 am: Mai 22, 2013, 07:51:24 Nachmittag »
Naja melde dich via Skype (sundtek), so eine Installation sollte keine 30 Sekunden dauern.

Ich sehe weder das /tmp als noexec gemountet wurde noch einen anderen Fehler.
Der Installer ist ein recht einfaches Skript, das sollte eigentlich problemlos ausgeführt werden.
Failure is a good thing! I'll fix it

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8096
    • Profil anzeigen
Re:Treiber Installation Raspbmc(RPi) Fehlermeldung
« Antwort #14 am: Mai 22, 2013, 08:17:25 Nachmittag »
Scheint wirklich ein Fehler in der Distribution zu sein, trotzdem lässt sich der Treiber recht problemlos installieren:

Zitat
cd /tmp
wget http://sundtek.de/media/sundtek_netinst.sh
sh sundtek_netinst.sh
Failure is a good thing! I'll fix it