Autor Thema: Installation on a xp1000/octagon settopbox  (Gelesen 6196 mal)

dolphs

  • Newbie
  • *
  • Beiträge: 6
    • Profil anzeigen
Installation on a xp1000/octagon settopbox
« am: Mai 18, 2013, 08:11:21 Nachmittag »
Hi - Anyone succeeded to get the Sundtek MediaTV Digital Home working on a MaxDigital XP1000 or an Octagon SF 8 HD, flashed with OpenPLI3?  When I install and set up the sundtekcontrolcenter it wants to load drivers but it does not as it seems, because when I connect the stick to a dm800 it does detect the box and installs the drivers afterwards. Therefore I like to know if sundtek will provide easy install as is on the dreamboxes, if not what can I do to make the device work on the xp1000, it is mipsel just as the vu+ and hd dreamboxes

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8040
    • Profil anzeigen
Re:Installation on a xp1000/octagon settopbox
« Antwort #1 am: Mai 18, 2013, 09:00:22 Nachmittag »
Well you can contact us via skype (sundtek) to check if that system supports external tuners at all.

Did you try to use the Sundtek Settopbox Installer:
http://support.sundtek.com/index.php/topic,348.0.html

This will set up the latest Sundtek Control Center on the settopbox (the one from the feed might be outdated).
Failure is a good thing! I'll fix it

dolphs

  • Newbie
  • *
  • Beiträge: 6
    • Profil anzeigen
Re:Installation on a xp1000/octagon settopbox
« Antwort #2 am: Mai 18, 2013, 09:30:11 Nachmittag »
Cheers for your quick response!

Meanwhile I checked current kernel, which is " Linux xp1000 3.5.1 #1 Thu May 9 05:31:28 CEST 2013 mips GNU/Linux "

An lsusb shows me:
@xp1000:~# lsusb
Bus 001 Device 006: ID eb1a:51b2
Bus 001 Device 003: ID 0a5c:5804
Bus 001 Device 001: ID 1d6b:0002
Bus 002 Device 001: ID 1d6b:0001

Doing this on a dm800 shows me " Linux dm800 2.6.18-7.4-dm800 #1 Sun Sep 23 19:44:46 CEST 2012 7401c0 GNU/Linux " and the expected eMPIA line, which is not shown at the xp1000:
@dm800:~# lsusb
Bus 003 Device 001: ID 0000:0000 
Bus 002 Device 001: ID 0000:0000 
Bus 001 Device 002: ID eb1a:51b2 eMPIA Technology, Inc.
Bus 001 Device 001: ID 0000:0000 

So this most likely means current 3.5.1 kernel used in openpli is not prepared for sundtek yet, also will check the link you supplied and will report back in the next 72 hours.

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8040
    • Profil anzeigen
Re:Installation on a xp1000/octagon settopbox
« Antwort #3 am: Mai 18, 2013, 09:37:22 Nachmittag »
The kernel does not matter we do not depend on a particular Version.

Just follow the installation instruction.

After the installation you can just run
/opt/bin/mediaclient -e

to see if the device is detected on it (it's also a check to see if the driver is installed on it).
« Letzte Änderung: Mai 18, 2013, 09:41:00 Nachmittag von Sundtek »
Failure is a good thing! I'll fix it

dolphs

  • Newbie
  • *
  • Beiträge: 6
    • Profil anzeigen
Re:Installation on a xp1000/octagon settopbox
« Antwort #4 am: Mai 19, 2013, 05:26:11 Nachmittag »
hi, executed the "Sundtek Settopbox installer" from my windows laptop and uploaded necessary tools, however no luck, no tuner B can be found

Trying to connect to server
Connected
Logging in
Password required
Login Successful
Installing Driver...
Installing Sundtek Control Center...
Setting Autostart
Rebooting system..
Installation done..
Finished, installation complete

@xp1000:~# lsusb
Bus 001 Device 002: ID eb1a:51b2
Bus 001 Device 003: ID 0a5c:5804
Bus 001 Device 001: ID 1d6b:0002
Bus 002 Device 001: ID 1d6b:0001

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8040
    • Profil anzeigen
Re:Installation on a xp1000/octagon settopbox
« Antwort #5 am: Mai 19, 2013, 09:25:47 Nachmittag »
Best would be to contact us via Skype (sundtek) to double check if that box is capable of using external tuners.

The default driver installation installs the driver on the box and thinks it's a normal linux based PC but does not try to register it to the settopbox.
If the settopbox supports external tuners the installer could be modified to automatically set up everything (as it's done with all the other settopboxes).
However we don't have that settopbox so you better check back with us via skype chat.
Failure is a good thing! I'll fix it

dolphs

  • Newbie
  • *
  • Beiträge: 6
    • Profil anzeigen
Re:Installation on a xp1000/octagon settopbox
« Antwort #6 am: Mai 21, 2013, 10:32:43 Vormittag »
hi - tried to contact support on Skype but no luck.
Anyway with help of PLi-members I managed to get the stick recognised.
However this was far from flawless, only after creating two softlinks ( /opt/script -> /usr/script + /opt/sundtek -> /usr/sundtek ) and a restart of enigma2 it got recognised. However the image is far from stable, it freezes a lot like it does on a dm800 first edition, especially if you want to view HD channels. At this moment a no go on this device, maybe drivers will get optimised one day so it can work, for now negative result ...

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8040
    • Profil anzeigen
Re:Installation on a xp1000/octagon settopbox
« Antwort #7 am: Mai 21, 2013, 11:52:27 Vormittag »
I think the installer did not recognize that box as a settopbox.
As far as I can see you're offline in skype.

If something crashes it's very likely an issue of the settopbox (possibly USB Controller), the driver has been proven for years on settopboxes already, but better wait for the technician to clarify that.
« Letzte Änderung: Mai 21, 2013, 01:12:43 Nachmittag von Sundtek »
Failure is a good thing! I'll fix it