Autor Thema: OpenWRT TL-WR2543N/ND >> 3 Sticks >> Network-Modus  (Gelesen 4005 mal)

vanhaakonnen

  • Newbie
  • *
  • Beiträge: 36
    • Profil anzeigen
OpenWRT TL-WR2543N/ND >> 3 Sticks >> Network-Modus
« am: März 08, 2013, 05:30:01 Nachmittag »
Hallo zusammen,

ich habe einen TP-Link TL-WR2543N/ND Router mit einem USB-Hub (aktiver Hub von D-Link) ausgestattet und daran drei Sundtek MediaTV Digital Home angeschlossen. Die Sticks werden erkannt und funktionieren prinzipiell auch im Netzwerkmodus mit meinem VDR auf einem anderen Server gut. Auf dem Router läuft OpenWRT (attitude_adjustment/12.09-rc1).

Leider ruckelt das Bild jedoch erbärmlich. Teilweise bleibt das Bild auch einfach nach ein paar Sekunden stehen und hängt. Dabei hat der Router eine recht hohe CPU-Last. Auffällig ist, dass diese schon existiert wenn der VDR nur angeschaltet ist (ohne das ein Sender geschaut wird).

Die CPU-Last des Routers ohne aktiven Treiber liegt bei maximal 1%. Mit Treiber und eingeschaltetem, entferntem VDR bei ca. 50%.
Sobald ein Sender eingeschaltet wird geht die Last auf über 80 bzw. 90% hoch.

iso und bulk Modus bringen beide keine echte Veränderung.

Habt ihr da eine Idee? Der Router hat eigentlich keine schlechte Hardware...


vanhaakonnen

  • Newbie
  • *
  • Beiträge: 36
    • Profil anzeigen
Re:OpenWRT TL-WR2543N/ND >> 3 Sticks >> Network-Modus
« Antwort #1 am: März 08, 2013, 06:57:18 Nachmittag »
Eine weitere Sache:

===
root@cablemonitor:~# mediaclient /opt/bin/mediaclient --scan-network
Scanning network for IPTV media servers
------------------------------------------------------------------------------
 IP address       | ID  |  devicename          | Users | Capabilities | Serial
------------------------------------------------------------------------------
 192.168.100.3    | 0   | Sundtek MediaTV Digital Home (USB 2.0)  |  0   | DVB-T, DVB-C | 0101129170358
 192.168.100.3    | 1   | Sundtek MediaTV Digital Home (USB 2.0)  |  0   | DVB-T, DVB-C | 0101208032416
 192.168.100.3    | 2   | Sundtek MediaTV Pro (USB 2.0)  |  0   | DVB-T, DVB-C | U110714144545
===

Ich kann jedoch immer nur den Stick mit der ID 0 auf anderen Geräten mounten.

==
root@cablemonitor:~# /opt/bin/mediaclient --mount=192.168.100.3:2
Unable to mount: 192.168.100.3:2
==

Dafür kann ich jedoch einen Stick auf unterscheidlichen Geräten gleichzeitig mounten - dann geht nur absolut nichts mehr...

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8040
    • Profil anzeigen
Re:OpenWRT TL-WR2543N/ND >> 3 Sticks >> Network-Modus
« Antwort #2 am: März 08, 2013, 09:42:35 Nachmittag »
Eventuell ein Endian Problem.

Treiber wurde aktualisiert, jetzt sollte das klappen.
« Letzte Änderung: März 09, 2013, 09:23:30 Vormittag von Sundtek »
Failure is a good thing! I'll fix it

vanhaakonnen

  • Newbie
  • *
  • Beiträge: 36
    • Profil anzeigen
Re:OpenWRT TL-WR2543N/ND >> 3 Sticks >> Network-Modus
« Antwort #3 am: März 12, 2013, 10:50:46 Vormittag »
Danke. Die Zuordnung der Sticks funktioniert jetzt.

vanhaakonnen

  • Newbie
  • *
  • Beiträge: 36
    • Profil anzeigen
Re:OpenWRT TL-WR2543N/ND >> 3 Sticks >> Network-Modus
« Antwort #4 am: März 21, 2013, 11:06:35 Nachmittag »
Also zuordnen kann ich die Sticks jetzt anscheinend korrekt. In den Client-Treibern sehe ich auch unterschiedliche Seriennummern und soweit scheint alles in Ordnung.

Leider verliert ab und an der Treiber die Verbindung zum Netwerk-Server und zeigt mir keine Stick mehr an.

So sieht es aus wenns läuft:

===
root@cablemonitor:~# mediaclient -e
**** List of Media Hardware Devices ****
device 0: [Sundtek MediaTV Pro (USB 2.0) (192.168.100.3)]  DVB-C, DVB-T, NETWORK-DEVICE
  [NETWORKPATH]:
     PATH: 192.168.100.3:2
  [SERIAL]:
     ID: U110714144545
  [DVB-C]:
     FRONTEND: /dev/dvb/adapter0/frontend0
     DVR: /dev/dvb/adapter0/dvr0
     DMX: /dev/dvb/adapter0/demux0
  [DVB-T]:
     FRONTEND: /dev/dvb/adapter0/frontend0
     DVR: /dev/dvb/adapter0/dvr0
     DMX: /dev/dvb/adapter0/demux0
===


Die Option --netrecoverymode=ON hat leider nichts gebracht. Überall verwende ich die Treiberversion: Build date: 2013-03-10 09:09:11


Woran kann das liegen?

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8040
    • Profil anzeigen
Re:OpenWRT TL-WR2543N/ND >> 3 Sticks >> Network-Modus
« Antwort #5 am: März 22, 2013, 12:11:30 Vormittag »
Versuch diesen Befehl hier:
Zitat
/opt/bin/mediaclient --netrecoverymode=ON -d /dev/dvb/adapter0/frontend0

-d FRONTENDNODE wird benötigt
Failure is a good thing! I'll fix it