Autor Thema: w_scan hängt bei niedriger Signalqualität  (Gelesen 10469 mal)

fatzgenfatz

  • Newbie
  • *
  • Beiträge: 42
    • Profil anzeigen
w_scan hängt bei niedriger Signalqualität
« am: August 26, 2009, 06:17:54 Nachmittag »
Hallo,

ich habe leider Probleme beim Scannen nach Kanälen.
Ich verwende Ubuntu 9.04 und den Treiber vom 25.08.

Bei Scannen mit w_scan (sowohl aus Ubuntu als auch direkt von der Webseite) bleibt das Programm immer an der selben Stelle hängen. Fehlermeldung gibt w_scan nicht aus, die letzte Meldung ist immer:
tune to: :418000:M64:C:6900:
Die Fehlermeldung in /var/log/mediasrv.log lautet:
CRC invalid of requested section (0010 40)
CRC invalid of requested section (0011 42)
CRC invalid of requested section (0000 00)
CRC invalid of requested section (0000 00)
CRC invalid of requested section (0000 00)
CRC invalid of requested section (0000 00)
CRC invalid of requested section (0000 00)
CRC invalid of requested section (0000 00)
CRC invalid of requested section (0000 00)

(Dies wiederholt sich unendlich, bis ich w_scan mit STRG-C beende.)

Ich hänge mal eine ausführliche logdatei des Scans und die mediasrv.log an.

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8357
    • Profil anzeigen
w_scan hängt bei niedriger Signalqualität
« Antwort #1 am: August 26, 2009, 06:24:00 Nachmittag »
Können Sie mit Kaffeine die Signalstärke dieses Senders überprüfen?

Der Treiber überprüft den Stream (hauptsächlich die Senderinformationen, nicht das Video an sich) auf seine Korrektheit, der mediasrv Logfile nach sind die empfangenen Daten ungültig, was auf eine schlechte Signalqualität hindeutet.

Wir haben hierfür jedoch ein Troubleticket angelegt, es sollte von unserer Seite her möglich sein bei solchen Kanälen ein Timeout auszulösen.
« Letzte Änderung: August 26, 2009, 07:01:11 Nachmittag von Sundtek »
Failure is a good thing! I'll fix it

fatzgenfatz

  • Newbie
  • *
  • Beiträge: 42
    • Profil anzeigen
w_scan hängt bei niedriger Signalqualität
« Antwort #2 am: August 26, 2009, 07:01:27 Nachmittag »
Hallo,
die Signalstärke ist 39% (niedrigster Wert), meist aber zwischen 69% und 99%.


Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8357
    • Profil anzeigen
w_scan hängt bei niedriger Signalqualität
« Antwort #3 am: August 26, 2009, 07:07:02 Nachmittag »
69% - 99% ist OK, 39% ist auf jeden Fall zu wenig um korrekte Daten zu empfangen.
Der Treiber gibt in diesem Fall keine Daten an w_scan weiter, wobei w_scan jedoch auf die Daten wartet.
Wir werden diese Woche noch an einer Lösung für dieses Problem arbeiten.
Failure is a good thing! I'll fix it

fatzgenfatz

  • Newbie
  • *
  • Beiträge: 42
    • Profil anzeigen
Re:w_scan hängt bei niedriger Signalqualität
« Antwort #4 am: August 27, 2009, 06:30:29 Nachmittag »
Ich habe mal testweise eine Terratec Cinergy 1200 PCI DVB-C Karte in meinen Rechner eingebaut.
Damit werden alle Sender (am selben Kabel) einwandfrei gefunden, die Signalqualität ist immer auf über 89%, auch auf dem betroffenen Transponder, der mit dem MediaTV-Stick nur 39% bringt.

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8357
    • Profil anzeigen
Re:w_scan hängt bei niedriger Signalqualität
« Antwort #5 am: August 27, 2009, 09:39:48 Nachmittag »
Es wurde zum Troubleticket hinzugefügt, und wird umgehend bearbeitet.
Failure is a good thing! I'll fix it

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8357
    • Profil anzeigen
Re:w_scan hängt bei niedriger Signalqualität
« Antwort #6 am: August 28, 2009, 12:41:20 Nachmittag »
Wir haben dies vorerst mit einem Kanal aus dem Kabeldeutschland Netz mit schlechtem Empfang getestet.

Zum Vergleich haben wir eine Settopbox von Thomson benutzt welche von KabelDeutschland geliefert wurde






Die angezeigte Signalstärke scheint 20% unter der KabelDeutschland Settopbox zu liegen, jedoch zeigt die Settopbox auch ohne Kabel sporatisch 10-15% Signalstärke an. Die Auswirkungen an sich auf das Video sind die selben. Wir werden zukünftig ebenfalls die Signalqualität z.B in Kaffeine wiedergeben. Tatsächlich konnte das Video mit Kaffeine/Xine noch bewegt dargestellt werden, wobei die STB von KabelDeutschland bereits Probleme hatte.

Wir sind der Annahme das wir hierbei nicht viel Spielraum haben, eventuell könnte die tatsächliche Frequenz etwas über oder unterhalb der angegebenen Frequenz liegen und die DVB-C Komponenten in unserem Gerät besitzen nicht so einen großen Spielraum wie jene welche auf der DVB-C PCI Karte verbaut wurden.

Auf jeden Fall werden wir dieses Problem weiter im Auge behalten, eventuell gibt es in Zukunft weitere Updates von Trident bezüglich der verwendeten DVB-C Firmware.
« Letzte Änderung: August 29, 2009, 01:33:56 Nachmittag von Sundtek »
Failure is a good thing! I'll fix it

fatzgenfatz

  • Newbie
  • *
  • Beiträge: 42
    • Profil anzeigen
Re:w_scan hängt bei niedriger Signalqualität
« Antwort #7 am: August 28, 2009, 06:11:00 Nachmittag »
Ich habe mit der Cinergy-Karte einen Kanalscan gemacht. Nun tauchen auch die von mir vermissten Sender auf.
Wenn ich nun mit dem MediaPro-Stick mit Kaffeine diese Kanäle anschaue wird zwar auch nur eine Signalstärke von 45% angezeigt, aber das Bild ist ohne irgendwelche Artefakte zu sehen.


Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8357
    • Profil anzeigen
Re:w_scan hängt bei niedriger Signalqualität
« Antwort #8 am: August 28, 2009, 06:28:38 Nachmittag »
Das Problem sind hierbei besonders die Kanaltabellen welche im Digitalen Strom übermittelt werden, diese Daten werden mit einem CRC Check überprüft, stimmt die Prüfsumme nicht überein dann werden keine Informationen an das scanner Programm weitergegeben.

Normalerweise sollte die Signalstärke jedoch überall gut genug sein um diese Informationen korrekt auslesen zu können. Wie schon in den Screenshots gezeigt gibt es auch von den Kabelanbietern nicht immer die beste Qualität. Hierbei kann bzw. sollte man die Einspeisquelle überprüfen bzw. überprüfen lassen um das eigentliche Problem zu beheben.
Failure is a good thing! I'll fix it

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8357
    • Profil anzeigen
Re:w_scan hängt bei niedriger Signalqualität
« Antwort #9 am: September 20, 2009, 10:46:06 Nachmittag »
Das w_scan Problem wurde ab Version 090920 gelöst.

http://www.sundtek.de/support/empia_installer.sh (zeigt derzeit auf die Treiberversion 090920).
Failure is a good thing! I'll fix it