Autor Thema: TVheadend Docker Compose Treiber läuft nicht im Docker.  (Gelesen 2427 mal)

Tihass1975

  • Newbie
  • *
  • Beiträge: 5
    • Profil anzeigen
TVheadend Docker Compose Treiber läuft nicht im Docker.
« am: Oktober 22, 2023, 05:17:05 Nachmittag »

Moin liebes Forum,

ich bräuchte mal euer Fachwissen, bezüglich der korrekten Installation des Sundtek Treibers in einem Docker !

Ich habe hier ein Einplatinencomputer Orange Pi PC2 mit Armbian (Debian Bullseye) am laufen, auf dem Openmediavault installiert ist. Ich versuche vergebens den Treiber in einem TVheadend Docker zu installieren und verstehe nicht was ich falsch mache !?

Folgende Vorgehensweise, die nicht zum Erfolg führte:

Auf dem Host habe ich die Nodes erstellt:

mkdir -p /dev/dvb/adapter0
mknod /dev/dvb/adapter0/frontend0 c 212 1
mknod /dev/dvb/adapter0/dvr0 c 212 5
mknod /dev/dvb/adapter0/demux0 c 212 3
mkdir -p /dev/dvb/adapter1
mknod /dev/dvb/adapter1/frontend0 c 212 7
mknod /dev/dvb/adapter1/dvr0 c 212 11
mknod /dev/dvb/adapter1/demux0 c 212 9
mkdir -p /dev/dvb/adapter2
mknod /dev/dvb/adapter2/frontend0 c 212 13
mknod /dev/dvb/adapter2/dvr0 c 212 17
mknod /dev/dvb/adapter2/demux0 c 212 15

Mit diesem Compose File habe ich den TVheadend Docker erstellt, ohne Fehlermeldung, TVheadend läuft.

---
version: "2.1"
services:
  tvheadend:
    image: lscr.io/linuxserver/tvheadend:latest
    container_name: tvheadend
    environment:
      - PUID=1000
      - PGID=100
      - TZ=Europe/Berlin
    # - RUN_OPTS= #optional
    volumes:
      - /srv/dev-disk-by-uuid-13dbfce5-ade5-4fe3-8f18-1f717ae91273/Master/TVheadend/config:/config
      - /srv/dev-disk-by-uuid-13dbfce5-ade5-4fe3-8f18-1f717ae91273/Master/TVheadend/recordings:/recordings
    ports:
      - 9981:9981
      - 9982:9982
    devices:
    # - /dev/dri:/dev/dri
      - /dev/dvb:/dev/dvb
      - /dev/bus/usb:/dev/bus/usb
    restart: unless-stopped

Danach bin ich in den Docker via SSH rein und habe den Treiber installiert und den Docker neu gestartet.

docker exec -it tvheadend /bin/sh

wget http://sundtek.de/media/sundtek_netinst.sh
chmod 777 sundtek_netinst.sh
./sundtek_netinst.sh -docker -use-custom-path /config

exit

Docker restart tvheadend

Die Treiberinstallation lief ohne Fehler ab.

adding /opt/bin to environment paths
adding administrator to audio group for playback...
unpacking...
checking system... OpenWRT/Fritzbox support enabled
64Bit ARM (musl) detected
installing (netinstall mode) ...
Downloading architecture specific driver ... arm64musl
Download finished, installing now ...
Starting driver...
2023-10-22 16:42:07 [367] UID: 0 SUID 0
done.

In TVheadend ist aber keine DVB Karte ersichtlich und auch die Abfrage im Docker verläuft ins leere !

docker exec -it tvheadend /bin/sh

root@22ef7ea8ab28:/# /opt/bin/mediaclient -e
/bin/sh: /opt/bin/mediaclient: not found

Auf dem Host lässt sich der Treiber einwandfrei installieren und ich bekomme auch ein Lock. Ich habe den auch wieder deinstalliert und hoffe das der sauber aus dem System ist.

./sundtek_netinst.sh -u
Ich komme einfach nicht weiter um bitte um Hilfe !

Gruß
Matthias

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8575
    • Profil anzeigen
Re: TVheadend Docker Compose Treiber läuft nicht im Docker.
« Antwort #1 am: Oktober 22, 2023, 06:20:58 Nachmittag »
-use-custom-path /config

Was zeigt denn das folgende an?

/config/opt/bin/mediaclient -e
Failure is a good thing! I'll fix it

Tihass1975

  • Newbie
  • *
  • Beiträge: 5
    • Profil anzeigen
Re: TVheadend Docker Compose Treiber läuft nicht im Docker.
« Antwort #2 am: Oktober 22, 2023, 07:17:36 Nachmittag »
Moin,
manchmal sieht man den Wald nicht weil man Tomaten auf den Augen hat  :)

**** List of Media Hardware Devices ****
device 0: [MediaTV Pro III (EU)]  DVB-C, DVB-T, DVB-T2, ANALOG-TV, FM-RADIO, REM                          OTE-CONTROL, OSS-AUDIO, RDS
  [INFO]:
     STATUS: STANDBY
  [BUS]:
     ID: 5-1
  [SERIAL]:
     ID: U150302144312
  [DVB-C,DVB-T,DVB-T2]:
     FRONTEND: /dev/dvb/adapter0/frontend0
     DVR: /dev/dvb/adapter0/dvr0
     DMX: /dev/dvb/adapter0/demux0
  [ANALOG-TV]:
     VIDEO0: /dev/video0
     VBI0: /dev/vbi0
  [FM-RADIO]:
     RADIO0: /dev/radio0
     RDS: /dev/rds0
  [REMOTECONTROL]:
     INPUT0: /dev/mediainput0
  [OSS]:
     OSS0: /dev/dsp0

Ich bekomme auch ein Lock.

root@22ef7ea8ab28:/# /config/opt/bin/mediaclient -m DVBC -f 554000000 -M Q256 -S 6900000 -d /dev/dvb/adapt
er0/frontend0
Using device: /dev/dvb/adapter0/frontend0
Checking for lock:
. [LOCKED]

Also muss es wohl am Compose File liegen oder ? In TVheadend unter TV Adapters ist kein Eintrag !

Hast du eine Idee ?

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8575
    • Profil anzeigen
Re: TVheadend Docker Compose Treiber läuft nicht im Docker.
« Antwort #3 am: Oktober 23, 2023, 02:05:59 Vormittag »
Ich denke dass ist das gleiche Problem welches wir auch kürzlich hatten, dass /usr/bin/tvheadend nicht umbenannt werden konnte.
vielleicht kannst Du dich im Laufe des Tages im chat melden dann können wir das durchgehen und den Installer aktualisieren.

Ich habe das im Installer nachgearbeitet (es ist aber noch nicht live).
Das Startskript für TVHeadend muss eventuell auch noch angepasst werden.
Deshalb melde dich bitte im Laufe des Tages im Chat, falls möglich mit Remote Zugriff auf das System dann würde ich die Installation einmal manuell durchspielen und die restlichen Anpassungen im Installer vornehmen damit ihr das wieder ohne unsere Hilfe installieren könnt.
Es gab wohl Änderungen im TVHeadend linuxserver.io Docker welche ein paar Skriptänderungen benötigen, der Treiber an sich ist davon unberührt.
« Letzte Änderung: Oktober 23, 2023, 03:59:51 Vormittag von Sundtek »
Failure is a good thing! I'll fix it

Tihass1975

  • Newbie
  • *
  • Beiträge: 5
    • Profil anzeigen
Re: TVheadend Docker Compose Treiber läuft nicht im Docker.
« Antwort #4 am: Oktober 23, 2023, 04:37:02 Nachmittag »

Bin im Chat !

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8575
    • Profil anzeigen
Re: TVheadend Docker Compose Treiber läuft nicht im Docker.
« Antwort #5 am: Oktober 23, 2023, 07:19:00 Nachmittag »
ok der Installer wurde aktualisiert, das klappt jetzt und sogar besser als zuvor.
Failure is a good thing! I'll fix it

Tihass1975

  • Newbie
  • *
  • Beiträge: 5
    • Profil anzeigen
Re: TVheadend Docker Compose Treiber läuft nicht im Docker.
« Antwort #6 am: Oktober 24, 2023, 04:33:07 Vormittag »

Moin nochmal,

ich habe jetzt ein Problem, wenn ich das System neustarte, startet der TVheadend Docker nicht, weil die Node vom Host System gelöscht werden. Ich muss die jetzt jedes mal von Hand neu erstellen.

mkdir -p /dev/dvb/adapter0
mknod /dev/dvb/adapter0/frontend0 c 212 1
mknod /dev/dvb/adapter0/dvr0 c 212 5
mknod /dev/dvb/adapter0/demux0 c 212 3

Hast du da eine Lösung für das Problem ? Oder soll ich das mit einem Cronjob lösen ? Nochmal Danke für dein Support !

Gruß
Matthias

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8575
    • Profil anzeigen
Re: TVheadend Docker Compose Treiber läuft nicht im Docker.
« Antwort #7 am: Oktober 24, 2023, 06:44:47 Vormittag »
Installiere den Treiber auf dem Host:
cd /tmp
wget http://sundtek.de/media/sundtek_netinst.sh
chmod 777 sundtek_netinst.sh
./sundtek_netinst.sh -dockerhost

das macht dann nichts weiteres als die Nodes zu erstellen - der Treiber startet - erstellt die Nodes und beendet sich wieder auf dem Host (so wie ein Skript)
Failure is a good thing! I'll fix it

Tihass1975

  • Newbie
  • *
  • Beiträge: 5
    • Profil anzeigen
Re: TVheadend Docker Compose Treiber läuft nicht im Docker.
« Antwort #8 am: Oktober 24, 2023, 05:05:55 Nachmittag »

Das läuft jetzt alles wunderbar.  :)

Magog

  • Newbie
  • *
  • Beiträge: 2
    • Profil anzeigen
Re: TVheadend Docker Compose Treiber läuft nicht im Docker.
« Antwort #9 am: November 05, 2023, 09:51:17 Nachmittag »
ok der Installer wurde aktualisiert, das klappt jetzt und sogar besser als zuvor.

Hello all.
Sorry for writing here in English but I am a bit desperate and I don't know if this has anything to do with my problem.
I have a Dreambox TWO and the tuner has always worked without any problem, but yesterday I did a clean install of the image and I have not been able to make it work again, it works once and when I restart the computer it doesn't start anymore.
I don't know if there has been any change by Sundtek.... I read this and I thought that maybe yes... otherwise my apologies for writing this here if it has nothing to do with it.
I have always used the SSI application to install drivers and control center and have done so many times.

Thanks.

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8575
    • Profil anzeigen
Re: TVheadend Docker Compose Treiber läuft nicht im Docker.
« Antwort #10 am: Februar 02, 2024, 09:31:25 Nachmittag »
Can you provide remote access (eg. via anydesk?) contact us via email kontakt at sundtek de for exchanging details about it.
Failure is a good thing! I'll fix it

Magog

  • Newbie
  • *
  • Beiträge: 2
    • Profil anzeigen
Re: TVheadend Docker Compose Treiber läuft nicht im Docker.
« Antwort #11 am: Februar 12, 2024, 08:05:44 Nachmittag »
Thanks, don´t know how and why but the usb worked fine next day .... working ok now.

Thanks.

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8575
    • Profil anzeigen
Re: TVheadend Docker Compose Treiber läuft nicht im Docker.
« Antwort #12 am: Februar 13, 2024, 12:37:24 Nachmittag »
Please note USB has to be connected "relatively" quickly, if it's connected too slow it might be recognized as USB 1.1 which will not work.
First USB will connect the power pins, which starts the controller on the device, there's some timing involved to determine if it's USB 1.1 or USB 2.0.

It also happened to me eg. when connecting a device to a NAS (the USB port is usually behind and a bit difficult to reach)

So the conclusion is just reconnect the device again and it should be okay (the second time is usually okay in such a rare event).
Failure is a good thing! I'll fix it