Autor Thema: Tunen fehlgeschlagen  (Gelesen 2164 mal)

BuSchu

  • Newbie
  • *
  • Beiträge: 12
    • Profil anzeigen
Tunen fehlgeschlagen
« am: Mai 25, 2019, 04:33:30 Nachmittag »
Bis zur letzten Neuinstallation meiner dm800sev2 hat alles geklappt und nun funktionieren keine Aufnahmen über den Stick (MediaTV Digital Home II) nicht mehr. Ich habe im Sundtek Control Center Folgendes konfiguriert:

Autostart: ja
Treiber autoupdate: ja
Loglevel: max
Enable TV-Server: aus  (wofür ist das gut?)
Hardware-PID-Filter: aus  (?)
vTuner-Beschleunigung für DM800: nein (?)
Enable Tuner 1: ja

Wenn ich nun zwei Aufnahmen gleichzeitig programmiere, wird nur eine aufgenommen, bei der zweiten hat die ts-Datei die Länge 0. Nehme ich aber mit Tuner A etwas auf, kann ich mit Tuner B ein anderes Programm ansehen.

In /etc/rc3.d steht: S99tuner.sh -> /usr/script/DVB_C_Tuner_starten.sh
Dann müsste doch wohl in Runlevel 3 alles nötige gestartet werden, oder?

Was läuft da falsch?

Grüße
Burkhard

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8254
    • Profil anzeigen
Re: Tunen fehlgeschlagen
« Antwort #1 am: Mai 26, 2019, 05:51:19 Vormittag »
Wurde der Tuner denn auch in der Tunerauswahl gleich wie Tuner A konfiguriert?
Failure is a good thing! I'll fix it

BuSchu

  • Newbie
  • *
  • Beiträge: 12
    • Profil anzeigen
Re: Tunen fehlgeschlagen
« Antwort #2 am: Mai 26, 2019, 11:30:23 Vormittag »
Wie komme ich denn in die Tunerauswahl?
In Information/Über finde ich:

Erkannte Tuner:
Tuner A: CXD1981 (DVB-C)
Tuner B: Sundtek DVB-C(III) (1/0) (USB) (DVB-C)

Ich habe gestern mal 2 gleichzeitige Aufnahmen programmiert und da hat's geklappt. Dann habe ich heute noch mal dasselbe gemacht, die Box in den Deep-Standby geschickt und nun ist die zweite Aufnahme wieder nichts. Fehlerfenster beim Einschalten: "Kein freier Tuner".

Danke schon mal für die Hilfe am Wochenende!

Grüße
Burkhard

BuSchu

  • Newbie
  • *
  • Beiträge: 12
    • Profil anzeigen
Re: Tunen fehlgeschlagen
« Antwort #3 am: Mai 26, 2019, 12:05:39 Nachmittag »
Unter Einstelllungen/Kanalsuche/Tunerkonfiguration finde ich:

Tuner A: CXD1981 (DVB-C)
       Umschaltbare Tuner-Typen: (DVB-T, DVB-C)
       aktiviert
Tuner B: Sundtek DVB-C (III) (1/0) (USB) (DVB-C)
       Umschaltbare Tuner-Typen: (DVB-T, DVB-C)
       aktiviert

Die Konfiguration beider Tuner sieht gleich aus.

Das hört sich doch alles gut an.

root@dm800sev2:~# ps -ef | grep media
root       583     1  0 10:46 ?        00:00:00 /usr/sundtek/mediasrv -d --no-nodes --wait-for-devices
root       584   583  0 10:46 ?        00:00:00 /usr/sundtek/mediasrv -d --no-nodes --wait-for-devices
root      3187  3145  0 12:00 pts/0    00:00:00 grep media
root@dm800sev2:~#

Warum funktioniert der Tuner nicht immer?

Grüße
Burkhard

BuSchu

  • Newbie
  • *
  • Beiträge: 12
    • Profil anzeigen
Re: Tunen fehlgeschlagen
« Antwort #4 am: Mai 26, 2019, 12:11:20 Nachmittag »
Ich habe jetzt während einer Aufnahme auf einen anderen Sender umgeschaltet und habe dann Empfang über Tuner B gehabt. Nur die gleichzeitige Aufnahme hat nicht funktioniert. Ich muss allerdings dazu sagen, dass ich früher immer wenigstens 1 Minute Unterschied beim Aufnahmebeginn programmiert habe, um gezielt Tuner A für die wichtigere Aufnahme auszuwählen, weil es immer mal wieder vorkommt, dass Aufnahmen über Tuner B gestört sind (da gibt's wohl immer noch Probleme mit dem USB-Anschluss!).

Ich werd's jetzt noch mal mit einem Zeitversatz probieren.

Grüße
Burkhard

BuSchu

  • Newbie
  • *
  • Beiträge: 12
    • Profil anzeigen
Re: Tunen fehlgeschlagen
« Antwort #5 am: Mai 26, 2019, 03:07:51 Nachmittag »
Auch mit einem Zeitversatz klappt die zweite Aufnahme nicht. Ich bin erst mal ratlos!

Grüße
Burkhard

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8254
    • Profil anzeigen
Re: Tunen fehlgeschlagen
« Antwort #6 am: Mai 26, 2019, 03:41:57 Nachmittag »
Hi,

kannst Du dich am Montag im Chat melden dann können wir das mit Dir durchgehen.

https://support.sundtek.de/chat.php
Failure is a good thing! I'll fix it

BuSchu

  • Newbie
  • *
  • Beiträge: 12
    • Profil anzeigen
Re: Tunen fehlgeschlagen
« Antwort #7 am: Mai 26, 2019, 03:44:26 Nachmittag »
Wann könnten wir das denn machen? Ich bin erst ab 18 Uhr zu Hause! Am Dienstag könnte ich früher.

BuSchu

  • Newbie
  • *
  • Beiträge: 12
    • Profil anzeigen
Re: Tunen fehlgeschlagen
« Antwort #8 am: Juni 01, 2019, 04:20:36 Nachmittag »
Die letzte Woche hat es nicht geklappt. Aber Montag muss ich Homeoffice machen, da werde ich mich im Chat melden!
Ich habe jetzt gerade noch einmal zwei Sendungen gleichzeitig programmiert und dann, während die Aufnahmen liefen, mal Sender umgeschaltet. Ich hatte eine Sendung auf Phoenix und eine auf One programmiert. Ich konnte im Aufnahmemodus wie erwartet nur zwischen Arte, Phoenix und One umschalten. Die Aufnahme bei Phoenix lief nicht (ts-Datei der Länge 0), der Prozess mediasrv lief natürlich auch nicht. Nach manuellem Umschalten auf Phoenix (dauerte ein paar Sekunden) füllte sich dann auch die leere ts-Datei und der Prozess mediasrv tauchte in top auf!

Hoffentlich können wir am Montag den Fehler finden, aber es ging ja schon mal! ;-)

Grüße
Burkhard

BuSchu

  • Newbie
  • *
  • Beiträge: 12
    • Profil anzeigen
Re: Tunen fehlgeschlagen
« Antwort #9 am: Juni 01, 2019, 04:51:03 Nachmittag »
Ich habe jetzt noch mal 2 gleichzeitige Aufnahmen programmiert. Dasselbe Verhalten. Ich habe dann /etc/rc3.d/S99tuner.sh aufgerufen und dann lief sofort mediasrv. Aber das hätte doch schon beim Start aufgerufen werden müssen.
Ich hab jetzt mal in die Datei /var/log/mediasrv.log geguckt:

root@dm800sev2:/var/volatile/log# cat mediasrv.log
2019-06-01 16:36:14 [563] Using /etc/sundtek.conf for deviceconfiguration
2019-06-01 16:42:18 [1508] Using /etc/sundtek.conf for deviceconfiguration
2019-06-01 16:42:28 [1619] Using /etc/sundtek.conf for deviceconfiguration

Da sehe ich, dass der Start von mediasrv vor der Aufnahme war, die um 16:40 begann. Die Aktion um 16:42 Uhr stamm offenbar von mir. Ich werde jetzt noch mal mit maximalem Logging starten.

Grüße
Burkhard

BuSchu

  • Newbie
  • *
  • Beiträge: 12
    • Profil anzeigen
Re: Tunen fehlgeschlagen
« Antwort #10 am: Juni 03, 2019, 11:07:14 Vormittag »
Ich habe mich jetzt im Chat gemeldet, aber da tut sich nichts. :-(

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8254
    • Profil anzeigen
Re: Tunen fehlgeschlagen
« Antwort #11 am: Juni 04, 2019, 04:14:17 Nachmittag »
Hi,

es geht erst übermorgen wieder weiter, der Support ist ab Donnerstag wieder verfügbar.
Failure is a good thing! I'll fix it