Autor Thema: Stick weg bei lsusb  (Gelesen 6061 mal)

hd-1958

  • Newbie
  • *
  • Beiträge: 6
    • Profil anzeigen
Stick weg bei lsusb
« am: März 16, 2014, 06:52:13 Nachmittag »
Hallo,
ich habe meinen Stick jetzt ein paar Wochen im Einsatz an Eisfair-Server mit Tvheadend und muss immer wieder feststellen, dass der Stick bei lsusb weg ist. Manchmal reicht es, usb restart einzugeben, aber meist muss ich den Stick abstöpseln. System ist Eisfair mit Kernel 3.2.55 und Tvheadend.

In Messages:
kernel: usb 2-1.5: USB disconnect, device number 10

dann:
tvheadend[23878]: dvb: "_dev_dvb_adapter0_Sundtek_DVB_C__III_" read() error 104

dann immer:
Mar 16 11:59:52 server kernel: usb 2-1.5: SerialNumber: U131223062846
Mar 16 11:59:52 server kernel: usb 2-1.5: Manufacturer: Sundtek
Mar 16 11:59:51 server kernel: usb 2-1.5: Product: MediaTV Pro Digital Home (EU)
Mar 16 11:59:51 server kernel: usb 2-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Mar 16 11:59:51 server kernel: usb 2-1.5: New USB device found, idVendor=2659, idProduct=1401
Mar 16 11:59:51 server kernel: usb 2-1.5: new high-speed USB device number 12 using ehci_hcd
Mar 16 11:59:51 server kernel: usb 2-1.5: USB disconnect, device number 11
Mar 16 11:59:50 server kernel: usb 2-1.5: usbfs: process 23593 (mediasrv) did not claim interface 0 before use
Mar 16 11:59:44 server kernel: usb 2-1.5: SerialNumber: U131223062846
Mar 16 11:59:44 server kernel: usb 2-1.5: Manufacturer: Sundtek
Mar 16 11:59:44 server kernel: usb 2-1.5: Product: MediaTV Pro Digital Home (EU)
Mar 16 11:59:44 server kernel: usb 2-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
Mar 16 11:59:44 server kernel: usb 2-1.5: New USB device found, idVendor=2659, idProduct=1401
Mar 16 11:59:43 server kernel: usb 2-1.5: new high-speed USB device number 11 using ehci_hcd

und:
kernel: usb 2-1.5: usbfs: process 23593 (mediasrv) did not claim interface 0 before use
kernel: usb 2-1.5: usbfs: USBDEVFS_CONTROL failed cmd mediasrv rqt 192 rq 6 len 4 ret -71

und:
Mar 16 12:04:27 server kernel: usb 2-1.5: usbfs: USBDEVFS_CONTROL failed cmd mediasrv rqt 64 rq 2 len 4 ret -71
Mar 16 12:04:27 server kernel: usb 2-1.5: usbfs: USBDEVFS_CONTROL failed cmd mediasrv rqt 192 rq 6 len 4 ret -71
Mar 16 12:04:17 server tvheadend[23878]: dvb: "/dev/dvb/adapter0" tuning to "KBW: 458,000 kHz" -- Front configuration failed -- Success, frequency: 458000000
Mar 16 12:04:13 server kernel: usb 2-1.5: usbfs: USBDEVFS_CONTROL failed cmd mediasrv rqt 192 rq 6 len 4 ret -71
Mar 16 12:03:56 server tvheadend[23878]: dvb: "/dev/dvb/adapter0" tuning to "KBW: 434,000 kHz" -- Front configuration failed -- Success, frequency: 434000000
Mar 16 12:03:45 server tvheadend[23878]: dvb: "/dev/dvb/adapter0" tuning to "KBW: 458,000 kHz" -- Front configuration failed -- Success, frequency: 458000000
Mar 16 12:03:40 server last message repeated 5 times

Mainboard ist Intel DH87RL
Wie kann ich eingrenzen?
Gruß
Thomas Ostermaier


Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8575
    • Profil anzeigen
Re:Stick weg bei lsusb
« Antwort #1 am: März 16, 2014, 09:15:44 Nachmittag »
Intel DH87RL hmm.. das Board hat USB 3.0 Bugs. Kannst du dort im Bios etwas bezüglich USB 3.0 abändern? z.B USB 2.0 Support?

Nicht nur das es dort erwähnt wurde:
http://www.heise.de/preisvergleich/?sr=954663,-1

sondern auch von einem Kunden, eventuell sogar hier im Forum inklusive Workaround, jedoch bin ich mir nicht ganz sicher und wüsste den Link jetzt auch nicht..
Failure is a good thing! I'll fix it

hd-1958

  • Newbie
  • *
  • Beiträge: 6
    • Profil anzeigen
Re:Stick weg bei lsusb
« Antwort #2 am: März 17, 2014, 11:51:53 Vormittag »
Der Stick steckt an USB 2.0

hd-1958

  • Newbie
  • *
  • Beiträge: 6
    • Profil anzeigen
Re:Stick weg bei lsusb
« Antwort #3 am: März 17, 2014, 12:10:05 Nachmittag »
Sorry, im PC ist ein DB75EN

kara2010

  • Newbie
  • *
  • Beiträge: 6
    • Profil anzeigen
Re:Stick weg bei lsusb
« Antwort #4 am: Mai 01, 2014, 02:44:58 Nachmittag »
Konntest Du das Problem lösen? Habe das gleiche mit einem DH87RL unter Ubuntu...

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8575
    • Profil anzeigen
Re:Stick weg bei lsusb
« Antwort #5 am: Mai 01, 2014, 03:12:39 Nachmittag »
Versuche mal ein älteres Linux zu installieren, dort funktionieren USB 3.0 Geräte dann zwar nur mit USB 2.0 Geschwindigkeit das jedoch sollte stabil sein; das Problem hat mit dem xhci Treiber auf einigen Systemen zu tun.

Wichtig hierbei wäre es Logfiles zu sammeln, wer die richtigen Logfiles bereitstellen kann hat auch bessere Chancen das die Probleme für das jeweilige System wirklich behoben werden. Blos kann das bedeuten das ein Kernel mit Debug Informationen entweder selber gebaut werden muss oder eventuell falls vorhanden via Paketmanager installiert werden muss.
« Letzte Änderung: Mai 01, 2014, 03:14:20 Nachmittag von Sundtek »
Failure is a good thing! I'll fix it