Autor Thema: S-Video mit vlc  (Gelesen 3475 mal)

tvpaul

  • Jr. Member
  • **
  • Beiträge: 64
    • Profil anzeigen
S-Video mit vlc
« am: Mai 12, 2012, 08:58:43 Nachmittag »
ich kann mit tvtime und mplayer ein S-Video-Eingangssignal wiedergeben.

Mit vlc klappt es allerdings nicht. Es kommt nur Rauschen.
ich habe schon versucht, mit "/opt/bin/mediaclient -I 0002" umzuschalten, aber da hat auch nichts gebracht.
unter advanced options gibts es einen Punkt input, der auf 0 gesetzt ist. Ich wollte ihn auf 2 setzen, aber er läst sich nicht verändern.
kann mir jemand verraten, wie das funktioniert?


« Letzte Änderung: Mai 12, 2012, 09:15:53 Nachmittag von tvpaul »

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8329
    • Profil anzeigen
Re:S-Video mit vlc
« Antwort #1 am: Mai 14, 2012, 08:42:28 Vormittag »
Scheint ein Bug im VLC zu sein.


Bei VLC in der V4L2 Schaltfläche "Show more options" oder "Erweitert" auswählen und einfach " :v4l2-input=1" oder " :v4l2-input=2" hinzufügen, das Leerzeichen nicht vergessen
« Letzte Änderung: Mai 14, 2012, 08:54:41 Vormittag von Sundtek »
Failure is a good thing! I'll fix it

tvpaul

  • Jr. Member
  • **
  • Beiträge: 64
    • Profil anzeigen
Re:S-Video mit vlc
« Antwort #2 am: Mai 14, 2012, 02:00:23 Nachmittag »
das funktioniert für video!

nur mit dem Ton gibt es Probleme. erst einmal bleibt es stumm.
nach Ausführen von "v4l2-ctl --set-ctrl mute=off -d /dev/video0" kommt Ton, aber er ist deutlich zeitversetzt.

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8329
    • Profil anzeigen
Re:S-Video mit vlc
« Antwort #3 am: Mai 15, 2012, 12:52:04 Nachmittag »
Kann es sein das du den Ton 2x bekommst?

1x vom Treiber während der Aufnahme, und einmal von VLC?

Den Treiber muesstest du wohl in der Volume Control von Pulseaudio stumm machen.
Failure is a good thing! I'll fix it