Autor Thema: MythTV LiveTV unknown error: LiveTV startet nicht mehr  (Gelesen 9480 mal)

astir13

  • Newbie
  • *
  • Beiträge: 11
    • Profil anzeigen
MythTV LiveTV unknown error: LiveTV startet nicht mehr
« am: Oktober 05, 2010, 10:46:29 Nachmittag »
Hallo,

ich kann wunderbar DVB-C in normal und HD Qualität sehen, Recordings wie auch LiveTV, jedoch tritt nach einem Recording Ende (oder anderes Event?) immer wieder die Situation auf, dass ich dann LiveTV nicht mehr starten kann: folgendes steht im Frontend Log:

2010-10-05 22:37:05.538 TV: Attempting to change from None to WatchingLiveTV
2010-10-05 22:37:05.549 MythContext: Connecting to backend server: 192.168.1.11:6543 (try 1 of 1)
2010-10-05 22:37:05.550 Using protocol version 56
2010-10-05 22:37:05.578 Spawning LiveTV Recorder -- begin
2010-10-05 22:37:09.408 Spawning LiveTV Recorder -- end
2010-10-05 22:37:09.417 ProgramInfo(): Updated pathname '':'' -> '1008_20101005223708.mpg'
2010-10-05 22:37:09.477 We have a playbackURL(myth://192.168.1.11:6543/1008_20101005223708.mpg) & cardtype(DUMMY)
2010-10-05 22:37:09.477 We have a RingBuffer
2010-10-05 22:37:09.597 NVP(1): Disabling Audio, params(-1,2,44100)
2010-10-05 22:37:09.658 ProgramInfo(): Updated pathname '':'' -> '1008_20101005223708.mpg'
2010-10-05 22:37:09.687 VideoOutputXv: XVideo Adaptor Name: 'ATI Radeon AVIVO Video'
2010-10-05 22:37:09.738 OSD Theme Dimensions W: 1280 H: 720
greedyhdeint: size changed from 0 x 0 -> 720 x 576
2010-10-05 22:37:09.838 Realtime priority would require SUID as root.
2010-10-05 22:37:09.838 OpenGLVideoSync()
2010-10-05 22:37:09.903 TV: Changing from None to WatchingLiveTV
2010-10-05 22:37:09.903 TV: State is LiveTV & mctx == ctx
2010-10-05 22:37:09.912 TV: UpdateOSDInput done
2010-10-05 22:37:09.912 TV: UpdateLCD done
2010-10-05 22:37:09.912 TV: ITVRestart done
2010-10-05 22:37:09.952 ScreenSaverX11Private: DPMS Deactivated 1
2010-10-05 22:37:10.002 Video timing method: SGI OpenGL
2010-10-05 22:37:11.164 ProgramInfo(): Updated pathname '':'' -> '1008_20101005223710.mpg'
2010-10-05 22:37:12.145 TV: Attempting to change from WatchingLiveTV to None
2010-10-05 22:37:12.145 RingBuf(myth://192.168.1.11:6543/1008_20101005223710.mpg) Warning: Peek() requested 2048 bytes, but only returning 376
2010-10-05 22:37:12.145 NVP::OpenFile(): Error, couldn't read file: myth://192.168.1.11:6543/1008_20101005223710.mpg
2010-10-05 22:37:12.146 NVP(1), Error: JumpToProgram failed.
2010-10-05 22:37:12.146 NVP(1), Error: Unknown recorder error, exiting decoder

2010-10-05 22:37:12.154 ~OpenGLVideoSync() -- closing opengl vsync
2010-10-05 22:37:13.145 RingBuf(myth://192.168.1.11:6543/1008_20101005223710.mpg): Waited too long for ringbuffer pause..
2010-10-05 22:37:14.385 TV: Changing from WatchingLiveTV to None
2010-10-05 22:37:14.397 MythSystemEventHandler ERROR: SendMythSystemPlayEvent() called with empty ProgramInfo
2010-10-05 22:37:14.414 ScreenSaverX11Private: DPMS Reactivated 1
2010-10-05 22:37:14.459 TV: Attempting to change from None to WatchingLiveTV
2010-10-05 22:37:14.459 MythContext: Connecting to backend server: 192.168.1.11:6543 (try 1 of 1)
2010-10-05 22:37:14.469 Using protocol version 56
2010-10-05 22:37:14.489 Spawning LiveTV Recorder -- begin
2010-10-05 22:37:17.848 Spawning LiveTV Recorder -- end
2010-10-05 22:37:17.861 ProgramInfo(): Updated pathname '':'' -> '1008_20101005223717.mpg'
2010-10-05 22:37:17.882 We have a playbackURL(myth://192.168.1.11:6543/1008_20101005223717.mpg) & cardtype(DUMMY)
2010-10-05 22:37:17.882 We have a RingBuffer
2010-10-05 22:37:17.933 TV Error: LiveTV not successfully started
2010-10-05 22:37:18.001 ScreenSaverX11Private: DPMS Deactivated 1
2010-10-05 22:37:18.001 ScreenSaverX11Private: DPMS Reactivated 1
2010-10-05 22:37:19.424 MythSystemEventHandler ERROR: SendMythSystemPlayEvent() called with empty ProgramInfo


mein MythTV Backend Setup besteht aus einem 1.5GHz VIA C7 Prozessor mit 1GB RAM und schreib folgendes ins backend Log:

2010-10-05 22:37:14.427 adding: bilbo as a client (events: 0)
2010-10-05 22:37:14.444 TVRec(1): Changing from None to WatchingLiveTV
2010-10-05 22:37:14.482 TVRec(1): HW Tuner: 1->1
2010-10-05 22:37:14.989 DVBChan(1:/dev/dvb/adapter0/frontend0) Warning: Symbol Rate setting (6952000) is out of range (min/max:6250000/690
0000)
2010-10-05 22:37:17.832 AutoExpire: CalcParams(): Max required Free Space: 3.0 GB w/freq: 14 min
2010-10-05 22:37:17.871 ProgramInfo(): Updated pathname '':'' -> '1008_20101005223717.mpg'
2010-10-05 22:37:17.899 ProgramInfo(): Updated pathname '':'' -> '1008_20101005223717.mpg'
2010-10-05 22:37:17.916 TVRec(1): Changing from WatchingLiveTV to None
2010-10-05 22:37:18.207 ProgramInfo(): Updated pathname '':'' -> '1008_20101005223717.mpg'
2010-10-05 22:37:18.221 Finished recording The Breed "Amerikansk gyser fra 2006. En gruppe unge venner flyver til en tilsyneladende forladt  for at feste og slappe af.": channel 1008
2010-10-05 22:37:18.252 ProgramInfo(): Updated pathname '':'' -> '1008_20101005223717.mpg'
2010-10-05 22:37:18.271 ProgramInfo(): Updated pathname '':'' -> '1008_20101005223717.mpg'
2010-10-05 22:37:18.294 ProgramInfo(): Updated pathname '':'' -> '1008_20101005223717.mpg'
2010-10-05 22:38:18.927 DVBChan(1:/dev/dvb/adapter0/frontend0) Warning: Symbol Rate setting (6952000) is out of range (min/max:6250000/6900000)

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8330
    • Profil anzeigen
Re:MythTV LiveTV unknown error: LiveTV startet nicht mehr
« Antwort #1 am: Oktober 06, 2010, 12:02:15 Vormittag »
Da noch immer "Warning: Symbol Rate setting (6952000) is out of range " sichtbar ist koennen Sie den aktuellen 'Entwicklungs'treiber testen:

http://www.sundtek.de/media/sundtek_installer_development.sh

Kurze Aufnahmen mittels dem Key 'r' funktionieren hier genauso wie bei Sendungen welche ueber EPG aufgenommen wurden.

Wir verwenden zum Testen MythTV 0.23 mit Ubuntu 10.04.

Welche Version wurde denn fuer die obrige Aufnahme verwendet?

Bitte geben Sie uns eine genaue Beschreibung wie wir diesen Fehler nachstellen koennen.
« Letzte Änderung: Oktober 06, 2010, 12:31:56 Vormittag von Sundtek »
Failure is a good thing! I'll fix it

astir13

  • Newbie
  • *
  • Beiträge: 11
    • Profil anzeigen
Re:MythTV LiveTV unknown error: LiveTV startet nicht mehr
« Antwort #2 am: Oktober 08, 2010, 09:16:14 Nachmittag »
Danke für die schnelle Antwort. Ich bin nicht ganz so schnell ...

(1) Software versionen:
- backend: Ubuntu 10.04, mythtv-backend version 0.23.0, euer treiber ist der development treiber downgeloaded am 2.10.
- frontend: Ubuntu 10.04, mythtv-frontend version 0.23.20100314-1

(2) leider gibt es keine mediclient --version, aber hier noch ein dump from mediasrv.log mit versionsnummer, etc. auf der Backend Maschine:
2010-09-19 12:02:57 [30038] Starting up Multimedia Framework (Sep 16 2010 23:24:40)
2010-09-19 12:02:57 [30039] Starting service processor (PID 30039)
2010-09-19 12:02:57 [30038] Detected DVB version.h
2010-09-19 12:02:57 [30038] API Version: 5.1
2010-09-19 12:02:57 [30038] Running on Linux (2.6.32-24-generic)
2010-09-19 12:02:57 [30038] Detected: CentaurHauls
2010-09-19 12:02:57 [30038] This CPU supports: MMX and SSE
2010-09-19 12:02:57 [30038] scanning devices
2010-09-19 12:02:57 [30038] scanning for plugins
2010-09-19 12:02:57 [30038] found lib: libdrv_net.so
2010-09-19 12:02:57 [30038] found lib: libdrv_vivi.so
2010-09-19 12:02:57 [30038] found lib: libdrv_em28xx.so
2010-09-19 12:02:57 [30038] Starting up device manager
2010-09-19 12:02:57 [30038] unable to open /dev/misc
2010-09-19 12:02:57 [30038] scanning devices done
2010-09-19 12:02:57 [30038] attached devices:
2010-09-19 12:02:57 [30038] registering ID: 0
2010-09-19 12:02:57 [30038] disconnecting kernel driver
2010-09-19 12:02:58 [30038] attaching Videodecoder
2010-09-19 12:03:01 [30038] attaching DVB-T, DVB-C
2010-09-19 12:03:05 [30038] demodulator successfully attached (DVB_C)!
2010-09-19 12:03:05 [30038] requesting to attach tuner(s) now
2010-09-19 12:03:07 [30038] registering: adapter0/0
2010-09-19 12:03:07 [30038] registered virtual: /dev/dvb/adapter0/frontend0
2010-09-19 12:03:07 [30038] registered virtual: /dev/dvb/adapter0/demux0
2010-09-19 12:03:07 [30038] registered virtual: /dev/dvb/adapter0/dvr0
2010-09-19 12:03:07 [30038] registered virtual: /dev/video1
2010-09-19 12:03:07 [30038] registered virtual: /dev/radio0
2010-09-19 12:03:07 [30038] registered virtual: /dev/rds0
2010-09-19 12:03:07 [30038] registered virtual: /dev/vbi1
2010-09-19 12:03:07 [30038] registered virtual: /dev/mediainput0
2010-09-19 12:03:07 [30039] trying to load uinput module
2010-09-19 12:03:10 [30039] loading uinput kernel extention succeeded
2010-09-19 12:03:10 [30038] Registering OSS emulation
2010-09-19 12:03:10 [30038] registered virtual: /dev/dsp0
2010-09-19 12:03:10 [30038]
2010-09-19 12:03:10 [30038] Sundtek MediaTV Driver loaded. This driver is licensed for non-commercial use
2010-09-19 12:03:10 [30038] with Sundtek MediaTV only
2010-09-19 12:03:10 [30038] Initial devicescan done, switching detection mode
2010-09-19 12:03:10 [30208] RC: IR Event /dev/input/event4
2010-09-19 12:03:10 [30218] RC: IR Event /dev/input/event4
2010-09-19 12:03:25 [30038] Enabling standby
2010-09-19 12:25:00 [30038] SETTING DVB-C
2010-09-19 12:25:00 [30038] switching to analog TV
2010-09-19 12:25:00 [30038] SETTING PAL/SECAM
2010-09-19 12:25:02 [30038] opening in digital TV mode
2010-09-19 12:25:02 [30038] SETTING DVB-C
2010-09-19 12:25:17 [30038] Enabling standby
2010-09-19 12:29:16 [30038] SETTING DVB-C
2010-09-19 12:29:16 [30038] switching to analog TV
2010-09-19 12:29:16 [30038] SETTING PAL/SECAM
2010-09-19 12:29:39 [30038] Enabling standby
2010-09-19 12:29:46 [30038] Using settings for Europe
2010-09-19 12:30:15 [30038] Enabling standby
2010-09-19 12:30:51 [30038] Using settings for Europe

(3) inzwischen habe ich festgestellt, dass das Problem nur auf der Ubuntu Linux Maschine für das Frontend auftaucht. Wenn ich meinen Apple MacBook Pro mit mythfrontend verwende, funktioniert das LiveTV einwandfrei.

(4) Aufnahmen kann ich auf dem Ubuntu Frontend auch alle ansehen

(5) Nur LiveTV gibt probleme auf dem Ubuntu Frontend

(6) das seltsame ist, dass das Problem nicht auftaucht, wenn ich meine analoge TV Karte auf dem gleichen Backend benutzte. Seltsam.

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8330
    • Profil anzeigen
Re:MythTV LiveTV unknown error: LiveTV startet nicht mehr
« Antwort #3 am: Oktober 08, 2010, 09:41:50 Nachmittag »
Der Stick kann auch analog TV, aber wie es scheint geht es bei der Aufnahme um digital TV.

Wir hatten derzeit nur versucht DVB-C aufzunehmen und dabei konnten wir soweit keine Probleme feststellen. Der Entwicklungstreiber/Beta Treiber wird beinahe taeglich aktualisiert eventuell versuchen Sie den nocheinmal zu installieren.
Failure is a good thing! I'll fix it

astir13

  • Newbie
  • *
  • Beiträge: 11
    • Profil anzeigen
Re:MythTV LiveTV unknown error: LiveTV startet nicht mehr
« Antwort #4 am: Oktober 08, 2010, 10:45:50 Nachmittag »
Berichtigung zu dem vorher gesagen:

zu (3) ist zu bemerken, dass derselbe Fehler auch auf dem MacBook Pro auftaucht, ich hatte es bisher nur noch nicht bemerkt.

Der Fehler ist ja nicht immer reproduzierbar, auch nicht auf der Ubuntu Maschine.

Ich installiere nun den neuen Treiber, vielleicht habe ich dann mehr Glück.

Muss ich nach dem Treiberupdate auch die Karte im MythBackend neu installieren oder reicht es einfach das Backend neu zu starten?

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8330
    • Profil anzeigen
Re:MythTV LiveTV unknown error: LiveTV startet nicht mehr
« Antwort #5 am: Oktober 08, 2010, 10:53:49 Nachmittag »
Ein Neustart von mythbackend ist soweit ausreichend.

Wir werden das naechste Woche auch nocheinmal genauer ueberpruefen.
Failure is a good thing! I'll fix it

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8330
    • Profil anzeigen
Re:MythTV LiveTV unknown error: LiveTV startet nicht mehr
« Antwort #6 am: Oktober 13, 2010, 12:21:51 Vormittag »
Laut MythTV Entwickler kann es zu Problemen kommen wenn MythBackend und MythFrontend nicht die exakt gleiche Version haben.

Wir nehmen selber auch an das die Verbreitung von MythTV fuer DVB-C nicht allzugross ist da wir default Probleme mit dem Deinterlacer bemerkt haben.

MythTV Entwickler haben soweit empfohlen MythTV zu aktualisieren bzw. auf eine gleiche Version zu bringen (MythTV Frontend / MythTV Backend).

Funktioniert es denn wenn nur das Frontend neu gestartet wird? Oder muss auch das Backend neu gestartet werden wenn dieses Problem auftritt?


Es gibt eine aktuelle Version von MythTV:

http://www.mythbuntu.org/auto-builds
Activate Auto Builds


Sollte es hier weiterhin Probleme geben bitte melden damit wir dies auch weiterleiten koennen und das Problem bei MythTV behoben wird. Bei Version 0.22 gab es noch Probleme mit Analog TV die Entwickler arbeiten jedoch auch kontinuierlich an Verbesserungen


MythTV Bugreport:
http://svn.mythtv.org/trac/ticket/9091#comment:5
« Letzte Änderung: Oktober 13, 2010, 02:18:19 Vormittag von Sundtek »
Failure is a good thing! I'll fix it

astir13

  • Newbie
  • *
  • Beiträge: 11
    • Profil anzeigen
Re:MythTV LiveTV unknown error: LiveTV startet nicht mehr
« Antwort #7 am: November 24, 2010, 07:51:31 Nachmittag »
Ich habe weiterhin das Problem. Es ist bisher immer notwendig gewesen
(1) das backend neu zu starten
(2) das frontend neu zu starten
(3) das USB dongle aus dem USB port zu entfernen und wieder hineinzustecken.

Nach einem solchen Zustand werden auch keine programmierten Sendungen mehr aufgenommen.

Auf dem Linux server/client, wo das Problem häufig auftritt, ist die gleiche Version von MythTV installiert, beides Ubuntu 10.04 HEAD revision (also die neuesten updates).

Wäre es evtl. ratsam, das USB dongle per SW kommando vor dem Aufnehmen eines Filmes zu resetten? Könnte ich das mit MythTV machen?

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8330
    • Profil anzeigen
Re:MythTV LiveTV unknown error: LiveTV startet nicht mehr
« Antwort #8 am: November 29, 2010, 02:30:08 Vormittag »
Es gab vor kurzem anscheinend MythTV Updates welche einige Probleme behoben haben. DVB-C hat bei uns kurzzeitig überhaupt nicht funktioniert - mittlerweile funktioniert es wieder.
Failure is a good thing! I'll fix it

astir13

  • Newbie
  • *
  • Beiträge: 11
    • Profil anzeigen
Re:MythTV LiveTV unknown error: LiveTV startet nicht mehr
« Antwort #9 am: Dezember 13, 2010, 08:34:53 Nachmittag »
Ich habe jetzt den DVB-C USB stick direkt an meinem Desktop PC hängen, so dass Masterbackend, Backend und Frontend auf der gleichen Maschine sind. Das funktioniert fast einwandfrei.

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8330
    • Profil anzeigen
Re:MythTV LiveTV unknown error: LiveTV startet nicht mehr
« Antwort #10 am: Dezember 14, 2010, 09:56:11 Nachmittag »
fast?
Failure is a good thing! I'll fix it

astir13

  • Newbie
  • *
  • Beiträge: 11
    • Profil anzeigen
Re:MythTV LiveTV unknown error: LiveTV startet nicht mehr
« Antwort #11 am: Dezember 15, 2010, 10:34:32 Nachmittag »
Ja, nach jedem Hochfahren des Rechners kann das Backend den receiver nicht finden, es werden keine Aufnahmen geschedult und ich muss einen restart mythtv-backend ausführen, damit das Backend den receiver findet und die Aufnahmen startet bzw. live TV funktioniert. Eine Lösung wäre natürlich willkommen ;.)

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8330
    • Profil anzeigen
Re:MythTV LiveTV unknown error: LiveTV startet nicht mehr
« Antwort #12 am: Dezember 16, 2010, 12:05:50 Vormittag »
MythTV unterstützt zwar kein Hotplugging aber

du kannst die folgende Konfigurationsdatei anlegen:

/etc/sundtek.conf
device_attach=/etc/init.d/mythtv restart


Sobald das Gerät dem System zur Verfügung steht startet es dann MythTV neu.
Failure is a good thing! I'll fix it