Autor Thema: MediaTV Pro und MythTV  (Gelesen 6971 mal)

Lutz Maendle

  • Newbie
  • *
  • Beiträge: 4
    • Profil anzeigen
MediaTV Pro und MythTV
« am: August 23, 2010, 01:49:54 Nachmittag »
Hallo,

ich bekomme den Stick nicht mit MythTV (0.23.1) verheiratet. Nach dem Starten des Backends wird der Stick als 4 neue Tuner angezeigt, das ist mit mythtv-setup auch so eingerichtet. Startet man jedoch eine Aufnahme bzw. LiveTV erscheint kein Bild. Im MythTV-Log tauchen folgende Zeilen auf:

2010-08-23 13:07:05.032 DevRdB(/dev/dvb/adapter3/frontend0): End-Of-File? fd(56)
2010-08-23 13:07:05.177 DVBSH(/dev/dvb/adapter3/frontend0) Error: Device EOF detected
2010-08-23 13:07:05.353 DVBRec(17:/dev/dvb/adapter3/frontend0) Error: Stream handler died unexpectedly.

Der Stick läuft im DVB-C-Modus.

uname -a liefert folgende Information:

Linux lutzhome 2.6.31.12-0.2-desktop #1 SMP PREEMPT 2010-03-16 21:25:39 +0100 x86_64 x86_64 x86_64 GNU/Linux


Mit Kaffeine und MPlayer läuft der Stick.

Der Transfermodus muß bei diesem Rechner auf Bulk gestellt werden, sonst bekommt man nur ein geschreddertes Bild und MPlayer bricht dann auch bald ab.

Ich habe verschiedene Versionen des Treibers ausprobiert (die letzte stabile und 2 Developmentversionen bis einschließlich letzten Freitag).


Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8355
    • Profil anzeigen
Re:MediaTV Pro und MythTV
« Antwort #1 am: August 23, 2010, 04:06:21 Nachmittag »
Der Transfermodus muß bei diesem Rechner auf Bulk gestellt werden, sonst bekommt man nur ein geschreddertes Bild und MPlayer bricht dann auch bald ab.

Ich habe verschiedene Versionen des Treibers ausprobiert (die letzte stabile und 2 Developmentversionen bis einschließlich letzten Freitag).

Development Versionen haben bezueglich Bulk definitiv eine bessere Stabilitaet.

Das geschredderte Bild ist auf einen Kernel Bug in der jeweiligen Version zurueckzufuehren. Bulk ist ein Workaround von unserer Seite der Kernelfehler bleibt natuerlich bestehen...
Der Kernelbug welcher bei Ihnen zutrifft:
http://lkml.org/lkml/2010/3/6/100

MythTV werden wir die kommenden Tage testen, eigentlich sollte es damit keine besonderen Probleme geben.
« Letzte Änderung: August 23, 2010, 05:05:03 Nachmittag von Sundtek »
Failure is a good thing! I'll fix it

chefcb

  • Newbie
  • *
  • Beiträge: 4
    • Profil anzeigen
Re:MediaTV Pro und MythTV
« Antwort #2 am: November 04, 2010, 08:32:09 Vormittag »
Hallo Zusammen,

von einem geschreddertem Bild weiß ich nichts, aber das EOF Problem habe ich ebenfalls.

Wenn mythbackend einige Zeit nach mediasrv gestartet wird (nachdem /dev/dvb/adapter0/*) zur verfügung steht und der Stick dann nicht in Standby geht, sollte es eigentlich Problemlos funktionieren.

Leider kommt entsprechend oft (also beinahe immer) erst mal der EOF-Fehler.
Bei Aufnahmen ist das besonders doof, weil diese dann komplett abbrechen (der Fehler kommt 'nur' direkt nachdem der Kanal umgeschalten wurde) - daher ist Aufnehmen momentan quasi gar nicht möglich.

Beim Live-TV versucht mythfrontend immer wieder den Sender zu wählen, was meistens dann auch nicht klappt. Bei jedem Versuch erscheint die Leiste mit den Senderinformationen und im backend besagte log-einträge.

Meist hilft es nicht, mediasrv oder mythbackend neu zu starten. Ein kompletter reboot hilft auch nicht immer.
Gestern war keines von beiden nötig, nach ca. 10 Versuchen (durch's Mythfrontend) war plötzlich ein Bild da - was bisher auch noch nicht passiert ist.

Auch ein Kernelupdate war nicht Zielführend.

Gibt es hierzu ein Statement?

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8355
    • Profil anzeigen
Re:MediaTV Pro und MythTV
« Antwort #3 am: November 04, 2010, 08:37:25 Vormittag »
Koennen Sie das mit http://www.sundtek.de/media/sundtek_installer_development.sh reproduzieren? (aktuellen development Treiber vom 4. November).
Failure is a good thing! I'll fix it

chefcb

  • Newbie
  • *
  • Beiträge: 4
    • Profil anzeigen
Re:MediaTV Pro und MythTV
« Antwort #4 am: November 04, 2010, 08:45:40 Nachmittag »
ja, konnte ich
konnte keine veränderung festellen,
bisher hatte ich das sundtek_installer_development.sh-Script vom 13.10 - also nicht sehr alt.

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8355
    • Profil anzeigen
Re:MediaTV Pro und MythTV
« Antwort #5 am: November 07, 2010, 04:39:48 Vormittag »
ja, konnte ich
konnte keine veränderung festellen,
bisher hatte ich das sundtek_installer_development.sh-Script vom 13.10 - also nicht sehr alt.


Wir konnten dies leider noch nicht nachvollziehen, zwischen dem development Treiber vom 13.10 und dem aktuellen Treiber gibt es recht grosse Unterschiede.

http://www.sundtek.de/media (der Development Treiber zeigt automatisch auf die letzte Treiberversion).
Mittlerweile wurde das ganze mit dem Treiber vom 5. November getestet und es konnten keine Probleme festgestellt werden.

Bitte eine genaue Beschreibung angeben wie wir dies nachvollziehen koennen.

Der Treiber vom 23. August ist mit der aktuellen Bulk Implementierung ebenfalls nicht mehr vergleichbar.

Falls moeglich wuerde eventuell auch ein remote Zugang helfen um das Problem bei Ihnen aufzuklaeren.
« Letzte Änderung: November 07, 2010, 04:55:14 Vormittag von Sundtek »
Failure is a good thing! I'll fix it

chefcb

  • Newbie
  • *
  • Beiträge: 4
    • Profil anzeigen
Re:MediaTV Pro und MythTV
« Antwort #6 am: November 07, 2010, 01:33:28 Nachmittag »
Der Treiber vom 5.11. ändert auch nichts.

Hardware:
Zotoc IONITX-F-E
Intel Atom 330
2GB Ram
8 GB CF-Card (rootfs,swap & datenbank/settings)
500 GB 3,5" Festplatte (Aufnahmen)

Software
Gentoo Linux
MythTV-0.23.1_p25496 (USE="alsa autostart css dbus dvb lirc mmx python", VIDEO_CARDS="nvidia")
Kernel:
Linux gentest 2.6.35-tuxonice-r5-MythPC #2 SMP Mon Nov 1 18:49:51 CET 2010 i686 Intel(R) Atom(TM) CPU 330 @ 1.60GHz GenuineIntel GNU/Linux
grub-menu.lst: kernel /boot/bzImage root=/dev/sda3 fastboot splash=silent,theme:MythTV console=tty1 video=uvesafb:ywrap,mtrr:3,800x600-32@70 resume=swap:/dev/sda2 quiet



FileSystems:
 SD-Karte:
  -15 MB boot partition (ext2) - auto,noatime,nodiratime,ro,commit=120
  -500 MB Swap
  -2 GB Rootfs (ext3) - Readonly gemountet (ändert hier nichts) - auto,data=writeback,noatime,commit=120,nodiratime
  -5 GB Datenpartition (ext3)  (u.A. für MySQL und EPG) - auto,data=writeback,noatime,commit=120,nodiratime,rw
 HardDisk:
  - 500 GB (ext3) für MythTV-Daten (Aufnahmen, Musik, Bilder etc) - auto,noatime,commit=120,nodiratime,rw


Reproduzieren:
Zum Reproduzieren gibt es nich viel zu sagen. Die normalen Installationsschritte von MythTV durchführen. Alle Einstellungen, die die Karte betreffen habe ich bereits beliebig geändert, der Fehler tritt weiterhin auf.
Dazu das Backend-Log beobachten und auf Live-TV schalten.
Sollte das funktionieren, den Sender wechseln - spätestens dann tritt bei mir der Fehler auf.

MythTV selbst ist funktionstüchtig - bevor ich umgezogen bin, lief alles einwandfrei per DVB-S


Remote-Zugang ist leider nicht möglich.

Wenn Sie möchten, könnte ich Ihnen einen Dump meiner MySQL Datenbank zur Verfügung stellen, dafür wäre vermutlich die selbe MythTV-Version nötig.

Alternativ könnte ich die Gesamte CF-Karte kopieren und Ihnen zukommen lassen - da alles CPU-Optimiert kompiliert wurde, ist höchstwarscheinlich ein Intel-Atom nötig.
Die Treiber etc. sind ebenfalls auf das Board angepasst, daher würde sich das selbe Mainboard empfehlen.


Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8355
    • Profil anzeigen
Re:MediaTV Pro und MythTV
« Antwort #7 am: November 07, 2010, 04:42:46 Nachmittag »
Ok, das Problem liegt wohl an der Abfrage ob Videodaten bereits vorhanden sind, diese Abfrage positiv antwortet jedoch noch keine Videodaten verfuegbar sind. MythTV nimmt bei einem 0 Wert an das keine Daten mehr kommen werden. Der Treiber wird in kuerze aktualisiert werden damit dieses Problem auch ausgeschlossen werden kann.

Das es bei uns nicht aufgetreten ist kann wohl an unserer Senderkonfiguration liegen.


Der Treiber wurde aktualisiert, zu solchen fehlern sollte es nicht mehr kommen koennen.

http://www.sundtek.de/media/sundtek_installer_development.sh (stand 7. Nov 2010)
« Letzte Änderung: November 07, 2010, 06:05:32 Nachmittag von Sundtek »
Failure is a good thing! I'll fix it

chefcb

  • Newbie
  • *
  • Beiträge: 4
    • Profil anzeigen
Re:MediaTV Pro und MythTV
« Antwort #8 am: November 07, 2010, 08:41:48 Nachmittag »
 ;D
Ihre seid meine Helden!!!


V I E L E N  D A N K ! ! !

(muss ich dazu schreiben, dass jetzt alles einwandfrei funktioniert ?!)