Autor Thema: DVB-T Scan unter Linux findet keine Sender  (Gelesen 9715 mal)

Mac_Ot

  • Newbie
  • *
  • Beiträge: 2
    • Profil anzeigen
DVB-T Scan unter Linux findet keine Sender
« am: Oktober 18, 2010, 02:30:32 Nachmittag »
Ich teste gerade den MediaTV Pro und habe zur Zeit ein Problem mit DVB-T und zwar kann ich nicht mal Sender finden. Unter Windows 7 funktioniert das ohne Probleme und dort kann ich auch die einzelnen Sender sehen, es sollte also nicht an einem schlechten Empfang liegen.

UMTS1:~# /opt/bin/mediaclient -e
**** List of Media Hardware Devices ****
device 0: [ Sundtek MediaTV Pro]  DVB-C, DVB-T, ANALOG-TV, FM-RADIO, REMOTE-CONTROL, OSS-AUDIO, RDS
  [DVB-C]:
     FRONTEND: /dev/dvb/adapter0/frontend0
     DVR: /dev/dvb/adapter0/dvr0
     DMX: /dev/dvb/adapter0/demux0
  [DVB-T]:
     FRONTEND: /dev/dvb/adapter0/frontend0
     DVR: /dev/dvb/adapter0/dvr0
     DMX: /dev/dvb/adapter0/demux0
  [ANALOG-TV]:
     VIDEO0: /dev/video0
     VBI0: /dev/vbi0
  [FM-RADIO]:
     RADIO0: /dev/radio0
     RDS: /dev/rds0
  [REMOTECONTROL]:
     INPUT0: /dev/mediainput0
  [OSS]:
     OSS0: /dev/dsp0

scan -n -o zap /usr/share/dvb/dvb-t/de-Berlin > /home/.xine/channels.conf
scanning /usr/share/dvb/dvb-t/de-Berlin
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
Frontend can not do INVERSION_AUTO, trying INVERSION_OFF instead
initial transponder 177500000 1 3 9 1 1 2 0
initial transponder 191500000 1 2 9 1 1 2 0
initial transponder 506000000 0 2 9 1 1 2 0
initial transponder 522000000 0 2 9 1 1 2 0
initial transponder 570000000 0 2 9 1 1 3 0
initial transponder 658000000 0 2 9 1 1 2 0
initial transponder 754000000 0 2 9 1 1 2 0
initial transponder 778000000 0 2 9 1 1 2 0
initial transponder 618000000 0 1 9 1 1 2 0
>>> tune to: 177500000:INVERSION_OFF:BANDWIDTH_7_MHZ:FEC_3_4:FEC_AUTO:QAM_16:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_8:HIERARCHY_NONE
WARNING: filter timeout pid 0x0011
WARNING: filter timeout pid 0x0000
WARNING: filter timeout pid 0x0010
WARNING: filter timeout pid 0x0010
>>> tune to: 191500000:INVERSION_OFF:BANDWIDTH_7_MHZ:FEC_2_3:FEC_AUTO:QAM_16:TRANSMISSION_MODE_8K:GUARD_INTERVAL_1_8:HIERARCHY_NONE
WARNING: filter timeout pid 0x0011
WARNING: filter timeout pid 0x0000

/opt/bin/mediacenter -D DVBT habe ich natürlich vorher ausgeführt.

Die Transponderliste, die scan benötigt, ist soweit aber auch korrekt, da sie selbe liste mit einem anderen DVB-T Empfänger funktioniert.

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8525
    • Profil anzeigen
Re:DVB-T Scan unter Linux findet keine Sender
« Antwort #1 am: Oktober 18, 2010, 03:04:38 Nachmittag »
Was zeigt denn /var/log/mediasrv.log an?

Um was fuer ein Notebook handelt es sich denn?

Signallevel auslesen:

/opt/bin/mediaclient --readsignal=0 -d /dev/dvb/adapterN/frontend0 (N=0,1,..)

zuerst jedoch bitte die obrigen Fragen beantworten.

Eventuell den aktuellen Beta Treiber installieren und das Geraet auf Bulk umschalten
/opt/bin/mediaclient --dtvtransfermode=bulk
« Letzte Änderung: Oktober 18, 2010, 03:22:54 Nachmittag von Sundtek »
Failure is a good thing! I'll fix it

Mac_Ot

  • Newbie
  • *
  • Beiträge: 2
    • Profil anzeigen
Re:DVB-T Scan unter Linux findet keine Sender
« Antwort #2 am: Oktober 18, 2010, 05:30:53 Nachmittag »
Also die Ausgabe ist folgende:

head -n 40 /var/log/mediasrv.log
2010-10-18 15:08:20 [1942] restarting logging
2010-10-18 15:08:20 [1942] Setting Frequency: 177500000
2010-10-18 15:08:20 [1942] Channel found (177500000)
2010-10-18 15:08:20 [1942] =============
2010-10-18 15:08:20 [1942] Bandwidth: 7 MHz
2010-10-18 15:08:20 [1942] FFT mode: 8k
2010-10-18 15:08:20 [1942] Guard Interval: 1/8th
2010-10-18 15:08:20 [1942] Constellation: QAM16
2010-10-18 15:08:20 [1942] Code rate: 3/4th
2010-10-18 15:08:20 [1942] Hierarchy: None
2010-10-18 15:08:20 [1942] Priority: High
2010-10-18 15:08:20 [1942] Mirroring: Normal
2010-10-18 15:08:20 [1942] TS Sync byte not aligned, realigning stream (0)
2010-10-18 15:08:20 [1942] TS Sync byte not aligned, realigning stream (0)
2010-10-18 15:08:20 [1942] TS Sync byte not aligned, realigning stream (0)
2010-10-18 15:08:20 [1942] TS Sync byte not aligned, realigning stream (0)
2010-10-18 15:08:20 [1942] TS Sync byte not aligned, realigning stream (0)
2010-10-18 15:08:20 [1942] skipped everything ...
2010-10-18 15:08:20 [1942] TS Sync byte not aligned, realigning stream (0)
2010-10-18 15:08:20 [1942] TS Sync byte not aligned, realigning stream (0)
2010-10-18 15:08:20 [1942] skipped everything ...
2010-10-18 15:08:20 [1942] TS Sync byte not aligned, realigning stream (0)
2010-10-18 15:08:20 [1942] skipped everything ...
2010-10-18 15:08:20 [1942] TS Sync byte not aligned, realigning stream (0)
2010-10-18 15:08:20 [1942] skipped everything ...
2010-10-18 15:08:20 [1942] TS Sync byte not aligned, realigning stream (0)
2010-10-18 15:08:20 [1942] skipped everything ...
2010-10-18 15:08:20 [1942] TS Sync byte not aligned, realigning stream (0)
2010-10-18 15:08:20 [1942] TS Sync byte not aligned, realigning stream (0)
2010-10-18 15:08:20 [1942] skipped everything ...
2010-10-18 15:08:20 [1942] TS Sync byte not aligned, realigning stream (0)
2010-10-18 15:08:20 [1942] skipped everything ...
2010-10-18 15:08:20 [1942] TS Sync byte not aligned, realigning stream (0)
2010-10-18 15:08:20 [1942] skipped everything ...
2010-10-18 15:08:20 [1942] TS Sync byte not aligned, realigning stream (0)
2010-10-18 15:08:20 [1942] skipped everything ...
2010-10-18 15:08:20 [1942] TS Sync byte not aligned, realigning stream (0)
2010-10-18 15:08:20 [1942] TS Sync byte not aligned, realigning stream (0)
2010-10-18 15:08:20 [1942] skipped everything ...
2010-10-18 15:08:20 [1942] TS Sync byte not aligned, realigning stream (0)
Das TS Sync und das skipped everything wiederholt sich noch sehr sehr oft ;)


Es handelt sich nicht um ein Notebook sondern um einen http://vip-de.aopen.com/Products_detail.aspx?ModelAuno=3026 (Aopen DE7000)


Der Signallevel liegt zwischen 49% und 53%


scanning /usr/share/dvb/dvb-t/de-Berlin
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
initial transponder 177500000 1 3 9 1 1 2 0
initial transponder 191500000 1 2 9 1 1 2 0
initial transponder 506000000 0 2 9 1 1 2 0
initial transponder 522000000 0 2 9 1 1 2 0
initial transponder 570000000 0 2 9 1 1 3 0
initial transponder 658000000 0 2 9 1 1 2 0
initial transponder 754000000 0 2 9 1 1 2 0
initial transponder 778000000 0 2 9 1 1 2 0
initial transponder 618000000 0 1 9 1 1 2 0
WARNING: frontend type (QAM) is not compatible with requested tuning type (OFDM)
WARNING: frontend type (QAM) is not compatible with requested tuning type (OFDM)
WARNING: frontend type (QAM) is not compatible with requested tuning type (OFDM)
WARNING: frontend type (QAM) is not compatible with requested tuning type (OFDM)
WARNING: frontend type (QAM) is not compatible with requested tuning type (OFDM)
WARNING: frontend type (QAM) is not compatible with requested tuning type (OFDM)
WARNING: frontend type (QAM) is not compatible with requested tuning type (OFDM)
WARNING: frontend type (QAM) is not compatible with requested tuning type (OFDM)
WARNING: frontend type (QAM) is not compatible with requested tuning type (OFDM)
ERROR: initial tuning failed
dumping lists (0 services)

Der Betatreiber mit dem Bulk scheint aber zu funktionieren. Das Scannen hat problemlos funktioniert, nur mit dem Aufschalten auf die Sender hängt noch etwas. Da bin ich mir aber noch nicht sicher, ob es nicht eher an der Abspielsoftware liegt.

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8525
    • Profil anzeigen
Re:DVB-T Scan unter Linux findet keine Sender
« Antwort #3 am: Oktober 18, 2010, 06:26:02 Nachmittag »
Zitat
WARNING: frontend type (QAM) is not compatible with requested tuning type (OFDM)

heisst das DVB-T gescannt wurde aber das Gerät noch im DVB-C Modus ist (/opt/bin/mediaclient -D DVBC zum Umschalten nicht vergessen).

Das Isochronous Probleme bereitet deutet auf Bugs im USB Controller Treiber hin (insbesonders wenn Windows funktioniert). Mit Bulk kann man die soweit übergehen (diese sind aber auch hardwarespezifisch, auf mehr als 95% aller Rechner funktioniert ISO problemlos, die anderen müssen auf Bulk umschalten - damit hatten wir bis jetzt 100% abgedeckt) - das Problem bleibt jedoch z.B.: für Analog TV bestehen.
Meist verwenden wir bei Embedded Systemen mit unausgereiften USB Controller Treibern den Bulk Mode des Geräts, der Stick ist diesbezüglich ja flexibel. Im Allgemeinen empfehlen wir jedoch ISO (so wie das Gerät geliefert wird da es weniger Resourcen benötigt).

Eventuell versuchen Sie hierbei einmal eine neuere Linux Version.
« Letzte Änderung: Oktober 18, 2010, 08:14:47 Nachmittag von Sundtek »
Failure is a good thing! I'll fix it