Autor Thema: Bilder alle sehr schlecht (alle Modi)  (Gelesen 5703 mal)

D.Cent

  • Newbie
  • *
  • Beiträge: 29
    • Profil anzeigen
Bilder alle sehr schlecht (alle Modi)
« am: Juni 27, 2010, 07:31:40 Nachmittag »
Ich habe meinen Stick schon länger nicht mehr benutzt. Heute wollte ich ihn bei der WM benutzen, jedoch ging das Bild nicht wirklich.

Egal ob DBV-C, DVB-T oder analog-TV - alle Bilder sehen so oder so ähnlich wie das im Anhang aus (meistens sind viele grüne Punkte im Bild). Jedoch funktionierte früher alles einwandfrei.

Ich benutze das gleiche System wie damals - OpenSuSE Linux 11.2 x86, KDE 4.4.2, Kaffeine 1.0 (oder auch Kaffeine für KDE 3) bzw. tvtime 1.0.2. Treiber ist der neueste vom 6. Mai 2010.

Folgendes Bild stammt vom alten Kaffeine für KDE 3 im DVB-C-Modus: http://intelcentino.in.funpic.de/upload/fernsehen_dvbc.png

Liegt das an irgendwelchen Codecs, den KDE 4 Desktopeffekten oder ist gar das Gerät hinüber?

Hier ein Auszug vom mediasrvlog:

2010-06-27 19:37:29 [635] TS Sync byte not aligned, realigning stream (1)
2010-06-27 19:37:29 [635] TS Sync byte not aligned, realigning stream (1)
2010-06-27 19:37:29 [635] skipped everything ...
2010-06-27 19:37:29 [635] TS Sync byte not aligned, realigning stream (1)
2010-06-27 19:37:29 [635] TS Sync byte not aligned, realigning stream (1)
« Letzte Änderung: Juni 27, 2010, 07:38:41 Nachmittag von D.Cent »

D.Cent

  • Newbie
  • *
  • Beiträge: 29
    • Profil anzeigen
Re:Bilder alle sehr schlecht (alle Modi)
« Antwort #1 am: Juni 27, 2010, 07:34:27 Nachmittag »
Tut mir leid, der Link geht nicht - hier ein anderer: http://img823.imageshack.us/img823/7926/fernsehendvbc.png

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8330
    • Profil anzeigen
Re:Bilder alle sehr schlecht (alle Modi)
« Antwort #2 am: Juni 27, 2010, 08:17:25 Nachmittag »
Was fuer ein Linux Kern wird denn verwendet (welche Version)?

2.6.32.9 - 2.6.33 wurden von Suse leider kaputtgepatched, der Fehler wurde ab 2.6.33.1 rueckgaengig gemacht.

Alternativ kann man das Geraet auch auf einen anderen Transfermodus schalten welcher diesen Bug nicht hat, jedoch etwas mehr Performance benoetigt:

Zitat
/opt/bin/mediaclient --dtvtransfermode=bulk

Anschliessend den USB Stick neu anschliessen. Hierfuer sollte dann aber am besten ein 'Entwicklungstreiber' verwendet werden.

http://www.sundtek.de/media/sundtek_installer_development.sh

Um den Stick wieder auf den normalen Transfermodus zurueckzuschalten:
Zitat
/opt/bin/mediaclient --dtvtransfermode=iso

Nach dem Ausfuehren der Befehle muss der Stick neu angeschlossen werden.
Failure is a good thing! I'll fix it

D.Cent

  • Newbie
  • *
  • Beiträge: 29
    • Profil anzeigen
Re:Bilder alle sehr schlecht (alle Modi)
« Antwort #3 am: Juni 27, 2010, 08:30:17 Nachmittag »
Vielen Dank für die schnelle Hilfe!

Der Kernel ist 2.6.31.12-0.2-desktop - der bulk-Modus hat aber trotzdem geholfen! :)

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8330
    • Profil anzeigen
Re:Bilder alle sehr schlecht (alle Modi)
« Antwort #4 am: Juni 27, 2010, 08:32:16 Nachmittag »
Dann hat Suse ihre Linux Versionen Kaputt-"Optimiert" ...

Sobald Sie auf eine neue Version wechseln schalten Sie bitte wieder auf Iso um, es ist um einiges performanter.

Es handelt sich um diesen Systemfehler:
http://lkml.org/lkml/2010/3/6/100
« Letzte Änderung: Juni 27, 2010, 08:34:15 Nachmittag von Sundtek »
Failure is a good thing! I'll fix it

athemis

  • Newbie
  • *
  • Beiträge: 8
    • Profil anzeigen
Re:Bilder alle sehr schlecht (alle Modi)
« Antwort #5 am: Juli 05, 2010, 09:51:14 Vormittag »
Habe eine ähnliche Ausgabe in mediasrv.log unter ArchLinux (Kernel 2.6.34). Da der Arch-Kernel eigentlich im Vergleich zum Vanilla-Kernel nur minimal gepatched wird, würde ich fast auf ein generelles Problem in den neueren Kernelversionen tippen. Bin allerdings noch nicht dazu gekommen, den Transfermodus umzustellen. Werde das heute Abend testen und sehen ob sich eine Besserung ergibt.

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8330
    • Profil anzeigen
Re:Bilder alle sehr schlecht (alle Modi)
« Antwort #6 am: Juli 05, 2010, 10:10:37 Vormittag »
Die neueren Kernelversionen sollten soweit alle gefixed sein, wir werden aber heute einige Stichproben machen.

Edit:
ein normaler 2.6.34 Kernel von ftp.kernel.org funktioniert einwandfrei.
« Letzte Änderung: Juli 05, 2010, 12:22:03 Nachmittag von Sundtek »
Failure is a good thing! I'll fix it

athemis

  • Newbie
  • *
  • Beiträge: 8
    • Profil anzeigen
Re:Bilder alle sehr schlecht (alle Modi)
« Antwort #7 am: Juli 07, 2010, 11:57:12 Nachmittag »
Nach meinen Beobachtungen von heute Abend hängt das vor allem von der Empfangssituation ab. Bei gutem Empfang habe ich keine Probleme mit besagten Fehlermeldungen. Bei schlechtem Empfang (z.B. in der Nähe von hohen Gebäuden) tritt das Problem dann wieder auf, lässt sich aber durch Ändern des Transfermodus beheben.

Ist der isochrone Transfermodus vielleicht schlicht anfälliger bei einem fehlerhaften Stream?

Für den Fall, dass es von Interesse ist, der Link zum ArchLinux-Patchset für Kernel 2.6.34.1:
ftp://ftp.archlinux.org/other/kernel26/patch-2.6.34.1-1-ARCH.bz2
« Letzte Änderung: Juli 08, 2010, 12:05:15 Vormittag von athemis »

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8330
    • Profil anzeigen
Re:Bilder alle sehr schlecht (alle Modi)
« Antwort #8 am: Juli 08, 2010, 12:11:32 Vormittag »
Der Stream hat idR eine gewisse Bandbreite, der Datenstrom wird mit Null Packets aufgefuellt. Bulk filtert diese bereits in der Hardware - Iso nicht (da es im Treiber so konfiguriert wurde und der Treiber diese selber filtert). Es waere moeglich dies auch fuer ISO dementsprechend anzupassen.
Uns ist aufgefallen das Mplayer diese NULL Pakete falsch verarbeitet und es zu Problemen in der Darstellung kommt.

Bei Isochronous gab es haeufiger Bugs in einigen Linux Kernelversionen.

Der Hauptunterschied zwischen Bulk und ISO ist jener das der Treiber bei BULK nur Daten erhaelt sofern sie verfuegbar sind. Bei ISO erhaelt der Treiber immer einige Pakete - jedoch in einem kontinuierlichem Interval.
Failure is a good thing! I'll fix it

athemis

  • Newbie
  • *
  • Beiträge: 8
    • Profil anzeigen
Re:Bilder alle sehr schlecht (alle Modi)
« Antwort #9 am: Juli 08, 2010, 05:00:16 Nachmittag »
Vielen Dank für die umfangreiche Antwort!
Das würde einiges erklären, denn ich setze den mplayer zum Abspielen der Streams ein.