Autor Thema: Probleme mit neuestem Treiber und VDR. Alter Treiber geht aber kein EPG  (Gelesen 3768 mal)

simonstar66

  • Newbie
  • *
  • Beiträge: 3
    • Profil anzeigen
Hallo Zusammen

Ich hatte den neuesten Treiber installiert. Damit aber grosse Probleme. Flush und Swap Prozesse liefen und nach einigen Minuten stürzte VDR ab. Danach wurde bis zu einem Neustart kein DVB Adapter mehr registriert.

Dann wieder auf den alten Treiber gewechselt. Damit läuft es stabil.
Ich kriege  jedoch keine EPG Daten rein.
Habe mit w_scan gescannt. Fast alle Kanäle werden erkannt und laufen. Aber auf den meisten keine EPG Daten.
Bei einem früheren Scan mit scan von den DVB Tools gingen die meisten der erkannten Sender nicht, es hatten jedoch alle EPG.

viele Grüsse

Mein System:
VDR 1.7.10 (Aus dem "the vdr team" Repo) auf Ubuntu Karmic 9.10 mit speziell für VIA kompiliertem 2.6.32.8 Kernel. VIA Epia 1GHZ Barebone mit 512MB. DVB-C Kabelanschluss Schweiz. VDR Client: XBMC auf Apple TV und MacBook Pro.

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8357
    • Profil anzeigen
Re:Probleme mit neuestem Treiber und VDR. Alter Treiber geht aber kein EPG
« Antwort #1 am: März 08, 2010, 09:41:21 Vormittag »
EPG hatte eigentlich lediglich bis zum Treiber vom 23. Januar 2010 mit VDR > 1.7.9 Probleme bereitet. Wir haben dies jedoch nocheinmal ueberprueft und konnten hierbei mit dem aktuellen Treiber vom 7. Maerz 2010 ebenfalls keine Probleme finden (die vorige Treiberversion sollte hierfuer ebenfalls keinen Unterschied bereiten)
Eventuell können Sie im VDR Menü versuchen EPG neu zu scannen?
« Letzte Änderung: März 08, 2010, 01:29:02 Nachmittag von Sundtek »
Failure is a good thing! I'll fix it

simonstar66

  • Newbie
  • *
  • Beiträge: 3
    • Profil anzeigen
Re:Probleme mit neuestem Treiber und VDR. Alter Treiber geht aber kein EPG
« Antwort #2 am: März 18, 2010, 01:11:43 Nachmittag »
Danke für die Antwort

Habe mittlerweile auf den neuesten Treiber gewechselt. Dieser läuft bislang stabil.
Aber das Problem, dass einige Sender kein EPG haben, besteht immer noch. Ein Scan aus dem VDR Menu half nichts.
Ausserdem habe ich das gleiche Problem wie in einem anderen Thread beschrieben, dass nicht alle Sender erkannt werden. w_scan und scan liefern beide bei einigen Sendern timeout Meldungen und die Sender erscheinen nicht in channels.conf. Auf der Settop Box des Kabelanbieters, die ich parallel betreibe, laufen alle Sender, daher liegt es wahrscheinlich nicht an der Signalstärke.
Kann das Problem damit zu tun haben, dass die PIDs nicht korrekt erkannt werden. w_scan und scan liefern mir zum teil unterschiedliche Ergebnisse und bei einigen Sendern erschien das EPG nachdem ich manuell die PIDs in der channels.conf geändert habe. Das fehlende EPG ist immer pro Transponder. Entweder haben alle Sender auf dem Transponder EPG oder keiner.

Ich bin kein Linux-Profi. Soll ich Log Files oder die channels.conf posten, damit Sie mir helfen können, das Problem einzugrenzen?

Grüsse

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8357
    • Profil anzeigen
Re:Probleme mit neuestem Treiber und VDR. Alter Treiber geht aber kein EPG
« Antwort #3 am: März 18, 2010, 01:20:15 Nachmittag »
Die EPG Informationen werden aus der PMT Tabelle im MPEG Strom ausgelesen, in der selben Tabelle stehen die Zuordnungen zwischen Audio und Video PIDs.
Koennen Sie eventuell /var/log/mediasrv.log im Forum hochladen?

CRC Errors in dieser Logfile zeigen Probleme mit der Signalstaerke auf.
Realigning Stream bedeutet USB Probleme.

eventuell ueberpruefen Sie die Logfile direkt nach einem Scan mit w_scan.

Es sind derzeit soweit keine Probleme mit dem PID Filter oder dem MPEG Transfer bekannt.
Eventuell koennten Sie dies auch mit Kaffeine ueberpruefen?

Das naechste Treiberupdate wird unter anderem die Signalqualitaet durch die Signalstaerke ersetzen, eventuell koennen Sie versuchen den Stick direkt an die Kabelbuchse anzuschliessen?
« Letzte Änderung: März 18, 2010, 01:22:28 Nachmittag von Sundtek »
Failure is a good thing! I'll fix it