Autor Thema: Treiber (sundtek_netinst.sh) funktioniert plötzlich nicht mehr  (Gelesen 254 mal)

tobias

  • Newbie
  • *
  • Beiträge: 6
    • Profil anzeigen
Treiber (sundtek_netinst.sh) funktioniert plötzlich nicht mehr
« am: August 05, 2021, 12:33:00 Nachmittag »
Hallo,

seit heute scheint der Sundtek Service (sundtek.service) auf meinem Raspberry Pi nicht mehr zu funktionieren. Gestern lief alles noch problemlos, ich habe keine Updates etc. gemacht...
Heute habe ich dann sowohl den Raspberry Pi selbst als auch die Treiber aktualisiert, allerdings ohne Erfolg.

wget http://www.sundtek.de/media/sundtek_netinst.sh
sudo chmod 777 sundtek_netinst.sh
sudo ./sundtek_netinst.sh
sudo apt update && sudo apt upgrade -y
sudo reboot

Hier ein paar Infos, wenn mehr gebraucht wird, einfach sagen:

pi@raspi-tv:~ $ /opt/bin/mediaclient -e
**** List of Media Hardware Devices ****
device 0: [SkyTV Ultimate 6 2016/Q1]  DVB-S/S2, ANALOG-TV, REMOTE-CONTROL, OSS-AUDIO
  [INFO]:
     STATUS: STANDBY
  [BUS]:
     ID: 1-1.5.1
  [SERIAL]:
     ID: U170329134514
  [DVB-S/S2]:
     FESTATUS: STANDBY
     LNBVOLTAGE: DISABLED
     LNBSUPPLY: ACADAPTER
     LNBSTATUS: OK
     FRONTEND: /dev/dvb/adapter0/frontend0
     DVR: /dev/dvb/adapter0/dvr0
     DMX: /dev/dvb/adapter0/demux0
  [ANALOG-TV]:
     VIDEO0: /dev/video13
     VBI0: /dev/vbi0
  [REMOTECONTROL]:
     INPUT0: /dev/mediainput0
  [OSS]:
     OSS0: /dev/dsp0

device 1: [SkyTV Ultimate 6 2016/Q1]  DVB-S/S2, ANALOG-TV, REMOTE-CONTROL, OSS-AUDIO
  [INFO]:
     STATUS: STANDBY
  [BUS]:
     ID: 1-1.5.2
  [SERIAL]:
     ID: U170327210946
  [DVB-S/S2]:
     FESTATUS: STANDBY
     LNBVOLTAGE: DISABLED
     LNBSUPPLY: ACADAPTER
     LNBSTATUS: OK
     FRONTEND: /dev/dvb/adapter1/frontend0
     DVR: /dev/dvb/adapter1/dvr0
     DMX: /dev/dvb/adapter1/demux0
  [ANALOG-TV]:
     VIDEO0: /dev/video14
     VBI0: /dev/vbi1
  [REMOTECONTROL]:
     INPUT0: /dev/mediainput1
  [OSS]:
     OSS0: /dev/dsp1


pi@raspi-tv:~ $ sudo systemctl status sundtek.service
● sundtek.service - Sundtek MediaTV
   Loaded: loaded (/lib/systemd/system/sundtek.service; enabled; vendor preset: enabled)
   Active: active (exited) since Thu 2021-08-05 11:29:17 CEST; 29min ago
  Process: 346 ExecStart=/opt/bin/mediaclient --start=4 (code=exited, status=0/SUCCESS)
 Main PID: 346 (code=exited, status=0/SUCCESS)
    Tasks: 11 (limit: 4915)
   CGroup: /system.slice/sundtek.service
           ├─562 /opt/bin/mediasrv -d --pluginpath=/opt/bin
           └─563 /opt/bin/mediasrv -d --pluginpath=/opt/bin

Aug 05 11:29:17 raspi-tv systemd[1]: Starting Sundtek MediaTV...
Aug 05 11:29:17 raspi-tv systemd[1]: Started Sundtek MediaTV.

Weder die Website (bei mir http://raspi-tv:22000) noch ein Zugriff per VLC funktioniert.

Ich bitte um Hilfe.

Vielen Dank!

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8252
    • Profil anzeigen
Re: Treiber (sundtek_netinst.sh) funktioniert plötzlich nicht mehr
« Antwort #1 am: August 05, 2021, 05:42:54 Nachmittag »
Ist der Streamingserver installiert?

/opt/bin/mediaclient --installstreamer
Failure is a good thing! I'll fix it

tobias

  • Newbie
  • *
  • Beiträge: 6
    • Profil anzeigen
Re: Treiber (sundtek_netinst.sh) funktioniert plötzlich nicht mehr
« Antwort #2 am: August 05, 2021, 09:47:08 Nachmittag »
Ich habe den Befehl jetzt nochmal ausgeführt:
pi@raspi-tv:~ $ sudo /opt/bin/mediaclient --installstreamer
Trying to connect to sundtek webserver
Downloading http://sundtek.de/media/streamer/armsysvhf/rtspd
Starting streamingserver...

Download successful...
Now please go to http://localhost:22000/

Der Streaming-Server scheint aber nicht zu laufen:
pi@raspi-tv:~ $ sudo netstat -tulpn | grep LISTEN
tcp        0      0 0.0.0.0:5900            0.0.0.0:*        LISTEN      446/vncserver-x11-c
tcp        0      0 0.0.0.0:80              0.0.0.0:*        LISTEN      559/nginx: master p
tcp        0      0 0.0.0.0:22              0.0.0.0:*        LISTEN      488/sshd
tcp6       0      0 :::5900                 :::*        LISTEN      446/vncserver-x11-c
tcp6       0      0 :::80                   :::*        LISTEN      559/nginx: master p
tcp6       0      0 :::22                   :::*        LISTEN      488/sshd

Auch mit dem Browser oder VLC bekommt man so erwartungsgemäß keine Verbindung...

Edit:

Hier noch ein paar Infos (vielleicht hilft es):
pi@raspi-tv:~ $ sudo systemctl restart sundtek.service
pi@raspi-tv:~ $ cat /var/log/syslog
[...]
Aug  6 13:02:12 raspi-tv systemd[1]: Stopping Sundtek MediaTV...
Aug  6 13:02:12 raspi-tv systemd-udevd[3003]: Process '/opt/bin/lirc.sh REMOVE' failed with exit code 1.
Aug  6 13:02:12 raspi-tv systemd-udevd[3007]: Process '/opt/bin/lirc.sh REMOVE' failed with exit code 1.
Aug  6 13:02:12 raspi-tv mediaclient[3002]: Shutting down Multimedia Stack
Aug  6 13:02:12 raspi-tv systemd[1]: Stopped Sundtek MediaTV.
Aug  6 13:02:13 raspi-tv systemd[1]: Starting Sundtek MediaTV...
Aug  6 13:02:13 raspi-tv systemd[1]: Started Sundtek MediaTV.
Aug  6 13:02:18 raspi-tv kernel: [20713.141528] input: Sundtek Remote Control as /devices/virtual/input/input8
Aug  6 13:02:18 raspi-tv systemd-udevd[3032]: Process '/usr/sbin/th-cmd --socket /var/run/thd.socket --passfd --udev' failed with exit code 1.
« Letzte Änderung: August 06, 2021, 01:04:44 Nachmittag von tobias »

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8252
    • Profil anzeigen
Re: Treiber (sundtek_netinst.sh) funktioniert plötzlich nicht mehr
« Antwort #3 am: August 07, 2021, 09:58:30 Vormittag »
Hi,

schau mal in den Chat, und bereite eventuell ne Anydesk ID vor damit wir das remote überprüfen können.
Failure is a good thing! I'll fix it