Autor Thema: X Problem  (Gelesen 4894 mal)

aassaa

  • Newbie
  • *
  • Beiträge: 22
    • Profil anzeigen
X Problem
« am: Februar 07, 2010, 12:04:47 Nachmittag »
Hallo,

folgenden Treiber habe ich installiert:

empia_installer_100125.sh

System: Debian lenny, X11 Gnome.

Das Problem ist das nach ca. 20-60min mein X crasht. Gibt es dazu irgendwie einen Patch oder sonstiges?

Als Anwedung habe ich me-tv bzw. kaffeine verwendet, ist aber von der Anwendung her vollig egal, X crash bei beiden. Ich denke es liegt an dem "mediasrv".

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8321
    • Profil anzeigen
Re:X Problem
« Antwort #1 am: Februar 07, 2010, 12:28:13 Nachmittag »
Um was fuer eine Hardware (insbesondere Graphikkarte) handelt es sich?

Koennten Sie folgende Dateien im Forum als Attachment hochladen?

/var/log/Xorg.0.log

Ein Crash des X-Window Systems Aufgrund des Treibers ist uns nicht bekannt.
Es ist uns jedoch bekannt das z.B.: durch defekte ATI Treiber oder durch Applikationen welche den Graphiktreiber - insbesondere die 2D Hardwarebeschleunigung - fehlerhaft ansprechen der X-Server abstuerzen kann.
Abhilfe kann hierbei meist durch Verwendung von Softwarerendering geschaffen werden.
Failure is a good thing! I'll fix it

aassaa

  • Newbie
  • *
  • Beiträge: 22
    • Profil anzeigen
Re:X Problem
« Antwort #2 am: Februar 07, 2010, 12:36:35 Nachmittag »
Grafikkarte: Geforce 7900GT, der nvidia Treiber ist installiert, wird geladen und genutzt.
Xorg.o.log sollte anhängen.

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8321
    • Profil anzeigen
Re:X Problem
« Antwort #3 am: Februar 07, 2010, 12:43:48 Nachmittag »
Aus der Logfile ist ersichtlich das Sie Linux 2.6.28 verwenden.


Laut unserer Installationsanleitung:
http://support.sundtek.com/index.php/topic,2.0.html

Zitat
Linux 2.6.27 bis alle Versionen kleiner 2.6.29 haben einen Fehler im USB Stack welcher den Systemspeicher allmählich anwachsen lässt. Weitere Informationen über dieses Problem kann man unter  Linux USB Mailinglist finden.

Dies wird sehr warscheinlich Ihr Problem sein
« Letzte Änderung: Februar 07, 2010, 12:45:55 Nachmittag von Sundtek »
Failure is a good thing! I'll fix it

aassaa

  • Newbie
  • *
  • Beiträge: 22
    • Profil anzeigen
Re:X Problem
« Antwort #4 am: Februar 08, 2010, 03:43:34 Nachmittag »
Ich werde es mit 2.6.30 versuchen.

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8321
    • Profil anzeigen
Re:X Problem
« Antwort #5 am: Februar 08, 2010, 03:46:46 Nachmittag »
Sie koennen das Problem ebenfalls durch folgenden Befehl ueberpruefen:

$ egrep 'kmalloc|size' /proc/slabinfo

Sollte, sobald analog oder digital TV laeuft, ein Wert kontinuierlich ansteigen handelt es sich um einen fehlerhaften 2.6.27 oder 2.6.28er Kernel
« Letzte Änderung: Februar 09, 2010, 04:28:22 Vormittag von Sundtek »
Failure is a good thing! I'll fix it