Autor Thema: MythTV & DVB-C  (Gelesen 8961 mal)

D.Cent

  • Newbie
  • *
  • Beiträge: 29
    • Profil anzeigen
MythTV & DVB-C
« am: Januar 05, 2010, 02:57:29 Vormittag »
Hallo,
ich wollte soeben einen Senderscan mit MythTV unter OpenSuSE Linux 11.2 durchführen. Doch es werden keine Sender gefunden, aufgrund dieser Ausgabe:

DVBChan(1:/dev/dvb/adapter0/frontend0) Error: Tune(): Setting Frontend tuning parameters failed.
                        eno: Erfolg (0)

Ich bin mir nicht ganz sicher, was das bedeuten soll - ich schließe mal auf falsche Einstellungen?
Habe den Treiber ganz sicher auf DVB-C gestellt und das Gerät wurde in MythTV auch erkannt.

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8357
    • Profil anzeigen
Re:MythTV & DVB-C
« Antwort #1 am: Januar 05, 2010, 03:23:09 Vormittag »
Das Problem liegt darin das der neue MythTV scan lediglich mit QAM_AUTO scannt, das Geraet benoetigt jedoch genaue Informationen ob nach einem QAM64, 128 oder 256 Kanal gescannt wird (dieser Fehler ist den Entwicklern derzeit ebenfalls bekannt)
Mit einer aelteren MythTV Version bzw. der alten Scan Methode funktionierte dies noch.

Als Ausweg kann man derzeit lediglich eine vorhandene channels.conf File bei MythTV importieren.
Failure is a good thing! I'll fix it

D.Cent

  • Newbie
  • *
  • Beiträge: 29
    • Profil anzeigen
Re:MythTV & DVB-C
« Antwort #2 am: Januar 05, 2010, 03:59:20 Vormittag »
Nun habe ich mittels w_scan eine channels.conf-Datei erstellt und versucht, diese zu importieren. Leider antwortet MythTV daraufhin mit dieser Fehlermeldung:
Konnte "%1" nicht analysieren
Daraufhin folgt diese Nachricht:

Programmierfehler: Tune fertig nicht behandelt.
Folgendes steht in der Konsole:

2010-01-05 02:50:19.357 DVBSM(/dev/dvb/adapter0/frontend0), Warning: Can not count Uncorrected Blocks
                        eno: Das Argument ist ungültig (22)
2010-01-05 02:50:19.359 ChScan, Error: Failed to handle tune complete.

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8357
    • Profil anzeigen
Re:MythTV & DVB-C
« Antwort #3 am: Januar 05, 2010, 01:32:25 Nachmittag »
Der Uncorrectable Blocks und Bit error ratio Statistik Parameter wird mit dem Treiber noch nicht uebergeben, unsere Entwickler sollten dies bis Freitag ebenfalls implementiert haben. Wir werden hierfuer diese Woche noch ein Update bereitstellen.
Failure is a good thing! I'll fix it

mythuser

  • Newbie
  • *
  • Beiträge: 4
    • Profil anzeigen
Re:MythTV & DVB-C
« Antwort #4 am: Januar 05, 2010, 04:05:00 Nachmittag »
Die aktuellen Versionen von MythTV haben ein Problem mit dem EPG wenn die Sender von einer channels.conf eingelesen werden -> http://svn.mythtv.org/trac/ticket/7701

Leider ist der Import einer channels.conf der beste Weg um eine vernünftige Sendertabelle zu bekommen -> http://svn.mythtv.org/trac/ticket/3640

der-bub

  • Newbie
  • *
  • Beiträge: 9
    • Profil anzeigen
Re:MythTV & DVB-C
« Antwort #5 am: April 12, 2011, 02:41:32 Nachmittag »
Ich habe das gleiche Problem: Keiner der Sendersuchläufe funktioniert und der Versuch, eine per w_scan erstellte channels.conf einzulesen, endet mit der Fehlermeldung "Konnte "%1" nicht analysieren".

Gibt es hier schon eine Lösung?

Hat es irgend jemand geschafft, einen Sundtek-DVB-C-Tuner in MythTV zum Laufen zu bekommen?

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8357
    • Profil anzeigen
Re:MythTV & DVB-C
« Antwort #6 am: April 12, 2011, 03:27:32 Nachmittag »
Ja wir :-) Bei uns läuft alles.

Um welches System handelt es sich denn?
Failure is a good thing! I'll fix it

der-bub

  • Newbie
  • *
  • Beiträge: 9
    • Profil anzeigen
Re:MythTV & DVB-C
« Antwort #7 am: April 12, 2011, 05:48:08 Nachmittag »
Es handelt sich um ein aktuelles Mythbuntu 10.10 (also mit MythTV 0.23).

Hier meine Erfahrungen:
  • Nach langem Ausprobieren habe ich nun eine Lösung gefunden. Die ist allerdings etwas umständlich. Details siehe unten
  • Der Vollautomatische Scan ("Vollständiger Suchlauf" ohne "Tuned") funktioniert nicht - wahrscheinlich wegen des nicht unterstützten QAM_AUTO.
  • Das Einlesen einer per w_scan -f c -c DE >> /tmp/channels.conf erstellte channels.conf geht ebenfalls nicht. Fehler: "Konnte "%1" nicht analysieren"

Hier meine Lösung:
  • Einen Sender aus der channels.conf auswählen und Frequenz und Modulation auslesen.
    Beispiel: ZDF HD;ZDF vision:370000:M256:C:6900:6110:6120=deu,6121=mis,6123=qaa;6122:6130:0:11110:1:1079:0
    hat die Frequenz 370000 und Modulation M256.
  • Unter „Scantyp“ den Eintrag „Vollständiger Suchlauf (Tuned)“ wählen (nicht „Vollständiger Suchlauf“)
  • Unter „Frequenz“ die Frequenz eintragen. Im Beispiel 370000000.
    Achtung: Frequenz und Symbolrate sind in der channels.conf in kHz. Beim Einstellen werden Hz erwartet, daher noch 000 ergänzen.
  • Unter „Modulation“ die Modulation eintragen. Im Beispiel „QAM 256“
« Letzte Änderung: April 17, 2011, 05:06:09 Nachmittag von der-bub »