Autor Thema: ARM EABI4 mit empia_installer_091221.sh geht nicht [geloest]  (Gelesen 6246 mal)

joergd

  • Newbie
  • *
  • Beiträge: 26
    • Profil anzeigen
ARM EABI4 mit empia_installer_091221.sh geht nicht [geloest]
« am: Dezember 22, 2009, 07:03:13 Nachmittag »
Hallo,

ich versuche gerade, das sehnlichst erwartete Update auf meinem OpenRD Client einzuspielen - leider bisher ohne Erfolg. Nach dem Aufruf von empia_installer_091221.sh passiert erstmal folg.:
unpacking...                        
checking system... ./install.sh: Zeile 185: /tmp/.sundtek/chkarmoabi: Keine Berechtigung
Your system is currently unsupported                                                    
Please contact <support@sundtek.de>                                                    

Wenn ich das richtig verstehe, sollte chkarmoabi eigentlich gar nicht mehr aufgerufen werden, da vorher mit chkarmsysv ein ARM EABI4 System erkannt werden sollte...

Also habe ich den Installer so abgeändert, daß die armsysv-Installation trotzdem gestartet wird. Leider funktioniert danach trotzdem nichts:

OpenRD ~ # ps ax | grep mediasrv
OpenRD ~ #
OpenRD ~ # /etc/init.d/mediasrv start
Starting Sundtek Multimedia Framework mediasrv ..... ok
OpenRD ~ # ps ax | grep mediasrv
OpenRD ~ #
OpenRD ~ # mediaclient -e
OpenRD ~ #

Was kann ich tun? Wird mein System wirklich nicht supportet? Mit der alten ARM-Version hats funktioniert (bis auf die bekannten Probleme).

Jörg
« Letzte Änderung: Dezember 28, 2009, 12:06:50 Nachmittag von Sundtek »
Hardware Server: 2x MediaTV Pro an OpenRD Client, TC Kabelanschluß
Software Server: Gentoo/ARM (EABI), VDR 1.6.0
Hardware Client: Commell LV-668 (AMD Geode NX), Reel eHD
Software Client: ReelVDR

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8317
    • Profil anzeigen
Re:ARM EABI4 mit empia_installer_091221.sh geht nicht
« Antwort #1 am: Dezember 22, 2009, 07:08:43 Nachmittag »
Eventuell koennen Sie kurz den Support kontaktieren (sundtek) Skype
« Letzte Änderung: Dezember 22, 2009, 07:48:11 Nachmittag von Sundtek »
Failure is a good thing! I'll fix it

joergd

  • Newbie
  • *
  • Beiträge: 26
    • Profil anzeigen
Re:ARM EABI4 mit empia_installer_091221.sh geht nicht
« Antwort #2 am: Dezember 22, 2009, 07:09:28 Nachmittag »
Nachtrag:

OpenRD ~ # mediasrv -l /var/log/mediasrv.log -p /opt/bin -v
Starting up Multimedia Framework (Dec 15 2009 10:56:08)
Detected DVB version.h
API Version: 5.0
scanning devices
scanning for plugins
found lib: libdrv_em28xx.so

[1]+  Angehalten              mediasrv -l /var/log/mediasrv.log -p /opt/bin -v
OpenRD ~ #
« Letzte Änderung: Dezember 22, 2009, 07:48:16 Nachmittag von Sundtek »
Hardware Server: 2x MediaTV Pro an OpenRD Client, TC Kabelanschluß
Software Server: Gentoo/ARM (EABI), VDR 1.6.0
Hardware Client: Commell LV-668 (AMD Geode NX), Reel eHD
Software Client: ReelVDR

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8317
    • Profil anzeigen
Re:ARM EABI4 mit empia_installer_091221.sh geht nicht
« Antwort #3 am: Dezember 22, 2009, 07:18:23 Nachmittag »
Wie schon erwaehnt, bitte kontaktieren Sie den Support via Skype.
« Letzte Änderung: Dezember 22, 2009, 07:48:23 Nachmittag von Sundtek »
Failure is a good thing! I'll fix it

joergd

  • Newbie
  • *
  • Beiträge: 26
    • Profil anzeigen
Re:ARM EABI4 mit empia_installer_091221.sh geht nicht
« Antwort #4 am: Dezember 22, 2009, 07:25:33 Nachmittag »
Hab kein Skype, ich würde aber auch eine normale Festnetz- oder Handynr. anrufen  ;)
« Letzte Änderung: Dezember 22, 2009, 07:48:29 Nachmittag von Sundtek »
Hardware Server: 2x MediaTV Pro an OpenRD Client, TC Kabelanschluß
Software Server: Gentoo/ARM (EABI), VDR 1.6.0
Hardware Client: Commell LV-668 (AMD Geode NX), Reel eHD
Software Client: ReelVDR

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8317
    • Profil anzeigen
Re:ARM EABI4 mit empia_installer_091221.sh geht nicht
« Antwort #5 am: Dezember 22, 2009, 07:30:45 Nachmittag »
Einer unserer Techniker installiert bereits einen Webchat.
« Letzte Änderung: Dezember 22, 2009, 07:48:34 Nachmittag von Sundtek »
Failure is a good thing! I'll fix it

joergd

  • Newbie
  • *
  • Beiträge: 26
    • Profil anzeigen
Re:ARM EABI4 mit empia_installer_091221.sh geht nicht
« Antwort #6 am: Dezember 23, 2009, 08:02:53 Vormittag »
Da nun gestern nichts mehr passiert ist: Ich würde es wirklich sehr begrüßen, wenn Sie sich heute um die Lösung dieses Problems kümmern könnten. Ich besitze den MediaTV Pro jetzt über einen Monat und er hat auf meinem VDR mit Intel-Hardware gar nicht und in der ARM-Umgebung nur eingeschränkt funktioniert. Mit dem neuen Treiber gehts wieder gar nicht. Ich würde meinen VDR über Weihnachten gern zum Aufnehmen benutzen können...
Hardware Server: 2x MediaTV Pro an OpenRD Client, TC Kabelanschluß
Software Server: Gentoo/ARM (EABI), VDR 1.6.0
Hardware Client: Commell LV-668 (AMD Geode NX), Reel eHD
Software Client: ReelVDR

joergd

  • Newbie
  • *
  • Beiträge: 26
    • Profil anzeigen
Re:ARM EABI4 mit empia_installer_091221.sh geht nicht
« Antwort #7 am: Dezember 23, 2009, 09:53:33 Vormittag »
Mit dem inzwischen aktualisierten empia_installer_091221.sh sieht es nun wesentlich besser aus:

OpenRD / # mediaclient -e
**** List of Media Hardware Devices ****
device 0: [ Sundtek MediaTV Pro]  DVB-C, DVB-T, ANALOG-TV, FM-RADIO, REMOTE-CONTROL, OSS-AUDIO, RDS
  [DVB-C]:
     FRONTEND: /dev/dvb/adapter0/frontend0
     DVR: /dev/dvb/adapter0/dvr0
     DMX: /dev/dvb/adapter0/demux0
  [DVB-T]:
     FRONTEND: /dev/dvb/adapter0/frontend0
     DVR: /dev/dvb/adapter0/dvr0
     DMX: /dev/dvb/adapter0/demux0
  [ANALOG-TV]:
     VIDEO0: /dev/video0
     VBI0: /dev/vbi0
  [FM-RADIO]:
     RADIO0: /dev/radio0
     RDS: /dev/rds0
  [REMOTECONTROL]:
     INPUT0: /dev/mediainput0
  [OSS]:
     OSS0: /dev/dsp0

Ob es wirklich mit dem VDR funktioniert, kann ich erst heute abend sagen, da ich derzeit nur einen SSH-Zugang dahin habe und demzufolge kein Bild sehe.

Was noch nicht funktioniert, ist die automatische Installation: Der Installer meint immer noch, mein System wäre nicht supportet. Mit dem Entpacken von Hand gehts aber.
Hardware Server: 2x MediaTV Pro an OpenRD Client, TC Kabelanschluß
Software Server: Gentoo/ARM (EABI), VDR 1.6.0
Hardware Client: Commell LV-668 (AMD Geode NX), Reel eHD
Software Client: ReelVDR

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8317
    • Profil anzeigen
Re:ARM EABI4 mit empia_installer_091221.sh geht nicht
« Antwort #8 am: Dezember 23, 2009, 12:03:43 Nachmittag »
Der Installer wurde nochmal aktualisiert, ARM kann groessere Bibliotheken nicht dynamisch laden, deshalb ist auf ARM der komplette Treiber direkt im Framework (sprich mediasrv) direkt inkludiert. Beim initialen Build wurden jedoch die Settings von x86 uebernommen.
Failure is a good thing! I'll fix it

joergd

  • Newbie
  • *
  • Beiträge: 26
    • Profil anzeigen
Re:ARM EABI4 mit empia_installer_091221.sh geht nicht
« Antwort #9 am: Dezember 28, 2009, 09:35:41 Vormittag »
Vor uns während der Feiertage bin ich nicht mehr zum antworten gekommen: Mit dem neuen Installer funktionierts nun also wirklich, meine 2 MediaTV Pro arbeiten mit dem VDR auf dem OpenRD-Client. Danke!
Hardware Server: 2x MediaTV Pro an OpenRD Client, TC Kabelanschluß
Software Server: Gentoo/ARM (EABI), VDR 1.6.0
Hardware Client: Commell LV-668 (AMD Geode NX), Reel eHD
Software Client: ReelVDR