Autor Thema: Raspberry Fehlersuche  (Gelesen 11204 mal)

morgon

  • Newbie
  • *
  • Beiträge: 13
    • Profil anzeigen
Re:Raspberry Fehlersuche
« Antwort #15 am: Juli 09, 2015, 11:37:36 Nachmittag »
Da der Thread ja nun schon ein paar Monate läuft nochmal eine Zusammenfassung:

Ich habe Bild- und Tonfehler auf einer Frequenz. ALLE Sender auf dieser Frequenz sind davon betroffen.
Es ist KEIN spezifisches Pi Problem, das Problem tritt auf meinem Pi und meinen Laptop gleichermassen auf.

Diese Frequenz hatte monatelang funktioniert, erst als ich aus einem Urlaub zurückkam traten die Probleme auf (alle vdr-aufnahmen unbrauchbar).

Es gibt aus meiner Sicht 3 mögliche Fehler: Stick hat einen Schlag, Kabelsignal ist plötzlich schlecht oder eine externe Fehlerquelle.

Ich würde gerne soweit als möglich die Fehlerquelle eingrenzen, da ich nicht selbst Kunde der Kabelgesellschaft bin (das ist mein Vermieter).

Output von "/opt/bin/mediaclient --readsignal=0 -d /dev/dvb/adapter0/frontend0":

SIGNAL: [..................               ] ( 55%)  BER:      0 FREQ: 442000000  Hz LOCKED: YES SYM: 6900000 MOD: QAM256

morgon

  • Newbie
  • *
  • Beiträge: 13
    • Profil anzeigen
Re:Raspberry Fehlersuche
« Antwort #16 am: Juli 09, 2015, 11:54:27 Nachmittag »
Nur noch als Nachtrag:

Ich habe das Problem mit mehreren Kabeln und auf unterschiedlichen usb-ports repoduziert.

Und den Output von "/opt/bin/mediaclient --readsignal=0" zu posten hatten wir schon.

Im Moment habe ich nicht den Eindruck dass wir hier Fortschritte machen und das heisst vorläufig für mich: Nach einem halben Jahr ist der Strick offenbar defekt, denn BER ist 0 und ich habe trotzdem Fehler.

Ich habe 100 Euro schon mal besser angelegt...

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8330
    • Profil anzeigen
Re:Raspberry Fehlersuche
« Antwort #17 am: Juli 10, 2015, 08:03:35 Vormittag »
Hallo,

das ist die alte Ausgabe, aktualisiere erst mal den Treiber und starte den readsignal Befehl dann erneut.
Der Tuner ist sicherlich nich defekt, 55% Signalstärke scheint soweit aber äußerst niedrig zu sein.
Failure is a good thing! I'll fix it

morgon

  • Newbie
  • *
  • Beiträge: 13
    • Profil anzeigen
Re:Raspberry Fehlersuche
« Antwort #18 am: Juli 10, 2015, 10:45:49 Nachmittag »
Gut, ich habe die Software aktualisiert.

Hier der output von "/opt/bin/mediaclient --readsignal=0 -d /dev/dvb/adapter0/frontend0" von einem fehlerbehafteten Kanal:

SIGNAL: [..................               ] ( 55%)  BER:      0 CNR: 27.50 FREQ: 442000000  Hz LOCKED: YES SYM: 6900000 MOD: QAM256

Und hier von einem Kanal der ok ist:

SIGNAL: [...................              ] ( 57%)  BER:    780 CNR: 30.20 FREQ: 530000000  Hz LOCKED: YES SYM: 6900000 MOD: QAM256

Interessanterweise habe ich also bei einem Kanal der ok ist Bitfehler, während der Kanal ohne Bitfehler starke Bild- und Tonstörungen aufweist.

Der signal-level scheint bei mir zu schwanken, ich hatte in der Vergangenheit aber auch diese Probleme bei einem level von 99% (siehe mein Posting weiter oben).

Ich habe keine Ahnung von Elektronik, und für mich ist dieser Stick eine black-box die aus einem dvb-c Signal mpeg-ts macht. Und das funkioniert nun (nachdem es in der Vergangenheit funktioniert hat) bei einer Frequenz nicht mehr, obwohl es keine Bitfehler gibt. Was anderes als der Stick selber kann das verursachen?

Wäre es denn plausibel dass BER konstant bei 0 liegt falls das ursächliche Problem die Signalqualität wäre?

Es gibt für mich nur zwei Szenarien: Entweder der Stick hat das Durchlaufen über 2 Wochen nicht verkraftet oder in meiner Abwesenheit hat sich irgendetwas auf der Seite meines Kabelanbieters getan was zu einer Verschlechterung des Signals geführt hat.

Da ich leider nichts selbst Kunde bin, sondern einen Techniker über meinen Vermieter anforderen müsste würde ich gerne den Fehler soweit es geht eingrenzen.

Falls eine Eingrenzung des Fehlers nicht möglich ist, dann ist das halt so, aber seit Ende Mai habe ich jetzt bei diesem Problem absolut Null Fortschritt gemacht und so langsam verliere ich den Glauben...

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8330
    • Profil anzeigen
Re:Raspberry Fehlersuche
« Antwort #19 am: Juli 15, 2015, 09:58:04 Vormittag »
Versuch mal das hier:
http://support.sundtek.com/index.php/topic,1768.msg13236.html#msg13236

Die BER von 780 ist noch ziemlich gering.

Es gab auch mal eine defekte TVHeadend Version, versuch mal eine rohe Aufnahme zu machen.

1. den Sender einstellen anschließend mittels Telnet einloggen und in etwa so mitschneiden:

/opt/bin/mediaclient --cat /dev/dvb/adapter0/dvr0 > test.ts

Der Tuner hat kein Problem mit dem Dauereinsatz, diese Tuner sind schon sehr lange im Einsatz.

Referenzwerte vom PC:
Zitat
442000000  Hz LOCKED: YES SYM: 6900000 MOD: QAM256
SIGNAL: [.................................] ( 99%)  BER:      0 CNR: 36.20 FREQ: 442000000  Hz LOCKED: YES SYM: 6900000 MOD: QAM256
SIGNAL: [.................................] ( 99%)  BER:      0 CNR: 36.20 FREQ: 442000000  Hz LOCKED: YES SYM: 6900000 MOD: QAM256
SIGNAL: [.................................] ( 99%)  BER:      0 CNR: 36.50 FREQ: 442000000  Hz LOCKED: YES SYM: 6900000 MOD: QAM256
SIGNAL: [.................................] ( 99%)  BER:      0 CNR: 36.50 FREQ: 442000000  Hz LOCKED: YES SYM: 6900000 MOD: QAM256
SIGNAL: [.................................] ( 99%)  BER:      0 CNR: 36.50 FREQ: 442000000  Hz LOCKED: YES SYM: 6900000 MOD: QAM256

Referenzwerte vom Raspberry PI mit unserem Primacom Anschluss:
Zitat
SIGNAL: [.................................] ( 99%)  BER:      0 CNR: 36.50 FREQ: 442000000  Hz LOCKED: YES SYM: 6900000 MOD: QAM256
SIGNAL: [.................................] ( 99%)  BER:      0 CNR: 36.20 FREQ: 442000000  Hz LOCKED: YES SYM: 6900000 MOD: QAM256
SIGNAL: [.................................] ( 99%)  BER:      0 CNR: 36.20 FREQ: 442000000  Hz LOCKED: YES SYM: 6900000 MOD: QAM256
SIGNAL: [.................................] ( 99%)  BER:      0 CNR: 36.20 FREQ: 442000000  Hz LOCKED: YES SYM: 6900000 MOD: QAM256
SIGNAL: [.................................] ( 99%)  BER:      0 CNR: 36.50 FREQ: 442000000  Hz LOCKED: YES SYM: 6900000 MOD: QAM256

Zitat
SIGNAL: [..............................   ] ( 92%)  BER:      0 CNR: 32.20 FREQ: 121000000  Hz LOCKED: YES SYM: 6900000 MOD: QAM64
SIGNAL: [..............................   ] ( 92%)  BER:      0 CNR: 32.20 FREQ: 121000000  Hz LOCKED: YES SYM: 6900000 MOD: QAM64
SIGNAL: [..............................   ] ( 92%)  BER:      0 CNR: 32.20 FREQ: 121000000  Hz LOCKED: YES SYM: 6900000 MOD: QAM64
SIGNAL: [..............................   ] ( 92%)  BER:      0 CNR: 32.00 FREQ: 121000000  Hz LOCKED: YES SYM: 6900000 MOD: QAM64
SIGNAL: [..............................   ] ( 92%)  BER:      0 CNR: 32.20 FREQ: 121000000  Hz LOCKED: YES SYM: 6900000 MOD: QAM64

Zitat
SIGNAL: [.................................] ( 99%)  BER:      0 CNR: 36.50 FREQ: 458000000  Hz LOCKED: YES SYM: 6900000 MOD: QAM256
SIGNAL: [.................................] ( 99%)  BER:      0 CNR: 36.20 FREQ: 458000000  Hz LOCKED: YES SYM: 6900000 MOD: QAM256
SIGNAL: [.................................] ( 99%)  BER:      0 CNR: 36.20 FREQ: 458000000  Hz LOCKED: YES SYM: 6900000 MOD: QAM256
SIGNAL: [.................................] ( 99%)  BER:      0 CNR: 36.20 FREQ: 458000000  Hz LOCKED: YES SYM: 6900000 MOD: QAM256


Du kannst den Tuner natürlich auch zur Überprüfung einschicken, jedoch denke ich eher das es bei Dir am Signal liegt, eventuell am TV Kabel (was im Fehlerfall ja nichts ungewöhnliches ist da dies dort auch schon mehrere Kunden -- wie erwähnt im Fehlerfall -- hatten)
« Letzte Änderung: Juli 15, 2015, 11:37:18 Vormittag von Sundtek »
Failure is a good thing! I'll fix it