Autor Thema: SkyTV über LAN an tvheadend auf virtuellem Rechner  (Gelesen 2024 mal)

kammann

  • Newbie
  • *
  • Beiträge: 1
    • Profil anzeigen
SkyTV über LAN an tvheadend auf virtuellem Rechner
« am: Februar 04, 2015, 12:20:45 Vormittag »
Hallo,

tvheadend funktioniert bei mir mit einem SkyTV III Stick einwandfrei - solange sich Stick und tvheadend auf demselben Rechner unter Ubuntu 14.04.befinden.

Nun möchte ich tvheadend auf einem Server in einer VM installieren (ebenfalls Ubuntu 14.04, Virtualisierung mit QEMU). Der SkyTV stick soll auf dem ursprünglichen Rechner verbleiben, also über das LAN mit tvheadend verbunden werden. Mediaclient mit --enablenetwork=on auf dem Rechner mit dem Stick, --mount=<IP> auf dem virtuellen Rechner. tvheadend (identische Konfiguration wie vorher auf dem physischen Rechner) erkennt den SkyTV Stick ("Sundtek DVB-S/S2 (III) (192.168.1.240) : DVB-S #0") - scannt aber weder die Transponder noch tuned auf einen Kanal.
tvheadend mit "-s --debug all" gestartet, meldet:
2015-02-03 22:58:16.623 [   INFO] linuxdvb: adapter added /dev/dvb/adapter0
mediaclient --lc:
root@tvheadend:~# /opt/bin/mediaclient --lc
**** List of Media Clients ****
/dev/dvb/adapter0/frontend0:
  No client connected
/dev/dvb/adapter0/dvr0:
  No client connected
/dev/dvb/adapter0/demux0:
  No client connected

Problem: tvheadend zeigt zwar den Stick an, verbindet sich aber nicht mit ihm.

Testweise VDR installiert -läuft
Testweise IPTV (T-Entertain) auf tvheadend konfiguriert - läuft ebenfalls.
Probleme mit dem LAN, bzw der Konfiguration des virtuellen Rechners schließe ich somit aus.
Verschiedene Versionen von tvheadend (stable/unstable) verwendet - gleicher Effekt.

Wie kann ich denn unter tvheadend ein etwas ausführlicheres Debugging aktivieren? "tvheaend -s --debug all" zeigt die oben zitierte [INFO]-Zeile an - keinerlei weiteren Meldungen, die auf eine Kommunikation mit dem Stick schließen lassen.

Jens