Autor Thema: Dauerhafte Installation an einem TPLink WDR4300  (Gelesen 23792 mal)

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8329
    • Profil anzeigen
Re:Dauerhafte Installation an einem TPLink WDR4300
« Antwort #30 am: März 12, 2015, 08:03:23 Nachmittag »
mv /tmp/opt /tmp/mnt/sda_part1

nach diesem Befehl wäre der Treiber in:
/tmp/mnt/sda_part1/opt/bin

Der Treiber würde sich so starten lassen:
cd /tmp/mnt/sda_part1/opt/bin
./mediasrv -d

mediaclient wäre:
/tmp/mnt/sda_part1/opt/bin/mediaclient
Failure is a good thing! I'll fix it

enormo

  • Newbie
  • *
  • Beiträge: 27
    • Profil anzeigen
Re:Dauerhafte Installation an einem TPLink WDR4300
« Antwort #31 am: März 12, 2015, 08:28:55 Nachmittag »
Vielen Dank. Hatte funktioniert. Und das auch nach einem reboot - HUHU - vielen Dank.

Nur musste ich nach dem reboot wieder den Netzwerkmodus starten.
root@DD-WRT:~# /tmp/mnt/sda_part1/opt/bin/mediaclient --enablenetwork=on
Enabling network support
root@DD-WRT:~# /tmp/mnt/sda_part1/opt/bin/mediaclient --scan-network
Scanning network for IPTV media servers
------------------------------------------------------------------------------
 IP address       | ID  |  devicename          | Users | Capabilities | Serial
------------------------------------------------------------------------------
 192.168.0.4      | 0   | Sundtek SkyTV Ultimate III (USB 2.0)  |  0   | DVB-S/S2 | U120420171619
-  1 IPTV server found -------------------------------------------------------

Wie geht das automatisch?
« Letzte Änderung: März 12, 2015, 08:34:30 Nachmittag von enormo »

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8329
    • Profil anzeigen
Re:Dauerhafte Installation an einem TPLink WDR4300
« Antwort #32 am: März 12, 2015, 09:23:07 Nachmittag »
Startest du denn den Treiber automatisch nach dem Reboot oder wie läuft das jetzt bei dir?
Failure is a good thing! I'll fix it

enormo

  • Newbie
  • *
  • Beiträge: 27
    • Profil anzeigen
Re:Dauerhafte Installation an einem TPLink WDR4300
« Antwort #33 am: März 12, 2015, 09:44:55 Nachmittag »
Ne. Das wäre dann mit mediasrv -d, oder?
Musste ich vorhin auch glaube nochmal manuell machen.

Mein Ziel ist es, dass der Stick nach einem Reboot direkt wieder im Netzwerk verfügbar.
Was müsste ich dafür machen?

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8329
    • Profil anzeigen
Re:Dauerhafte Installation an einem TPLink WDR4300
« Antwort #34 am: März 12, 2015, 09:50:18 Nachmittag »
Ok, also doch alles wie ich angenommen hatte.

Kannst du mal in einem DD-WRT Forum fragen wie du ein Shellskript automatisch nach dem Reboot starten kannst?

Das würde Dein Problem lösen (dann könnte ich Dir ab dort auch weiterhelfen).
Failure is a good thing! I'll fix it

enormo

  • Newbie
  • *
  • Beiträge: 27
    • Profil anzeigen
Re:Dauerhafte Installation an einem TPLink WDR4300
« Antwort #35 am: März 12, 2015, 10:10:38 Nachmittag »
Alles klar - Versuch ich zu klären - vielen Dank

enormo

  • Newbie
  • *
  • Beiträge: 27
    • Profil anzeigen
Re:Dauerhafte Installation an einem TPLink WDR4300
« Antwort #36 am: März 12, 2015, 10:13:28 Nachmittag »

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8329
    • Profil anzeigen
Re:Dauerhafte Installation an einem TPLink WDR4300
« Antwort #37 am: März 12, 2015, 10:28:02 Nachmittag »
Ich denke ja, dort steht ja alles.


Erstelle auch die Datei /tmp/mnt/sda_part1/opt/bin/sundtek.conf mit dem Inhalt
enablenetwork=on

Das würde den Netzwerksupport automatisch starten.

Du kannst die ganzen Befehle in ein Skript reinstecken, starte den Treiber dann wie folgt:

./mediasrv -d --config /tmp/mnt/sda_part1/opt/bin/sundtek.conf

sundtek.conf muss dann natürlich auch in dem Verzeichnis sein.
Failure is a good thing! I'll fix it

enormo

  • Newbie
  • *
  • Beiträge: 27
    • Profil anzeigen
Re:Dauerhafte Installation an einem TPLink WDR4300
« Antwort #38 am: März 12, 2015, 10:41:30 Nachmittag »
Also das mit dem Netzwerkstart bekomm ich glaube ich hin.

Für das Skript muss ich dann eine *.startup Datei erstellen. Richtig?
Und was muss da rein?

Beide Dateien sollen dann unter /tmp/mnt/sda_part1/opt/bin liegen? Richtig

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8329
    • Profil anzeigen
Re:Dauerhafte Installation an einem TPLink WDR4300
« Antwort #39 am: März 12, 2015, 10:46:08 Nachmittag »
Als erstes musst du das mit jffs hinbekommen, ich hab hier leider keine so eine Routerinstallation, bekommst du das hin?


Danach musst du das Startupskript das du erstellt hast nach /jffs/etc/config kopieren
(es ist ein einfaches Shellscript, dort steckst du einfach die Shellbefehle rein zum Starten des Treibers -- wie etwas weiter oben erwähnt).

In der DD-WRT Doku steht das so:

chmod 700 /jffs/etc/config/<scriptname>.startup
Failure is a good thing! I'll fix it

enormo

  • Newbie
  • *
  • Beiträge: 27
    • Profil anzeigen
Re:Dauerhafte Installation an einem TPLink WDR4300
« Antwort #40 am: März 12, 2015, 10:48:58 Nachmittag »
Ok, ich probier das am WE aus & melde mich dann nochmal.
Vielen Dank!

enormo

  • Newbie
  • *
  • Beiträge: 27
    • Profil anzeigen
Re:Dauerhafte Installation an einem TPLink WDR4300
« Antwort #41 am: März 14, 2015, 06:48:41 Nachmittag »
So habe nun etwas getestet, aber leider läuft es noch nicht wie gewünscht.
Kurz zum Status qou.
JFFS eingeschaltet und genügend freier Platz.
Installation des Treiber ist nun unter /jffs/opt/bin
Dort liegt auch die Datei sundtek.conf mit dem Inhalt enablenetwork=on
Mit einer shellskript.startup Datei kam ich irgendwie nicht klar. Hatte dann hier im Thread gelesen, dass der user niedi_74 (seite 2) das in der Webgui eingetragen hat. Das hatte ich dann auch versucht:

- zunächst mit dem Eintrag ./mediasrv -d --config /jffs/opt/bin/sundtek.conf      ---> erfolgslos
- dann mit /opt/bin/mediaclient --start --config=/jffs/opt/bin/sundtek.conft      --->leider auch erfolglos

Jemand eine Idee? Vielen Dank

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8329
    • Profil anzeigen
Re:Dauerhafte Installation an einem TPLink WDR4300
« Antwort #42 am: März 14, 2015, 08:03:09 Nachmittag »
Halte dich an das Startskript so schwierig ist das nicht.

#!/bin/sh
cd /jffs/opt/bin
./mediasrv -d --config /jffs/opt/bin

Die Konfigurationsdatei
/jffs/opt/bin/sundtek.conf
enablenetwork=on
Failure is a good thing! I'll fix it

enormo

  • Newbie
  • *
  • Beiträge: 27
    • Profil anzeigen
Re:Dauerhafte Installation an einem TPLink WDR4300
« Antwort #43 am: März 15, 2015, 06:41:22 Nachmittag »
Ok Datei (treiber.startup) ist erstellt, mit dem Inhalt, den Du geschrieben hattest.
Wo soll dieses nun hin? Dort wo auch die sundtek.conf liegt? Also /jffs/opt/bin?
Anschließend noch Berechtigung 700, geht ja auch dann über filezilla.

Richtig so?

enormo

  • Newbie
  • *
  • Beiträge: 27
    • Profil anzeigen
Re:Dauerhafte Installation an einem TPLink WDR4300
« Antwort #44 am: März 15, 2015, 07:02:27 Nachmittag »
Also nachdem ich nochmal die Beiträge der letzten Tage durch bin, bin ich wie folgt vorgegangen:

- die Datei treiber.startup mit dem Inhalt:
#!/bin/sh
cd /jffs/opt/bin
./mediasrv -d --config /jffs/opt/bin
nach /jffs/etc/config kopiert und mit chmod 700 ausführbar gemacht
- die Datei sundtek.conf mit dem Inhalt:
enablenetwork=on
nach /jffs/opt/bin kopiert

Neustart -> leider erfolglos ?!?