Autor Thema: VDR - missing audio on some channels  (Gelesen 4496 mal)

bpbastos

  • Newbie
  • *
  • Beiträge: 17
    • Profil anzeigen
VDR - missing audio on some channels
« am: September 25, 2014, 06:51:47 Nachmittag »
Hello all,

I've set up VDR + XBMC but the majority of HD channels haven't audio.

I don't know if is something related to vdr+sundtek compatibility, i think not.

Any guidance will be welcome

Thanks!


Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8078
    • Profil anzeigen
Re:VDR - missing audio on some channels
« Antwort #1 am: September 25, 2014, 07:08:09 Nachmittag »
Which system do you use?

HD Channels need AC3 Support, does your XBMC Setup support AC3?

I am not entirely sure but usually HD channels also deliver MP2 Audio channels, you possibly might have to change the Audio channel in the tvheadend setup (I didn't do that myself yet because we never experienced such issue yet).
Failure is a good thing! I'll fix it

bpbastos

  • Newbie
  • *
  • Beiträge: 17
    • Profil anzeigen
Re:VDR - missing audio on some channels
« Antwort #2 am: September 25, 2014, 07:39:35 Nachmittag »
Which system do you use?

HD Channels need AC3 Support, does your XBMC Setup support AC3?

I am not entirely sure but usually HD channels also deliver MP2 Audio channels, you possibly might have to change the Audio channel in the tvheadend setup (I didn't do that myself yet because we never experienced such issue yet).

It's working with some HD channels including with AC3 audio xbmc doesn't shows audio tracks in the problematic ones.

I think it's some related to how channels.conf was generated.

Looking at channels.conf w_scan has generated, I've found that the channels without audio doesn't have APID set up like the channels with audio:

Without audio : FOX HD;(null):267000:M256:C:5217:2320=27:0;2321,2322:0;2116:1861,1802:631:2:40:0
With audio: ESPN HD ;(null):129000:M256:C:5217:1056=27:1057=eng@4;1058:0:1802,1861:571:2:35:0

I'm using VDR 2.1.6 + VNSI Server 1.2


Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8078
    • Profil anzeigen
Re:VDR - missing audio on some channels
« Antwort #3 am: September 25, 2014, 09:04:49 Nachmittag »
can you tune to that particular transponder and run following command:

/opt/bin/mediaclient --tsscan /dev/dvb/adapter0/dvr0

(this should give you some Channellist)

Next just run /opt/bin/mediaclient --lc

so we know which PIDs are used by the application

and then try

/opt/bin/mediaclient --cat /dev/dvb/adapter0/dvr0 | mplayer -cache 15240 -

and check if audio is there (the driver allows multiaccess to the devicenodes, so it will also deliver the same data which is sent via tvheadend to xbmc to mplayer)
Failure is a good thing! I'll fix it

bpbastos

  • Newbie
  • *
  • Beiträge: 17
    • Profil anzeigen
Re:VDR - missing audio on some channels
« Antwort #4 am: September 25, 2014, 09:34:57 Nachmittag »
can you tune to that particular transponder and run following command:

/opt/bin/mediaclient --tsscan /dev/dvb/adapter0/dvr0

(this should give you some Channellist)

Next just run /opt/bin/mediaclient --lc

so we know which PIDs are used by the application

and then try

/opt/bin/mediaclient --cat /dev/dvb/adapter0/dvr0 | mplayer -cache 15240 -

and check if audio is there (the driver allows multiaccess to the devicenodes, so it will also deliver the same data which is sent via tvheadend to xbmc to mplayer)

Sure! I'll test it as soon as I get home.

The parameter --tsscan from mediaclient can generate a VDR compatible channels.conf?
I'm afraid I can't test using mplayer, I'm on "semi-headless" server with just vdr+xbmc installed.

Just a correction, I'm using VDR and not tvheadend as backend.
« Letzte Änderung: September 25, 2014, 09:42:47 Nachmittag von bpbastos »

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8078
    • Profil anzeigen
Re:VDR - missing audio on some channels
« Antwort #5 am: September 25, 2014, 09:39:20 Nachmittag »
Use mplayer -ao null -vo null (add the last 4 parameters), mplayer will show up some Details on the console.


tsscan will show up transponder information in a more verbose format (not the one which can be read by vdr).
Failure is a good thing! I'll fix it

bpbastos

  • Newbie
  • *
  • Beiträge: 17
    • Profil anzeigen
Re:VDR - missing audio on some channels
« Antwort #6 am: September 26, 2014, 08:43:48 Nachmittag »
Use mplayer -ao null -vo null (add the last 4 parameters), mplayer will show up some Details on the console.


tsscan will show up transponder information in a more verbose format (not the one which can be read by vdr).

Hello, thank you for your help! I've found a solution for my problem.

I have set StandardCompliance = 1 in setup.conf and everything is working now.