Autor Thema: tvheadend auf OpenWrt stuerzt ab  (Gelesen 3326 mal)

msauter

  • Newbie
  • *
  • Beiträge: 1
    • Profil anzeigen
tvheadend auf OpenWrt stuerzt ab
« am: Juli 07, 2014, 10:50:22 Nachmittag »
Ich verwende den Sundtek MediaTV Pro III an einem TP-Link WDR4900 Router mit OpenWrt zum Empfang von DVB-C.
Die Hardware ist also ein PowerPC mit Freescale MPC85xx CPU, 128 MB RAM und 800 MHz.
Das Problem ist, dass ich tvheadend nicht zum Laufen bekomme. Genauer gesagt, sobald ich dafuer sorge, dass es den Tuner sieht, dann stuerzt es schliesslich ab.

Genauer dazu was klappt und was nicht:
Nach ein bisschen Compilieren habe ich w_scan und mumudvb zum Laufen bekommen. So kann ich die Kanaele auf einer Frequenz einwandfrei streamen.  Natuerlich ist dann der Frequenzwechsel unbequem, da mumudvb auf ein Mehrtunersetup ausgelegt ist. Dann habe ich festgestellt, dass man mit der Sundtek Treibersoftware den Tuner uebers Netzwerk mounten kann. Damit kann ich auf einem anderen Rechner tvheadend mit dem vom Router exportierten Tuner betreiben, was soweit auch gut funktioniert.

Allerdings wuerde ich gerne tvheadend auf dem Router laufen lassen. Dazu habe ich schon so allerlei probiert.
Zuerst habe ich tvheadend (in mehreren Versionen, von antik bis git, und unterschiedlicher Konfiguration) fuer den Router kompiliert und gegen libmediaclient.so gelinkt. Resultat war ein "bus error" bei der Initialisierung. Fuer w_scan und mumudvb war das erfolgreich. Inzwischen habe ich ein eigenes OpenWrt Image (Bleeding Edge, r41527) mit LD_PRELOAD Unterstuetzung. Damit gibt es bei tvheadend immer noch den "bus error", was natuerlich nicht verwunderlich ist. Wenn ich das LD_PRELOAD=/opt/lib/libmediaclient.so weglasse, dann startet tvheadend erfolgreich (inklusive Webinterface), findet aber natuerlich keinen Tuner. Mit dem LD_PRELOAD findet es den Tuner, landet dann allerdings kurz darauf beim "bus error". Das Webinterface ist da noch nicht initialisiert.

Dann habe ich es mit dem Patch von folgender Seite versucht (der uebrigens nicht mehr auf die aktuelle git Version von tvheadend angewendet werden kann; ich habe es dann mit git a28734498c7d06e8390f520fe332652941d983e1 probiert):
http://support.sundtek.com/index.php/topic,1607.0.html
http://sundtek.de/support/tvh_file_ops.diff
Damit findet er den Tuner und startet auch ins Webinterface. Wenn ich den Tuner dann allerdings im Webinterface konfiguriere, verabschiedet tvheadend sich mit "Segmentation fault" sobald es versucht zu scannen.

Interessant ist auch, dass ich den Tuner mit tvheadend am Notebook getestet habe. Dort funktioniert tvheadend mit LD_PRELOAD, aber wie auf dem Router bekomme ich mit dem Patch ein "Segmentation fault" wenn es scannt.

Schliesslich zu den Fragen: Gibt es eine neue Version von dem tvheadend Patch? Hat jemand eine Idee woran das liegen koennte und wie man das beheben kann? Auf dem Notebook habe ich gdb mit einem coredump gefuettert. Der verweist auf src/input/mpegts/linuxdvb/linuxdvb_frontend.c:624. Das ist folgende Zeile (in linuxdvb_sbuf_read):
ssize_t n = tfo.read(fd, sb->sb_data + sb->sb_ptr, sb->sb_size - sb->sb_ptr);Allem Anschein nach geht das also direkt an das "Quickzap Plugin" /opt/lib/libmcsimple.so.

Danke fuer jedwede Hilfe. Einfach nachfragen, falls zusaetzliche Information benoetigt werden sollte.

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8095
    • Profil anzeigen
Re:tvheadend auf OpenWrt stuerzt ab
« Antwort #1 am: Juli 08, 2014, 12:17:55 Vormittag »
Kontaktiere uns besser via Skype das ist wohl ein Thema für einen Entwickler bei uns.

Skype - sundtek

Den Patch zu aktualisieren sollte ja kein Problem sein, auch wurde er eigentlich von den tvheadend Leuten akzeptiert aber wir müssen da noch etwas aufräumen bevor wir ihn an deren Mailingliste schicken.
Failure is a good thing! I'll fix it