Autor Thema: Abbruch nach Sek/Minuten TVHeadend - Media TV Pro Synology 212+  (Gelesen 6306 mal)

barsch

  • Newbie
  • *
  • Beiträge: 9
    • Profil anzeigen
Abbruch nach Sek/Minuten TVHeadend - Media TV Pro Synology 212+
« am: März 13, 2014, 09:22:00 Nachmittag »
Hallo,

es geht um die Kombi Media TV Pro an Front USB 2.0 Port einer Synology DS212+ (DSM 4.3) mit TVHeadend. Bekam das mit etwas frickeln (was wann starten...) alles schön zum laufen mit guter Qualität - lief dann ein paar Tage. Aber inzwischen aber nach Minuten / Stunden (gefühlt inzwischen eher Sekunden bis Minuten) bricht entweder schon der Suchlauf nach 20-30 Muxen ab, und/oder die Bandbreite geht auf Null runter  Meldung no Input detected oder auch "dvb: "/dev/dvb/adapter0" tuning to "KBW: 698,000 kHz" -- Front configuration failed -- Broken pipe, frequency: 698000000", Empfangsstärke noch 99%, dann auch runter auf Null,

Zunächst so:
OetziStation>  /opt/bin/mediaclient --lc
**** List of Media Clients ****
/dev/dvb/adapter0/frontend0:
  19227 ... tvheadend
  19621 ... tvheadend
/dev/dvb/adapter0/dvr0:
  No client connected
/dev/dvb/adapter0/demux0:
  No client connected
/dev/mediainput0:
  No client connected

dann
OetziStation> /opt/bin/mediaclient --lc
OetziStation>  /opt/bin/mediaclient --start
OetziStation> /opt/bin/mediaclient --lc
OetziStation>

Treiber abgeschmiert?

Muss dann rebooten und/Stick rein/raus. Habe schon einige Tage alles probiert, alle Software /Treiber X-mal installiert, Transfer auf ISO Modus umgestellt… Komme auch nach Studium aller Foreneinträge nicht weiter – Habt ihr eine Idee??

dmesg | grep -i usb sieht auch komisch aus...

OetziStation> dmesg | grep -i usb
[ 8961.590000] usb 1-1.4: unlock for hub EH
[ 9205.290000] usb 1-1.3: USB disconnect, address 90
[ 9205.360000] usb 1-1.4: USB disconnect, address 91
[ 9205.660000] usb 1-1: lock for hub EH
[ 9205.780000] usb 1-1: reset high speed USB device using orion-ehci and address                                                           89
[ 9205.930000] usb 1-1: device firmware changed
[ 9205.930000] usb 1-1: unlock for hub EH
[ 9206.060000] usb 1-1: USB disconnect, address 89
[ 9206.650000] usb 1-1: new high speed USB device using orion-ehci and address 9                                                          2
[ 9206.820000] usb 1-1: configuration #1 chosen from 1 choice
[ 9207.000000] hub 1-1:1.0: USB hub found
[ 9207.290000] usb 1-1.3: new high speed USB device using orion-ehci and address                                                           93
[ 9207.410000] usb 1-1.3: configuration #1 chosen from 1 choice
[ 9207.820000] usb 1-1.4: new high speed USB device using orion-ehci and address                                                           94
[ 9207.970000] usb 1-1.4: configuration #1 chosen from 1 choice
[ 9207.990000] scsi36 : SCSI emulation for USB Mass Storage devices
[ 9208.180000] usb-storage: device found at 94
[ 9208.180000] usb-storage: waiting for device to settle before scanning
[ 9214.060000] usb-storage: device scan complete
[ 9243.880000] usb 1-1.4: lock for hub EH
[ 9244.070000] hub 1-1:1.0: Cannot enable port 4.  Maybe the USB cable is bad?
[ 9244.300000] hub 1-1:1.0: Cannot enable port 4.  Maybe the USB cable is bad?
[ 9244.530000] hub 1-1:1.0: Cannot enable port 4.  Maybe the USB cable is bad?
[ 9244.760000] hub 1-1:1.0: Cannot enable port 4.  Maybe the USB cable is bad?
[ 9244.840000] usb 1-1.4: unlock for hub EH
[ 9489.200000] usb 1-1.3: USB disconnect, address 93
[ 94

usw mehrfach....

 ggf hier ein USB Problem? Habe schon Station runtergefahren, vom Strom getrennt, wieder hoch, Stick rein... ohne Efo

Gruss, Barsch
 

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8530
    • Profil anzeigen
Re:Abbruch nach Sek/Minuten TVHeadend - Media TV Pro Synology 212+
« Antwort #1 am: März 13, 2014, 09:45:50 Nachmittag »
  19227 ... tvheadend
  19621 ... tvheadend

tvheadend läuft 2x und beide benutzen den gleichen Adapter, da kann nichts gutes dabei rauskommen.


killall -9 tvheadend und tvheadend dann neu starten.
Es ist uns soweit bekannt das es früher bei älteren tvheadend Versionen anscheinend Probleme beim stoppen gab, ist die Software eventuell nicht aktuell?


Zum anderen würde ich hier erst mal nichts schreiben, da erstes Problem das TVHeadend 2x läuft wohl das schlimmere ist.
Failure is a good thing! I'll fix it

barsch

  • Newbie
  • *
  • Beiträge: 9
    • Profil anzeigen
Re:Abbruch nach Sek/Minuten TVHeadend - Media TV Pro Synology 212+
« Antwort #2 am: März 13, 2014, 10:07:07 Nachmittag »
versuche ich mal. Allerdings war das der xte Versuch und bisher gab es keine 2x TVHeadend... eher eine weitere Verschlimmerung...

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8530
    • Profil anzeigen
Re:Abbruch nach Sek/Minuten TVHeadend - Media TV Pro Synology 212+
« Antwort #3 am: März 13, 2014, 10:18:08 Nachmittag »
Tja dazu sollte bei tvheadend ein Bugreport aufgemacht werden damit die das fixen. Ich denke aber die haben nie auf NAS Systeme abgezielt, es läuft halt drauf aber ist auch nicht 100% optimiert dafür. Mittlerweile haben einige der TVHeadend Entwickler auch Geräte von uns und können daher auch so einiges testen.

Wie es einige Kunden aber überhaupt schaffen auf dem NAS Probleme zu bekommen ist uns auch etwas schleierhaft, normalerweise funktioniert das problemlos. Wir können uns das ansehen aber dafür müsstest du uns via Skype (sundtek) kontaktieren.

Die übliche Installationsanleitung für Synology ist:
1. tvheadend installieren
2. Treiber installieren
3. NAS Neu starten

Das einzige Problem das wir bestätigen können ist bei den USB 3.0er Controllern, oder das der Stick dort nicht als USB 2.0 erkannt wird (was aber auch wieder mit den USB 3.0er Controllern zusammenhängt) aber das kann sich mit DSM5 wohl weiter gebessert haben. Als Workaround wurde hier soweit herausgefunden das ein Neustart ausreichend ist.
« Letzte Änderung: März 13, 2014, 10:32:31 Nachmittag von Sundtek »
Failure is a good thing! I'll fix it

barsch

  • Newbie
  • *
  • Beiträge: 9
    • Profil anzeigen
Re:Abbruch nach Sek/Minuten TVHeadend - Media TV Pro Synology 212+
« Antwort #4 am: März 16, 2014, 06:05:46 Nachmittag »
hallo, habe inzwischen den stick und tvheadend auf einer anderen synology station ds214 (mit frot USB 2.0)  und dsm 5.0 ohne probleme zum laufen bekommen (musste nur für download der community pakete a la tvheadend auch beta aktivieren). war anscheinend irgendetwas faul mit der ds212+... danke trotzdem für die hilfe. barsch