Autor Thema: Mac OS X (Lion und Mavericks): Keine Geräte nach Installation verfügbar  (Gelesen 5730 mal)

x11max

  • Newbie
  • *
  • Beiträge: 8
    • Profil anzeigen
Mac OS X (Lion und Mavericks): Keine Geräte nach Installation verfügbar
« am: Dezember 27, 2013, 07:37:50 Nachmittag »
Ich habe den neuen Sundtek MediaTV Pro III (DVB-C/T/T2/AnalogTV/FM Radio) erhalten und an zwei verschiedenen Macs getestet.

- an einem Mac mit OS X Lion und
- an einem Mac mit OS X Mavericks.

Der Sundtek Adapter selbst ist mit DVB-C verkabelt.

Nach fehlerfreier Installation von Treiber und Mendienprogrammen mit Hilfe des Diskimage “sundtek_driver_macosx_130915.1211.dmg” sind aber weder die digitalen noch die analogen Geräte und das Gerät für die Fernbedienung vorhanden. Sie werden auch nicht bei der Initialisierung des Mediaclient erstellt. Und weil keine Geräte vorhanden sind, können VLC und MPlayer nicht auf den Sundtek Adapter zugreifen.

Laut Protokoll (s.u.) sollen aber alle Geräte vorhanden sein. Ein “ls /dev/…” zeigt keines dieser Geräte an.

registered virtual: /dev/dvb/adapter0/frontend0
registered virtual: /dev/dvb/adapter0/demux0
registered virtual: /dev/dvb/adapter0/dvr0
registered virtual: /dev/dsp0
registered virtual: /dev/video0
registered virtual: /dev/vbi0
registered virtual: /dev/radio0
registered virtual: /dev/rds0
Initializing Remote Control Support
registered virtual: /dev/mediainput0
Initialized MediaTV Pro III USB (EU)

Daher dir Frage: “wo stimmt nicht hier was nicht ?”

————————————————————————————————————————

START DES MEDIACLIENT MIT DVB-C ANBINDUNG NACH DER INSTALLATION:

--> /opt/bin/mediaclient -m DVBC -f 113000000 -M Q64 -S 6900000”

Using device: /dev/dvb/adapter0/frontend0
Checking for lock:
..........

Dazu in /var/log/mediasrv.log:

2013-12-27 17:49:09 [7225] Waking up device
2013-12-27 17:49:09 [7225] Setting frequency: 245250000
2013-12-27 17:49:09 [7225] Switching to Digital TV
2013-12-27 17:49:11 [7225] Initializing DVB-C
2013-12-27 17:49:13 [7225] Setting Frequency: 113000000
2013-12-27 17:49:13 [7225] Setting Symbolrate: 6900000
2013-12-27 17:49:13 [7225] Setting Modulation: 3
2013-12-27 17:49:31 [7225] Enabling Standby

--> mplayer /dev/dvb/adapter0/dvr0

MPlayer 1.1-4.2.1 (C) 2000-2012 MPlayer Team
192 audio & 400 video codecs

Playing /dev/dvb/adapter0/dvr0.
File not found: '/dev/dvb/adapter0/dvr0'
Failed to open /dev/dvb/adapter0/dvr0.

Exiting... (End of file)


INSTALLATION und PROTOKOLLE:

Der Serverprozess:

--> ps -ef

/opt/bin/mediasrv -l /var/log/mediasrv.log -p /opt/bin
/opt/bin/mediasrv -l /var/log/mediasrv.log -p /opt/bin

Der Mediaserver sagte, dass alle Treiber geladen wurden. Jedoch sind die unter “registered virtual:” gelisteten Geräte nicht vorhanden.

Start des Media Frameworks in /var/log/mediasrv.log:

--> sudo launchctl load -w com.sundtek.plist

2013-12-27 17:40:59 [7225] Starting up Multimedia Framework (Sep 15 2013 12:08:23)
2013-12-27 17:40:59 [7225] API Version: 5.10
2013-12-27 17:40:59 [7225] Running on Darwin (11.4.2)
2013-12-27 17:40:59 [7226] Starting service processor (PID 7226)
2013-12-27 17:40:59 [7225] scanning devices
2013-12-27 17:40:59 [7225]
2013-12-27 17:40:59 [7225] Scanning for drivers
2013-12-27 17:40:59 [7225] found lib: libdrv_em28xx.dylib
2013-12-27 17:40:59 [7225] found lib: libdrv_fm.dylib
2013-12-27 17:40:59 [7225] found lib: libdrv_hikarisoft_isdb.dylib
2013-12-27 17:40:59 [7225] found lib: libdrv_net.dylib
2013-12-27 17:40:59 [7225] found lib: libdrv_ngTV.dylib
2013-12-27 17:40:59 [7225] found lib: libdrv_tntdvb.dylib
2013-12-27 17:40:59 [7225] found lib: libdrv_vivi.dylib
2013-12-27 17:40:59 [7225]
2013-12-27 17:40:59 [7225] Scanning for plugins
2013-12-27 17:40:59 [7225] *WARNING* could not open plugin path
2013-12-27 17:40:59 [7225]
2013-12-27 17:40:59 [7225] Adjusting Buffers
2013-12-27 17:40:59 [7225] Driver is running in 64bit mode
2013-12-27 17:40:59 [7225] scanning devices done
2013-12-27 17:40:59 [7225] attached devices:
2013-12-27 17:40:59 [7226] Autostarting scripts in /etc/sundtek/
2013-12-27 17:40:59 [7226] executed all available items
2013-12-27 17:40:59 [7225] scanning for devices:
2013-12-27 17:40:59 [7225] registering ID: 0
2013-12-27 17:41:03 [7225] Using dynamic configuration
2013-12-27 17:41:03 [7225] DTV1 Transfer is set to: Bulk
2013-12-27 17:41:05 [7225] Allocation using pg for type 65678
2013-12-27 17:41:05 [7225] attaching DVB-T, DVB-T2, DVB-C
2013-12-27 17:41:05 [7225] Initializing frontend...
2013-12-27 17:41:06 [7225] demodulator successfully attached (DVBC)!
2013-12-27 17:41:06 [7225] Allocation using pg for type 16
2013-12-27 17:41:06 [7225] attaching video decoder
2013-12-27 17:41:07 [7225] Setting frequency: 245250000
2013-12-27 17:41:07 [7225] attaching radio module
2013-12-27 17:41:08 [7225] configure urbs for bulk
2013-12-27 17:41:08 [7225] Registering OSS emulation
2013-12-27 17:41:08 [7225] registering: adapter0/0
2013-12-27 17:41:08 [7225] registered virtual: /dev/dvb/adapter0/frontend0
2013-12-27 17:41:08 [7225] registered virtual: /dev/dvb/adapter0/demux0
2013-12-27 17:41:08 [7225] registered virtual: /dev/dvb/adapter0/dvr0
2013-12-27 17:41:08 [7225] registered virtual: /dev/dsp0
2013-12-27 17:41:08 [7225] registered virtual: /dev/video0
2013-12-27 17:41:08 [7225] registered virtual: /dev/vbi0
2013-12-27 17:41:08 [7225] registered virtual: /dev/radio0
2013-12-27 17:41:08 [7225] registered virtual: /dev/rds0
2013-12-27 17:41:08 [7225] Initializing Remote Control Support
2013-12-27 17:41:08 [7225] registered virtual: /dev/mediainput0
2013-12-27 17:41:08 [7225] Initialized MediaTV Pro III USB (EU)
2013-12-27 17:41:08 [7225] Driver loaded within 8348 milliseconds


Der Mediaclient selbst erkennt folgende Mediengeräte:

--> /opt/bin/mediaclient -e

**** List of Media Hardware Devices ****
device 0: [MediaTV Pro III USB (EU)]  DVB-C, DVB-T, DVB-T2, ANALOG-TV, FM-RADIO, REMOTE-CONTROL, OSS-AUDIO, RDS
  [BUS]:
     ID: 0-0xfd100000
  [SERIAL]:
     ID: U131223125314
  [DVB-C]:
     FRONTEND: /dev/dvb/adapter0/frontend0
     DVR: /dev/dvb/adapter0/dvr0
     DMX: /dev/dvb/adapter0/demux0
  [DVB-T]:
     FRONTEND: /dev/dvb/adapter0/frontend0
     DVR: /dev/dvb/adapter0/dvr0
     DMX: /dev/dvb/adapter0/demux0
  [DVB-T2]:
     FRONTEND: /dev/dvb/adapter0/frontend0
     DVR: /dev/dvb/adapter0/dvr0
     DMX: /dev/dvb/adapter0/demux0
  [ANALOG-TV]:
     VIDEO0: /dev/video0
     VBI0: /dev/vbi0
  [FM-RADIO]:
     RADIO0: /dev/radio0
     RDS: /dev/rds0
  [REMOTECONTROL]:
     INPUT0: /dev/mediainput0
  [OSS]:
     OSS0: /dev/dsp0




Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8356
    • Profil anzeigen
Re:Mac OS X (Lion und Mavericks): Keine Geräte nach Installation verfügbar
« Antwort #1 am: Dezember 27, 2013, 07:43:35 Nachmittag »
Was für ein Kabelanbieter?

Versuch ggf. Q256 anstelle von Q64 die meisten Anbieter haben bereits auf Qam256 umgestellt.

Der Mac Treiber wird aber morgen wohl auch nocheinmal aktualisiert, den Status des aktuellen Treibers unter Mac kann ich derzeit nicht beurteilen.
Failure is a good thing! I'll fix it

x11max

  • Newbie
  • *
  • Beiträge: 8
    • Profil anzeigen
Re:Mac OS X (Lion und Mavericks): Keine Geräte nach Installation verfügbar
« Antwort #2 am: Dezember 27, 2013, 07:54:41 Nachmittag »
Kabelanbieter ist UM. Die nutzen je nach Kanal sowohl als auch eine Quadraturamplitudenmodulation 64/256. Aber viel wichtiger ist, warum die Geräte nicht da sind.

Ohne diese Geräte kann ich keinen Mediaplayer starten:

mplayer /dev/dvb/adapter0/dvr0

Playing /dev/dvb/adapter0/dvr0.
File not found: '/dev/dvb/adapter0/dvr0'
Failed to open /dev/dvb/adapter0/dvr0.

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8356
    • Profil anzeigen
Re:Mac OS X (Lion und Mavericks): Keine Geräte nach Installation verfügbar
« Antwort #3 am: Dezember 27, 2013, 07:57:02 Nachmittag »
Du machst es dir etwas zu einfach.

/opt/bin/mediaclient --cat /dev/dvb/adapter0/dvr0 | mplayer -cache 10240 -


das sind virtuelle Nodes die das Linux Protokoll verstehen.
Viele Linux Programme sind aber unter MacOSX ohnehin nicht mit V4L oder DVB Support kompiliert, da müsste man noch etwas arbeit investieren.
Failure is a good thing! I'll fix it

x11max

  • Newbie
  • *
  • Beiträge: 8
    • Profil anzeigen
Re:Mac OS X (Lion und Mavericks): Keine Geräte nach Installation verfügbar
« Antwort #4 am: Januar 03, 2014, 02:12:52 Nachmittag »

Ich habe nun den Stick sowohl unter OSX als auch unter Solaris probiert. Das Ergebnis ist für Beide gleich. Der Stick wird mit "MediaTV Pro III (EU)" erkannt und die Treiber geladen, aber bei der Installation jeweils nur das Verzeichnis "/dev/dvb" ohne Inhalte (Geräte Devices) angelegt.

Sundtek schreibt, dass man mit dem Befehl "/opt/bin/mediaclient --cat /dev/dvb/adapter0/dvr0 | mplayer -cache 10240 -" zum Ziel kommt. Mach ein "cat" auf das Device und lass den Inhalt von "mplayer" wiedergeben.

Aber unterhalb von "/dev/dvb" gibt es keine Geräte wie "adapter0/dvr0", die vom Treiber angesprochen werden, geschweige denn, die mit "cat" ausgelesen werden können. "mediaclient -e" zeigt zwar virtuelle Geräte an, aber wie nutze ich diese ?

Frage daher: "welcher Prozess legt die Geräte an ?"
Kann Sundtek mir erklären, wie ich das primär unter Solaris hinkriege ? OSX wäre auch toll, aber das kann warten.

Ich habe mir den Stick, nur deswegen gekauft, weil

a) im Sundteck Wiki und den Dokumentationen beschrieben steht, dass er unter beiden Betriebssystemen laufen soll. Zu Solaris 11 steht sogar: "getestet". Aber wie ? und
b) als alternative zu Mac und EyeTV

Es gibt im Forum einige Beiträge, dass "/dev/dvb" leer ist. Aber dazu sind keine Lösungen beschrieben.

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8356
    • Profil anzeigen
Re:Mac OS X (Lion und Mavericks): Keine Geräte nach Installation verfügbar
« Antwort #5 am: Januar 03, 2014, 03:03:53 Nachmittag »
Es mangelt leider derzeit etwas an Zeit bei uns, dies wird sich in den kommenden Tagen wohl legen.

Es sind keine echten Verzeichnisse sondern nur verweise, "mediaclient --cat /dev/dvb/..." ist nahezu das selbe wie cat, jedoch wird hier direkt auf die Treiberschnittstelle (Unix Domainsocket) zugegriffen und die Daten werden direkt vom Treiber ausgelesen, wie ich aus dem Post lese wurde dieser Befehl noch nicht ausgeführt.

Der Native Treiber erstellt einen virtuellen Device Node Namespace, unter Linux gibt es ein zusätzliches Kompatibilitätslayer damit man dort auch mit den regulären Befehlen darauf zugreifen kann. Unter anderen Unix Systemen muss man entweder "mediaclient" verwenden oder die Applikationen gegen /opt/lib/libmcsimple.so kompilieren.
Failure is a good thing! I'll fix it

matzkowksky

  • Newbie
  • *
  • Beiträge: 2
    • Profil anzeigen
Re:Mac OS X (Lion und Mavericks): Keine Geräte nach Installation verfügbar
« Antwort #6 am: Februar 13, 2016, 08:43:55 Nachmittag »
Auf die Frage wie der MediaTV Pro III auf dem Mac zu benutzen sei, gibt's hier eine Anleitung http://support.sundtek.com/index.php/topic,399.msg16093.html#msg16093.