Autor Thema: Sundtek Fernbedienung wird immer wieder geladen  (Gelesen 5056 mal)

Engelsen

  • Newbie
  • *
  • Beiträge: 6
    • Profil anzeigen
Sundtek Fernbedienung wird immer wieder geladen
« am: Februar 10, 2013, 08:19:55 Nachmittag »
Hallo zusammen,

ich habe folgendes Problem:

Nach dem Start von Ubuntu habe ich unter cat /proc/bus/input/devices immer noch die Sundtek Remote stehen, obwohl ich mit -nolirc installiert habe und nachträglich noch unter /etc/udev/rules.d und unter lib/udev/rules.d/ die 80-remote ... entfernt habe ...

Die /opt/bin.lirc.sh habe ich auch gelöscht ....

Im Log sehe ich auch folgendes:

Feb  7 16:26:49 ubuntu lircd-0.9.0[1170]: accepted new client on /var/run/lirc/lircd
Feb  7 16:26:49 ubuntu kernel: [   16.212306] input: Sundtek Ltd. Remote Control as /devices/virtual/input/input10

Desweiteren habe ich die /etc/sundtek.conf angelegt und dort ir_disabled = 1 und [seriennummer] ir_disabled=1 eingestellt.

Wie kann ich der FB denn nun endgültig den gar ausmachen?! :(

Danke schonmal im Vorraus!

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8355
    • Profil anzeigen
Re:Sundtek Fernbedienung wird immer wieder geladen
« Antwort #1 am: Februar 10, 2013, 08:38:16 Nachmittag »
ir_disable=1 ist ausreichend, danach werden keine Keys mehr an das Input Node geschickt.
Die Node an sich wird aber dennoch erstellt da man die Fernbedienung während der Laufzeit nach wievor einschalten kann.

Der Parameter -nolirc installiert die Fernbedienungsskripte nicht welche den LIRC Daemon neu starten, diese Option funktioniert problemlos
« Letzte Änderung: Februar 10, 2013, 08:41:32 Nachmittag von Sundtek »
Failure is a good thing! I'll fix it

Engelsen

  • Newbie
  • *
  • Beiträge: 6
    • Profil anzeigen
Re:Sundtek Fernbedienung wird immer wieder geladen
« Antwort #2 am: Februar 10, 2013, 08:44:11 Nachmittag »
Danke für die schnelle Antwort.

Also in der sundtek.conf steht es genauso drin...

Trotzdem merke ich im XBMC, dass die Harmony-Fernbedienung erst sofort funktioniert und dann auf einmal aussetzt...

Dann nach kurzer Zeit (2-3 Minuten) geht sie wieder...

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8355
    • Profil anzeigen
Re:Sundtek Fernbedienung wird immer wieder geladen
« Antwort #3 am: Februar 10, 2013, 08:55:56 Nachmittag »
Das sollte mit uns nichts zu tun haben, wenn die Fernbedienung ausgeschalten wurde reportet der Treiber nichts mehr an das Input-Subsystem.
Failure is a good thing! I'll fix it

Cheese

  • Newbie
  • *
  • Beiträge: 15
    • Profil anzeigen
Re:Sundtek Fernbedienung wird immer wieder geladen
« Antwort #4 am: November 09, 2014, 01:52:43 Nachmittag »
Tja, wenn's denn funktionieren würde:

xbmc@xbmc:~$ cat /etc/sundtek.conf
loglevel=full
first_adapter=5
first_videodev=5
ir_disabled=1
enablenetwork=off

[U14041523XXXX]
initial_dvb_mode=DVBC
disable_analogtv=1

xbmc@xbmc:~$ cat /proc/bus/input/devices
[...]
I: Bus=0003 Vendor=0000 Product=0000 Version=0001
N: Name="Sundtek Ltd. Remote Control"
P: Phys=
S: Sysfs=/devices/virtual/input/input17
U: Uniq=
H: Handlers=sysrq rfkill kbd event17
B: PROP=0
B: EV=100017
B: KEY=1fffff ffffffffffffffff ffffffffffffffff ffffffff00000000 0 feffffffffffff ffffffffffffffff ffffffffffffffff fffffffffffffffe
B: REL=0
B: MSC=0

xbmc@xbmc:~$ cat /var/log/sundtek.log
2014-11-09 12:27:04 [1261] Starting up Multimedia Framework (Oct 16 2014 18:18:04)
2014-11-09 12:27:04 [1263] Starting service processor (PID 1263)
2014-11-09 12:27:04 [1261] Detected DVB version.h
2014-11-09 12:27:04 [1261] API Version: 5.10
2014-11-09 12:27:04 [1261] Running on Linux (3.17.0-031700-generic)
2014-11-09 12:27:04 [1261] Detected: GenuineIntel
2014-11-09 12:27:04 [1261] This CPU supports: MMX, SSE, SSE2
2014-11-09 12:27:04 [1261] unable to open /dev/misc
2014-11-09 12:27:04 [1261] scanning devices
2014-11-09 12:27:04 [1261]
2014-11-09 12:27:04 [1261] Scanning for drivers
2014-11-09 12:27:04 [1261] found lib: libdrv_net.so
2014-11-09 12:27:04 [1261] found lib: libdrv_hikarisoft_isdb.so
2014-11-09 12:27:04 [1261] found lib: libdrv_ngTV.so
2014-11-09 12:27:04 [1261] found lib: libdrv_tntdvb.so
2014-11-09 12:27:04 [1261] found lib: libdrv_em28xx.so
2014-11-09 12:27:04 [1261] found lib: libdrv_vivi.so
2014-11-09 12:27:04 [1261] found lib: libdrv_fm.so
2014-11-09 12:27:04 [1261]
2014-11-09 12:27:04 [1261] Scanning for plugins
2014-11-09 12:27:04 [1261] found lib: libencoder_plugin.so
2014-11-09 12:27:04 [1261] MediaAVPlugin: MPEG Encoder
2014-11-09 12:27:04 [1261] Copyright: (C) Tpe 2011/2012
2014-11-09 12:27:04 [1261]
2014-11-09 12:27:04 [1261] Starting up device manager
2014-11-09 12:27:04 [1261] Setting permission of /dev/dvb to 777
2014-11-09 12:27:04 [1261] This is to avoid problems if TV Applications are started as another user
2014-11-09 12:27:04 [1261] as seen on eg. Synology NAS Systems where tvheadend is unable to read
2014-11-09 12:27:04 [1261] /dev/dvb and because of that would not detect the TV tuner
2014-11-09 12:27:04 [1261] scanning devices done
2014-11-09 12:27:04 [1261] attached devices:
2014-11-09 12:27:04 [1263] Autostarting scripts in /etc/sundtek/
2014-11-09 12:27:04 [1263] executed all available items
2014-11-09 12:27:04 [1261] registering ID: 0
2014-11-09 12:27:04 [1261] Using dynamic configuration
2014-11-09 12:27:04 [1261] DTV1 Transfer is set to: Bulk
2014-11-09 12:27:05 [1261] Using Sundtek remote control layout
2014-11-09 12:27:05 [1261]
2014-11-09 12:27:05 [1261] IR Setup
2014-11-09 12:27:05 [1261] Initial mode request: DVBC
2014-11-09 12:27:05 [1261] Allocation using pg for type 65678
2014-11-09 12:27:05 [1261] attaching DVB-T, DVB-C, DVB-T2
2014-11-09 12:27:05 [1261] demodulator successfully attached (DVB-C)!
2014-11-09 12:27:05 [1261] This device uses the third generation Tuner
2014-11-09 12:27:05 [1261] Power up demodulator
2014-11-09 12:27:09 [1261] Allocation using pg for type 16
2014-11-09 12:27:09 [1261] SETTING PAL/SECAM
2014-11-09 12:27:09 [1261] SETTING PAL/SECAM
2014-11-09 12:27:09 [1261] attaching video decoder
2014-11-09 12:27:09 [1261] SETTING PAL/SECAM
2014-11-09 12:27:09 [1261] Setting frequency: 245250000
2014-11-09 12:27:09 [1261] Setting analogTV Parameters
2014-11-09 12:27:09 [1261] Setting PAL-B
2014-11-09 12:27:09 [1261] attaching radio module
2014-11-09 12:27:11 [1261] requesting to tune to frequency: 87900000 4
2014-11-09 12:27:11 [1261] Setting Radio Volume: 219
2014-11-09 12:27:11 [1261] configure urbs for bulk
2014-11-09 12:27:11 [1261] Registering OSS emulation
2014-11-09 12:27:11 [1261] registering: adapter5/0
2014-11-09 12:27:11 [1261] registered virtual: /dev/dvb/adapter5/frontend0
2014-11-09 12:27:11 [1261] registered virtual: /dev/dvb/adapter5/demux0
2014-11-09 12:27:11 [1261] registered virtual: /dev/dvb/adapter5/dvr0
2014-11-09 12:27:11 [1261] registered virtual: /dev/dsp0
2014-11-09 12:27:15 [1261] registered virtual: /dev/video5
2014-11-09 12:27:15 [1261] registered virtual: /dev/vbi0
2014-11-09 12:27:15 [1261] registered virtual: /dev/radio0
2014-11-09 12:27:15 [1261] registered virtual: /dev/rds0
2014-11-09 12:27:15 [1261] Initializing Remote Control Support
2014-11-09 12:27:15 [1261] This system does not support memory mapped USB transfers
2014-11-09 12:27:15 [1261] Once your system reaches the latest kernel version the
2014-11-09 12:27:15 [1261] performance will increase automatically
2014-11-09 12:27:15 [1261] registered virtual: /dev/mediainput0
2014-11-09 12:27:15 [1261] Trying to load ffmpeg codecs
2014-11-09 12:27:15 [1261] could not load libavutil.so
2014-11-09 12:27:15 [1261] could not load libswscale.so
2014-11-09 12:27:15 [1261] could not load libavcodec.so
2014-11-09 12:27:15 [1261] could not load libavformat.so
2014-11-09 12:27:15 [1261] AnalogTV encoding won't be possible in driver's side
2014-11-09 12:27:15 [1261] Initialized MediaTV Pro III USB (EU)
2014-11-09 12:27:15 [1261] Driver loaded within 11124 milliseconds
2014-11-09 12:27:15 [1261] Initial devicescan done, switching detection mode
2014-11-09 12:27:18 [1261] mute fm radio
2014-11-09 12:27:18 [1261] Switching to Digital TV
2014-11-09 12:27:18 [1261] Power up demodulator
2014-11-09 12:27:21 [1261] SETTING DVB-C
2014-11-09 12:27:25 [1261] Switching to analogTV
2014-11-09 12:27:26 [1261] SETTING PAL/SECAM
2014-11-09 12:27:26 [1261] analog TV read request :0
2014-11-09 12:27:26 [1261] No frames allocated, choosing default 5fps, probably read request
2014-11-09 12:27:26 [1261] Initializing data transfer
2014-11-09 12:27:26 [1320] Starting audio processor (PID 1320)
2014-11-09 12:27:26 [1320] initializing audio in audio processor
2014-11-09 12:27:28 [1261] Switching to Digital TV
2014-11-09 12:27:28 [1261] Power up demodulator
2014-11-09 12:27:31 [1261] SETTING DVB-C
2014-11-09 12:27:31 [1261] Setting Frequency: 442000000
2014-11-09 12:27:31 [1261] Setting Symbolrate: 6900000
2014-11-09 12:27:31 [1261] Setting Modulation: 3
2014-11-09 12:27:31 [1261] setting symbolrate: 6900
2014-11-09 12:27:31 [1261] Tuning DVB-C Frequency: 442000000
2014-11-09 12:27:31 [1261] Resetting TS Port
2014-11-09 12:27:31 [1261] TS Sync byte not aligned, realigning stream (6580 // 168)
2014-11-09 12:27:33 [1261] Setting Frequency: 322000000
2014-11-09 12:27:33 [1261] Setting Symbolrate: 6900000
2014-11-09 12:27:33 [1261] Setting Modulation: 5
2014-11-09 12:27:33 [1261] setting symbolrate: 6900
2014-11-09 12:27:33 [1261] Tuning DVB-C Frequency: 322000000

xbmc@xbmc:~$ sudo evtest /dev/input/event17
Input driver version is 1.0.1
Input device ID: bus 0x3 vendor 0x0 product 0x0 version 0x1
Input device name: "Sundtek Ltd. Remote Control"
Supported events:
  Event type 0 (EV_SYN)
  Event type 1 (EV_KEY)
    Event code 1 (KEY_ESC)
    Event code 2 (KEY_1)
    Event code 3 (KEY_2)
    Event code 4 (KEY_3)
    [...]
    Event code 530 (KEY_TOUCHPAD_TOGGLE)
    Event code 531 (KEY_TOUCHPAD_ON)
    Event code 532 (KEY_TOUCHPAD_OFF)
  Event type 2 (EV_REL)
  Event type 4 (EV_MSC)
Properties:
  Property type 20 (EV_REP)
    Property code 0 (REP_DELAY)
      Value    250
    Property code 1 (REP_PERIOD)
      Value     33
Testing ... (interrupt to exit)
Event: time 1415532886.309641, type 1 (EV_KEY), code 2 (KEY_1), value 1
Event: time 1415532886.309641, -------------- SYN_REPORT ------------
Event: time 1415532886.309652, type 1 (EV_KEY), code 2 (KEY_1), value 0
Event: time 1415532886.309652, -------------- SYN_REPORT ------------
Event: time 1415532886.854810, type 1 (EV_KEY), code 3 (KEY_2), value 1
Event: time 1415532886.854810, -------------- SYN_REPORT ------------
Event: time 1415532886.854821, type 1 (EV_KEY), code 3 (KEY_2), value 0
Event: time 1415532886.854821, -------------- SYN_REPORT ------------
Event: time 1415532887.364718, type 1 (EV_KEY), code 4 (KEY_3), value 1
Event: time 1415532887.364718, -------------- SYN_REPORT ------------
Event: time 1415532887.364729, type 1 (EV_KEY), code 4 (KEY_3), value 0
Event: time 1415532887.364729, -------------- SYN_REPORT ------------
^Cxbmc@xbmc:~$


ir_disabled=1 ist dem Treiber herzlich egal. Gibt es sonst noch eine Idee wie man diesen IR-Empfänger komplett deaktivieren kann?


Übrigens: Auch first_adapter=X funktioniert nicht, wenn X=1 ist. x-mal getestet, ich spare mir die Mühe hier Logs dafür einzustellen.



Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8355
    • Profil anzeigen
Re:Sundtek Fernbedienung wird immer wieder geladen
« Antwort #5 am: November 09, 2014, 02:18:47 Nachmittag »
Sobald du eine Seriennummer eines Tuners in der Konfiguration hast musst du ir_disabled in die Sektion der Seriennummer für den jeweiligen Tuner stecken.

Es könnte ja sein das du mehrere Tuner hast und nur einen IR Empfänger abschalten möchtest.
Failure is a good thing! I'll fix it

Cheese

  • Newbie
  • *
  • Beiträge: 15
    • Profil anzeigen
Re:Sundtek Fernbedienung wird immer wieder geladen
« Antwort #6 am: November 10, 2014, 10:42:52 Nachmittag »
Aha, soso. Und ist das auch irgendwo dokumentiert?

Also hier

http://wiki.sundtek.de/index.php?title=TreiberKonfiguration

finde ich dazu keinen Hinweis. Da steht ir_disabled in der "Global Section". In der "Section for adapter with [SERIALNUMBER]" kann ich dazu nichts finden.

Und wenn ihr da schonmal aufräumt (aufräumen solltet  ::) ), dann könntet ihr auch den Kommentar zu loglevel anpassen: Ist es nun "full" oder "max"?