Autor Thema: czap bringt Treiber/Stick zum Absturz  (Gelesen 2927 mal)

BloodOfMe

  • Newbie
  • *
  • Beiträge: 4
    • Profil anzeigen
czap bringt Treiber/Stick zum Absturz
« am: Dezember 17, 2012, 01:23:21 Nachmittag »
Hallo,

nach dem ich mit einem VDR Probleme beim Tuning hatte, habe ich versucht mit einfacheren mitteln das Tuning zu testen:

Dazu habe ich eine channels.conf für czap erstellt und anschließend versucht tunen:

bloodofme@mini:~$ cat .czap/channels.conf | grep ZDF
ZDF HD(ZDFvision):450000000:INVERSION_AUTO:6900000:FEC_NONE:QAM_256:6110:6122:11110
ZDF(ZDFvision):450000000:INVERSION_AUTO:6900000:FEC_NONE:QAM_256:110:125:28006
3sat(ZDFvision):450000000:INVERSION_AUTO:6900000:FEC_NONE:QAM_256:210:225:28007
KiKA(ZDFvision):450000000:INVERSION_AUTO:6900000:FEC_NONE:QAM_256:310:325:28008
ZDFinfo(ZDFvision):450000000:INVERSION_AUTO:6900000:FEC_NONE:QAM_256:610:625:28011
zdf_neo(ZDFvision):450000000:INVERSION_AUTO:6900000:FEC_NONE:QAM_256:660:675:28014
zdf.kultur(ZDFvision):450000000:INVERSION_AUTO:6900000:FEC_NONE:QAM_256:1110:1125:28016

bloodofme@mini:~$ sudo czap -H -x -n "ZDF(ZDFvision)"
using '/dev/dvb/adapter0/frontend0' and '/dev/dvb/adapter0/demux0'
reading channels from file '/home/bloodofme/.czap/channels.conf'
 25 ZDF(ZDFvision):450000000:INVERSION_AUTO:6900000:FEC_NONE:QAM_256:110:125:28006
 25 ZDF(ZDFvision): f 450000000, s 6900000, i 2, fec 0, qam 5, v 0x6e, a 0x7d, s 0x6d66
ERROR: failed opening '/dev/dvb/adapter0/demux0' (No such device or address)

Meldung im Syslog:
Dec 17 12:05:27 mini kernel: [  852.063804] mediasrv[1098]: segfault at 39 ip 08067337 sp b2af3f60 error 4 in mediasrv[8048000+58000]

Treiberlog:
2012-12-17 12:04:02 [1002] demodulator successfully attached (DVBC)!
2012-12-17 12:04:02 [1002] Allocation using pg for type 65678
2012-12-17 12:04:02 [1002] requesting to attach tuner(s) now
2012-12-17 12:04:04 [1002] registering: adapter0/0
2012-12-17 12:04:04 [1002] registered virtual: /dev/dvb/adapter0/frontend0
2012-12-17 12:04:04 [1002] registered virtual: /dev/dvb/adapter0/demux0
2012-12-17 12:04:04 [1002] registered virtual: /dev/dvb/adapter0/dvr0
2012-12-17 12:04:04 [1002] Allocation using pg for type 16
2012-12-17 12:04:04 [1002] registered virtual: /dev/video1
2012-12-17 12:04:04 [1002] registered virtual: /dev/radio0
2012-12-17 12:04:04 [1002] registered virtual: /dev/rds0
2012-12-17 12:04:04 [1002] registered virtual: /dev/vbi0
2012-12-17 12:04:04 [1002] Setting RC Protocol to NEC
2012-12-17 12:04:04 [1002] registered virtual: /dev/mediainput0
2012-12-17 12:04:04 [1002] Remote Control Layout: 0
2012-12-17 12:04:04 [1002] Using flat remote control layout
2012-12-17 12:04:04 [1002] IR Setup
2012-12-17 12:04:04 [1002] Infrared support enabled on startup
2012-12-17 12:04:04 [1002] Registering OSS emulation
2012-12-17 12:04:04 [1002] registered virtual: /dev/dsp0
2012-12-17 12:04:04 [1002] Trying to load ffmpeg codecs
2012-12-17 12:04:04 [1002] could not load libavutil.so
2012-12-17 12:04:04 [1002] could not load libswscale.so
2012-12-17 12:04:04 [1002] could not load libavcodec.so
2012-12-17 12:04:04 [1002] could not load libavformat.so
2012-12-17 12:04:04 [1002] AnalogTV encoding won't be possible in driver's side
2012-12-17 12:04:04 [1002]
2012-12-17 12:04:04 [1002] Sundtek MediaTV Driver loaded. This driver is licensed for non-commercial use
2012-12-17 12:04:04 [1002] with Sundtek MediaTV only
2012-12-17 12:04:04 [1002] Driver loaded within 9908 milliseconds
2012-12-17 12:04:04 [1002] Serial(0): U120608113320
2012-12-17 12:04:04 [1063] RC: IR Event /dev/input/event9
2012-12-17 12:04:04 [1072] RC: IR Event /dev/input/event9
2012-12-17 12:04:29 [1002] Enabling standby
2012-12-17 12:05:26 [1002] SETTING DVB-C
2012-12-17 12:05:26 [1002] Setting Frequency: 450000000
2012-12-17 12:05:26 [1002] Setting Symbolrate: 6900000
2012-12-17 12:05:26 [1002] Setting Modulation: 5
2012-12-17 12:05:27 [1002] TS Sync byte not aligned, realigning stream (0 // 0)
2012-12-17 12:05:27 [1003] problem reading data in service processor...
2012-12-17 12:05:27 [1099] RC: detached remote control

Danach muss ich den Treiber erneut starten..

Das System ist ein frisches, aktuelles Ubuntu 12.04.1 mit den Netinstall-Treibern von heute morgen. Habe dieses System extra aufgesetzt weil ich auf einem anderen System das gleiche Problem hatte und die Hardware ausschließen wollte.

Bitte um Hilfe.

Gruß
BloodOfMe

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8330
    • Profil anzeigen
Re:czap bringt Treiber/Stick zum Absturz
« Antwort #1 am: Dezember 17, 2012, 06:17:43 Nachmittag »
Melde dich ggf via Skype (sundtek) oder Webchat (http://chat.sundtek.de ).

Dieses Problem ist nicht nachvollziehbar, insbesondere da wir auf Ubuntu 12.04.1 arbeiten, und dieses Problem noch nie hatten.
czap läuft bei uns ohne irgendwelche Probleme auf 32 und 64bit.
Failure is a good thing! I'll fix it

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8330
    • Profil anzeigen
Re:czap bringt Treiber/Stick zum Absturz
« Antwort #2 am: Dezember 18, 2012, 09:47:07 Nachmittag »
Der USB Port liefert zu wenig Strom, man sieht das in der Logfile dadurch das die Kommunikation mit dem Stick teilweise gestört ist.

Durch das anschließen des aktiven USB Hubs hat sich das Problem anscheinend gelöst. Der Treiber wurde zusätzlich abgesichert damit der Treiber trotz zuwenig Strom nicht mehr an der Stelle abstürzen kann.

Danke soweit für das Feedback!
Failure is a good thing! I'll fix it