Autor Thema: Nach Treiberinstallation geht nichts mehr  (Gelesen 3136 mal)

pampa

  • Newbie
  • *
  • Beiträge: 22
    • Profil anzeigen
Nach Treiberinstallation geht nichts mehr
« am: November 09, 2012, 12:57:06 Nachmittag »
Hallo,

ich habe auf 2 Rechnern nach einer Installation des Sky Ultimate Treiber nach einem Neustart keine Möglichkeit mehr das System zu benutzen.

Rechner:  Samsung NC10 und ein ASUS AT5IONT-i mit Sabayon 10 KDE (einmal 32Bit, einmal 64 Bit)

Auf beiden Rechnern erhalte ich das gleiche Verhalten: das Sabayon läuft super stabil und flüssig. Updates alle verarbeitet (Kernel 3.5). Solbald ich den Treiber installiere wird der auch völlig korrekt installiert und gestartet. Ein Neustart bleibt bei einer Verwendung von LVM schon beim Herunterfahren stehen mit dem Hinweis: "Filesystem in use" und bleibt dort bis zu einem harten Reset hängen. Danach bleibt das System beim Neustart an der Stelle mit einer Konsole stehen wo KDM starten sollte. Eine Eingabeaufforderung erscheint auf der man sich machmal einloggen kann. startx klappt auch nicht mehr. Die Xorg.conf ist ok...das System unbenutzbar.
Auch ein Wechsel auf ein Standart Partitionslayout hilft nicht. Dadurch fährt der Rechner zwar korrekt herunter, aber der Neustart zeigt das gleiche System.

Vorher hatte ich Opensuse und Kubuntu ohne Probleme. Es muss an Sabayon/Gentoo liegen, die irgendwie mit dem Treiber nicht klar kommen.

Sorry für die lange Fehlerbeschreibung, aber ich möchte gerne Sabayon/Gentoo benutzen. Evtl muss der Treiber hier anders installiert werden? Die Installation zeigt im Terminal jedenfalls das Selbe wie bei Kubuntu und Co.

Danke
« Letzte Änderung: November 09, 2012, 06:06:10 Nachmittag von pampa »

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8317
    • Profil anzeigen
Re:Nach Treiberinstallation geht nichts mehr
« Antwort #1 am: November 11, 2012, 03:08:00 Nachmittag »
Es liegt wohl daran das die Installation des Systemd/Udev Services nach /usr/lib Probleme bereitet, /usr/lib ist ursprünglich ein Symlink, dieser wird beim Entpacken durch ein richtiges Verzeichnis überschrieben. Der Installer muss wohl etwas abgeändert werden.

Im Grunde gibt es kein Problem mit dem Treiber auf dem System.

Lennart Poettering bereitet uns stets eine Menge Probleme mit seinen Projekten (Pulseaudio Bugs wobei wir wieder Workarounds einarbeiten mussten), auch Systemd benötigt wieder Workarounds da einige Versionen fehlerhaft sind.
In diesem Fall sorgt der Workaround für den Systemd Bug für Probleme
« Letzte Änderung: November 12, 2012, 03:55:14 Nachmittag von Sundtek »
Failure is a good thing! I'll fix it

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8317
    • Profil anzeigen
Re:Nach Treiberinstallation geht nichts mehr
« Antwort #2 am: November 11, 2012, 05:43:22 Nachmittag »
Der Installer wurde aktualisiert (der Systemd Workaround wird nun im Allgemeinen anders installiert), das Ganze sollte auf Sabayon nun kein Problem mehr sein.
Failure is a good thing! I'll fix it

pampa

  • Newbie
  • *
  • Beiträge: 22
    • Profil anzeigen
Re:Nach Treiberinstallation geht nichts mehr
« Antwort #3 am: November 12, 2012, 02:11:22 Nachmittag »
Spitze, läuft!

Danke!