Autor Thema: Not detecting channels on Qnap  (Gelesen 3745 mal)

jteeuw

  • Newbie
  • *
  • Beiträge: 24
    • Profil anzeigen
Not detecting channels on Qnap
« am: Oktober 31, 2012, 09:33:31 Nachmittag »
Hello,

I just installed my suntek on a Qnap TS-119II and the problem that i have is the tuner is not detecting any channels ( see log )

 
2012-10-31 20:18:55 [6036] Sundtek MediaTV Driver loaded. This driver is licensed for non-commercial use
2012-10-31 20:18:55 [6036] with Sundtek MediaTV only
2012-10-31 20:18:55 [6036] Driver loaded within 7107 milliseconds
2012-10-31 20:18:55 [6036] Serial(0): U111215143813
2012-10-31 20:18:55 [6036] Initial devicescan done, switching detection mode
2012-10-31 20:18:55 [6036] received device attach message
2012-10-31 20:18:55 [6037] notify request: media device connected
2012-10-31 20:18:58 [6036] Submitting 4 failed (112800)
2012-10-31 20:18:58 [6036] RV: -1
2012-10-31 20:18:58 [6036] ERROR: Cannot allocate memory
2012-10-31 20:18:58 [6036] Error enabling USB transfer
2012-10-31 20:18:58 [6036] Setting Frequency: 164000000
2012-10-31 20:18:58 [6036] Setting Symbolrate: 6900000
2012-10-31 20:18:58 [6036] Setting Modulation: 3
2012-10-31 20:18:59 [6036] Submitting 5 failed (112800)
2012-10-31 20:18:59 [6036] RV: -1
2012-10-31 20:18:59 [6036] ERROR: Cannot allocate memory
2012-10-31 20:18:59 [6036] Error enabling USB transfer
2012-10-31 20:18:59 [6036] Submitting 4 failed (112800)
2012-10-31 20:18:59 [6036] RV: -1
2012-10-31 20:18:59 [6036] ERROR: Cannot allocate memory
2012-10-31 20:18:59 [6036] Error enabling USB transfer
2012-10-31 20:18:59 [6036] Submitting 4 failed (112800)
2012-10-31 20:18:59 [6036] RV: -1
2012-10-31 20:18:59 [6036] ERROR: Cannot allocate memory
2012-10-31 20:18:59 [6036] Error enabling USB transfer
2012-10-31 20:18:59 [6036] Submitting 4 failed (112800)
2012-10-31 20:18:59 [6036] RV: -1
2012-10-31 20:18:59 [6036] ERROR: Cannot allocate memory
2012-10-31 20:18:59 [6036] Error enabling USB transfer
2012-10-31 20:19:00 [6036] Submitting 4 failed (112800)
2012-10-31 20:19:00 [6036] RV: -1
2012-10-31 20:19:00 [6036] ERROR: Cannot allocate memory
2012-10-31 20:19:00 [6036] Error enabling USB transfer
2012-10-31 20:19:00 [6036] Current mode: Media Digital TV
2012-10-31 20:19:00 [6036] Requested mode: Media Analog TV
2012-10-31 20:19:00 [6036] PID: 6174
2012-10-31 20:19:00 [6036] Application: ld-linux.so.3
2012-10-31 20:19:00 [6036] current mode != requested mode .. but there are still users there! 2
2012-10-31 20:19:01 [6036] Channel found (164000000)

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8216
    • Profil anzeigen
Re:Not detecting channels on Qnap
« Antwort #1 am: Oktober 31, 2012, 10:01:06 Nachmittag »
Hmm, try to patch the firmware, run following command on the terminal:
Zitat
/opt/bin/mediaclient --dtvtransfermode=bulk

Afterwards reconnect the device, seems like there's some bug on the NAS system (although as mentioned you can try to work around with some features of the stick)
Failure is a good thing! I'll fix it

jteeuw

  • Newbie
  • *
  • Beiträge: 24
    • Profil anzeigen
Re:Not detecting channels on Qnap
« Antwort #2 am: Oktober 31, 2012, 10:13:51 Nachmittag »
Thank you for the awnser, but how do i flash the stick ?

Hmm, try to patch the firmware, run following command on the terminal:
Zitat
/opt/bin/mediaclient --dtvtransfermode=bulk

Afterwards reconnect the device, seems like there's some bug on the NAS system (although as mentioned you can try to work around with some features of the stick)

Sundtek

  • Administrator
  • Hero Member
  • *****
  • Beiträge: 8216
    • Profil anzeigen
Re:Not detecting channels on Qnap
« Antwort #3 am: Oktober 31, 2012, 10:34:24 Nachmittag »
Just run that command

Zitat
/opt/bin/mediaclient --dtvtransfermode=bulk

the driver will do everything for you
Failure is a good thing! I'll fix it