Beiträge anzeigen

Diese Sektion erlaubt es ihnen alle Beiträge dieses Mitglieds zu sehen. Beachten sie, dass sie nur solche Beiträge sehen können, zu denen sie auch Zugriffsrechte haben.


Nachrichten - Want2Play

Seiten: [1] 2
1
Yes with pleasure.

I use OSMC whith KODI on my Raspberry Pi2. Some functions are available with the native remote, like the cursors touch, the volume +/- when I watch a record, but not the "OK"/Return.

I'd like to have a full integration of the remote for all Kodi's features.

I've tested your advice on this subject (http://support.sundtek.com/index.php/topic,2014.0.html) without success, prabably because I havent' acquired enough knowledge on this subject.

I'll appreciate very much your help.

Maybe in an other thread, because this thread is, in my opion, finished. This thread "Raspberry PI2 + Openelec 6.0 + MediaPro III + VDR + Remote command"(http://support.sundtek.com/index.php/topic,2014.0.html) can be used or a new thread could be open. As you want :)

2
Now, if I want finish my multimedia center, It would be perfect to have the remote command to control it ;)
I reactive my other thread.
In my case there is some success with TV remote control(CEC support on Pi) :-\
I've desactived the CEC support because when I stop the TV, the Raspberry stop too.

3
Hi, sorry if my explanation wasn't clear, there is a confusion.

The software update is an OpenElec's update, NOT a Sundtek's update. There is NO trouble with your software :)

My last issue to take enough time to make working de remote command, but it's an other story ;-)

4
Hello,

I have two problem after some hours : the system freeze or VDR (VNSI) say "no data" and it is impossible to access at a channel.

The configuration :
- Raspberry 2;
- Power 5 V / 2A;
- the MerdiaPro III is connected to a powered Hub USB;
- SD cards "SanDisk Ultra microSDXC UHS-I card 64 GB (Up to 48 MB/S)"
- Openelec 6.0.0;
- VDR backend + VDR frontend (VDSI) "Priority -1" "Demander le différé 1" , IP by default not modified 127.0.0.1;
- MediaPro configured for DVB-T with "Enable hardware PID = ON", "Enable IR Receiver = ON", "Enable suspend/resume the driver = ON";
- the last version of the Sundtek driver is used : manual update via the GUI;
- some plugins in the "Video" section;


I have a freeze of the image after some hours or it's impossible to obtain a channel.

The details now.

Problem 1 :
After some hours, 5 hours in the last case, and with a HD channel (ARTE HD) selected, the image an the sound are stopped. The image is static on the screen. Impossible to stop or change the channel. The reboot is the only solution.

Problem 2 :
Some records are scheduled by the "Guide" menu in the night and are correctly done. But in the morning, it's impossible to see a channel. The VDR frontend (VDSI) report "No data" for each channel. The reboot is the only solution.

I don't know if it's related to your hardware or software, I could post in the Openelec forum if your are not concern. I hope that you can help me.

Edit : With Overclock Turob or Pi2 or no overclock, I notice that the CPU frequency could by 100 MHz or 900 Mhz, but sometimes the frequency is 600 MHz and return to 900 or 100 MHz. The temperature is between 42 °C or 50 °C - Pi2 mode without dissipators. I can't say why.
I've try to use the "performance" option (https://www.raspberrypi.org/forums/viewtopic.php?f=29&t=128872&p=872235#p872235) : "echo performance > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor" for each CPU, but the default "ondemand" value is set at the boot time.

If I can give you some other usefull informations, ask them please.

Best regards.

The problem anymore present. Some weeks I've tested the VDR configuration, it was freezing the morning, but become operational few minutes after. This week all is operational. Since the first time, there was many software updates. For me, it's not a hardware problem, only a software problem.

Thanks.

5
Software / Re:Tvheadend and the options "Low Noise Amplifier / LNA" and "Power save"
« am: Januar 13, 2016, 05:46:12 Nachmittag »
Thanks, I'll go try the power saving.

6
Software / Tvheadend and the options "Low Noise Amplifier / LNA" and "Power save"
« am: Januar 13, 2016, 04:13:31 Nachmittag »
Hi,

I'm using :
* Sundtek MediaPro III
* Raspberry Pi 2
* 3 A / 5 V power supply
* Osmc (November 2015)
* Tvheadend
* external hard drive with power supply
* /sys/devices/system/cpu/cpu[0-9]*/cpufreq/scaling_governor in "performance" mode

In Tvheadend, for the tuner's configuration there is the options :
* Low Noise Amplifier (LNA)
* Power saving

What is the good settings for this options ?



Somewhere, I found "DiseqC", I understand that it's for the satellite (DVB-S), so nothing to do with this. I'm right or not ?

7
Software / Re:Raspberry PI2 + Openelec 6.0 + MediaPro III + VDR + Remote command
« am: Januar 13, 2016, 03:54:20 Nachmittag »
Have you some suggestions ?

For the moment, I use Osmc (November 2015). I would want to controm Kodi with the remote control.

Thanks for any help.

8
Hello,

Good news : I have an operational system - without the remote.

New configuration :
* 3 A / 5V power supply
* MediaPro III directly connected to the Raspberry
* Wifi dongle for Rii keyboard
* External hard drive with power supply
* Ethernet connexion
* Osmc version of November 2015
* Tvheadend
* without and with overcloking in "Turbo" mode defined in Osmc
* cpu working in "performance" mode

Evaluation after 48 hours and some records scheduled :
* even the problematic HD channel is accessible without freeze
* I can change of channel without freeze
* the update of EPG data is done

To be complete, I must test the later configuration : Openelec + VDR but with the 3 A power supply. I suppose that there is two possible origins : a faulty power supply or a bug in VDR or it's configuration.

I'll come back later to give the results of this tests.

Thanks for the support and the different advices.
I've updated the Raspberrypi.org forum.

Now, if I want finish my multimedia center, It would be perfect to have the remote command to control it ;)
I reactive my other thread.

9
Hi,

The "dmesg" result after boot : [    3.545659] systemd[1]: Starting Apply Kernel Variables...
[    3.564585] systemd[1]: Started Create Static Device Nodes in /dev.
[    3.567042] systemd[1]: Started Setup Timezone data.
[    3.582316] systemd[1]: Started Apply Kernel Variables.
[    3.616943] systemd[1]: Started Journal Service.
[    3.711825] systemd-journald[174]: Received request to flush runtime journal from PID 1
[    5.003402] Console: switching to colour dummy device 80x30
[    5.348710] gpiomem-bcm2835 3f200000.gpiomem: Initialised: Registers at 0x3f200000
[    5.926446] random: nonblocking pool is initialized
[    5.937258] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup
[    5.937821] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[    7.220110] input: Sundtek Ltd. Remote Control as /devices/virtual/input/input2
[    7.468839] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[    7.472313] smsc95xx 1-1.1:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0xC5E1
[   10.980516] usb 1-1.2: usbfs: process 456 (mediasrv) did not claim interface 0 before use
[   11.048536] usb 1-1.4: new high-speed USB device number 6 using dwc_otg
[   11.187051] usb 1-1.4: New USB device found, idVendor=18a5, idProduct=0400
[   11.187077] usb 1-1.4: New USB device strings: Mfr=2, Product=3, SerialNumber=1
[   11.187087] usb 1-1.4: Product: USB 3.0 Desktop HD
[   11.187097] usb 1-1.4: Manufacturer: Verbatim
[   11.187107] usb 1-1.4: SerialNumber: 201507014000036D
[   11.188147] usb-storage 1-1.4:1.0: USB Mass Storage device detected
[   11.188499] scsi host0: usb-storage 1-1.4:1.0
[   12.191349] scsi 0:0:0:0: Direct-Access     ST2000DM 001-1ER164       0    PQ: 0 ANSI: 6
[   12.194975] sd 0:0:0:0: [sda] 3907029168 512-byte logical blocks: (2.00 TB/1.81 TiB)
[   12.196443] sd 0:0:0:0: [sda] Write Protect is off
[   12.196483] sd 0:0:0:0: [sda] Mode Sense: 43 00 00 00
[   12.197314] sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
[   12.226355]  sda: sda1 sda2 sda3
[   12.234105] sd 0:0:0:0: [sda] Attached SCSI disk
[   12.996612] EXT4-fs (sda2): mounted filesystem with ordered data mode. Opts: (null)
[   13.194671] EXT4-fs (sda3): mounted filesystem with ordered data mode. Opts: (null)
[   13.459166] EXT4-fs (sda1): mounted filesystem with ordered data mode. Opts: (null)
[   17.649455] usb 1-1.2: usbfs: process 569 (mediasrv) did not claim interface 2 before use


This is the head of my drivers's configuration : # cat /storage/.kodi/userdata/addon_data/driver.dvb.sundtek-mediatv/sundtek.conf
#
# sundtek.conf
#

loglevel=min

# enable HW PID filter (default on for RPi)
use_hwpidfilter=on

# enable listening on network
enablenetwork=off

# Lowest adapter number to start with, e.g. /dev/dvb/adapter5/frontend0
first_adapter=0

# Infrared Control Support is disabled/enabled
ir_disabled=0

# trigger device_attach only once if more devices is used
bulk_notification=on

# Get adapter serial number with mediaclient -e
# or look into file adapter_serial_number.txt
#[SERIALNUMBER]
# Choose initial DVB mode for hybrid DVB-T/DVB-C devices only
#initial_dvb_mode=[DVBC|DVBT]
# default mode is DVB-C, we must set it to DVB-T if needed
#initial_dvb_mode=DVBT

#[U123456789012]
#initial_dvb_mode=DVBT

#[NETWORK]
#device=192.168.1.1:0
#device=192.168.1.1:1

[U151204174522]
initial_dvb_mode=DVBT


I'm connected to the chat - 19 h 50

10
rasp1:~ # mediaclient --cpucheck
Sundtek CPU Check

cpu0:
   current scheduler: performance
   available schedulers: powersave ondemand performance
   to change the scheduler you might run following command:

   echo performance > /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

cpu1:
   current scheduler: performance
   available schedulers: powersave ondemand performance
   to change the scheduler you might run following command:

   echo performance > /sys/devices/system/cpu/cpu1/cpufreq/scaling_governor

cpu2:
   current scheduler: performance
   available schedulers: powersave ondemand performance
   to change the scheduler you might run following command:

   echo performance > /sys/devices/system/cpu/cpu2/cpufreq/scaling_governor

cpu3:
   current scheduler: performance
   available schedulers: powersave ondemand performance
   to change the scheduler you might run following command:

   echo performance > /sys/devices/system/cpu/cpu3/cpufreq/scaling_governor


For the log, I'll try it tomorrow.

For the "chat", during the week, I can chat after 18h30, it's not easy for you. And you don't work the week-end, I suppose.

11
Have you made some tests to use a PVR/DVR with the Raspberry and Osmc or Openelec ?

I use VDR because it is available under Osmc and Openelec. I can't see the records of HD channel with Raspbian. I'm ready to change the solution, but I 'd like keep the Raspberry and your tuner.
Have you a idea ?


12
This morning, I've selected a HD channel. Few seconds of pictures and freeze because the update of the EPG data is done, KODI is active, channel unselected. Later, channel selected, but freeze and message from "VDR VNSI" : "no data", after unfreeze and freeze again.

This situation is better than the previous one :
* the Kodi interface is always active;
* few seconds of a channel can be view.

But the freeze because the update of EPG data is strange. The update is programmed to be done every 120 minutes :
* why an update only when I select a channel ? (contact lost during the night with the tuner ?)

I've two messages generated during the night, the two last lines :
[    2.702070] systemd[1]: Started Create Static Device Nodes in /dev.
[    2.722737] systemd[1]: Started Setup machine-id.
[    2.825279] systemd[1]: Started udev Coldplug all Devices.
[    2.827718] systemd[1]: Started Mounting swapfile.
[    2.986070] systemd[1]: Reached target Swap.
[    2.986245] systemd[1]: Starting Swap.
[    2.989938] systemd[1]: Starting Journal Service...
[    2.991624] systemd[1]: Reached target Local File Systems (Pre).
[    2.991924] systemd[1]: Starting Local File Systems (Pre).
[    3.000920] systemd[1]: Starting Setup Timezone data...
[    3.003679] systemd[1]: Reached target Local File Systems.
[    3.003912] systemd[1]: Starting Local File Systems.
[    3.004588] systemd[1]: Started Rebuild Journal Catalog.
[    3.006250] systemd[1]: Started Debug /var/log relink.
[    3.536835] systemd[1]: Started Load Kernel Modules.
[    3.538359] systemd[1]: Started Setup Timezone data.
[    3.581465] systemd[1]: Started Journal Service.
[    3.665422] systemd-journald[178]: Received request to flush runtime journal from PID 1
[    4.958336] gpiomem-bcm2835 3f200000.gpiomem: Initialised: Registers at 0x3f200000
[    5.027704] Console: switching to colour dummy device 80x30
[    5.734787] smsc95xx 1-1.1:1.0 eth0: hardware isn't capable of remote wakeup
[    5.735578] random: nonblocking pool is initialized
[    5.735654] IPv6: ADDRCONF(NETDEV_UP): eth0: link is not ready
[    7.321334] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[    7.327938] smsc95xx 1-1.1:1.0 eth0: link up, 100Mbps, full-duplex, lpa 0xC5E1
[    7.376668] input: Sundtek Ltd. Remote Control as /devices/virtual/input/input2
[   11.077757] usb 1-1.5: usbfs: process 415 (mediasrv) did not claim interface 0 before use
[  265.655892] usb 1-1.5: usbfs: process 445 (mediasrv) did not claim interface 2 before use
[ 4534.718318] usb 1-1.5: USB disconnect, device number 5
[ 4534.924882] usb 1-1.5: new high-speed USB device number 6 using dwc_otg
[ 4535.021162] usb 1-1.5: New USB device found, idVendor=2659, idProduct=1210
[ 4535.021189] usb 1-1.5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 4535.021200] usb 1-1.5: Product: MediaTV Pro III (EU)
[ 4535.021210] usb 1-1.5: Manufacturer: Sundtek
[ 4535.021220] usb 1-1.5: SerialNumber: U151204174522
[ 4535.958485] input: Sundtek Ltd. Remote Control as /devices/virtual/input/input3
[ 4539.589023] usb 1-1.5: usbfs: process 415 (mediasrv) did not claim interface 0 before use
[ 4576.247940] usb 1-1.5: usbfs: process 854 (mediasrv) did not claim interface 2 before use


Nothing to do with the driver's option "suspend/resume" setted "ON" ?


13
Bravo ! Good diagnostic !

This evening I've power on my Raspberry and my HUB. But VDR proclaims "no data" because my HUB's power supply is dead  :(

I've plugged the tuner directly on the Raspberry and it's WORKING !!  :)

For change the "scaling_governor" the solution is :
cd /storage/.config
touch autostart.sh
chmod a+x autostart.sh
vi autostart.sh

This is my "autostart.sh"
(
  for gov in /sys/devices/system/cpu/cpu[0-9]*/cpufreq/scaling_governor
  do echo "performance" > $gov
  done
) &

Two references :
* http://openelec.tv/forum/148-usage/77654-setting-cpu-scaling-governor-to-performance
* http://wiki.openelec.tv/index.php?title=Autostart.sh

About of your demands
Zitat
First of all try to connect the tuner directly not via the USB hub.
All paper that I've read said to use a HUB to connect the tuner... Maybe for the previous version of the Raspberry Pi2 ???


But, don't be too optimistic, few minutes it's not enough to validate the solution. I'm going to schedule a record and see tomorrow if I can see a channel.

If this is the solution, the next step is to have the remote control usable  ;)

14
I'm waiting a 5V / 3 A power supply for the Raspberry... We'll see if it's the only problem - I hope that.

15
This time, there is no freeze, but it was impossible to see a channel.

My HUB is a "DIGITUS / 4-Port USB 2.0 / Design HUB / DA-70220" with a power supply 5 V / 2 A. There is only the MediaPro connected to the HUB, nothing else.

Connected to the Raspberry, I have a keyboard and a Wifi dongle for a "Rii 8 " Keyboard - http://www.kubii.fr/peripheriques-usb-rapsberry-pi/671-mini-clavier-rii-mini-i8-azerty-6952917708002.html. But I kept the keyboard "power off" when I don't use it.


Zitat
I guess it has something to do with some power failure, either the USB hub or the RPI might not have enough power.
If it is the HUB, what's the power necessary for the MediaPro III?

Seiten: [1] 2