Willkommen Gast. Bitte einloggen oder registrieren.

Einloggen mit Benutzername, Passwort und Sitzungslänge

 
Erweiterte Suche

17818 Beiträge in 2134 Themen- von 3035 Mitglieder - Neuestes Mitglied: Pazzeo

Juni 21, 2018, 09:49:15 pm
Sundtek Support ForumDeutschSundtek MediaTV ProVerwendung auf OpenWRT über WLAN
Seiten: [1]
Drucken
Autor Thema: Verwendung auf OpenWRT über WLAN  (Gelesen 401 mal)
Tomate
Newbie
*
Beiträge: 3


Profil anzeigen
« am: März 26, 2018, 11:43:06 pm »

Hallo Sundtek Team,

erstmal vorweg: Schönen Stick, den ihr da entwickelt habt, läuft bei mir seit einigen Jahren einwandfrei Smiley

Was bei mir im Wohnzimmer nur etwas unpraktisch ist, dass die Kabeldose genau an der gegenüberliegenden Wand wie mein PC ist, ich hab also ein Kabel am Boden liegen, und an einer Stelle lässt es sich nicht vermeiden, dass es etwas im Weg liegt. Deshalb hatte ich folgende Idee:
Auf einem kleinen Router OpenWRT und den Treiber installieren und dann über mein WLAN darauf zugreifen. Hab auch noch etwas ungenutzte Hardware rumliegen und das Ganze versucht damit zu realisieren, leider erfolglos. Der Router hat ne MIPS (mipsel) Architektur, die ja prinzipiell unterstützt wird, aber der Installer meinte das System wird nicht unterstützt. Hab dann noch den Treiber direkt runtergeladen, aber das lief dann auch nicht.
Ein alternativer Versuch war dann noch via USB over IP das ohne Treiberinstallation auf dem Router an meinen PC weiterzuleiten. Damit wurde der Stick dann zwar vom PC erkannt, dann aber nur als USB1.1 und funktioniert hat es letztendlich auch nicht.

Es kann natürlich gut sein, dass die Hardware zu schwach ist (RT3050F mit 320MHz und 32MB RAM). Wenn das Ganze aber prinzipiell funktionieren würde dann würde ich mir entsprechend bessere Hardware zulegen. Ich fände das nämlich eine recht elegante Lösung Zwinkernd
Wie sieht es denn aus, was bräuchte man eigentlich so als Mindestvoraussetzung bezüglich Prozessorleistung/RAM? Flash ist kein Problem, mit extroot kann ich da ja genug erweitern.
Gespeichert
Sundtek
Administrator
Hero Member
*****
Beiträge: 7674


Profil anzeigen
« Antworten #1 am: März 27, 2018, 07:11:57 am »

Streamen sollte da kein Problem sein, aber EPG müsste ausgeschalten werden bei unserem Streamingserver (denn das braucht Arbeitsspeicher).
Du kannst ja mal versuchen den Treiber + Streamingserver auf dem System zu installieren.

Treiberinstallation:
http://support.sundtek.com/index.php/topic,2.0.html
bzw.
Zitat
cd /tmp
wget http://sundtek.de/media/sundtek_netinst.sh
chmod 777 sundtek_netinst.sh
./sundtek_netinst.sh
Der Streaminserver ist recht einfach:
http://support.sundtek.com/index.php/topic,2075.0.html
bzw.
/opt/bin/mediaclient --installstreamer

(das klappt jetzt nur wenn /opt/bin beschreibbar ist ansonsten melde dich einfach im Chat dann können wir das kurz gemeinsam durchgehen und eventuell die Installationsroutine für den Streamingserver etwas anpassen).
Gespeichert

Sundtek Ltd. Support Engineer
Tomate
Newbie
*
Beiträge: 3


Profil anzeigen
« Antworten #2 am: März 27, 2018, 11:42:50 pm »

Danke schon mal für die schnelle Reaktion Smiley

Mein Problem ist ja, dass das Installationsscript meldet: "Your system is currently unsupported".
Aus dem Script habe ich mir auch den Direktlink zu der mipsel Treiberversion rausgesucht und diesen auf dem System entpackt. Der Aufruf von mediaclient gab dann nur eine Fehlermeldung "not found" und den Code -1. Muss ich vielleicht noch sysctl zuvor etwas mitteilen oder sonstige Sachen konfigurieren?
Gespeichert
Sundtek
Administrator
Hero Member
*****
Beiträge: 7674


Profil anzeigen
« Antworten #3 am: März 28, 2018, 06:01:26 am »

Hi,

schau mal im Chat vorbei

http://chat.sundtek.de

Es kann sein das /tmp es nicht erlaubt Skripte auszuführen! (noexec Flag gesetzt).
Gespeichert

Sundtek Ltd. Support Engineer
Tomate
Newbie
*
Beiträge: 3


Profil anzeigen
« Antworten #4 am: April 01, 2018, 12:44:23 am »

Mit dem Chat muss ich mal sehen wann ich es schaffe zu ner "normalen" Zeit hier rein zu schauen Zwinkernd


Ich habe inzwischen aber wohl herausgefunden warum der Installer das System nicht unterstützt. OpenWRT verwendet seit einiger Zeit nicht mehr die uClibc, sondern die musl libc:
https://lists.openwrt.org/pipermail/openwrt-devel/2015-June/033702.html

Ich habe das aktuellste Release (Reboot 17.01.4) installiert, und diese verwendet die musl libc. Jetzt werde ich mal ein älteres Release ausprobieren, das noch mit der uClibC arbeitet.

Was mit dem System aber funktioniert ist, den Stick mit USB over IP an den PC zu tunneln. Der Grund warum das zuvor nicht funktionierte war, weil ich den Stick an einem alten USB1.0-Hub angeschlossen hatte. Mit einem 2.0 Hub funktioniert es jetzt.
Gespeichert
Sundtek
Administrator
Hero Member
*****
Beiträge: 7674


Profil anzeigen
« Antworten #5 am: April 01, 2018, 05:57:42 am »

Hi,

wie erwähnt schau mal rein in den Chat wir sind auch zu nicht so üblicheren Zeiten online.
Einen Musl Build zu erstellen wäre kein Problem.
Gespeichert

Sundtek Ltd. Support Engineer
Seiten: [1]
Drucken
Gehe zu: