Willkommen Gast. Bitte einloggen oder registrieren.

Einloggen mit Benutzername, Passwort und Sitzungslänge

 
Erweiterte Suche

17655 Beiträge in 2111 Themen- von 3011 Mitglieder - Neuestes Mitglied: peter_pan

Februar 20, 2018, 09:16:44 pm
Sundtek Support ForumDeutschSundtek Streaming ServerSundtek Streaming Server (Deutsch / German)
Seiten: 1 ... 14 15 [16] 17 18 ... 20
Drucken
Autor Thema: Sundtek Streaming Server (Deutsch / German)  (Gelesen 60400 mal)
Adolar
Newbie
*
Beiträge: 5


Profil anzeigen
« Antworten #225 am: Oktober 01, 2017, 01:46:01 pm »

Hallo Sundtek-Team,

ich habe mal bei MiniDVBLinux Distribution (MLD) https://www.minidvblinux.de nachgehakt,
ob der Sundtek Streaming Server vielleicht mit in die Pakete aufgenommen wird.
Claus Muus antwortete mir:

Zitat
Wie gesagt, der Server ist bei den MLD Paketen mit dabei. Du musst Dir lediglich ein Init Script erstellen, das beim Booten den Start ausführt.
Welche Vorteile bietet der sundtek Streaming Server denn gegenüber den von der MLD angebotenen Techniken?
Claus

Ist der Server, an dem ihr gerade so fleißig arbeitet, wirklich dort mit dabei?
Oder nur der Client, der Treiber?

Und wie könnte ich ihn mit einem Script zum Starten bringen? Ist er nicht schon nach der Installation oder einem Neustart automatisch aktiv?
Gespeichert
Sundtek
Administrator
Hero Member
*****
Beiträge: 7605


Profil anzeigen
« Antworten #226 am: Oktober 01, 2017, 02:33:54 pm »

Hallo,

Ich weiß nicht ob der dort dabei ist.

Derzeit haben wir leider auch noch keine Zeit das weiter zu überprüfen, in der kommenden Woche sind eine Reihe von Updates geplant (und auch der Streamingserver für Windows).
Gegen Mitte Oktober können wir das auch besser mit den verschiedenen Image-Projekten absprechen.
Gespeichert

Sundtek Ltd. Support Engineer
Sundtek
Administrator
Hero Member
*****
Beiträge: 7605


Profil anzeigen
« Antworten #227 am: Oktober 02, 2017, 08:40:33 am »

Es wird hier erst mal empfohlen den aktuellen Treiber ab 1. Oktober 2017 und aktuellen Streamingserver zu installieren.
Im Treiber sind Schnittstellen vorhanden die vom Streamingserver verwendet werden.
Gespeichert

Sundtek Ltd. Support Engineer
Adolar
Newbie
*
Beiträge: 5


Profil anzeigen
« Antworten #228 am: Oktober 08, 2017, 09:26:10 am »

Hallo,

der Neustart des Servers nach einem Reboot händisch über Terminal oder in der /etc/rc.local
klappt nicht:
Code:
sudo -s
killall -9 rtspd
/opt/bin/mediaclient --shutdown
/opt/bin/mediaclient --start


Unmittelbar nach der Installation sind mittels /opt/bin/mediaclient --lc
auch noch bestehende Client-Verbindungen zu sehen und die Verbindung zum Localhost klappt.
Nach dem Reboot, der ja auch obige Anweisungen abarbeitet, sind keine Verbindungen mehr
sichtbar und die Verbindung zum Localhost funktioniert auch nicht.
Erst wenn ich nochmals /opt/bin/mediaclient --installstreamer ausführe
habe ich wieder Verbindung zum Localhost.
Die List of Media Clients bleibt dennoch ohne sichtbare Verbindungen !?!

Also /opt/bin/mediaclient --start  bringt jedenfalls nichts und wird bei der Ausführung auch von keinem Kommentar begleitet - im Gegensatz zu /opt/bin/mediaclient --shutdown !
Gespeichert
Sundtek
Administrator
Hero Member
*****
Beiträge: 7605


Profil anzeigen
« Antworten #229 am: Oktober 08, 2017, 11:08:50 am »

Welches System ist das?

Bei unserem Raspberry PI mit Raspbian und PC mit Ubuntu funktioniert der Autostart ohne Probleme - vor allem wird dieser durch den Treiber vorgenommen wenn rtspd in /opt/bin/ liegt.
Gespeichert

Sundtek Ltd. Support Engineer
Sundtek
Administrator
Hero Member
*****
Beiträge: 7605


Profil anzeigen
« Antworten #230 am: Oktober 08, 2017, 11:46:04 am »

Der Streamingserver lässt sich seit 1. bzw 2. Oktober so starten und stoppen:

START:
/opt/bin/rtspd -d

STOP:
/opt/bin/rtspd --shutdown

STATUS:
/opt/bin/rtspd --status

echo $?

0 ... läuft
1 ... läuft nicht
Gespeichert

Sundtek Ltd. Support Engineer
Adolar
Newbie
*
Beiträge: 5


Profil anzeigen
« Antworten #231 am: Oktober 08, 2017, 12:33:01 pm »

Der Streamingserver lässt sich seit 1. bzw 2. Oktober so starten und stoppen:

START:
/opt/bin/rtspd -d

STOP:
/opt/bin/rtspd --shutdown

STATUS:
/opt/bin/rtspd --status

echo $?

0 ... läuft
1 ... läuft nicht

Ja, so klappt es jetzt ! Danke   (Ich habe gerade auch einen Raspi3 mit Raspian)


Nur schade, dass bei einem Neustart 50% der Informationen des Fensters "Medien/Geplante Aufnahmen verloren gehen" (Länge und Titel)
Und bei den EPG-Inhalten habe ich in letzter Zeit größere inhaltliche Lücken gesehen. Ist das bekannt? Heute z.B. bei RTL2:
Code:
13:00 Die Schnäppchenhäuser - Der Traum vom Eigenheim
23:05 The Walking Dead

Gespeichert
Sundtek
Administrator
Hero Member
*****
Beiträge: 7605


Profil anzeigen
« Antworten #232 am: Oktober 08, 2017, 12:35:50 pm »

Ja, so klappt es jetzt ! Danke   (Ich habe gerade auch einen Raspi3 mit Raspian)


Nur schade, dass bei einem Neustart 50% der Informationen des Fensters "Medien/Geplante Aufnahmen verloren gehen" (Länge und Titel)
Und bei den EPG-Inhalten habe ich in letzter Zeit größere inhaltliche Lücken gesehen. Ist das bekannt? Heute z.B. bei RTL2:
Code:
13:00 Die Schnäppchenhäuser - Der Traum vom Eigenheim
23:05 The Walking Dead



Die von dir erwähnten Punkte sind aktuell noch in Bearbeitung!
Die EPG Lücken wurden nur noch nicht gescannt, der Scan-Scheduler muss da etwas nachgestellt werden (das müssen wir im Server erledigen)
Gespeichert

Sundtek Ltd. Support Engineer
kodi-ak
Newbie
*
Beiträge: 10


Profil anzeigen
« Antworten #233 am: Oktober 08, 2017, 08:14:49 pm »

Hallo, ich versuche den Streaming Server unter OSMC auf einem Raspberry Pi 2 zum Laufen zu bringen.

Folgende Probleme habe ich dabei:

- Server startet nicht automatisch beim Start bzw Neustart des Raspberry Pis und muss von Hand gestartet werden

- Nach jeden (Neu)Start kommt die Meldung, das kein Tuner konfiguriert ist. Ältere Scans sind aber vorhanden und können unter dem Tab "TV/Radio" genutzt werden

- die Standard-Playlisten funktionieren nicht richtig: mal waren es leere Dateien mit 0 Byte, mal leere Playlisten oder sie enthielten nur einen Teil der Sender. selbst angelegte Favoriten-Playlisten funktionieren aber.





Gespeichert
kodi-ak
Newbie
*
Beiträge: 10


Profil anzeigen
« Antworten #234 am: Oktober 08, 2017, 08:21:08 pm »

und welche funktion haben die einstellungen unter Setup->Streaming Server->IP Adressen?

wenn ich dort ein häkchen setze scheint das kein auswirkung zu haben bzw wird nicht gespeichert. selbst wenn ich auf einen anderen einstellungspunkt umschalte und wieder zurückspringe sind die checkboxen wieder leer. aber auch ohne das dort etwas angehakt ist, kann ich zumindest mit VLC auf den Server zugreifen
Gespeichert
Sundtek
Administrator
Hero Member
*****
Beiträge: 7605


Profil anzeigen
« Antworten #235 am: Oktober 09, 2017, 12:44:38 pm »

und welche funktion haben die einstellungen unter Setup->Streaming Server->IP Adressen?

Die Funktionalität dahinter kommt in einem zukünftigen Update, man kann dort die IP Adressen einstellen wo der Streamingserver zuhören soll. Insbesondere nützlich wenn der Streamingserver z.B auf einem Router läuft.
Gespeichert

Sundtek Ltd. Support Engineer
Sundtek
Administrator
Hero Member
*****
Beiträge: 7605


Profil anzeigen
« Antworten #236 am: Oktober 09, 2017, 02:05:32 pm »

Hallo, ich versuche den Streaming Server unter OSMC auf einem Raspberry Pi 2 zum Laufen zu bringen.

Folgende Probleme habe ich dabei:

- Server startet nicht automatisch beim Start bzw Neustart des Raspberry Pis und muss von Hand gestartet werden

Also das ist OSMC + Raspberry PI richtig?

Wir verwenden Raspbian und dort startet es automatisch, ist aber kein Problem OSMC mal zu testen.

Zitat
- Nach jeden (Neu)Start kommt die Meldung, das kein Tuner konfiguriert ist. Ältere Scans sind aber vorhanden und können unter dem Tab "TV/Radio" genutzt werden

ist bekannt und wird im Laufe der Woche korrigiert.

Zitat
- die Standard-Playlisten funktionieren nicht richtig: mal waren es leere Dateien mit 0 Byte, mal leere Playlisten oder sie enthielten nur einen Teil der Sender. selbst angelegte Favoriten-Playlisten funktionieren aber.

Ist bekannt, es muss zur Zeit eine Favoritenliste angelegt werden (das war ursprünglich ziemlich einfach implementiert, wir müssen hier aber jetzt von mehreren Empfangsgeräten ausgehen und es deshalb noch etwas überarbeiten).
Gespeichert

Sundtek Ltd. Support Engineer
aki-gm
Newbie
*
Beiträge: 6


Profil anzeigen
« Antworten #237 am: Oktober 09, 2017, 07:39:04 pm »

Kann es sein, dass der Streaming-Server seit dem letzten Treiber-Update (Ver. 01.10.2017) nicht mehr automatisch startet? Bei mir scheint es so zu sein. Momentan behelfe ich mich mit dem Komando "/opt/bin/rtspd -d", welches ich bei den Startprogrammen (Linux Mint 18.2 Mate) eingetragen habe.
Gespeichert
kodi-ak
Newbie
*
Beiträge: 10


Profil anzeigen
« Antworten #238 am: Oktober 10, 2017, 11:17:55 am »

Also das ist OSMC + Raspberry PI richtig?

richtig!

Wir verwenden Raspbian und dort startet es automatisch, ist aber kein Problem OSMC mal zu testen.

OSMC basiert ebenfalls auf Debian und verwendet auch systemd als Init-System. Werde es mir die Tage noch mal genauer ansehen...
Gespeichert
kodi-ak
Newbie
*
Beiträge: 10


Profil anzeigen
« Antworten #239 am: Oktober 11, 2017, 11:49:39 am »

auf welche art und weise wird denn der automatische start des streaming servers beim systemstart normalerweise durchgeführt?
Gespeichert
Seiten: 1 ... 14 15 [16] 17 18 ... 20
Drucken
Gehe zu: